Linux XFS
[Prev Page][Next Page]
- [PATCH 02/30] xfs: remove the ATTR_INCOMPLETE flag, (continued)
- [PATCH 02/30] xfs: remove the ATTR_INCOMPLETE flag, Christoph Hellwig
- [PATCH 03/30] xfs: merge xfs_attr_remove into xfs_attr_set, Christoph Hellwig
- [PATCH 04/30] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set, Christoph Hellwig
- [PATCH 05/30] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE, Christoph Hellwig
- [PATCH 06/30] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op, Christoph Hellwig
- [PATCH 07/30] xfs: remove the name == NULL check from xfs_attr_args_init, Christoph Hellwig
- [PATCH 08/30] xfs: remove the MAXNAMELEN check from xfs_attr_args_init, Christoph Hellwig
- [PATCH 09/30] xfs: move struct xfs_da_args to xfs_types.h, Christoph Hellwig
- [PATCH 10/30] xfs: turn xfs_da_args.value into a void pointer, Christoph Hellwig
- [PATCH 11/30] xfs: pass an initialized xfs_da_args structure to xfs_attr_set, Christoph Hellwig
- [PATCH 12/30] xfs: pass an initialized xfs_da_args to xfs_attr_get, Christoph Hellwig
- [PATCH 13/30] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked, Christoph Hellwig
- [PATCH 14/30] xfs: remove ATTR_KERNOVAL, Christoph Hellwig
- [PATCH 15/30] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL, Christoph Hellwig
- [PATCH 16/30] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME, Christoph Hellwig
- [PATCH 17/30] xfs: factor out a xfs_attr_match helper, Christoph Hellwig
- [PATCH 18/30] xfs: cleanup struct xfs_attr_list_context, Christoph Hellwig
- [PATCH 19/30] xfs: remove the unused ATTR_ENTRY macro, Christoph Hellwig
- [PATCH 20/30] xfs: open code ATTR_ENTSIZE, Christoph Hellwig
- [PATCH 21/30] xfs: move the legacy xfs_attr_list to xfs_ioctl.c, Christoph Hellwig
- [PATCH 22/30] xfs: rename xfs_attr_list_int to xfs_attr_list, Christoph Hellwig
- [PATCH 23/30] xfs: lift common checks into xfs_ioc_attr_list, Christoph Hellwig
- [PATCH 24/30] xfs: lift buffer allocation into xfs_ioc_attr_list, Christoph Hellwig
- [PATCH 25/30] xfs: lift cursor copy in/out into xfs_ioc_attr_list, Christoph Hellwig
- [PATCH 26/30] xfs: improve xfs_forget_acl, Christoph Hellwig
- [PATCH 27/30] xfs: clean up the ATTR_REPLACE checks, Christoph Hellwig
- [PATCH 28/30] xfs: clean up the attr flag confusion, Christoph Hellwig
- [PATCH 29/30] xfs: remove XFS_DA_OP_INCOMPLETE, Christoph Hellwig
- [PATCH 30/30] xfs: embedded the attrlist cursor into struct xfs_attr_list_context, Christoph Hellwig
- [PATCH v10 0/2] New zonefs file system,
Damien Le Moal
- stop generating platform_defs.h V2,
Christoph Hellwig
- [PATCH v4] xfstests: xfs mount option sanity test,
Zorro Lang
- [PATCH V3 1/2] xfsprogs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize,
Chandan Rajendra
- [PATCH V3 1/2] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize,
Chandan Rajendra
- [PATCH] xfsprogs: mkfs: don't default to the physical sector size if it's bigger than XFS_MAX_SECTORSIZE,
Jeff Moyer
- [PATCH v2] sched, fair: Allow a per-cpu kthread waking a task to stack on the same CPU, Mel Gorman
- [PATCH 0/4] xfs: Remove wrappers for some semaphores,
Pavel Reichl
- [PATCH] xfsprogs: do not redeclare globals provided by libraries,
Eric Sandeen
- [PATCH] sched, fair: Allow a per-cpu kthread waking a task to stack on the same CPU,
Mel Gorman
- Re: [PATCH v9 1/2] fs: New zonefs file system,
Markus Elfring
- [PATCH v9 0/2] New zonefs file system,
Damien Le Moal
- Some tasks got to hang_task in XFS,
Satoru Takeuchi
- stop generating platform_defs.h,
Christoph Hellwig
- [PATCH] libxfs: turn the xfs_buf_incore stub into an inline function,
Christoph Hellwig
- [PATCH 00/12] Change readahead API,
Matthew Wilcox
- [ANNOUNCE] xfs-linux: for-next updated to b3531f5fc16d, Darrick J. Wong
- [PATCH] xfs: remove unnecessary variable,
Darrick J. Wong
- [PATCH v5 00/12] xfs: make buffer functions return error codes,
Darrick J. Wong
- [PATCH 02/12] xfs: make xfs_buf_get_map return an error code, Darrick J. Wong
- [PATCH 03/12] xfs: make xfs_buf_read_map return an error code, Darrick J. Wong
- [PATCH 01/12] xfs: make xfs_buf_alloc return an error code, Darrick J. Wong
- [PATCH 04/12] xfs: make xfs_buf_get return an error code, Darrick J. Wong
- [PATCH 05/12] xfs: make xfs_buf_get_uncached return an error code, Darrick J. Wong
- [PATCH 06/12] xfs: make xfs_buf_read return an error code, Darrick J. Wong
- [PATCH 07/12] xfs: make xfs_trans_get_buf_map return an error code, Darrick J. Wong
- [PATCH 08/12] xfs: make xfs_trans_get_buf return an error code, Darrick J. Wong
- [PATCH 09/12] xfs: remove the xfs_btree_get_buf[ls] functions, Darrick J. Wong
- [PATCH 10/12] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers, Darrick J. Wong
- [PATCH 11/12] xfs: remove unnecessary null pointer checks from _read_agf callers, Darrick J. Wong
- [PATCH 12/12] xfs: fix xfs_buf_ioerror_alert location reporting, Darrick J. Wong
- [PATCH v3 0/6] xfs_repair: do not trash valid root dirs,
Darrick J. Wong
- [PATCH 0/8] xfsprogs: random fixes,
Darrick J. Wong
- [PATCH 2/8] man: document the xfs_db btheight command, Darrick J. Wong
- [PATCH 4/8] man: document some missing xfs_db commands, Darrick J. Wong
- [PATCH 5/8] xfs_db: dump per-AG reservations, Darrick J. Wong
- [PATCH 6/8] xfs_io: fix copy_file_range length argument overflow, Darrick J. Wong
- [PATCH 7/8] xfs_io: fix pwrite/pread length truncation on 32-bit systems, Darrick J. Wong
- [PATCH 8/8] xfs_repair: fix totally broken unit conversion in directory invalidation, Darrick J. Wong
- [PATCH 1/8] man: list xfs_io lsattr inode flag letters, Darrick J. Wong
- [PATCH 3/8] man: reformat xfs_quota commands in the manpage for testing, Darrick J. Wong
- [PATCH 9/8] xfs_io: fix integer over/underflow handling in timespec_from_string, Darrick J. Wong
- [PATCH 10/8] libxfs: remove duplicate attr function declarations, Darrick J. Wong
- [PATCH 11/8] xfs_repair: don't corrupt a attr fork da3 node when clearing forw/back, Darrick J. Wong
- [PATCH] Documentation: changes.rst: update several outdated project URLs,
Randy Dunlap
- [PATCH] xfs: fix uninitialized variable in xfs_attr3_leaf_inactive,
Darrick J. Wong
- A NFS, xfs, reflink and rmapbt story,
Murphy Zhou
- [PATCH v4 00/12] xfs: make buffer functions return error codes,
Darrick J. Wong
- [PATCH 01/12] xfs: make xfs_buf_alloc return an error code, Darrick J. Wong
- [PATCH 02/12] xfs: make xfs_buf_read return an error code, Darrick J. Wong
- [PATCH 03/12] xfs: make xfs_buf_get return an error code, Darrick J. Wong
- [PATCH 04/12] xfs: make xfs_buf_get_uncached return an error code, Darrick J. Wong
- [PATCH 05/12] xfs: make xfs_buf_read_map return an error code, Darrick J. Wong
- [PATCH 06/12] xfs: make xfs_buf_get_map return an error code, Darrick J. Wong
- [PATCH 08/12] xfs: make xfs_trans_get_buf return an error code, Darrick J. Wong
- [PATCH 09/12] xfs: remove the xfs_btree_get_buf[ls] functions, Darrick J. Wong
- [PATCH 10/12] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers, Darrick J. Wong
- [PATCH 12/12] xfs: fix xfs_buf_ioerror_alert location reporting, Darrick J. Wong
- [PATCH 11/12] xfs: remove unnecessary null pointer checks from _read_agf callers, Darrick J. Wong
- [PATCH 07/12] xfs: make xfs_trans_get_buf_map return an error code, Darrick J. Wong
- [bug report] xfs: streamline xfs_attr3_leaf_inactive,
Dan Carpenter
- [ANNOUNCE] xfsprogs for-next updated to 251257e6, Eric Sandeen
- [PATCH 0/2] xfsprogs: libxfs cosmetic tidyups,
Eric Sandeen
- [ANNOUNCE] xfs-linux: for-next updated to aa124436f329, Darrick J. Wong
- [PATCH v8 0/2] New zonefs file system,
Damien Le Moal
- [PATCH v3 00/13] xfs: make buffer functions return error codes,
Darrick J. Wong
- [PATCH 01/13] xfs: make xfs_buf_alloc return an error code, Darrick J. Wong
- [PATCH 02/13] xfs: make xfs_buf_read return an error code, Darrick J. Wong
- [PATCH 03/13] xfs: make xfs_buf_get return an error code, Darrick J. Wong
- [PATCH 04/13] xfs: make xfs_buf_get_uncached return an error code, Darrick J. Wong
- [PATCH 05/13] xfs: make xfs_buf_read_map return an error code, Darrick J. Wong
- [PATCH 07/13] xfs: make xfs_trans_get_buf_map return an error code, Darrick J. Wong
- [PATCH 08/13] xfs: make xfs_trans_get_buf return an error code, Darrick J. Wong
- [PATCH 10/13] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers, Darrick J. Wong
- [PATCH 13/13] xfs: fix xfs_buf_ioerror_alert location reporting, Darrick J. Wong
- [PATCH 06/13] xfs: make xfs_buf_get_map return an error code, Darrick J. Wong
- [PATCH 09/13] xfs: remove the xfs_btree_get_buf[ls] functions, Darrick J. Wong
- [PATCH 11/13] xfs: remove unnecessary null pointer checks from _read_agf callers, Darrick J. Wong
- [PATCH 12/13] xfs: move buffer read io error logging to xfs_buf_read_map, Darrick J. Wong
- [PATCH v6 00/16] xfs: Delay Ready Attributes,
Allison Collins
- [PATCH v6 01/16] xfs: Replace attribute parameters with struct xfs_name, Allison Collins
- [PATCH v6 06/16] xfs: Factor out xfs_attr_leaf_addname helper, Allison Collins
- [PATCH v6 07/16] xfs: Refactor xfs_attr_try_sf_addname, Allison Collins
- [PATCH v6 08/16] xfs: Factor out trans roll from xfs_attr3_leaf_setflag, Allison Collins
- [PATCH v6 09/16] xfs: Factor out xfs_attr_rmtval_invalidate, Allison Collins
- [PATCH v6 11/16] xfs: Check for -ENOATTR or -EEXIST, Allison Collins
- [PATCH v6 12/16] xfs: Add helper function xfs_attr_init_unmapstate, Allison Collins
- [PATCH v6 02/16] xfs: Embed struct xfs_name in xfs_da_args, Allison Collins
- [PATCH v6 15/16] xfs: Add delay ready attr remove routines, Allison Collins
- [PATCH v6 13/16] xfs: Add helper function xfs_attr_rmtval_unmap, Allison Collins
- [PATCH v6 14/16] xfs: Simplify xfs_attr_set_args, Allison Collins
- [PATCH v6 16/16] xfs: Add delay ready attr set routines, Allison Collins
- [PATCH v6 05/16] xfs: Factor out trans handling in xfs_attr3_leaf_flipflags, Allison Collins
- [PATCH v6 04/16] xfs: Factor out new helper functions xfs_attr_rmtval_set, Allison Collins
- [PATCH v6 10/16] xfs: Factor out trans roll in xfs_attr3_leaf_clearflag, Allison Collins
- [PATCH v6 03/16] xfs: Add xfs_has_attr and subroutines, Allison Collins
- [PATCH v6 00/17] xfsprogs: Delayed Ready Attributes,
Allison Collins
- [PATCH v6 05/17] xfsprogs: Factor out new helper functions xfs_attr_rmtval_set, Allison Collins
- [PATCH v6 02/17] xfsprogs: Replace attribute parameters with struct xfs_name, Allison Collins
- [PATCH v6 06/17] xfsprogs: Factor out trans handling in xfs_attr3_leaf_flipflags, Allison Collins
- [PATCH v6 09/17] xfsprogs: Factor out trans roll from xfs_attr3_leaf_setflag, Allison Collins
- [PATCH v6 10/17] xfsprogs: Factor out xfs_attr_rmtval_invalidate, Allison Collins
- [PATCH v6 03/17] xfsprogs: Embed struct xfs_name in xfs_da_args, Allison Collins
- [PATCH v6 08/17] xfsprogs: Refactor xfs_attr_try_sf_addname, Allison Collins
- [PATCH v6 11/17] xfsprogs: Factor out trans roll in xfs_attr3_leaf_clearflag, Allison Collins
- [PATCH v6 13/17] xfsprogs: Add helper function xfs_attr_init_unmapstate, Allison Collins
- [PATCH v6 16/17] xfsprogs: Add delay ready attr remove routines, Allison Collins
- [PATCH v6 17/17] xfsprogs: Add delay ready attr set routines, Allison Collins
- [PATCH v6 01/17] xfsprogs: Remove all strlen in all xfs_attr_* functions for attr names., Allison Collins
- [PATCH v6 04/17] xfsprogs: Add xfs_has_attr and subroutines, Allison Collins
- [PATCH v6 07/17] xfsprogs: Factor out xfs_attr_leaf_addname helper, Allison Collins
- [PATCH v6 12/17] xfsprogs: Check for -ENOATTR or -EEXIST, Allison Collins
- [PATCH v6 14/17] xfsprogs: Add helper function xfs_attr_rmtval_unmap, Allison Collins
- [PATCH v6 15/17] xfsprogs: Simplify xfs_attr_set_args, Allison Collins
- [PATCH] xfs_repair: stop using ->data_entry_p(),
Eric Sandeen
- Bug#921509: marked as done (please package new upstream version), Debian Bug Tracking System
- Bug#510516: marked as done (is not a native package), Debian Bug Tracking System
- Bug#144876: marked as done (xfsprogs: Please don't package it as a native package), Debian Bug Tracking System
- [PATCH v2 00/11] xfs: make buffer functions return error codes,
Darrick J. Wong
- [PATCH 01/11] xfs: make xfs_buf_alloc return an error code, Darrick J. Wong
- [PATCH 02/11] xfs: make xfs_buf_read return an error code, Darrick J. Wong
- [PATCH 03/11] xfs: make xfs_buf_get return an error code, Darrick J. Wong
- [PATCH 04/11] xfs: make xfs_buf_get_uncached return an error code, Darrick J. Wong
- [PATCH 05/11] xfs: make xfs_buf_read_map return an error code, Darrick J. Wong
- [PATCH 06/11] xfs: make xfs_buf_get_map return an error code, Darrick J. Wong
- [PATCH 07/11] xfs: make xfs_trans_get_buf_map return an error code, Darrick J. Wong
- [PATCH 08/11] xfs: make xfs_trans_get_buf return an error code, Darrick J. Wong
- [PATCH 09/11] xfs: remove the xfs_btree_get_buf[ls] functions, Darrick J. Wong
- [PATCH 10/11] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers, Darrick J. Wong
- [PATCH 11/11] xfs: remove unnecessary null pointer checks from _read_agf callers, Darrick J. Wong
- [PATCH -next] xfs: remove unused variable 'done',
YueHaibing
- [PATCH] xfs: remove the di_version field from struct icdinode,
Christoph Hellwig
- [RFC] iomap: fix race between readahead and direct write,
yu kuai
- [PATCH 0/2] xfs: fix stale disk exposure after crash,
Darrick J. Wong
- [PATCH 0/1] xfs: test xfs_scrub media scan,
Darrick J. Wong
[PATCH 0/7] fstests: random fixes,
Darrick J. Wong
linux-next: build warning after merge of the xfs tree,
Stephen Rothwell
[ANNOUNCE] xfs-linux: for-next updated to ca78eee7b4ac, Darrick J. Wong
[PATCH 0/9] xfs: make buffer functions return error codes,
Darrick J. Wong
[PATCH v4 0/7] xfs: fix buf log item memory corruption on non-amd64,
Darrick J. Wong
xfs/191 failures?,
Christoph Hellwig
[PATCH] xfs: fix IOCB_NOWAIT handling in xfs_file_dio_aio_read,
Christoph Hellwig
[PATCH V2 1/2] xfsprogs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize,
Chandan Rajendra
[PATCH V2 1/2] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize,
Chandan Rajendra
[PATCH v3] xfstests: xfs mount option sanity test,
Zorro Lang
[PATCH v7 0/2] New zonefs file system,
Damien Le Moal
[RFC v2 0/9] Replacing the readpages a_op,
Matthew Wilcox
- [PATCH v2 6/9] iomap,xfs: Convert from readpages to readahead, Matthew Wilcox
- [PATCH v2 9/9] mm: Unify all add_to_page_cache variants, Matthew Wilcox
- [PATCH v2 2/9] readahead: Ignore return value of ->readpages, Matthew Wilcox
- [PATCH v2 7/9] cifs: Convert from readpages to readahead, Matthew Wilcox
- [PATCH v2 3/9] XArray: Add xarray_for_each_range, Matthew Wilcox
- [PATCH v2 8/9] mm: Remove add_to_page_cache_locked, Matthew Wilcox
- [PATCH v2 5/9] mm: Add readahead address space operation, Matthew Wilcox
- [PATCH v2 1/9] mm: Fix the return type of __do_page_cache_readahead, Matthew Wilcox
- [PATCH v2 4/9] readahead: Put pages in cache earlier, Matthew Wilcox
- Re: [RFC v2 0/9] Replacing the readpages a_op, Matthew Wilcox
- Re: [RFC v2 0/9] Replacing the readpages a_op, Jan Kara
Problems with determining data presence by examining extents?,
David Howells
Making linkat() able to overwrite the target,
David Howells
RFC: hold i_rwsem until aio completes,
Christoph Hellwig
[Index of Archives]
[XFS Filesystem Development]
[Linux USB Devel]
[Linux SCSI]
[Linux RAID]
[Yosemite Forum]