Linux ACPI
[Prev Page][Next Page]
- Re: [PATCH v3 1/3] ACPI/APEI: Add hest_parse_pcie_aer(), (continued)
- [PATCH v3 0/7] Improvements to pcie_bandwidth_available() for eGPUs,
Mario Limonciello
- [RFC PATCH 0/6] cxl: Add support for CXL feature commands, CXL device patrol scrub control and DDR5 ECS control features,
shiju.jose
- [PATCH] ACPI: Run USB4 _OSC() first with query bit set,
Mika Westerberg
- [PATCH] ACPI: acenv: Permit compilation from within the kernel,
Linus Walleij
- [PATCH] ACPICA: debugger: check status of acpi_evaluate_object in acpi_db_walk_for_fields,
Nikita Kiryushin
- [PATCH 0/2] ACPI: video: Use acpi_device_fix_up_power_children(),
Hans de Goede
- [PATCH 1/1] ACPI: XSDT: struct acpi_table_xsdt must be packed,
Heinrich Schuchardt
- [PATCH] ACPI: OSL: Initialize output value,
Nikita Kiryushin
- [PATCH 0/3] Add API for missing PCI firmware specification funcs,
Mario Limonciello
- [rafael-pm:bleeding-edge] BUILD SUCCESS 5bd262f4820f2d5645d8ff1f251ef8e96715ef84, kernel test robot
- [REGRESSION]: acpi/nouveau: Hardware unavailable upon resume or suspend fails,
Owen T. Heisler
- [Patch v6 0/2] Add support for _TFP and change throttle pctg,
Sumit Gupta
- [PATCH] ACPI: LPIT: fix u32 multiplication overflow,
Nikita Kiryushin
- [PATCH] ACPI: video: check for error while searching for backlit device parent,
Nikita Kiryushin
- [PATCH v6 0/7] consolidate and cleanup CPU capacity,
Vincent Guittot
- [RESEND PATCH v4 0/3 Make fwnode_property_get_reference_args accept NULL args,
Sakari Ailus
- [rafael-pm:acpi-mipi-disco-img 5/7] drivers/acpi/mipi-disco-img.c:537:6: warning: format specifies type 'int' but the argument has type 'unsigned long', kernel test robot
- [rafael-pm:acpi-mipi-disco-img 5/7] drivers/acpi/mipi-disco-img.c:536:42: warning: format '%d' expects argument of type 'int', but argument 4 has type 'long unsigned int', kernel test robot
- [rafael-pm:acpi-mipi-disco-img 5/7] drivers/acpi/mipi-disco-img.c:536:42: warning: format '%lu' expects argument of type 'long unsigned int', but argument 4 has type 'unsigned int', kernel test robot
- [rafael-pm:bleeding-edge] BUILD SUCCESS 6c0a00ab98434b944ea817c95c8435d67700423f, kernel test robot
- [RESEND v5 0/4] Add support for Vendor Defined Error Types in Einj Module,
Avadhut Naik
- [PATCH AUTOSEL 6.1 15/18] ACPI: EC: Add quirk for HP 250 G7 Notebook PC, Sasha Levin
- [PATCH AUTOSEL 6.5 27/30] gpiolib: acpi: Add a ignore interrupt quirk for Peaq C1010, Sasha Levin
- [PATCH AUTOSEL 6.5 25/30] ACPI: EC: Add quirk for HP 250 G7 Notebook PC, Sasha Levin
- [PATCH AUTOSEL 6.5 11/30] ACPI: APEI: Fix AER info corruption when error status data has multiple sections, Sasha Levin
- [PATCH AUTOSEL 6.6 28/31] gpiolib: acpi: Add a ignore interrupt quirk for Peaq C1010, Sasha Levin
- [PATCH AUTOSEL 6.6 26/31] ACPI: EC: Add quirk for HP 250 G7 Notebook PC, Sasha Levin
- [PATCH AUTOSEL 6.6 11/31] ACPI: APEI: Fix AER info corruption when error status data has multiple sections, Sasha Levin
- [PATCH RFC 00/22] Initial cleanups for vCPU hotplug,
Russell King (Oracle)
- [PATCH RFC 01/22] arch_topology: Make register_cpu_capacity_sysctl() tolerant to late CPUs, Oracle
- [PATCH RFC 02/22] x86: intel_epb: Don't rely on link order, Oracle
- [PATCH RFC 03/22] x86/topology: remove arch_*register_cpu() exports, Russell King (Oracle)
- [PATCH RFC 04/22] Loongarch: remove arch_*register_cpu() exports, Russell King (Oracle)
- [PATCH RFC 06/22] drivers: base: Use present CPUs in GENERIC_CPU_DEVICES, Oracle
- [PATCH RFC 09/22] drivers: base: add arch_cpu_is_hotpluggable(), Russell King (Oracle)
- [PATCH RFC 07/22] drivers: base: Allow parts of GENERIC_CPU_DEVICES to be overridden, Oracle
- [PATCH RFC 08/22] drivers: base: Implement weak arch_unregister_cpu(), Oracle
- [PATCH RFC 10/22] drivers: base: Move cpu_dev_init() after node_dev_init(), Oracle
- [PATCH RFC 05/22] ACPI: Move ACPI_HOTPLUG_CPU to be disabled on arm64 and riscv, Oracle
- [PATCH RFC 11/22] drivers: base: remove unnecessary call to register_cpu_under_node(), Russell King (Oracle)
- [PATCH RFC 13/22] arm64: setup: Switch over to GENERIC_CPU_DEVICES using arch_register_cpu(), Oracle
- [PATCH RFC 12/22] drivers: base: Print a warning instead of panic() when register_cpu() fails, Oracle
- [PATCH RFC 14/22] arm64: convert to arch_cpu_is_hotpluggable(), Russell King (Oracle)
- [PATCH RFC 15/22] x86/topology: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH RFC 16/22] x86/topology: use weak version of arch_unregister_cpu(), Russell King (Oracle)
- [PATCH RFC 17/22] x86/topology: convert to use arch_cpu_is_hotpluggable(), Russell King (Oracle)
- [PATCH RFC 18/22] LoongArch: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH RFC 19/22] LoongArch: Use the __weak version of arch_unregister_cpu(), Oracle
- [PATCH RFC 20/22] LoongArch: convert to use arch_cpu_is_hotpluggable(), Russell King (Oracle)
- [PATCH RFC 21/22] riscv: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH RFC 22/22] riscv: convert to use arch_cpu_is_hotpluggable(), Russell King (Oracle)
- [RESEND v2] ACPI: APEI: Skip initialization of GHES_ASSIST structures for Machine Check Architecture,
Avadhut Naik
- [PATCH v3 0/7] ACPI: scan: MIPI DisCo for Imaging support,
Rafael J. Wysocki
- Fwd: System will crash when trying to wake up from second suspend, Bagas Sanjaya
- [RESEND PATCH v4 1/1] device property: Add fwnode_name_eq(),
Sakari Ailus
- [PATCH v2 1/4] ACPI: scan: Add LNXVIDEO HID to ignore_serial_bus_ids[],
Hans de Goede
- [GIT PULL] Compute Express Link (CXL) for 6.7,
Dan Williams
- [rafael-pm:bleeding-edge] BUILD SUCCESS 742513f48261e9dd7c74e179f96afa1674acfe37, kernel test robot
- [PATCH v5 0/7] consolidate and cleanup CPU capacity,
Vincent Guittot
- [PATCH v2 0/9] Improvements to pcie_bandwidth_available() for eGPUs,
Mario Limonciello
- [PATCH v2 1/9] drm/nouveau: Switch from pci_is_thunderbolt_attached() to dev_is_removable(), Mario Limonciello
- [PATCH v2 2/9] drm/radeon: Switch from pci_is_thunderbolt_attached() to dev_is_removable(), Mario Limonciello
- [PATCH v2 3/9] PCI: Drop pci_is_thunderbolt_attached(), Mario Limonciello
- [PATCH v2 5/9] PCI: pciehp: Move check for is_thunderbolt into a quirk, Mario Limonciello
- [PATCH v2 4/9] PCI: Move the `PCI_CLASS_SERIAL_USB_USB4` definition to common header, Mario Limonciello
- [PATCH v2 6/9] PCI: Rename is_thunderbolt to is_tunneled, Mario Limonciello
- [PATCH v2 7/9] PCI: ACPI: Detect PCIe root ports that are used for tunneling, Mario Limonciello
- [PATCH v2 8/9] PCI: Exclude PCIe ports used for tunneling in pcie_bandwidth_available(), Mario Limonciello
- [PATCH v2 9/9] PCI: Add a quirk to mark 0x8086 : 0x9a23 as supporting PCIe tunneling, Mario Limonciello
- Re: [PATCH v2 0/9] Improvements to pcie_bandwidth_available() for eGPUs, Bjorn Helgaas
- [PATCH RFC 00/17] Solve iommu probe races around iommu_fwspec,
Jason Gunthorpe
- [PATCH RFC 04/17] acpi: Do not return struct iommu_ops from acpi_iommu_configure_id(), Jason Gunthorpe
- [PATCH RFC 05/17] iommu: Make iommu_fwspec->ids a distinct allocation, Jason Gunthorpe
- [PATCH RFC 07/17] iommu: Add iommu_probe_device_fwspec(), Jason Gunthorpe
- [PATCH RFC 06/17] iommu: Add iommu_fwspec_alloc/dealloc(), Jason Gunthorpe
- [PATCH RFC 16/17] iommu: Mark dev_iommu_get() with lockdep, Jason Gunthorpe
- [PATCH RFC 15/17] iommu: Add ops->of_xlate_fwspec(), Jason Gunthorpe
- [PATCH RFC 12/17] iommu: Make iommu_ops_from_fwnode() static, Jason Gunthorpe
- [PATCH RFC 13/17] iommu: Remove dev_iommu_fwspec_set(), Jason Gunthorpe
- [PATCH RFC 08/17] of: Do not use dev->iommu within of_iommu_configure(), Jason Gunthorpe
- [PATCH RFC 14/17] iommu: Remove pointless iommu_fwspec_free(), Jason Gunthorpe
- [PATCH RFC 01/17] iommu: Remove struct iommu_ops *iommu from arch_setup_dma_ops(), Jason Gunthorpe
- [PATCH RFC 10/17] acpi: Do not use dev->iommu within acpi_iommu_configure(), Jason Gunthorpe
- [PATCH RFC 11/17] iommu: Hold iommu_probe_device_lock while calling ops->of_xlate, Jason Gunthorpe
- [PATCH RFC 17/17] iommu: Mark dev_iommu_priv_set() with a lockdep, Jason Gunthorpe
- [PATCH RFC 03/17] of: Use -ENODEV consistently in of_iommu_configure(), Jason Gunthorpe
- [PATCH RFC 09/17] iommu: Add iommu_fwspec_append_ids(), Jason Gunthorpe
- [PATCH RFC 02/17] of: Do not return struct iommu_ops from of_iommu_configure(), Jason Gunthorpe
- Re: [PATCH RFC 00/17] Solve iommu probe races around iommu_fwspec, André Draszik
- Re: [PATCH RFC 00/17] Solve iommu probe races around iommu_fwspec, Zhenhua Huang
- [PATCH] driver: acpi: fix the memory leak issue in the cm_write() function., shiqiang.deng
- [GIT PULL] ACPI fix for v6.7-rc1,
Rafael J. Wysocki
- [PATCH] x86/acpi: Use %rip-relative addressing in wakeup_64.S,
Uros Bizjak
- [PATCH v4 0/3] Make fwnode_property_get_reference_args accept NULL args,
Sakari Ailus
- [PATCH v4 1/1] device property: Add fwnode_name_eq(),
Sakari Ailus
- [bug report] device property: Add helper to match multiple connections, Dan Carpenter
- [PATCH] lib/fw_table: Remove acpi_parse_entries_array() export,
Dan Williams
- [PATCH v3 0/3] Make fwnode_property_get_reference_args accept NULL args,
Sakari Ailus
- [PATCH v3 1/1] device property: Add fwnode_name_eq(),
Sakari Ailus
- [PATCH 1/1] ACPI: property: Replicate DT-aligned u32 properties from DisCo for Imaging,
Sakari Ailus
- [PATCH v2 0/3] Make fwnode_property_get_reference_args accept NULL args,
Sakari Ailus
- [PATCH] software node: Remove usage of the deprecated ida_simple_xx() API, Christophe JAILLET
- [PATCH 0/3] Make fwnode_property_get_reference_args accept NULL args,
Sakari Ailus
- [PATCH v2 1/1] device property: Add fwnode_name_eq(),
Sakari Ailus
- [PATCH 1/1] device property: Add fwnode_name_eq(),
Sakari Ailus
- [PATCH] ACPI: thermal: Fix acpi_thermal_unregister_thermal_zone() cleanup,
Dan Carpenter
- [PATCH v1 1/1] power: reset: pwr-mlxbf: support graceful reboot instead of emergency reset,
Asmaa Mnebhi
- [PATCH V10 0/7] amd-pstate preferred core,
Meng Li
- [PATCH V3] ACPI: APEI: Use ERST timeout for slow devices,
Jeshua Smith
- [PATCH] acpi_idle: use raw_safe_halt() from acpi_idle_play_dead(),
David Woodhouse
- [rafael-pm:bleeding-edge] BUILD SUCCESS 3335ef03ad81e7ec516494af41ee417b630dd843, kernel test robot
- [GIT PULL] ACPI updates for v6.7-rc1,
Rafael J. Wysocki
- [GIT PULL] Thermal control updates for v6.7-rc1,
Rafael J. Wysocki
- [PATCH v4 0/7] consolidate and cleanup CPU capacity,
Vincent Guittot
- [PATCH 0/7] Subject: coresight: Move remaining AMBA ACPI devices into platform driver,
Anshuman Khandual
- [linux-next:master] BUILD REGRESSION 2ef7141596eed0b4b45ef18b3626f428a6b0a822, kernel test robot
- [PATCH v2 0/2] Fixes for s3 with parallel bootup,
Mario Limonciello
- [PATCH] ACPI: video: Add comment about acpi_video_backlight_use_native() usage,
Hans de Goede
- [PATCH v2] ACPI: LPSS: use acpi_dev_uid_match() for matching _UID,
Raag Jadav
- [RFC PATCH v2 00/21] RISC-V: ACPI: Add external interrupt controller support,
Sunil V L
- [RFC PATCH v2 01/21] arm64: PCI: Migrate ACPI related functions to pci-acpi.c, Sunil V L
- [RFC PATCH v2 02/21] RISC-V: ACPI: Implement PCI related functionality, Sunil V L
- [RFC PATCH v2 03/21] ACPI: Kconfig: Introduce new option to support deferred GSI probe, Sunil V L
- [RFC PATCH v2 04/21] ACPI: irq: Add support for deferred probe in acpi_register_gsi(), Sunil V L
- [RFC PATCH v2 05/21] pnp.h: Return -EPROBE_DEFER for disabled IRQ resource in pnp_irq(), Sunil V L
- [RFC PATCH v2 06/21] RISC-V: Kconfig: Select deferred GSI probe for ACPI systems, Sunil V L
- [RFC PATCH v2 07/21] serial: 8250_pnp: Add support for deferred probe, Sunil V L
- [RFC PATCH v2 08/21] ACPI: pci_irq: Avoid warning for deferred probe in acpi_pci_irq_enable(), Sunil V L
- [RFC PATCH v2 09/21] ACPI: scan.c: Add weak arch specific function to reorder the IRQCHIP probe, Sunil V L
- [RFC PATCH v2 10/21] ACPI: RISC-V: Implement arch function to reorder irqchip probe entries, Sunil V L
- [RFC PATCH v2 11/21] PCI: MSI: Add helper function to set system wide MSI support, Sunil V L
- [RFC PATCH v2 12/21] PCI: pci-acpi.c: Return correct value from pcibios_alloc_irq(), Sunil V L
- [RFC PATCH v2 13/21] irqchip: riscv-intc: Add ACPI support for AIA, Sunil V L
- [RFC PATCH v2 14/21] irqchip: riscv-imsic: Add ACPI support, Sunil V L
- [RFC PATCH v2 15/21] irqchip: riscv-aplic: Add ACPI support, Sunil V L
- [RFC PATCH v2 16/21] irqchip: irq-sifive-plic: Add ACPI support, Sunil V L
- [RFC PATCH v2 17/21] ACPI: bus: Add RINTC IRQ model for RISC-V, Sunil V L
- [RFC PATCH v2 18/21] irqchip: riscv-intc: Set ACPI irqmodel, Sunil V L
- [RFC PATCH v2 19/21] ACPI: bus: Add acpi_riscv_init function, Sunil V L
- [RFC PATCH v2 20/21] ACPI: RISC-V: Create APLIC platform device, Sunil V L
- [RFC PATCH v2 21/21] ACPI: RISC-V: Create PLIC platform device, Sunil V L
- [PATCH v1 0/3] gpio: mmio: Make driver agnostic,
Andy Shevchenko
[GIT PULL] ACPI fix for v6.6-rc8,
Rafael J. Wysocki
[PATCH v1 0/6] Replace acpi_driver with platform_driver,
Michal Wilczynski
[PATCH v1] ACPI: LPSS: use acpi_dev_uid_match() for matching _UID,
Raag Jadav
[RFC PATCH v3 00/39] ACPI/arm64: add support for virtual cpuhotplug,
Russell King (Oracle)
- [PATCH 01/39] parisc: simplify smp_prepare_boot_cpu(), Russell King (Oracle)
- [PATCH 02/39] ACPI: Use the acpi_device_is_present() helper in more places, Oracle
- [PATCH 03/39] ACPI: Rename acpi_scan_device_not_present() to be about enumeration, Oracle
- [PATCH 04/39] arm64, irqchip/gic-v3, ACPI: Move MADT GICC enabled check into a helper, Oracle
- [PATCH 06/39] drivers: base: Use present CPUs in GENERIC_CPU_DEVICES, Oracle
- [PATCH 08/39] drivers: base: Move cpu_dev_init() after node_dev_init(), Oracle
- [PATCH 07/39] drivers: base: Allow parts of GENERIC_CPU_DEVICES to be overridden, Oracle
- [PATCH 09/39] drivers: base: remove unnecessary call to register_cpu_under_node(), Russell King (Oracle)
- [PATCH 11/39] arm64: setup: Switch over to GENERIC_CPU_DEVICES using arch_register_cpu(), Oracle
- [PATCH 10/39] drivers: base: Print a warning instead of panic() when register_cpu() fails, Oracle
- [PATCH 13/39] x86: intel_epb: Don't rely on link order, Oracle
- [PATCH 12/39] ia64/topology: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH 14/39] x86/topology: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH 15/39] LoongArch: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH 16/39] riscv: Switch over to GENERIC_CPU_DEVICES, Oracle
- [PATCH 17/39] arch_topology: Make register_cpu_capacity_sysctl() tolerant to late CPUs, Oracle
- [PATCH 18/39] ACPI: Only enumerate enabled (or functional) devices, Oracle
- [PATCH 19/39] ACPI: processor: Add support for processors described as container packages, Oracle
- [PATCH 20/39] ACPI: processor: Register CPUs that are online, but not described in the DSDT, Oracle
- [PATCH 21/39] ACPI: processor: Register all CPUs from acpi_processor_get_info(), Oracle
- [PATCH 23/39] drivers: base: Implement weak arch_unregister_cpu(), Oracle
- [PATCH 24/39] ACPI: Move acpi_bus_trim_one() before acpi_scan_hot_remove(), Oracle
- [PATCH 25/39] ACPI: Rename acpi_processor_hotadd_init and remove pre-processor guards, Oracle
- [PATCH 22/39] ACPI: Rename ACPI_HOTPLUG_CPU to include 'present', Oracle
- [PATCH 05/39] ACPI: Move ACPI_HOTPLUG_CPU to be disabled on arm64 and riscv, Oracle
- [PATCH 27/39] ACPI: Check _STA present bit before making CPUs not present, Oracle
- [PATCH 28/39] ACPI: Warn when the present bit changes but the feature is not enabled, Oracle
- [PATCH 26/39] ACPI: Add post_eject to struct acpi_scan_handler for cpu hotplug, Oracle
- [PATCH 29/39] LoongArch: Use the __weak version of arch_unregister_cpu(), Oracle
- [PATCH 30/39] arm64: acpi: Move get_cpu_for_acpi_id() to a header, Oracle
- [PATCH 31/39] ACPICA: Add new MADT GICC flags fields, Oracle
- [PATCH 32/39] irqchip/gic-v3: Don't return errors from gic_acpi_match_gicc(), Oracle
- [PATCH 33/39] irqchip/gic-v3: Add support for ACPI's disabled but 'online capable' CPUs, Oracle
- [PATCH 34/39] arm64: psci: Ignore DENIED CPUs, Oracle
- [PATCH 35/39] ACPI: add support to register CPUs based on the _STA enabled bit, Oracle
- [PATCH 36/39] arm64: document virtual CPU hotplug's expectations, Oracle
- [PATCH 38/39] cpumask: Add enabled cpumask for present CPUs that can be brought online, Oracle
- [PATCH 39/39] ACPI: processor: Only call arch_unregister_cpu() if HOTPLUG_CPU is selected, Oracle
- [PATCH 37/39] ACPI: Add _OSC bits to advertise OS support for toggling CPU present/enabled, Oracle
- Re: [RFC PATCH v3 00/39] ACPI/arm64: add support for virtual cpuhotplug, Russell King (Oracle)
- Re: [RFC PATCH v3 00/39] ACPI/arm64: add support for virtual cpuhotplug, Rafael J. Wysocki
[Index of Archives]
[Linux IBM ACPI]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[IETF Annouce]
[Security]
[Netfilter]
[Bugtraq]