Linux Sparse
[Prev Page][Next Page]
- [PATCH 0/9] option parsing improvements,
Luc Van Oostenryck
- [PATCH] cgcc: teach cgcc about freebsd & netbsd, Luc Van Oostenryck
- [PATCH] volatile loads are side-effects too,
Luc Van Oostenryck
- [PATCH] graph: do not scan removed instructions,
Luc Van Oostenryck
- [PATCH 0/2] make builtins more built-in,
Luc Van Oostenryck
- [PATCH 00/36] Makefile reorganization,
Luc Van Oostenryck
- [PATCH 01/36] build: make PREFIX overwritable from the environment, Luc Van Oostenryck
- [PATCH 02/36] build: put comment about local.mk to the place where it is included, Luc Van Oostenryck
- [PATCH 03/36] build: drop BASIC_CFLAGS and ALL_CFLAGS, Luc Van Oostenryck
- [PATCH 04/36] build: drop -g from LDFLAGS, Luc Van Oostenryck
- [PATCH 05/36] build: pass CPPFLAGS to compiler, Luc Van Oostenryck
- [PATCH 06/36] build: fix effectiveness of generated dependencies, Luc Van Oostenryck
- [PATCH 07/36] build: remove unused support for pkgconfig, Luc Van Oostenryck
- [PATCH 08/36] build: use '_OBJS' instead of '_EXTRA_DEPS', Luc Van Oostenryck
- [PATCH 09/36] build: use '_LDLIBS' instead of '_EXTRA_OBJS', Luc Van Oostenryck
- [PATCH 10/36] build: allow target-specific CFLAGS, CPPFLAGS, LDFLAGS & LDLIBS, Luc Van Oostenryck
- [PATCH 12/36] build: avoid rule-specific CFLAGS, Luc Van Oostenryck
- [PATCH 11/36] build: allow CFLAGS & friends from command line, Luc Van Oostenryck
- [PATCH 13/36] build: use $LIBS directly in the dependency list, Luc Van Oostenryck
- [PATCH 14/36] build: no need to use wildcards for generated dependencies, Luc Van Oostenryck
- [PATCH 15/36] build: reuse rule for ALL_OBJS, Luc Van Oostenryck
- [PATCH 16/36] build: CHECKER_FLAGS=-Wno-vla for all targets, Luc Van Oostenryck
- [PATCH 17/36] build: move tests near their use, Luc Van Oostenryck
- [PATCH 18/36] build: only generate version.h when needed, Luc Van Oostenryck
- [PATCH 19/36] build: add note about overwritable vars, Luc Van Oostenryck
- [PATCH 20/36] build: remove references to unexisting pre-process.h, Luc Van Oostenryck
- [PATCH 21/36] build: no need to clean *.so and SLIB_FILE, Luc Van Oostenryck
- [PATCH 22/36] build: move clean & clean-check together, Luc Van Oostenryck
- [PATCH 23/36] build: make clean targets quieter, Luc Van Oostenryck
- [PATCH 24/36] build: remove rule for shared lib, it's unused, Luc Van Oostenryck
- [PATCH 25/36] build: normalize rules, Luc Van Oostenryck
- [PATCH 26/36] build: remove the dist rule since unused, Luc Van Oostenryck
- [PATCH 27/36] build: use one line per item, Luc Van Oostenryck
- [PATCH 28/36] build: use a dot file name instead of local.mk: .sparse.mk, Luc Van Oostenryck
- [PATCH 29/36] build: use git-clean, Luc Van Oostenryck
- [PATCH 30/36] build: use standard rules for install, Luc Van Oostenryck
- [PATCH 31/36] build: remove unused QUIET_INST_SH, Luc Van Oostenryck
- [PATCH 32/36] build: let quiet commands use less indentation, Luc Van Oostenryck
- [PATCH 33/36] build: simpler logic for quiet commands, Luc Van Oostenryck
- [PATCH 34/36] build: avoid foreach, Luc Van Oostenryck
- [PATCH 35/36] build: reorg & add comment, Luc Van Oostenryck
- [PATCH 36/36] build: use a single space before assignments, Luc Van Oostenryck
- Re: [PATCH 00/36] Makefile reorganization, Luc Van Oostenryck
- multiarch & base dir,
Luc Van Oostenryck
- [PATCH] Simplify expr->flags assignement, Christopher Li
- [SPARSE] Questions for distros,
Luc Van Oostenryck
- [PATCH] build: clean up $CFLAGS handling in the makefile,
Jeff Layton
- [GIT PULL] debug build of sparse v4,
Christopher Li
- [PATCH] build: assign extra flags to ALL_CFLAGS instead of CFLAGS,
Jeff Layton
- [PATCH] sparse: document that -Wbitwise is default,
Jacob Keller
- [PATCH 0/6] build: various updates,
Uwe Kleine-König
[PATCH] cgcc: provide __ARM_PCS_VFP for armhf,
Uwe Kleine-König
[PATCH] build: make PREFIX overwritable on the commandline,
Uwe Kleine-König
[PATCH] compile-i386: Use SPARSE_VERSION instead of __DATE__,
Uwe Kleine-König
[PATCH 0/2] cleanup prototype,
Luc Van Oostenryck
[PATCH 0/2] cleanup of cclass[],
Luc Van Oostenryck
[PATCH 0/5] expressions without a type,
Luc Van Oostenryck
[PATCH 0/3] return type's testcases,
Luc Van Oostenryck
[PATCH] testsuite: respect command line's quotes & whitespaces, Luc Van Oostenryck
[GIT PULL] llvm fixes,
Luc Van Oostenryck
[PATCH 0/5] extra fixes for LLVM,
Luc Van Oostenryck
[PATCH] use a specific struct for asm operands, Luc Van Oostenryck
[PATCH 0/3] testcases for memory-to-register conversion,
Luc Van Oostenryck
[PATCH 0/4] testcases for optimization problems,
Luc Van Oostenryck
[PATCH 00/15] testcases for bugs,
Luc Van Oostenryck
- [PATCH 01/15] add test case for using multiple input files, Luc Van Oostenryck
- [PATCH 02/15] add test case for VLA sizeof, Luc Van Oostenryck
- [PATCH 03/15] add test case for memory to register problem, Luc Van Oostenryck
- [PATCH 04/15] add test case for conditionally undefined var, Luc Van Oostenryck
- [PATCH 05/15] add test case for incomplete type, Luc Van Oostenryck
- [PATCH 06/15] add test case bitfields in K&R decl, Luc Van Oostenryck
- [PATCH 07/15] add test case storage specifier in struct member, Luc Van Oostenryck
- [PATCH 08/15] add test case using sizeof on incomplete type, Luc Van Oostenryck
- [PATCH 09/15] add test case for bad layout of bool in bitfields, Luc Van Oostenryck
- [PATCH 10/15] add test case for missed overflow detection, Luc Van Oostenryck
- [PATCH 11/15] add test case for compound literals, Luc Van Oostenryck
- [PATCH 12/15] add test case for pre-processor extra tokens warning, Luc Van Oostenryck
- [PATCH 15/15] add test case for missing conversion to select, Luc Van Oostenryck
- [PATCH 14/15] add test case for superfluous cast with volatiles, Luc Van Oostenryck
- [PATCH 13/15] add test case for space within command line, Luc Van Oostenryck
[PATCH 0/8] dump the IR,
Luc Van Oostenryck
[PATCH 0/9] Simplify the parsion of options,
Luc Van Oostenryck
[PATCH 00/28] testsuite improvements,
Luc Van Oostenryck
- [PATCH 01/28] testsuite: 'echo -n' may not be interpreted as '-n', Luc Van Oostenryck
- [PATCH 02/28] testsuite: allow to test a few cases at once, Luc Van Oostenryck
- [PATCH 03/28] testsuite: move verbose() & error(), Luc Van Oostenryck
- [PATCH 04/28] testsuite: better message for pattern nbr checking, Luc Van Oostenryck
- [PATCH 05/28] testsuite: better message for pattern absence/presence, Luc Van Oostenryck
- [PATCH 06/28] testsuite: saner checking of pattern occurences, Luc Van Oostenryck
- [PATCH 07/28] testsuite: clearer result summary, Luc Van Oostenryck
- [PATCH 08/28] testsuite: check error messages first, Luc Van Oostenryck
- [PATCH 09/28] testsuite: saner handling of 'must_fail', Luc Van Oostenryck
- [PATCH 10/28] testsuite: allow to parse several options, Luc Van Oostenryck
- [PATCH 11/28] testsuite: add support for -q|--quiet, Luc Van Oostenryck
- [PATCH 12/28] testsuite: add support for -a|--abort, Luc Van Oostenryck
- [PATCH 13/28] testsuite: get options from env too, Luc Van Oostenryck
- [PATCH 14/28] testsuite: allow --format & --single, Luc Van Oostenryck
- [PATCH 15/28] testsuite: remove useless selftest, Luc Van Oostenryck
- [PATCH 16/28] testsuite: remove useless test-be.c, Luc Van Oostenryck
- [PATCH 17/28] testsuite: extract disable(), Luc Van Oostenryck
- [PATCH 18/28] testsuite: simplify documentation, Luc Van Oostenryck
- [PATCH 19/28] testsuite: allow arch-specific tests, Luc Van Oostenryck
- [PATCH 20/28] testsuite: save screen real estate, Luc Van Oostenryck
- [PATCH 21/28] testsuite: add a blank line before format, Luc Van Oostenryck
- [PATCH 22/28] testsuite: 'quiet' must be initialized earlier, Luc Van Oostenryck
- [PATCH 23/28] testsuite: move up arg_file(), Luc Van Oostenryck
- [PATCH 24/28] testsuite: make do_format() more self-contained, Luc Van Oostenryck
- [PATCH 25/28] testsuite: format: saner defaults handling, Luc Van Oostenryck
- [PATCH 26/28] testsuite: format: strip .c from default name, Luc Van Oostenryck
- [PATCH 27/28] testsuite: add support for 'format -f', Luc Van Oostenryck
- [PATCH 28/28] testsuite: add support for 'format -l', Luc Van Oostenryck
- Re: [PATCH 00/28] testsuite improvements, Christopher Li
- Re: [PATCH 00/28] testsuite improvements, Christopher Li
[PATCH] compile-i386: make use of expression_list_size(),
Martin Kepplinger
[PATCH] use shorter name for constexpr tests,
Luc Van Oostenryck
[PATCH] cgcc: teach cgcc about GNU/kFreeBSD,
Uwe Kleine-König
[PATCH] build: only generate version.h when needed and remove it in clean target,
Uwe Kleine-König
Re: SMATCH indicates warning to almost all files in Linux Kernel + ARM,
Christopher Li
Potential problem with variable handling - Was: Handling of local variables in the backend,
Dibyendu Majumdar
Handling of local variables in the backend,
Dibyendu Majumdar
Experimenting with dmrC as backend for Lua, Dibyendu Majumdar
[PATCH] compile-i386.c: fix a memory leak in sort_array(),
Martin Kepplinger
Some thoughts on the SSA debate,
Dibyendu Majumdar
Sparse-llvm question regarding handling of phi/phsrc instructions,
Dibyendu Majumdar
Another code snippet that Sparse has problems with,
Dibyendu Majumdar
no more tar balls?,
Uwe Kleine-König
[ANN] dmr_C 0.1 alpha release,
Dibyendu Majumdar
[PATCH] kernel: Emphasize the return value of READ_ONCE() is honored, Boqun Feng
Sparse preprocessing bug with zero-arg variadic macros,
Josh Poimboeuf
sparse test failures on ppc32le (and other not so common archs),
Uwe Kleine-König
Re: sparse test failures on ppc32le (and other not so common archs), Uwe Kleine-König
[RFC PATCH 00/48] fix promotion of symbol to register,
Luc Van Oostenryck
- [RFC PATCH 01/48] remove wrong part of simplify_loads(), Luc Van Oostenryck
- [RFC PATCH 02/48] remove trivial phi-nodes during clean_up_phi(), Luc Van Oostenryck
- [RFC PATCH 03/48] give a type to OP_PHISOURCEs, Luc Van Oostenryck
- [RFC PATCH 04/48] fix test case kill-phi-ttsb, Luc Van Oostenryck
- [RFC PATCH 05/48] add test case for incomplete type, Luc Van Oostenryck
- [RFC PATCH 06/48] add test case for bad return type, Luc Van Oostenryck
- [RFC PATCH 07/48] topasm: top-level asm is special, Luc Van Oostenryck
- [RFC PATCH 08/48] ret-void: return nothing only for void functions, Luc Van Oostenryck
- [RFC PATCH 09/48] small code reorg of add_store(), Luc Van Oostenryck
- [RFC PATCH 10/48] add PSEUDO_UNDEF, Luc Van Oostenryck
- [RFC PATCH 11/48] add undef_pseudo(), Luc Van Oostenryck
- [RFC PATCH 12/48] add insert_phi_node(), Luc Van Oostenryck
- [RFC PATCH 13/48] extract alloc_phisrc() from alloc_phi(), Luc Van Oostenryck
- [RFC PATCH 14/48] add remove_use(), Luc Van Oostenryck
- [RFC PATCH 15/48] rename 'struct warning' to 'struct flag', Luc Van Oostenryck
- [RFC PATCH 16/48] let handle_simple_switch() handle an array of flags, Luc Van Oostenryck
- [RFC PATCH 17/48] dump-ir: rename -fdump-linearize to -fdump-ir, Luc Van Oostenryck
- [RFC PATCH 18/48] dump-ir: use defines, Luc Van Oostenryck
- [RFC PATCH 19/48] dump-ir: add an helper to parse sub-options, Luc Van Oostenryck
- [RFC PATCH 20/48] dump-ir: make it more flexible, Luc Van Oostenryck
- [RFC PATCH 21/48] sssa: move simplify_one_symbol() to a separate file, Luc Van Oostenryck
- [RFC PATCH 22/48] mem2reg: rename to use 'promote' instead of 'simplify', Luc Van Oostenryck
- [RFC PATCH 23/48] mem2reg: simplify check of modifiers for external visibility, Luc Van Oostenryck
- [RFC PATCH 24/48] mem2reg: extract externaly_visible(), Luc Van Oostenryck
- [RFC PATCH 25/48] mem2reg: reorg externaly_visible() returns, Luc Van Oostenryck
- [RFC PATCH 26/48] mem2reg: ignore all killed instructions, Luc Van Oostenryck
- [RFC PATCH 27/48] mem2reg: extract kill_pseudo_stores(), Luc Van Oostenryck
- [RFC PATCH 28/48] mem2reg: extract kill_pseudo_dominated_stores(), Luc Van Oostenryck
- [RFC PATCH 29/48] mem2reg: extract kill_pseudo_dead_stores(), Luc Van Oostenryck
- [RFC PATCH 30/48] mem2reg: remove one indent level, Luc Van Oostenryck
- [RFC PATCH 31/48] mem2reg: add comment to find_dominating_stores(), Luc Van Oostenryck
- [RFC PATCH 32/48] mem2reg: add flags to enable/disable some parts, Luc Van Oostenryck
- [RFC PATCH 33/48] mem2reg: rename the other kill_dominated_stores(), Luc Van Oostenryck
- [RFC PATCH 34/48] mem2reg: move rewrite_load_instruction() here, Luc Van Oostenryck
- [RFC PATCH 35/48] mem2reg: be clear that we're using a symbol/var, Luc Van Oostenryck
- [RFC PATCH 36/48] mem2reg: be clear that we're using a symbol/var here too, Luc Van Oostenryck
- [RFC PATCH 37/48] mem2reg: add description for find_dominating_parents(), Luc Van Oostenryck
- [RFC PATCH 38/48] mem2reg: let rewrite_load_instruction() take the symbol as arg, Luc Van Oostenryck
- [RFC PATCH 39/48] mem2reg: remove check phisrc_in_bb(), Luc Van Oostenryck
- [RFC PATCH 40/48] mem2reg: delay the creation of phi-sources, Luc Van Oostenryck
- [RFC PATCH 41/48] mem2reg: make rewrite_load_instruction() functional, Luc Van Oostenryck
- [RFC PATCH 42/48] mem2reg: rename one->target to dom, Luc Van Oostenryck
- [RFC PATCH 43/48] mem2reg: get recursion right, Luc Van Oostenryck
- [RFC PATCH 44/48] mem2reg: don't check dominance by removed instructions, Luc Van Oostenryck
- [RFC PATCH 45/48] mem2reg: update copyright, Luc Van Oostenryck
- [RFC PATCH 46/48] mem2reg: allow dumping IR, Luc Van Oostenryck
- [RFC PATCH 47/48] mem2reg: add some small test cases, Luc Van Oostenryck
- [RFC PATCH 48/48] mem2reg: don't promote unused or already promoted vars, Luc Van Oostenryck
- Re: [RFC PATCH 00/48] fix promotion of symbol to register, Christopher Li
- Re: [RFC PATCH 00/48] fix promotion of symbol to register, Christopher Li
Sparse parsing question - iterator statements,
Dibyendu Majumdar
[GIT PULL] Makefile: debug target V2, Christopher Li
Question about Sparse parsing - return statement,
Dibyendu Majumdar
master merge plans,
Christopher Li
Question about Sparse parsing of initializers,
Dibyendu Majumdar
RFC: One strange idea inspired by the SSSA,
Christopher Li
[PATCH] fix expansion of constant bitfield dereference,
Luc Van Oostenryck
Sparse parsing question: symbols in parse tree,
Dibyendu Majumdar
Question about Sparse Linear form and pseudos,
Dibyendu Majumdar
Sparse parsing question: string literal,
Dibyendu Majumdar
SSSA and some C pointer manipulation.,
Christopher Li
Issue with bitfield,
Dibyendu Majumdar
Sparse-llvm: Incorrect conversion to bool value in CBR: was: Investigating a problem,
Dibyendu Majumdar
Investigating a problem,
Dibyendu Majumdar
Sparse 0.5.1 is released,
Christopher Li
idea/question about sparse's context checking,
Luc Van Oostenryck
[RFC PATCH 0/4] simple, registrable, promotable & friends,
Luc Van Oostenryck
[GIT PULL] Sparse v0.5.1, Luc Van Oostenryck
[RFC PATCH 00/14] rework of cast operations,
Luc Van Oostenryck
- [RFC PATCH 01/14] add documentation for IR instructions, Luc Van Oostenryck
- [RFC PATCH 02/14] cast: add tests for warnings issued by sparse -v, Luc Van Oostenryck
- [RFC PATCH 03/14] cast: prepare finer grained cast instructions, Luc Van Oostenryck
- [RFC PATCH 04/14] cast: specialize FPCAST into [USF]CVTF, Luc Van Oostenryck
- [RFC PATCH 05/14] cast: handle NO-OP casts, Luc Van Oostenryck
- [RFC PATCH 06/14] cast: specialize floats to integer conversion, Luc Van Oostenryck
- [RFC PATCH 07/14] cast: specialize casts from unsigned to pointers, Luc Van Oostenryck
- [RFC PATCH 08/14] cast: make [u]intptr_ctype alias of [s]size_t_ctype, Luc Van Oostenryck
- [RFC PATCH 09/14] cast: make pointer casts always size preserving, Luc Van Oostenryck
- [RFC PATCH 10/14] cast: temporary simplify handling cast to/from void*, Luc Van Oostenryck
- [RFC PATCH 11/14] cast: specialize cast from pointers, Luc Van Oostenryck
- [RFC PATCH 12/14] cast: add support for -Wpointer-to-int-cast, Luc Van Oostenryck
- [RFC PATCH 13/14] cast: make casts from pointer always size preserving, Luc Van Oostenryck
- [RFC PATCH 14/14] cast: specialize integer casts, Luc Van Oostenryck
[PATCH 00/29] Simple & Efficient SSA construction.,
Luc Van Oostenryck
- [PATCH 01/29] remove wrong part of simplify_loads(), Luc Van Oostenryck
- [PATCH 02/29] give a type to OP_PHISOURCEs, Luc Van Oostenryck
- [PATCH 03/29] fix test case kill-phi-ttsb, Luc Van Oostenryck
- [PATCH 04/29] add test case for incomplete type, Luc Van Oostenryck
- [PATCH 05/29] add test case for bad return type, Luc Van Oostenryck
- [PATCH 06/29] topasm: top-level asm is special, Luc Van Oostenryck
- [PATCH 07/29] ret-void: return nothing only for void functions, Luc Van Oostenryck
- [PATCH 08/29] small code reorg of add_store(), Luc Van Oostenryck
- [PATCH 09/29] add helper to test if a variable is "simple", Luc Van Oostenryck
- [PATCH 10/29] add helper imple_access() to test if an access is "simple", Luc Van Oostenryck
- [PATCH 11/29] add PSEUDO_UNDEF, Luc Van Oostenryck
- [PATCH 12/29] add undef_pseudo(), Luc Van Oostenryck
- [PATCH 13/29] add insert_phi_node(), Luc Van Oostenryck
- [PATCH 14/29] extract alloc_phisrc() from alloc_phi(), Luc Van Oostenryck
[Index of Archives]
[Trinity Fuzzer Tool]
[Linux Kernel]
[Netdev]
[IETF Annouce]
[Security]
[Bugtraq]