Linux XFS
[Prev Page][Next Page]
- [PATCH 17/24] xfs: move the log ioend workqueue to struct xlog, (continued)
- Polish translation update for xfsprogs 5.0.0,
Jakub Bogusz
- [bug report][stable] xfstests:generic/538 failed on xfs,
Alvin Zheng
- [PATCH] include WARN, REPAIR build options in XFS_BUILD_OPTIONS,
Eric Sandeen
- [PATCH v2 00/10] xfs: refactor and improve inode iteration,
Darrick J. Wong
- [PATCH 03/10] xfs: bulkstat should copy lastip whenever userspace supplies one, Darrick J. Wong
- [PATCH 02/10] xfs: convert quotacheck to use the new iwalk functions, Darrick J. Wong
- [PATCH 04/10] xfs: convert bulkstat to new iwalk infrastructure, Darrick J. Wong
- [PATCH 05/10] xfs: move bulkstat ichunk helpers to iwalk code, Darrick J. Wong
- [PATCH 06/10] xfs: change xfs_iwalk_grab_ichunk to use startino, not lastino, Darrick J. Wong
- [PATCH 07/10] xfs: clean up long conditionals in xfs_iwalk_ichunk_ra, Darrick J. Wong
- [PATCH 08/10] xfs: multithreaded iwalk implementation, Darrick J. Wong
- [PATCH 09/10] xfs: poll waiting for quotacheck, Darrick J. Wong
- [PATCH 10/10] xfs: refactor INUMBERS to use iwalk functions, Darrick J. Wong
- [PATCH 01/10] xfs: create simplified inode walk function, Darrick J. Wong
- [PATCH v2 0/4] xfs: refactor inode geometry,
Darrick J. Wong
- [RFC PATCH] xfstests: test new v5 bulkstat commands, Darrick J. Wong
- [ANNOUNCE] xfs-linux: for-next updated to 025197ebb08a, Darrick J. Wong
- [PATCH v5 8/9] vfs: allow copy_file_range to copy across devices,
Amir Goldstein
- understanding xfs vs. ext4 log performance,
Lucas Stach
- [PATCH v2 0/5] xfs: refactor inode geometry,
Darrick J. Wong
- [PATCH v3 0/6] fstests: copy_file_range() tests,
Amir Goldstein
- [PATCH v4 0/9] Fixes for major copy_file_range() issues,
Amir Goldstein
- [PATCH 0/9] xfs: introduce new BULKSTAT and INUMBERS ioctls,
Darrick J. Wong
- [PATCH 00/11] xfs: refactor and improve inode iteration,
Darrick J. Wong
- [PATCH 01/11] xfs: separate inode geometry, Darrick J. Wong
- [PATCH 02/11] xfs: create simplified inode walk function, Darrick J. Wong
- [PATCH 03/11] xfs: convert quotacheck to use the new iwalk functions, Darrick J. Wong
- [PATCH 04/11] xfs: bulkstat should copy lastip whenever userspace supplies one, Darrick J. Wong
- [PATCH 05/11] xfs: convert bulkstat to new iwalk infrastructure, Darrick J. Wong
- [PATCH 06/11] xfs: move bulkstat ichunk helpers to iwalk code, Darrick J. Wong
- [PATCH 07/11] xfs: change xfs_iwalk_grab_ichunk to use startino, not lastino, Darrick J. Wong
- [PATCH 08/11] xfs: clean up long conditionals in xfs_iwalk_ichunk_ra, Darrick J. Wong
- [PATCH 09/11] xfs: multithreaded iwalk implementation, Darrick J. Wong
- [PATCH 10/11] xfs: poll waiting for quotacheck, Darrick J. Wong
- [PATCH 11/11] xfs: refactor INUMBERS to use iwalk functions, Darrick J. Wong
- Re: How to package e2scrub,
Darrick J. Wong
- [PATCH v3 00/13] Fixes for major copy_file_range() issues,
Amir Goldstein
- [PATCH v3 01/13] vfs: introduce generic_copy_file_range(), Amir Goldstein
- [PATCH v3 02/13] vfs: no fallback for ->copy_file_range, Amir Goldstein
- [PATCH v3 03/13] vfs: introduce generic_file_rw_checks(), Amir Goldstein
- [PATCH v3 04/13] vfs: remove redundant checks from generic_remap_checks(), Amir Goldstein
- [PATCH v3 07/13] xfs: use file_modified() helper, Amir Goldstein
- [PATCH v3 08/13] vfs: copy_file_range needs to strip setuid bits and update timestamps, Amir Goldstein
- [PATCH v3 09/13] ceph: copy_file_range needs to strip setuid bits and update timestamps, Amir Goldstein
- [PATCH v3 10/13] cifs: copy_file_range needs to strip setuid bits and update timestamps, Amir Goldstein
- [PATCH v3 12/13] nfs: copy_file_range needs to strip setuid bits and update timestamps, Amir Goldstein
- [PATCH v3 13/13] vfs: allow copy_file_range to copy across devices, Amir Goldstein
- [PATCH v3 11/13] fuse: copy_file_range needs to strip setuid bits and update timestamps, Amir Goldstein
- [PATCH v3 14/13] man-pages: copy_file_range updates, Amir Goldstein
- [PATCH v3 06/13] vfs: introduce file_modified() helper, Amir Goldstein
- [PATCH v3 05/13] vfs: add missing checks to copy_file_range, Amir Goldstein
- [PATCH] xfs_io: allow passing an open file to copy_range,
Amir Goldstein
- [PATCH] xfs: inode btree scrubber should calculate im_boffset correctly,
Darrick J. Wong
- [RFC][PATCH] link.2: AT_ATOMIC_DATA and AT_ATOMIC_METADATA,
Amir Goldstein
- [PATCH v2 0/5] fstests: copy_file_range() tests,
Amir Goldstein
- [PATCH] ovl: support the FS_IOC_FS[SG]ETXATTR ioctls,
Amir Goldstein
- [PATCH v2 0/8] Fixes for major copy_file_range() issues,
Amir Goldstein
- use bios directly in the log code v2,
Christoph Hellwig
- [PATCH 01/20] xfs: remove the no-op spinlock_destroy stub, Christoph Hellwig
- [PATCH 02/20] xfs: remove the never used _XBF_COMPOUND flag, Christoph Hellwig
- [PATCH 03/20] xfs: renumber XBF_WRITE_FAIL, Christoph Hellwig
- [PATCH 04/20] xfs: make mem_to_page available outside of xfs_buf.c, Christoph Hellwig
- [PATCH 05/20] xfs: reformat xlog_get_lowest_lsn, Christoph Hellwig
- [PATCH 06/20] xfs: don't use REQ_PREFLUSH for split log writes, Christoph Hellwig
- [PATCH 07/20] xfs: factor out log buffer writing from xlog_sync, Christoph Hellwig
- [PATCH 08/20] xfs: factor out splitting of an iclog from xlog_sync, Christoph Hellwig
- [PATCH 09/20] xfs: factor out iclog size calculation from xlog_sync, Christoph Hellwig
- [PATCH 10/20] xfs: update both stat counters together in xlog_sync, Christoph Hellwig
- [PATCH 11/20] xfs: remove the syncing argument from xlog_verify_iclog, Christoph Hellwig
- [PATCH 12/20] xfs: make use of the l_targ field in struct xlog, Christoph Hellwig
- [PATCH 13/20] xfs: use bios directly to write log buffers, Christoph Hellwig
- [PATCH 14/20] xfs: move the log ioend workqueue to struct xlog, Christoph Hellwig
- [PATCH 15/20] xfs: return an offset instead of a pointer from xlog_align, Christoph Hellwig
- [PATCH 16/20] xfs: use bios directly to read and write the log recovery buffers, Christoph Hellwig
- [PATCH 17/20] xfs: stop using bp naming for log recovery buffers, Christoph Hellwig
- [PATCH 18/20] xfs: remove unused buffer cache APIs, Christoph Hellwig
- [PATCH 19/20] xfs: properly type the b_log_item field in struct xfs_buf, Christoph Hellwig
- [PATCH 20/20] xfs: remove the b_io_length field in struct xfs_buf, Christoph Hellwig
- <Possible follow-ups>
- use bios directly in the log code v2, Christoph Hellwig
- [PATCH 01/20] xfs: remove the no-op spinlock_destroy stub, Christoph Hellwig
- [PATCH 02/20] xfs: remove the never used _XBF_COMPOUND flag, Christoph Hellwig
- [PATCH 03/20] xfs: renumber XBF_WRITE_FAIL, Christoph Hellwig
- [PATCH 04/20] xfs: make mem_to_page available outside of xfs_buf.c, Christoph Hellwig
- [PATCH 05/20] xfs: reformat xlog_get_lowest_lsn, Christoph Hellwig
- [PATCH 06/20] xfs: don't use REQ_PREFLUSH for split log writes, Christoph Hellwig
- [PATCH 07/20] xfs: factor out log buffer writing from xlog_sync, Christoph Hellwig
- [PATCH 08/20] xfs: factor out splitting of an iclog from xlog_sync, Christoph Hellwig
- [PATCH 09/20] xfs: factor out iclog size calculation from xlog_sync, Christoph Hellwig
- [PATCH 10/20] xfs: update both stat counters together in xlog_sync, Christoph Hellwig
- [PATCH 11/20] xfs: remove the syncing argument from xlog_verify_iclog, Christoph Hellwig
- [PATCH 12/20] xfs: make use of the l_targ field in struct xlog, Christoph Hellwig
- [PATCH 13/20] xfs: use bios directly to write log buffers, Christoph Hellwig
- [PATCH 14/20] xfs: move the log ioend workqueue to struct xlog, Christoph Hellwig
- [PATCH 15/20] xfs: return an offset instead of a pointer from xlog_align, Christoph Hellwig
- [PATCH 16/20] xfs: use bios directly to read and write the log recovery buffers, Christoph Hellwig
- [PATCH 17/20] xfs: stop using bp naming for log recovery buffers, Christoph Hellwig
- [PATCH 18/20] xfs: remove unused buffer cache APIs, Christoph Hellwig
- [PATCH 20/20] xfs: remove the b_io_length field in struct xfs_buf, Christoph Hellwig
- [PATCH 19/20] xfs: properly type the b_log_item field in struct xfs_buf, Christoph Hellwig
- Re: use bios directly in the log code v2, Darrick J. Wong
- [PATCH] xfs: fix broken log reservation debugging,
Darrick J. Wong
- [GIT PULL] xfs: fixes for 5.2,
Darrick J. Wong
- [RFC][PATCH] kernel.h: Add generic roundup_64() macro,
Steven Rostedt
- [PATCH v2 00/11] xfs: rework extent allocation,
Brian Foster
- [PATCH v2 01/11] xfs: clean up small allocation helper, Brian Foster
- [PATCH v2 03/11] xfs: skip small alloc cntbt logic on NULL cursor, Brian Foster
- [PATCH v2 02/11] xfs: move small allocation helper, Brian Foster
- [PATCH v2 04/11] xfs: always update params on small allocation, Brian Foster
- [PATCH v2 05/11] xfs: track active state of allocation btree cursors, Brian Foster
- [PATCH v2 06/11] xfs: use locality optimized cntbt lookups for near mode allocations, Brian Foster
- [PATCH v2 07/11] xfs: refactor exact extent allocation mode, Brian Foster
- [PATCH v2 08/11] xfs: refactor by-size extent allocation mode, Brian Foster
- [PATCH v2 09/11] xfs: replace small allocation logic with agfl only logic, Brian Foster
- [PATCH v2 10/11] xfs: refactor successful AG allocation accounting code, Brian Foster
- [PATCH v2 11/11] xfs: condense high level AG allocation functions, Brian Foster
- Re: [PATCH v2 00/11] xfs: rework extent allocation, Dave Chinner
- Re: [PATCH v2 00/11] xfs: rework extent allocation, Darrick J. Wong
- Recurring hand in XFS inode reclaim on 4.10,
Jeffrey Baker
- [ANNOUNCE] xfsprogs for-next updated to 5539639, Eric Sandeen
- [ANNOUNCE] xfs-linux: for-next updated to 5cd213b0fec6, Darrick J. Wong
- [PATCH v10 0/7] virtio pmem driver,
Pankaj Gupta
- [PATCH 0/7] xfsprogs: libxfs spring cleaning take 3,
Eric Sandeen
- [PATCH 0/8] xfsprogs: document the ioctls scrub uses,
Darrick J. Wong
- [PATCH 00/12] xfsprogs-5.1: fix various problems,
Darrick J. Wong
- [PATCH 01/12] libxfs: fix attr include mess, Darrick J. Wong
- [PATCH 02/12] libxfs: set m_finobt_nores when initializing library, Darrick J. Wong
- [PATCH 03/12] libxfs: refactor online geometry queries, Darrick J. Wong
- [PATCH 04/12] libxfs: refactor open-coded bulkstat calls, Darrick J. Wong
- [PATCH 05/12] libxfs: refactor open-coded INUMBERS calls, Darrick J. Wong
- [PATCH 06/12] misc: remove all use of xfs_fsop_geom_t, Darrick J. Wong
- [PATCH 07/12] libfrog: fix bitmap return values, Darrick J. Wong
- [PATCH 08/12] xfs_repair: refactor namecheck functions, Darrick J. Wong
- [PATCH 09/12] xfs_scrub: fix background-mode sleep throttling, Darrick J. Wong
- [PATCH 10/12] mkfs: allow setting dax flag on root directory, Darrick J. Wong
- [PATCH 11/12] mkfs: validate start and end of aligned logs, Darrick J. Wong
- [PATCH 12/12] mkfs: enable reflink by default, Darrick J. Wong
- [PATCH 0/1] xfs: test overflow of delalloc block counters,
Darrick J. Wong
- [PATCH 0/1] xfs: health tracking tests,
Darrick J. Wong
- [ANNOUNCE] xfsdump updated to 86b0b04, Eric Sandeen
- use bios directly in the log code,
Christoph Hellwig
- [PATCH 01/17] xfs: remove the no-op spinlock_destroy stub, Christoph Hellwig
- [PATCH 02/17] xfs: remove the never used _XBF_COMPOUND flag, Christoph Hellwig
- [PATCH 03/17] xfs: renumber XBF_WRITE_FAIL, Christoph Hellwig
- [PATCH 04/17] xfs: reformat xlog_get_lowest_lsn, Christoph Hellwig
- [PATCH 05/17] xfs: don't use REQ_PREFLUSH for split log writes, Christoph Hellwig
- [PATCH 06/17] xfs: factor out log buffer writing, Christoph Hellwig
- [PATCH 07/17] xfs: factor out splitting of an iclog from xlog_sync, Christoph Hellwig
- [PATCH 08/17] xfs: split iclog size calculation out of xlog_sync, Christoph Hellwig
- [PATCH 09/17] xfs: update both state counters together in xlog_sync, Christoph Hellwig
- [PATCH 10/17] xfs: remove the syncing argument from xlog_verify_iclog, Christoph Hellwig
- [PATCH 11/17] xfs: make use of the l_targ field in struct xlog, Christoph Hellwig
- [PATCH 12/17] xfs: use bios directly to write log buffers, Christoph Hellwig
- [PATCH 13/17] xfs: return an offset instead of a pointer from xlog_align, Christoph Hellwig
- [PATCH 14/17] xfs: use bios directly to read and write the log recovery buffers, Christoph Hellwig
- [PATCH 15/17] xfs: remove unused buffer cache APIs, Christoph Hellwig
- [PATCH 16/17] xfs: properly type the b_log_item field in struct xfs_buf, Christoph Hellwig
- [PATCH 17/17] xfs: remove the b_io_length field in struct xfs_buf, Christoph Hellwig
- [Bug 203655] New: XFS: Assertion failed: 0, xfs_log_recover.c, line: 551,
bugzilla-daemon
- Re: [Bug 203655] New: XFS: Assertion failed: 0, xfs_log_recover.c, line: 551, Brian Foster
- [Bug 203655] XFS: Assertion failed: 0, xfs_log_recover.c, line: 551, bugzilla-daemon
- [Bug 203655] XFS: Assertion failed: 0, xfs_log_recover.c, line: 551, bugzilla-daemon
- [Bug 203655] XFS: Assertion failed: 0, xfs_log_recover.c, line: 551, bugzilla-daemon
- [Bug 203655] XFS: Assertion failed: 0, xfs_log_recover.c, line: 551, bugzilla-daemon
- [Bug 203653] New: XFS: Internal error xlog_clear_stale_blocks(2) at line 1794 of file ../fs/xfs/xfs_log_recover.c,
bugzilla-daemon
- [PATCH v2] xfs_io: support splice data between two files,
Zorro Lang
- [PATCH] xfsdump: add a space after commas and semicolons where was none,
Jan Tulak
- misc log item related cleanups,
Christoph Hellwig
- [PATCH 01/20] xfs: fix a trivial comment typo in the xfs_trans_committed_bulk, Christoph Hellwig
- [PATCH 02/20] xfs: stop using XFS_LI_ABORTED as a parameter flag, Christoph Hellwig
- [PATCH 03/20] xfs: don't require log items to implement optional methods, Christoph Hellwig
- [PATCH 04/20] xfs: remove the dummy iop_push implementation for inode creation items, Christoph Hellwig
- [PATCH 05/20] xfs: remove the iop_push implementation for quota off items, Christoph Hellwig
- [PATCH 06/20] xfs: don't use xfs_trans_free_items in the commit path, Christoph Hellwig
- [PATCH 07/20] xfs: split iop_unlock, Christoph Hellwig
- [PATCH 08/20] xfs: add a flag to release log items on commit, Christoph Hellwig
- [PATCH 09/20] xfs: don't cast inode_log_items to get the log_item, Christoph Hellwig
- [PATCH 10/20] xfs: remove the xfs_log_item_t typedef, Christoph Hellwig
- [PATCH 11/20] xfs: use a list_head for iclog callbacks, Christoph Hellwig
- [PATCH 12/20] xfs: remove a pointless comment duplicated above all xfs_item_ops instances, Christoph Hellwig
- [PATCH 13/20] xfs: merge xfs_efd_init into xfs_trans_get_efd, Christoph Hellwig
- [PATCH 14/20] xfs: merge xfs_cud_init into xfs_trans_get_cud, Christoph Hellwig
- [PATCH 15/20] xfs: merge xfs_rud_init into xfs_trans_get_rud, Christoph Hellwig
- [PATCH 16/20] xfs: merge xfs_bud_init into xfs_trans_get_bud, Christoph Hellwig
- [PATCH 17/20] xfs: merge xfs_trans_extfree.c into xfs_extfree_item.c, Christoph Hellwig
- [PATCH 18/20] xfs: merge xfs_trans_refcount.c into xfs_refcount_item.c, Christoph Hellwig
- [PATCH 19/20] xfs: merge xfs_trans_rmap.c into xfs_rmap_item.c, Christoph Hellwig
- [PATCH 20/20] xfs: merge xfs_trans_bmap.c into xfs_bmap_item.c, Christoph Hellwig
- Question about commit b450672fb66b ("iomap: sub-block dio needs to zeroout beyond EOF"),
Hou Tao
- [PATCH 0/3] xfsprogs: more libxfs/ spring cleaning,
Eric Sandeen
- [PATCH 1/3] libxfs: rename shared kernel functions from libxfs_ to xfs_, Eric Sandeen
- [PATCH 2/3] libxfs: remove libxfs API #defines for unexported xfs functions, Eric Sandeen
- [PATCH 3/3] xfsprogs: remove unused flags arg from getsb interfaces, Eric Sandeen
- [PATCH 4/3] libxfs: Remove XACT_DEBUG #ifdefs, Eric Sandeen
- [PATCH 5/3] libxfs: rename bli_format to avoid confusion with bli_formats, Eric Sandeen
- [PATCH 6/3] libxfs: factor common xfs_trans_bjoin code, Eric Sandeen
- [PATCH 7/3] libxfs: fix argument to xfs_trans_add_item, Eric Sandeen
- [PATCH 8/3] xfs: factor log item initialisation, Eric Sandeen
- [PATCH 9/3] libxfs: create current_time helper and sync xfs_trans_ichgtime, Eric Sandeen
- [PATCH 10/3] libxfs: share kernel's xfs_trans_inode.c, Eric Sandeen
- Re: [PATCH 0/3] xfsprogs: more libxfs/ spring cleaning, Darrick J. Wong
- [ANNOUNCE] xfsprogs for-next updated to 065a57f, Eric Sandeen
- [PATCH v2] xfs: merge xfs_buf_zero and xfs_buf_iomove,
Christoph Hellwig
- xfsdump confused by ino's < root ino,
Omar Sandoval
- [PATCH] xfs: remove unused flag arguments,
Eric Sandeen
- [PATCH] xfsdump: (style) remove spaces for pointers and negations,
Jan Tulak
- [PATCH] xfs: remove the debug-only q_transp field from struct xfs_dquot,
Christoph Hellwig
- [PATCH] xfs: merge xfs_buf_zero and xfs_buf_iomove,
Christoph Hellwig
[Index of Archives]
[XFS Filesystem Development]
[Linux USB Devel]
[Linux SCSI]
[Linux RAID]
[Yosemite Forum]