Linux Live Patching
[Prev Page][Next Page]
- [PATCH 0/2] vhost: improve livepatch switching for heavily loaded vhost worker kthreads,
Seth Forshee (DigitalOcean)
- Re: [PATCH v9] livepatch: Clear relocation targets on a module removal,
Josh Poimboeuf
- [PATCHv3 bpf-next 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Jiri Olsa
- [PATCHv2 bpf-next 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Jiri Olsa
- [PATCH v3] kallsyms: Remove the performance test from kallsyms_selftest.c,
Zhen Lei
- [PATCH v8] livepatch: Clear relocation targets on a module removal,
Song Liu
- [PATCH 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Zhen Lei
- [PATCH v7] livepatch: Clear relocation targets on a module removal,
Song Liu
- [GIT PULL] livepatching for 6.2,
Petr Mladek
- [PATCH] livepatch: Call klp_match_callback() in klp_find_callback() to avoid code duplication,
Zhen Lei
- Re: [PATCH v6] livepatch: Clear relocation targets on a module removal,
Song Liu
- [PATCH v9] kallsyms: Add self-test facility,
Zhen Lei
- Re: [PATCH v9] kallsyms: Add self-test facility, Luis Chamberlain
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- [PATCH 40/46] x86/livepatch, lto: Disable live patching with gcc LTO,
Jiri Slaby (SUSE)
- [PATCH v8 0/9] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
- [PATCH v8 1/9] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
- [PATCH v8 3/9] kallsyms: Correctly sequence symbols when CONFIG_LTO_CLANG=y, Zhen Lei
- [PATCH v8 5/9] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
- [PATCH v8 9/9] kallsyms: Add self-test facility, Zhen Lei
- [PATCH v8 4/9] kallsyms: Reduce the memory occupied by kallsyms_seqs_of_names[], Zhen Lei
- [PATCH v8 7/9] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v8 8/9] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v8 2/9] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
- [PATCH v8 6/9] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
- Re: [PATCH v8 0/9] kallsyms: Optimizes the performance of lookup symbols, Luis Chamberlain
- [PATCH v2 0/4] livepatch: Add garbage collection for shadow variables,
Marcos Paulo de Souza
- [PATCH v7 00/11] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[PATCH v7 08/11] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
[PATCH v7 01/11] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
[PATCH v7 03/11] scripts/kallsyms: remove helper sym_name() and cleanup, Zhen Lei
[PATCH v7 06/11] kallsyms: Improve the performance of kallsyms_lookup_name() when CONFIG_LTO_CLANG=y, Zhen Lei
[PATCH v7 02/11] scripts/kallsyms: don't compress symbol types, Zhen Lei
[PATCH v7 05/11] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
[PATCH v7 07/11] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
[PATCH v7 10/11] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
[PATCH v7 09/11] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
[PATCH v7 04/11] kallsyms: Add helper kallsyms_compress_symbol_name(), Zhen Lei
Re: [PATCH v7 00/11] kallsyms: Optimizes the performance of lookup symbols, Luis Chamberlain
[GIT PULL] livepatching for 6.1,
Petr Mladek
[PATCH] livepatch: Move the result-invariant calculation out of the loop,
Zhen Lei
[PATCH v10 00/27] Rust support,
Miguel Ojeda
[PATCH v6 00/11] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[PATCH v6 09/11] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
[PATCH v6 10/11] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
[PATCH v5 00/10] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
- [PATCH v5 09/10] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v5 02/10] scripts/kallsyms: don't compress symbol types, Zhen Lei
- [PATCH v5 01/10] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
- [PATCH v5 03/10] scripts/kallsyms: remove helper sym_name() and cleanup, Zhen Lei
- [PATCH v5 08/10] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v5 07/10] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
- [PATCH v5 06/10] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
- [PATCH v5 04/10] scripts/kallsyms: generate kallsyms_best_token_table[], Zhen Lei
- [PATCH v5 10/10] kallsyms: Add self-test facility, Zhen Lei
- [PATCH v5 05/10] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
[PATCH v4 0/8] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[PATCH v3 0/8] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[RFC] Objtool toolchain proposal: -fannotate-{jump-table,noreturn},
Josh Poimboeuf
[PATCH v2 0/8] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[PATCH 0/7] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[PATCH v3 0/2] add sysfs entry "patched" for each klp_object,
Song Liu
[PATCH] livepatch: Move error print out of lock protection in klp_enable_patch(),
Zhen Lei
Re: [PATCH v5] livepatch: Clear relocation targets on a module removal,
Christophe Leroy
[PATCH] livepatch: Add a missing newline character in klp_module_coming(),
Zhen Lei
[RFC PATCH 0/3] kallsyms: add option to include relative filepaths into kallsyms,
Alexander Lobakin
ftrace regression with CONFIG_UNWINDER_FRAME_POINTER,
Johannes Erdfelt
[PATCH] selftests/livepatch: normalize sysctl error message,
Joe Lawrence
[PATCH v5] livepatch: fix race between fork and KLP transition,
Rik van Riel
[PATCH v9 00/27] Rust support,
Miguel Ojeda
[GIT PULL] livepatching for 5.20,
Petr Mladek
[PATCH v8 00/31] Rust support,
Miguel Ojeda
[PATCH v2 0/2] add sysfs entry "patched" for each klp_object,
Song Liu
[PATCH v4] livepatch: Clear relocation targets on a module removal,
Song Liu
[PATCH bpf-next] bpf: fix test_progs -j error with fentry/fexit tests,
Song Liu
[PATCH RFC] livepatch: add sysfs entry "patched" for each klp_object,
Song Liu
[PATCH v3] livepatch: Clear relocation targets on a module removal,
Song Liu
unload and reload modules with patched function,
Song Liu
[PATCH,RFC] livepatch: fix race between fork and klp_reverse_transition,
Rik van Riel
Re: ftrace_kill() leads to kmalloc-512 UAF,
Steven Rostedt
[PATCH v5 bpf-next 0/4] ftrace: host klp and bpf trampoline together,
Song Liu
[PATCH v4 bpf-next 0/4] ftrace: host klp and bpf trampoline together,
Song Liu
[PATCH v3 bpf-next 0/4] ftrace: host klp and bpf trampoline together,
Song Liu
Re: [PATCH v2 bpf-next 0/5] ftrace: host klp and bpf trampoline together,
Steven Rostedt
[PATCH v16 0/1] arm64: Reorganize the unwinder,
madvenka
[PATCH] init/Kconfig: update KALLSYMS_ALL help text,
Baruch Siach
[PATCH 0/4] livepatch: Add garbage collection for shadow variables,
Marcos Paulo de Souza
Re: [PATCH 1/2] modules: Ensure natural alignment for .altinstructions and __bug_table sections,
Luis Chamberlain
[PATCH v2 0/2] livepatch: Move tests from lib/livepatch to selftests/livepatch,
Marcos Paulo de Souza
[PATCH v5 00/33] objtool: add base support for arm64,
Chen Zhongjin
- [PATCH v5 16/33] arm64: kgdb: Add reachable annotation after kgdb brk, Chen Zhongjin
- [PATCH v5 13/33] objtool: arm64: Enable ORC for arm64, Chen Zhongjin
- [PATCH v5 02/33] objtool: arm64: Add base definition for arm64 backend, Chen Zhongjin
- [PATCH v5 09/33] objtool: check: Support data in text section, Chen Zhongjin
- [PATCH v5 17/33] objtool: arm64: Add unwind_hint support, Chen Zhongjin
- [PATCH v5 15/33] arm64: bug: Add reachable annotation to warning macros, Chen Zhongjin
- [PATCH v5 10/33] objtool: arm64: Handle supported relocations in alternatives, Chen Zhongjin
- [PATCH v5 14/33] objtool: arm64: Add annotate_reachable() for objtools, Chen Zhongjin
- [PATCH v5 01/33] tools: arm64: Make aarch64 instruction decoder available to tools, Chen Zhongjin
- [PATCH v5 04/33] objtool: arm64: Decode jump and call related instructions, Chen Zhongjin
- [PATCH v5 03/33] objtool: arm64: Decode add/sub instructions, Chen Zhongjin
- [PATCH v5 07/33] objtool: arm64: Decode LDR instructions, Chen Zhongjin
- [PATCH v5 08/33] objtool: arm64: Accept non-instruction data in code sections, Chen Zhongjin
- [PATCH v5 12/33] objtool: arm64: Enable stack validation for arm64, Chen Zhongjin
- [PATCH v5 18/33] arm64: Change symbol type annotations, Chen Zhongjin
- [PATCH v5 05/33] objtool: arm64: Decode other system instructions, Chen Zhongjin
- [PATCH v5 06/33] objtool: arm64: Decode load/store instructions, Chen Zhongjin
- [PATCH v5 11/33] objtool: arm64: Ignore replacement section for alternative callback, Chen Zhongjin
- [PATCH v5 22/33] arm64: efi-header: Mark efi header as data, Chen Zhongjin
- [PATCH v5 31/33] arm64: kernel: Skip validation of proton-pack.c, Chen Zhongjin
- [PATCH v5 23/33] arm64: head: Mark constants as data, Chen Zhongjin
- [PATCH v5 26/33] arm64: crypto: Remove unnecessary stackframe, Chen Zhongjin
[Index of Archives]
[Linux Kernel]
[Linux NFS]
[Linux NILFS]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]