On Wed 2022-12-14 09:40:35, Song Liu wrote: > From: Miroslav Benes <mbenes@xxxxxxx> > > Josh reported a bug: > > When the object to be patched is a module, and that module is > rmmod'ed and reloaded, it fails to load with: > > module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 2, loc 00000000ba0302e9, val ffffffffa03e293c > livepatch: failed to initialize patch 'livepatch_nfsd' for module 'nfsd' (-8) > livepatch: patch 'livepatch_nfsd' failed for module 'nfsd', refusing to load module 'nfsd' > > The livepatch module has a relocation which references a symbol > in the _previous_ loading of nfsd. When apply_relocate_add() > tries to replace the old relocation with a new one, it sees that > the previous one is nonzero and it errors out. > > On ppc64le, we have a similar issue: > > module_64: livepatch_nfsd: Expected nop after call, got e8410018 at e_show+0x60/0x548 [livepatch_nfsd] > livepatch: failed to initialize patch 'livepatch_nfsd' for module 'nfsd' (-8) > livepatch: patch 'livepatch_nfsd' failed for module 'nfsd', refusing to load module 'nfsd' > > He also proposed three different solutions. We could remove the error > check in apply_relocate_add() introduced by commit eda9cec4c9a1 > ("x86/module: Detect and skip invalid relocations"). However the check > is useful for detecting corrupted modules. > > We could also deny the patched modules to be removed. If it proved to be > a major drawback for users, we could still implement a different > approach. The solution would also complicate the existing code a lot. > > We thus decided to reverse the relocation patching (clear all relocation > targets on x86_64). The solution is not > universal and is too much arch-specific, but it may prove to be simpler > in the end. > > --- a/arch/x86/kernel/module.c > +++ b/arch/x86/kernel/module.c > @@ -163,40 +165,60 @@ static int __apply_relocate_add(Elf64_Shdr *sechdrs, > case R_X86_64_NONE: > break; > case R_X86_64_64: > - if (*(u64 *)loc != 0) > - goto invalid_relocation; > - write(loc, &val, 8); > + if (apply) { > + if (*(u64 *)loc != 0) > + goto invalid_relocation; > + write(loc, &val, 8); > + } else { > + write(loc, &zero, 8); It might make sense to check if the cleared value is the expected one. if (*(u64 *)loc != (u64)val) goto invalid_relocation; write(loc, &zero, 8); Maybe, we could put this into a helper function or macro that would do this operation #define check_and_write(loc, orig_val, new_val, type) \ ({ \ int err = 0; \ \ if (*(type)loc == (type)old_val) \ write(loc, &new_val, sizeof(type)); \ else \ err = -EINVAL; \ \ err; \ }) It would make it more robust. The relocation might be different when it it redirected somewhere, for example, by ftrace. Something might go wrong in this case. On the other hand. I wonder if the relocation might actually by redirected intentionally, for example, by apply_alternatives() or apply_retpolines(). These would be hard to check. Best Regards, Petr