Hi folks, Could you please share your comments on v8 patch? Thanks, Song On Fri, Jan 6, 2023 at 12:01 PM Song Liu <song@xxxxxxxxxx> wrote: > > From: Miroslav Benes <mbenes@xxxxxxx> > > Josh reported a bug: > > When the object to be patched is a module, and that module is > rmmod'ed and reloaded, it fails to load with: > > module: x86/modules: Skipping invalid relocation target, existing value is nonzero for type 2, loc 00000000ba0302e9, val ffffffffa03e293c > livepatch: failed to initialize patch 'livepatch_nfsd' for module 'nfsd' (-8) > livepatch: patch 'livepatch_nfsd' failed for module 'nfsd', refusing to load module 'nfsd' > > The livepatch module has a relocation which references a symbol > in the _previous_ loading of nfsd. When apply_relocate_add() > tries to replace the old relocation with a new one, it sees that > the previous one is nonzero and it errors out. > > On ppc64le, we have a similar issue: > > module_64: livepatch_nfsd: Expected nop after call, got e8410018 at e_show+0x60/0x548 [livepatch_nfsd] > livepatch: failed to initialize patch 'livepatch_nfsd' for module 'nfsd' (-8) > livepatch: patch 'livepatch_nfsd' failed for module 'nfsd', refusing to load module 'nfsd' > > He also proposed three different solutions. We could remove the error > check in apply_relocate_add() introduced by commit eda9cec4c9a1 > ("x86/module: Detect and skip invalid relocations"). However the check > is useful for detecting corrupted modules. > > We could also deny the patched modules to be removed. If it proved to be > a major drawback for users, we could still implement a different > approach. The solution would also complicate the existing code a lot. > > We thus decided to reverse the relocation patching (clear all relocation > targets on x86_64). The solution is not > universal and is too much arch-specific, but it may prove to be simpler > in the end. > > Signed-off-by: Miroslav Benes <mbenes@xxxxxxx> > Signed-off-by: Song Liu <song@xxxxxxxxxx> > Reported-by: Josh Poimboeuf <jpoimboe@xxxxxxxxxx> > > --- > > NOTE: powerpc32 code is only compile tested. > > Changes v7 = v8: > 1. Remove the logic in powerpc/kernel/module_64.c, as there is ongoing > discussions. > 2. For x86_64, add check for expected value during clear_relocate_add(). > (Petr Mladek) > 3. Optimize the logic in klp_write_section_relocs(). (Petr Mladek) > 4. Optimize __write_relocate_add (x86_64). (Joe Lawrence) > > Changes v6 = v7: > 1. Reduce code duplication in livepatch/core.c and x86/kernel/module.c. > 2. Add more comments to powerpc/kernel/module_64.c. > 3. Added Joe's Tested-by (which I should have added in v6). [...]