Linux Live Patching
[Prev Page][Next Page]
- Re: [PATCH] doc: module: update file references, (continued)
- [PATCH 0/2] livepatch: Move tests from lib/livepatch to selftests/livepatch,
Marcos Paulo de Souza
- [PATCH v2] selftests/livepatch: better synchronize test_klp_callbacks_busy,
Joe Lawrence
- [GIT PULL] livepatching for 5.19,
Petr Mladek
- [GIT PULL] Modules fixes for v5.19-rc1,
Luis Chamberlain
- [RFC PATCH v2 00/20] arm64: livepatch: Use ORC for dynamic frame pointer validation,
madvenka
- [RFC PATCH v2 01/20] objtool: Reorganize CFI code, madvenka
- [RFC PATCH v2 03/20] objtool: Move decode_instructions() to a separate file, madvenka
- [RFC PATCH v2 02/20] objtool: Reorganize instruction-related code, madvenka
- [RFC PATCH v2 04/20] objtool: Reorganize Unwind hint code, madvenka
- [RFC PATCH v2 07/20] objtool: Reorganize ORC kernel code, madvenka
- [RFC PATCH v2 10/20] objtool: arm64: Compute destinations for call and jump instructions, madvenka
- [RFC PATCH v2 08/20] objtool: arm64: Implement decoder for FP validation, madvenka
- [RFC PATCH v2 14/20] objtool: arm64: Add unwind hint support, madvenka
- [RFC PATCH v2 06/20] objtool: Reorganize ORC code, madvenka
- [RFC PATCH v2 11/20] objtool: arm64: Walk instructions and compute CFI for each instruction, madvenka
- [RFC PATCH v2 09/20] objtool: arm64: Implement command to invoke the decoder, madvenka
- [RFC PATCH v2 13/20] objtool: arm64: Dump ORC data present in object files, madvenka
- [RFC PATCH v2 05/20] objtool: Reorganize ORC types, madvenka
- [RFC PATCH v2 12/20] objtool: arm64: Generate ORC data from CFI for object files, madvenka
- [RFC PATCH v2 15/20] arm64: Add unwind hints to specific points in code, madvenka
- [RFC PATCH v2 16/20] arm64: Add kernel and module support for ORC, madvenka
- [RFC PATCH v2 18/20] arm64: unwinder: Add a reliability check in the unwinder based on ORC, madvenka
- [RFC PATCH v2 20/20] arm64: Enable livepatch for ARM64, madvenka
- [RFC PATCH v2 19/20] arm64: Miscellaneous changes required for enabling livepatch, madvenka
- [RFC PATCH v2 17/20] arm64: Build the kernel with ORC information, madvenka
- Re: [RFC PATCH v2 00/20] arm64: livepatch: Use ORC for dynamic frame pointer validation, Chen Zhongjin
- Re: [RFC PATCH v2 00/20] arm64: livepatch: Use ORC for dynamic frame pointer validation, Ivan T. Ivanov
- [PATCH v7 00/25] Rust support,
Miguel Ojeda
- [PATCH] selftests/livepatch: better synchronize test_klp_callbacks_busy,
Joe Lawrence
- [RFC] sched,livepatch: call klp_try_switch_task in __cond_resched,
Song Liu
- [PATCH v6 00/23] Rust support,
Miguel Ojeda
- [PATCH v2 0/3] kallsyms: Rust requirements,
Miguel Ojeda
- [PATCH v1 0/3] kallsyms: Rust requirements,
Miguel Ojeda
- [PATCH] entry/kvm: Exit to user mode when TIF_NOTIFY_SIGNAL is set,
Seth Forshee
- [PATCH v2] entry/kvm: Make vCPU tasks exit to userspace when a livepatch is pending,
Seth Forshee
- [PATCH] entry/kvm: Make vCPU tasks exit to userspace when a livepatch is pending,
Seth Forshee
- [PATCH v14 0/7] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v14 5/7] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v14 4/7] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v14 1/7] arm64: Split unwind_init(), madvenka
- [PATCH v14 2/7] arm64: Copy the task argument to unwind_state, madvenka
- [PATCH v14 3/7] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v14 7/7] arm64: Select HAVE_RELIABLE_STACKTRACE, madvenka
- [PATCH v14 6/7] arm64: Introduce arch_stack_walk_reliable(), madvenka
- Re: [PATCH v14 0/7] arm64: Reorganize the unwinder and implement stack trace reliability checks, Madhavan T. Venkataraman
- Re: [PATCH v14 0/7] arm64: Reorganize the unwinder and implement stack trace reliability checks, Madhavan T. Venkataraman
- Re: [PATCH v14 0/7] arm64: Reorganize the unwinder and implement stack trace reliability checks, Mark Brown
- [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation,
madvenka
- [RFC PATCH v1 3/9] dwarf: Build the kernel with DWARF information, madvenka
- [RFC PATCH v1 2/9] objtool: Generate DWARF rules and place them in a special section, madvenka
- [RFC PATCH v1 4/9] dwarf: Implement DWARF rule processing in the kernel, madvenka
- [RFC PATCH v1 5/9] dwarf: Implement DWARF support for modules, madvenka
- [RFC PATCH v1 6/9] arm64: unwinder: Add a reliability check in the unwinder based on DWARF CFI, madvenka
- [RFC PATCH v1 7/9] arm64: dwarf: Implement unwind hints, madvenka
- [RFC PATCH v1 9/9] dwarf: Enable livepatch for ARM64, madvenka
- [RFC PATCH v1 8/9] dwarf: Miscellaneous changes required for enabling livepatch, madvenka
- [RFC PATCH v1 1/9] objtool: Parse DWARF Call Frame Information in object files, madvenka
- Re: [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation, Josh Poimboeuf
- Re: [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation, Madhavan T. Venkataraman
- Re: [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation, Peter Zijlstra
- Re: [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation, Peter Zijlstra
[GIT PULL] livepatching for 5.18,
Petr Mladek
[PATCH] livepatch: Remove klp_arch_set_pc() and asm/livepatch.h,
Christophe Leroy
[PATCH v2] livepatch: Reorder to use before freeing a pointer,
trix
[PATCH] livepatch: Reorder to use before freeing a pointer,
trix
[PATCH v5 00/20] Rust support,
Miguel Ojeda
[PATCH v3] livepatch: Don't block removal of patches that are safe to unload,
Chengming Zhou
[no subject], Unknown
[PATCH v2] livepatch: Don't block removal of patches that are safe to unload,
Chengming Zhou
[PATCH] livepatch: Only block the removal of KLP_UNPATCHED forced transition patch,
Chengming Zhou
[PATCH v6 11/13] module: Move sysfs support into a separate file,
Aaron Tomlin
[PATCH v6 00/13] module: core code clean up,
Aaron Tomlin
- [PATCH v6 01/13] module: Move all into module/, Aaron Tomlin
- [PATCH v6 02/13] module: Simple refactor in preparation for split, Aaron Tomlin
- [PATCH v6 06/13] module: Move strict rwx support to a separate file, Aaron Tomlin
- [PATCH v6 04/13] module: Move livepatch support to a separate file, Aaron Tomlin
- [PATCH v6 09/13] module: Move kallsyms support into a separate file, Aaron Tomlin
- [PATCH v6 08/13] module: Move kmemleak support to a separate file, Aaron Tomlin
- [PATCH v6 10/13] module: Move procfs support into a separate file, Aaron Tomlin
- [PATCH v6 03/13] module: Make internal.h and decompress.c more compliant, Aaron Tomlin
- [PATCH v6 07/13] module: Move extra signature support out of core code, Aaron Tomlin
- [PATCH v6 05/13] module: Move latched RB-tree support to a separate file, Aaron Tomlin
- Re: [PATCH v6 00/13] module: core code clean up, Luis Chamberlain
[no subject], Unknown
[RFC PATCH v6 00/12] livepatch: klp-convert tool,
Joe Lawrence
- [RFC PATCH v6 02/12] kbuild: Support for symbols.klp creation, Joe Lawrence
- [RFC PATCH v6 01/12] livepatch: Create and include UAPI headers, Joe Lawrence
- [RFC PATCH v6 05/12] modpost: Integrate klp-convert, Joe Lawrence
- [RFC PATCH v6 07/12] documentation: Update on livepatch elf format, Joe Lawrence
- [RFC PATCH v6 03/12] livepatch: Add klp-convert tool, Joe Lawrence
- [RFC PATCH v6 04/12] livepatch: Add klp-convert annotation helpers, Joe Lawrence
- [RFC PATCH v6 10/12] livepatch/selftests: add __asm__ symbol renaming examples, Joe Lawrence
- [RFC PATCH v6 09/12] livepatch/selftests: test multiple sections, Joe Lawrence
- [RFC PATCH v6 11/12] livepatch/selftests: add data relocations test, Joe Lawrence
- [RFC PATCH v6 08/12] livepatch/selftests: add klp-convert, Joe Lawrence
- [RFC PATCH v6 06/12] livepatch: Add sample livepatch module, Joe Lawrence
- [RFC PATCH v6 12/12] livepatch/selftests: add static keys test, Joe Lawrence
- Re: [RFC PATCH v6 00/12] livepatch: klp-convert tool, Joe Lawrence
- Re: [RFC PATCH v6 00/12] livepatch: klp-convert tool, Marcos Paulo de Souza
[PATCH v3] livepatch: Skip livepatch tests if ftrace cannot be configured,
David Vernet
[PATCH v4 00/20] Rust support,
Miguel Ojeda
[no subject], Unknown
[no subject], Unknown
[no subject], Unknown
[no subject], Unknown
[PATCH v10 00/15] Function Granular KASLR,
Alexander Lobakin
- [PATCH v10 14/15] Documentation: add documentation for FG-KASLR, Alexander Lobakin
- [PATCH v10 01/15] modpost: fix removing numeric suffixes, Alexander Lobakin
- [PATCH v10 05/15] x86: support asm function sections, Alexander Lobakin
- [PATCH v10 12/15] module: add arch-indep FG-KASLR for randomizing function layout, Alexander Lobakin
- [PATCH v10 09/15] x86: Add support for function granular KASLR, Alexander Lobakin
- [PATCH v10 15/15] maintainers: add MAINTAINERS entry for FG-KASLR, Alexander Lobakin
- [PATCH v10 07/15] Makefile: add config options and build scripts for FG-KASLR, Alexander Lobakin
- [PATCH v10 06/15] x86: decouple ORC table sorting into a separate file, Alexander Lobakin
- [PATCH v10 10/15] FG-KASLR: use a scripted approach to handle .text.* sections, Alexander Lobakin
- [PATCH v10 03/15] kallsyms: randomize /proc/kallsyms output order, Alexander Lobakin
- [PATCH v10 04/15] arch: introduce asm function sections, Alexander Lobakin
- [PATCH v10 02/15] livepatch: avoid position-based search if `-z unique-symbol` is available, Alexander Lobakin
- [PATCH v10 11/15] x86/boot: allow FG-KASLR to be selected, Alexander Lobakin
- [PATCH v10 08/15] x86/tools: Add relative relocs for randomized functions, Alexander Lobakin
- [PATCH v10 13/15] module: use a scripted approach for FG-KASLR, Alexander Lobakin
[PATCH v5 11/13] module: Move sysfs support into a separate file,
Aaron Tomlin
[PATCH v5 07/13] module: Move extra signature support out of core code,
Aaron Tomlin
[PATCH v5 00/13] module: core code clean up,
Aaron Tomlin
[PATCH] livepatch: Skip livepatch tests if ftrace cannot be configured,
David Vernet
[RFC PATCH v4 00/13] module: core code clean up,
Aaron Tomlin
- [RFC PATCH v4 01/13] module: Move all into module/, Aaron Tomlin
- [RFC PATCH v4 02/13] module: Simple refactor in preparation for split, Aaron Tomlin
- [RFC PATCH v4 03/13] module: Move livepatch support to a separate file, Aaron Tomlin
- [RFC PATCH v4 05/13] module: Move arch strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v4 04/13] module: Move latched RB-tree support to a separate file, Aaron Tomlin
- [RFC PATCH v4 06/13] module: Move strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v4 11/13] module: Move sysfs support into a separate file, Aaron Tomlin
- [RFC PATCH v4 12/13] module: Move kdb_modules list out of core code, Aaron Tomlin
- [RFC PATCH v4 13/13] module: Move version support into a separate file, Aaron Tomlin
- [RFC PATCH v4 10/13] module: Move procfs support into a separate file, Aaron Tomlin
- [RFC PATCH v4 09/13] module: Move kallsyms support into a separate file, Aaron Tomlin
- [RFC PATCH v4 08/13] module: Move kmemleak support to a separate file, Aaron Tomlin
- [RFC PATCH v4 07/13] module: Move extra signature support out of core code, Aaron Tomlin
- Re: [RFC PATCH v4 00/13] module: core code clean up, Allen
- Re: [RFC PATCH v4 00/13] module: core code clean up, Luis Chamberlain
- Re: [RFC PATCH v4 00/13] module: core code clean up, Luis Chamberlain
[RFC PATCH v3 00/13] module: core code clean up,
Aaron Tomlin
- [RFC PATCH v3 01/13] module: Move all into module/, Aaron Tomlin
- [RFC PATCH v3 03/13] module: Move livepatch support to a separate file, Aaron Tomlin
- [RFC PATCH v3 02/13] module: Simple refactor in preparation for split, Aaron Tomlin
- [RFC PATCH v3 05/13] module: Move arch strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v3 04/13] module: Move latched RB-tree support to a separate file, Aaron Tomlin
- [RFC PATCH v3 06/13] module: Move strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v3 07/13] module: Move extra signature support out of core code, Aaron Tomlin
- [RFC PATCH v3 08/13] module: Move kmemleak support to a separate file, Aaron Tomlin
- [RFC PATCH v3 10/13] module: Move procfs support into a separate file, Aaron Tomlin
- [RFC PATCH v3 09/13] module: Move kallsyms support into a separate file, Aaron Tomlin
- [RFC PATCH v3 11/13] module: Move sysfs support into a separate file, Aaron Tomlin
- [RFC PATCH v3 13/13] module: Move version support into a separate file, Aaron Tomlin
- [RFC PATCH v3 12/13] module: Move kdb_modules list out of core code, Aaron Tomlin
- Re: [RFC PATCH v3 00/13] module: core code clean up, Oleksandr Natalenko
[PATCH v13 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v13 01/11] arm64: Remove NULL task check from unwind_frame(), madvenka
- [PATCH v13 02/11] arm64: Rename unwinder functions, madvenka
- [PATCH v13 03/11] arm64: Rename stackframe to unwind_state, madvenka
- [PATCH v13 04/11] arm64: Split unwind_init(), madvenka
- [PATCH v13 05/11] arm64: Copy the task argument to unwind_state, madvenka
- [PATCH v13 07/11] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind(), madvenka
- [PATCH v13 08/11] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v13 09/11] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v13 11/11] arm64: Select HAVE_RELIABLE_STACKTRACE, madvenka
- [PATCH v13 10/11] arm64: Introduce arch_stack_walk_reliable(), madvenka
[GIT PULL] livepatching for 5.17,
Petr Mladek
Re: [RFC PATCH v2 03/13] module: Move livepatch support to a separate file,
Petr Mladek
[PATCH v12 00/10] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v12 01/10] arm64: Remove NULL task check from unwind_frame(), madvenka
- [PATCH v12 02/10] arm64: Rename unwinder functions, madvenka
- [PATCH v12 03/10] arm64: Rename stackframe to unwind_state, madvenka
- [PATCH v12 04/10] arm64: Split unwind_init(), madvenka
- [PATCH v12 06/10] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v12 05/10] arm64: Copy unwind arguments to unwind_state, madvenka
- [PATCH v12 07/10] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v12 08/10] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v12 09/10] arm64: Introduce arch_stack_walk_reliable(), madvenka
- [PATCH v12 10/10] arm64: Select HAVE_RELIABLE_STACKTRACE, madvenka
[PATCH bpf-next v5 1/9] kernel: Add kallsyms_on_each_symbol variant for single module, Kumar Kartikeya Dwivedi
[PATCH] livepatch: Avoid CPU hogging with cond_resched,
David Vernet
[PATCH -next] livepatch: Fix missing unlock on error in klp_enable_patch(),
Yang Yingliang
[PATCH v9 00/15] Function Granular KASLR,
Alexander Lobakin
- [PATCH v9 01/15] modpost: fix removing numeric suffixes, Alexander Lobakin
- [PATCH v9 02/15] livepatch: use `-z unique-symbol` if available to nuke pos-based search, Alexander Lobakin
- [PATCH v9 05/15] x86: support ASM function sections, Alexander Lobakin
- [PATCH v9 06/15] x86: decouple ORC table sorting into a separate file, Alexander Lobakin
- [PATCH v9 08/15] x86/tools: Add relative relocs for randomized functions, Alexander Lobakin
- [PATCH v9 07/15] Makefile: Add build and config option for CONFIG_FG_KASLR, Alexander Lobakin
- [PATCH v9 09/15] x86: Add support for function granular KASLR, Alexander Lobakin
- [PATCH v9 10/15] FG-KASLR: use a scripted approach to handle .text.* sections, Alexander Lobakin
- [PATCH v9 11/15] x86/boot: allow FG-KASLR to be selected, Alexander Lobakin
- [PATCH v9 03/15] kallsyms: Hide layout, Alexander Lobakin
- [PATCH v9 13/15] module: use a scripted approach for FG-KASLR, Alexander Lobakin
- [PATCH v9 14/15] Documentation: add documentation for FG-KASLR, Alexander Lobakin
- [PATCH v9 04/15] arch: introduce ASM function sections, Alexander Lobakin
- [PATCH v9 15/15] maintainers: add MAINTAINERS entry for FG-KASLR, Alexander Lobakin
- [PATCH v9 12/15] module: Reorder functions, Alexander Lobakin
- Re: [PATCH v9 00/15] Function Granular KASLR, Alexander Lobakin
- Re: [PATCH v9 00/15] Function Granular KASLR, Christoph Hellwig
[PATCH v3] livepatch: Fix kobject refcount bug on klp_init_patch_early failure path,
David Vernet
[PATCH v3] Documentation: livepatch: Add livepatch API page,
David Vernet
[PATCH v2 00/13] Implement livepatch on PPC32 and more,
Christophe Leroy
- [PATCH v2 01/13] livepatch: Fix build failure on 32 bits processors, Christophe Leroy
- [PATCH v2 02/13] tracing: Fix selftest config check for function graph start up test, Christophe Leroy
- [PATCH v2 03/13] powerpc/module_32: Fix livepatching for RO modules, Christophe Leroy
- [PATCH v2 04/13] powerpc/ftrace: Add support for livepatch to PPC32, Christophe Leroy
- [PATCH v2 05/13] powerpc/ftrace: Don't save again LR in ftrace_regs_caller() on PPC32, Christophe Leroy
- [PATCH v2 06/13] powerpc/ftrace: Simplify PPC32's return_to_handler(), Christophe Leroy
- [PATCH v2 07/13] powerpc/ftrace: Prepare PPC32's ftrace_caller() for CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 08/13] powerpc/ftrace: Prepare PPC64's ftrace_caller() for CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 09/13] powerpc/ftrace: Implement CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 10/13] powerpc/ftrace: Refactor ftrace_{en/dis}able_ftrace_graph_caller, Christophe Leroy
- [PATCH v2 11/13] powerpc/ftrace: directly call of function graph tracer by ftrace caller, Christophe Leroy
- [PATCH v2 12/13] powerpc/ftrace: Prepare ftrace_64_mprofile.S for reuse by PPC32, Christophe Leroy
- [PATCH v2 13/13] powerpc/ftrace: Remove ftrace_32.S, Christophe Leroy
- Re: [PATCH v2 00/13] Implement livepatch on PPC32 and more, Michael Ellerman
[Index of Archives]
[Linux Kernel]
[Linux NFS]
[Linux NILFS]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]