Linux Live Patching
[Prev Page][Next Page]
- [PATCH v5 08/13] module: Move kmemleak support to a separate file, (continued)
- [PATCH v5 00/13] module: core code clean up,
Aaron Tomlin
- [PATCH] livepatch: Skip livepatch tests if ftrace cannot be configured,
David Vernet
- [RFC PATCH v4 00/13] module: core code clean up,
Aaron Tomlin
- [RFC PATCH v4 01/13] module: Move all into module/, Aaron Tomlin
- [RFC PATCH v4 02/13] module: Simple refactor in preparation for split, Aaron Tomlin
- [RFC PATCH v4 03/13] module: Move livepatch support to a separate file, Aaron Tomlin
- [RFC PATCH v4 05/13] module: Move arch strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v4 04/13] module: Move latched RB-tree support to a separate file, Aaron Tomlin
- [RFC PATCH v4 06/13] module: Move strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v4 11/13] module: Move sysfs support into a separate file, Aaron Tomlin
- [RFC PATCH v4 12/13] module: Move kdb_modules list out of core code, Aaron Tomlin
- [RFC PATCH v4 13/13] module: Move version support into a separate file, Aaron Tomlin
- [RFC PATCH v4 10/13] module: Move procfs support into a separate file, Aaron Tomlin
- [RFC PATCH v4 09/13] module: Move kallsyms support into a separate file, Aaron Tomlin
- [RFC PATCH v4 08/13] module: Move kmemleak support to a separate file, Aaron Tomlin
- [RFC PATCH v4 07/13] module: Move extra signature support out of core code, Aaron Tomlin
- Re: [RFC PATCH v4 00/13] module: core code clean up, Allen
- Re: [RFC PATCH v4 00/13] module: core code clean up, Luis Chamberlain
- Re: [RFC PATCH v4 00/13] module: core code clean up, Luis Chamberlain
- [RFC PATCH v3 00/13] module: core code clean up,
Aaron Tomlin
- [RFC PATCH v3 01/13] module: Move all into module/, Aaron Tomlin
- [RFC PATCH v3 03/13] module: Move livepatch support to a separate file, Aaron Tomlin
- [RFC PATCH v3 02/13] module: Simple refactor in preparation for split, Aaron Tomlin
- [RFC PATCH v3 05/13] module: Move arch strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v3 04/13] module: Move latched RB-tree support to a separate file, Aaron Tomlin
- [RFC PATCH v3 06/13] module: Move strict rwx support to a separate file, Aaron Tomlin
- [RFC PATCH v3 07/13] module: Move extra signature support out of core code, Aaron Tomlin
- [RFC PATCH v3 08/13] module: Move kmemleak support to a separate file, Aaron Tomlin
- [RFC PATCH v3 10/13] module: Move procfs support into a separate file, Aaron Tomlin
- [RFC PATCH v3 09/13] module: Move kallsyms support into a separate file, Aaron Tomlin
- [RFC PATCH v3 11/13] module: Move sysfs support into a separate file, Aaron Tomlin
- [RFC PATCH v3 13/13] module: Move version support into a separate file, Aaron Tomlin
- [RFC PATCH v3 12/13] module: Move kdb_modules list out of core code, Aaron Tomlin
- Re: [RFC PATCH v3 00/13] module: core code clean up, Oleksandr Natalenko
- [PATCH v13 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v13 01/11] arm64: Remove NULL task check from unwind_frame(), madvenka
- [PATCH v13 02/11] arm64: Rename unwinder functions, madvenka
- [PATCH v13 03/11] arm64: Rename stackframe to unwind_state, madvenka
- [PATCH v13 04/11] arm64: Split unwind_init(), madvenka
- [PATCH v13 05/11] arm64: Copy the task argument to unwind_state, madvenka
- [PATCH v13 07/11] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind(), madvenka
- [PATCH v13 08/11] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v13 09/11] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v13 11/11] arm64: Select HAVE_RELIABLE_STACKTRACE, madvenka
- [PATCH v13 10/11] arm64: Introduce arch_stack_walk_reliable(), madvenka
- [GIT PULL] livepatching for 5.17,
Petr Mladek
- Re: [RFC PATCH v2 03/13] module: Move livepatch support to a separate file,
Petr Mladek
- [PATCH v12 00/10] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v12 01/10] arm64: Remove NULL task check from unwind_frame(), madvenka
- [PATCH v12 02/10] arm64: Rename unwinder functions, madvenka
- [PATCH v12 03/10] arm64: Rename stackframe to unwind_state, madvenka
- [PATCH v12 04/10] arm64: Split unwind_init(), madvenka
- [PATCH v12 06/10] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v12 05/10] arm64: Copy unwind arguments to unwind_state, madvenka
- [PATCH v12 07/10] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v12 08/10] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v12 09/10] arm64: Introduce arch_stack_walk_reliable(), madvenka
- [PATCH v12 10/10] arm64: Select HAVE_RELIABLE_STACKTRACE, madvenka
- [PATCH bpf-next v5 1/9] kernel: Add kallsyms_on_each_symbol variant for single module, Kumar Kartikeya Dwivedi
- [PATCH] livepatch: Avoid CPU hogging with cond_resched,
David Vernet
- [PATCH -next] livepatch: Fix missing unlock on error in klp_enable_patch(),
Yang Yingliang
- [PATCH v9 00/15] Function Granular KASLR,
Alexander Lobakin
- [PATCH v9 01/15] modpost: fix removing numeric suffixes, Alexander Lobakin
- [PATCH v9 02/15] livepatch: use `-z unique-symbol` if available to nuke pos-based search, Alexander Lobakin
- [PATCH v9 05/15] x86: support ASM function sections, Alexander Lobakin
- [PATCH v9 06/15] x86: decouple ORC table sorting into a separate file, Alexander Lobakin
- [PATCH v9 08/15] x86/tools: Add relative relocs for randomized functions, Alexander Lobakin
- [PATCH v9 07/15] Makefile: Add build and config option for CONFIG_FG_KASLR, Alexander Lobakin
- [PATCH v9 09/15] x86: Add support for function granular KASLR, Alexander Lobakin
- [PATCH v9 10/15] FG-KASLR: use a scripted approach to handle .text.* sections, Alexander Lobakin
- [PATCH v9 11/15] x86/boot: allow FG-KASLR to be selected, Alexander Lobakin
- [PATCH v9 03/15] kallsyms: Hide layout, Alexander Lobakin
- [PATCH v9 13/15] module: use a scripted approach for FG-KASLR, Alexander Lobakin
- [PATCH v9 14/15] Documentation: add documentation for FG-KASLR, Alexander Lobakin
- [PATCH v9 04/15] arch: introduce ASM function sections, Alexander Lobakin
- [PATCH v9 15/15] maintainers: add MAINTAINERS entry for FG-KASLR, Alexander Lobakin
- [PATCH v9 12/15] module: Reorder functions, Alexander Lobakin
- Re: [PATCH v9 00/15] Function Granular KASLR, Alexander Lobakin
- Re: [PATCH v9 00/15] Function Granular KASLR, Christoph Hellwig
- [PATCH v3] livepatch: Fix kobject refcount bug on klp_init_patch_early failure path,
David Vernet
- [PATCH v3] Documentation: livepatch: Add livepatch API page,
David Vernet
- [PATCH v2 00/13] Implement livepatch on PPC32 and more,
Christophe Leroy
- [PATCH v2 01/13] livepatch: Fix build failure on 32 bits processors, Christophe Leroy
- [PATCH v2 02/13] tracing: Fix selftest config check for function graph start up test, Christophe Leroy
- [PATCH v2 03/13] powerpc/module_32: Fix livepatching for RO modules, Christophe Leroy
- [PATCH v2 04/13] powerpc/ftrace: Add support for livepatch to PPC32, Christophe Leroy
- [PATCH v2 05/13] powerpc/ftrace: Don't save again LR in ftrace_regs_caller() on PPC32, Christophe Leroy
- [PATCH v2 06/13] powerpc/ftrace: Simplify PPC32's return_to_handler(), Christophe Leroy
- [PATCH v2 07/13] powerpc/ftrace: Prepare PPC32's ftrace_caller() for CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 08/13] powerpc/ftrace: Prepare PPC64's ftrace_caller() for CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 09/13] powerpc/ftrace: Implement CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Christophe Leroy
- [PATCH v2 10/13] powerpc/ftrace: Refactor ftrace_{en/dis}able_ftrace_graph_caller, Christophe Leroy
- [PATCH v2 11/13] powerpc/ftrace: directly call of function graph tracer by ftrace caller, Christophe Leroy
- [PATCH v2 12/13] powerpc/ftrace: Prepare ftrace_64_mprofile.S for reuse by PPC32, Christophe Leroy
- [PATCH v2 13/13] powerpc/ftrace: Remove ftrace_32.S, Christophe Leroy
- Re: [PATCH v2 00/13] Implement livepatch on PPC32 and more, Michael Ellerman
- [PATCH v2] Documentation: livepatch: Add livepatch API page,
David Vernet
- [PATCH v2] livepatch: Fix leak on klp_init_patch_early failure path,
David Vernet
- [PATCH] livepatch: Fix leak on klp_init_patch_early failure path,
David Vernet
- [PATCH v2 0/2] livepatch: Allow user to specify functions to search for on a stack,
Miroslav Benes
- [PATCH] Documentation: livepatch: Add kernel-doc link to klp_enable_patch,
David Vernet
- Some questions about arm64 live-patching support,
Hubin
- Re: [PATCH] powerpc/module_64: Fix livepatching for RO modules,
Joe Lawrence
- [PATCH v8 00/14] Function Granular KASLR,
Alexander Lobakin
- [PATCH v8 01/14] x86: Makefile: Add build and config option for CONFIG_FG_KASLR, Alexander Lobakin
- [PATCH v8 02/14] x86/tools: Add relative relocs for randomized functions, Alexander Lobakin
- [PATCH v8 03/14] x86: Add support for function granular KASLR, Alexander Lobakin
- [PATCH v8 04/14] linkage: add macros for putting ASM functions into own sections, Alexander Lobakin
- [PATCH v8 07/14] kallsyms: Hide layout, Alexander Lobakin
- [PATCH v8 08/14] livepatch: only match unique symbols when using FG-KASLR, Alexander Lobakin
- [PATCH v8 06/14] FG-KASLR: use a scripted approach to handle .text.* sections, Alexander Lobakin
- [PATCH v8 10/14] arm64/crypto: conditionally place ASM functions into separate sections, Alexander Lobakin
- [PATCH v8 09/14] x86/boot: allow FG-KASLR to be selected, Alexander Lobakin
- [PATCH v8 12/14] module: use a scripted approach for FG-KASLR, Alexander Lobakin
- [PATCH v8 13/14] Documentation: add documentation for FG-KASLR, Alexander Lobakin
- [PATCH v8 14/14] maintainers: add MAINTAINERS entry for FG-KASLR, Alexander Lobakin
- [PATCH v8 11/14] module: Reorder functions, Alexander Lobakin
- Message not available
- Re: [PATCH v8 00/14] Function Granular KASLR, Peter Zijlstra
[PATCH v11 0/5] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
Re: CET/IBT support and live-patches,
Miroslav Benes
[PATCH 0/3] livepatch: Allow user to specify functions to search for on a stack,
Miroslav Benes
Re: [PATCH 20/22] x86,word-at-a-time: Remove .fixup usage,
Josh Poimboeuf
[PATCH] arm64: module: Use aarch64_insn_write when updating relocations later on,
Suraj Jitindar Singh
[PATCH V4 0/3] livepatch: cleanup kpl_patch kobject release,
Ming Lei
[PATCH V3 0/3] livepatch: cleanup kpl_patch kobject release,
Ming Lei
ppc64le STRICT_MODULE_RWX and livepatch apply_relocate_add() crashes,
Joe Lawrence
[PATCH V2 0/3] livepatch: cleanup kpl_patch kobject release,
Ming Lei
[PATCH 0/3] livepatch: cleanup kpl_patch kobject release,
Ming Lei
[PATCH v1 0/5] Implement livepatch on PPC32,
Christophe Leroy
[PATCH] livepatch: Fix build failure on 32 bits processors, Christophe Leroy
[PATCH v7 0/2] fix & prevent the missing preemption disabling,
王贇
[PATCH v6 0/2] fix & prevent the missing preemption disabling,
王贇
[PATCH v5 0/2] fix & prevent the missing preemption disabling,
王贇
Re: [PATCH v8 11/12] zram: fix crashes with cpu hotplug multistate,
Miroslav Benes
[PATCH v2] tracing: Have all levels of checks prevent recursion,
Steven Rostedt
[PATCH v4 0/2] fix & prevent the missing preemption disabling,
王贇
[PATCH] tracing: Have all levels of checks prevent recursion,
Steven Rostedt
[PATCH v10 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v10 01/11] arm64: Select STACKTRACE in arch/arm64/Kconfig, madvenka
- [PATCH v10 02/11] arm64: Make perf_callchain_kernel() use arch_stack_walk(), madvenka
- [PATCH v10 03/11] arm64: Make get_wchan() use arch_stack_walk(), madvenka
- [PATCH v10 07/11] arm64: Call stack_backtrace() only from within walk_stackframe(), madvenka
- [PATCH v10 05/11] arm64: Make dump_stacktrace() use arch_stack_walk(), madvenka
- [PATCH v10 06/11] arm64: Make profile_pc() use arch_stack_walk(), madvenka
- [PATCH v10 04/11] arm64: Make return_address() use arch_stack_walk(), madvenka
- [PATCH v10 08/11] arm64: Rename unwinder functions, prevent them from being traced and kprobed, madvenka
- [PATCH v10 09/11] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- [PATCH v10 10/11] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v10 11/11] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- Re: [PATCH v10 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks, Madhavan T. Venkataraman
[PATCH v9 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks,
madvenka
- [PATCH v9 01/11] arm64: Select STACKTRACE in arch/arm64/Kconfig, madvenka
- [PATCH v9 10/11] arm64: Introduce stack trace reliability checks in the unwinder, madvenka
- [PATCH v9 11/11] arm64: Create a list of SYM_CODE functions, check return PC against list, madvenka
- [PATCH v9 02/11] arm64: Make perf_callchain_kernel() use arch_stack_walk(), madvenka
- [PATCH v9 04/11] arm64: Make return_address() use arch_stack_walk(), madvenka
- [PATCH v9 03/11] arm64: Make get_wchan() use arch_stack_walk(), madvenka
- [PATCH v9 05/11] arm64: Make dump_stacktrace() use arch_stack_walk(), madvenka
- [PATCH v9 06/11] arm64: Make profile_pc() use arch_stack_walk(), madvenka
- [PATCH v9 07/11] arm64: Call stack_backtrace() only from within walk_stackframe(), madvenka
- [PATCH v9 08/11] arm64: Rename unwinder functions, prevent them from being traced and kprobed, madvenka
- [PATCH v9 09/11] arm64: Make the unwind loop in unwind() similar to other architectures, madvenka
- Re: [PATCH v9 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks, Madhavan T. Venkataraman
[PATCH v3 0/2] fix & prevent the missing preemption disabling,
王贇
[RESEND PATCH v2 0/2] fix & prevent the missing preemption disabling,
王贇
[PATCH 0/2] ftrace: make sure preemption disabled on recursion testing,
王贇
[Index of Archives]
[Linux Kernel]
[Linux NFS]
[Linux NILFS]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]