Git Distributed Software Revision Control — Thread Index
[Prev Page][Next Page]
- Re: [PATCH v4 05/25] midx: clear auxiliary .rev after replacing the MIDX, (continued)
- [PATCH v4 06/25] midx: reject empty `--preferred-pack`'s, Taylor Blau
- [PATCH v4 07/25] midx: infer preferred pack when not given one, Taylor Blau
- [PATCH v4 08/25] midx: close linked MIDXs, avoid leaking memory, Taylor Blau
- [PATCH v4 09/25] midx: avoid opening multiple MIDXs when writing, Taylor Blau
- [PATCH v4 10/25] pack-bitmap.c: introduce 'bitmap_num_objects()', Taylor Blau
- [PATCH v4 11/25] pack-bitmap.c: introduce 'nth_bitmap_object_oid()', Taylor Blau
- [PATCH v4 12/25] pack-bitmap.c: introduce 'bitmap_is_preferred_refname()', Taylor Blau
- [PATCH v4 13/25] pack-bitmap.c: avoid redundant calls to try_partial_reuse, Taylor Blau
- [PATCH v4 14/25] pack-bitmap: read multi-pack bitmaps, Taylor Blau
- [PATCH v4 15/25] pack-bitmap: write multi-pack bitmaps, Taylor Blau
- [PATCH v4 16/25] t5310: move some tests to lib-bitmap.sh, Taylor Blau
- [PATCH v4 17/25] t/helper/test-read-midx.c: add --checksum mode, Taylor Blau
- [PATCH v4 19/25] t0410: disable GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP, Taylor Blau
- [PATCH v4 20/25] t5310: disable GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP, Taylor Blau
- [PATCH v4 18/25] t5326: test multi-pack bitmap behavior, Taylor Blau
- [PATCH v4 21/25] t5319: don't write MIDX bitmaps in t5319, Taylor Blau
- [PATCH v4 23/25] midx: respect 'GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP', Taylor Blau
- [PATCH v4 25/25] p5326: perf tests for MIDX bitmaps, Taylor Blau
- [PATCH v4 24/25] p5310: extract full and partial bitmap tests, Taylor Blau
- [PATCH v4 22/25] t7700: update to work with MIDX bitmap test knob, Taylor Blau
- Re: [PATCH v4 00/25] multi-pack reachability bitmaps, Jeff King
- [PATCH v5 00/27] multi-pack reachability bitmaps, Taylor Blau
- [PATCH v5 01/27] pack-bitmap.c: harden 'test_bitmap_walk()' to check type bitmaps, Taylor Blau
- [PATCH v5 02/27] pack-bitmap-write.c: gracefully fail to write non-closed bitmaps, Taylor Blau
- [PATCH v5 03/27] pack-bitmap-write.c: free existing bitmaps, Taylor Blau
- [PATCH v5 04/27] Documentation: describe MIDX-based bitmaps, Taylor Blau
- [PATCH v5 05/27] midx: disallow running outside of a repository, Taylor Blau
- [PATCH v5 06/27] midx: fix `*.rev` cleanups with `--object-dir`, Taylor Blau
- [PATCH v5 07/27] midx: clear auxiliary .rev after replacing the MIDX, Taylor Blau
- [PATCH v5 09/27] midx: infer preferred pack when not given one, Taylor Blau
- [PATCH v5 08/27] midx: reject empty `--preferred-pack`'s, Taylor Blau
- [PATCH v5 10/27] midx: close linked MIDXs, avoid leaking memory, Taylor Blau
- [PATCH v5 11/27] midx: avoid opening multiple MIDXs when writing, Taylor Blau
- [PATCH v5 12/27] pack-bitmap.c: introduce 'bitmap_num_objects()', Taylor Blau
- [PATCH v5 13/27] pack-bitmap.c: introduce 'nth_bitmap_object_oid()', Taylor Blau
- [PATCH v5 14/27] pack-bitmap.c: introduce 'bitmap_is_preferred_refname()', Taylor Blau
- [PATCH v5 16/27] pack-bitmap: read multi-pack bitmaps, Taylor Blau
- [PATCH v5 15/27] pack-bitmap.c: avoid redundant calls to try_partial_reuse, Taylor Blau
- [PATCH v5 17/27] pack-bitmap: write multi-pack bitmaps, Taylor Blau
- [PATCH v5 18/27] t5310: move some tests to lib-bitmap.sh, Taylor Blau
- [PATCH v5 19/27] t/helper/test-read-midx.c: add --checksum mode, Taylor Blau
- [PATCH v5 20/27] t5326: test multi-pack bitmap behavior, Taylor Blau
- [PATCH v5 21/27] t0410: disable GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP, Taylor Blau
- [PATCH v5 22/27] t5310: disable GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP, Taylor Blau
- [PATCH v5 23/27] t5319: don't write MIDX bitmaps in t5319, Taylor Blau
- [PATCH v5 24/27] t7700: update to work with MIDX bitmap test knob, Taylor Blau
- [PATCH v5 25/27] midx: respect 'GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP', Taylor Blau
- [PATCH v5 26/27] p5310: extract full and partial bitmap tests, Taylor Blau
- [PATCH v5 27/27] p5326: perf tests for MIDX bitmaps, Taylor Blau
- Re: [PATCH v5 00/27] multi-pack reachability bitmaps, Junio C Hamano
- Re: [PATCH v5 00/27] multi-pack reachability bitmaps, Jeff King
- [PATCH v2 0/7] doc make and lint fixes,
Ævar Arnfjörð Bjarmason
- Possible memory leak bug reports for the latest "git" repository.,
우승훈[ 대학원석·박사통합과정수료연구(재학) / 컴퓨터학과 ]
- [PATCH] [GSOC] ref-filter: get rid of show_ref_array_item,
ZheNing Hu via GitGitGadget
Re: [PATCH 5/5] doc lint: lint and fix missing "GIT" end sections,
Ævar Arnfjörð Bjarmason
[PATCH v3 0/8] rev-parse: implement object type filter,
Patrick Steinhardt
- [PATCH v3 1/8] uploadpack.txt: document implication of `uploadpackfilter.allow`, Patrick Steinhardt
- [PATCH v3 2/8] revision: mark commit parents as NOT_USER_GIVEN, Patrick Steinhardt
- [PATCH v3 3/8] list-objects: move tag processing into its own function, Patrick Steinhardt
- [PATCH v3 4/8] list-objects: support filtering by tag and commit, Patrick Steinhardt
- [PATCH v3 5/8] list-objects: implement object type filter, Patrick Steinhardt
- [PATCH v3 6/8] pack-bitmap: implement object type filter, Patrick Steinhardt
- [PATCH v3 7/8] pack-bitmap: implement combined filter, Patrick Steinhardt
- [PATCH v3 8/8] rev-list: allow filtering of provided items, Patrick Steinhardt
- Re: [PATCH v3 0/8] rev-parse: implement object type filter, Junio C Hamano
- [PATCH v4 0/8] rev-list: implement object type filter, Patrick Steinhardt
- [PATCH v4 1/8] uploadpack.txt: document implication of `uploadpackfilter.allow`, Patrick Steinhardt
- [PATCH v4 2/8] revision: mark commit parents as NOT_USER_GIVEN, Patrick Steinhardt
- [PATCH v4 3/8] list-objects: move tag processing into its own function, Patrick Steinhardt
- [PATCH v4 4/8] list-objects: support filtering by tag and commit, Patrick Steinhardt
- [PATCH v4 5/8] list-objects: implement object type filter, Patrick Steinhardt
- [PATCH v4 6/8] pack-bitmap: implement object type filter, Patrick Steinhardt
- [PATCH v4 7/8] pack-bitmap: implement combined filter, Patrick Steinhardt
- [PATCH v4 8/8] rev-list: allow filtering of provided items, Patrick Steinhardt
- Re: [PATCH v4 0/8] rev-list: implement object type filter, Jeff King
- [PATCH v5 0/8] rev-list: implement object type filter, Patrick Steinhardt
[PATCH 0/2] blob/object.c: trivial readability improvements,
Ævar Arnfjörð Bjarmason
- [PATCH 2/2] object.c: initialize automatic variable in lookup_object(), Ævar Arnfjörð Bjarmason
- [PATCH 1/2] blob.c: remove buffer & size arguments to parse_blob_buffer(), Ævar Arnfjörð Bjarmason
- [PATCH 0/6] {tag,object}*.c: refactorings + prep for a larger change, Ævar Arnfjörð Bjarmason
- [PATCH 2/6] object.c: remove "gently" argument to type_from_string_gently(), Ævar Arnfjörð Bjarmason
- [PATCH 1/6] object.c: stop supporting len == -1 in type_from_string_gently(), Ævar Arnfjörð Bjarmason
- [PATCH 3/6] object.c: make type_from_string() return "enum object_type", Ævar Arnfjörð Bjarmason
- [PATCH 4/6] object-file.c: make oid_object_info() return "enum object_type", Ævar Arnfjörð Bjarmason
- [PATCH 6/6] tag.c: use type_from_string_gently() when parsing tags, Ævar Arnfjörð Bjarmason
- [PATCH 5/6] object-name.c: make dependency on object_type order more obvious, Ævar Arnfjörð Bjarmason
- [PATCH 0/7] object.c: add and use "is expected" utility function + object_as_type() use, Ævar Arnfjörð Bjarmason
- [PATCH 2/7] object.c: add a utility function for "expected type X, got Y", Ævar Arnfjörð Bjarmason
- [PATCH 1/7] tree.c: fix misindentation in parse_tree_gently(), Ævar Arnfjörð Bjarmason
- [PATCH 3/7] object.c: add and use oid_is_type_or_die_msg() function, Ævar Arnfjörð Bjarmason
- [PATCH 4/7] commit-graph: use obj->type, not object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH 5/7] commit.c: don't use deref_tag() -> object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH 6/7] object.c: normalize brace style in object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH 7/7] object.c: remove "quiet" parameter from object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH v2 0/8] object.c: add and use "is expected" utility function + object_as_type() use, Ævar Arnfjörð Bjarmason
- [PATCH v2 1/8] tree.c: fix misindentation in parse_tree_gently(), Ævar Arnfjörð Bjarmason
- [PATCH v2 2/8] object.c: add a utility function for "expected type X, got Y", Ævar Arnfjörð Bjarmason
- [PATCH v2 4/8] commit-graph: use obj->type, not object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH v2 5/8] branch tests: assert lookup_commit_reference_gently() error, Ævar Arnfjörð Bjarmason
- [PATCH v2 6/8] commit.c: don't use deref_tag() -> object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH v2 3/8] object.c: add and use oid_is_type_or_die_msg() function, Ævar Arnfjörð Bjarmason
- [PATCH v2 7/8] object.c: normalize brace style in object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH v2 8/8] object.c: remove "quiet" parameter from object_as_type(), Ævar Arnfjörð Bjarmason
- [PATCH v2 00/10] {tag,object}*.c: refactorings + prep for a larger change, Ævar Arnfjörð Bjarmason
- [PATCH v2 01/10] object.c: stop supporting len == -1 in type_from_string_gently(), Ævar Arnfjörð Bjarmason
- [PATCH v2 02/10] object.c: remove "gently" argument to type_from_string_gently(), Ævar Arnfjörð Bjarmason
- [PATCH v2 03/10] object.c: make type_from_string() return "enum object_type", Ævar Arnfjörð Bjarmason
- [PATCH v2 05/10] object-name.c: make dependency on object_type order more obvious, Ævar Arnfjörð Bjarmason
- [PATCH v2 06/10] tag.c: use type_from_string_gently() when parsing tags, Ævar Arnfjörð Bjarmason
- [PATCH v2 07/10] hash-object: pass along type length to object.c, Ævar Arnfjörð Bjarmason
- [PATCH v2 09/10] hash-object: show usage on invalid --type, Ævar Arnfjörð Bjarmason
- [PATCH v2 04/10] object-file.c: make oid_object_info() return "enum object_type", Ævar Arnfjörð Bjarmason
- [PATCH v2 08/10] hash-object: refactor nested else/if/if into else if/else if, Ævar Arnfjörð Bjarmason
- [PATCH v2 10/10] object.c: move type_from_string() code to its last user, Ævar Arnfjörð Bjarmason
- [PATCH v2 00/10] object.c et al: tests, small bug fixes etc., Ævar Arnfjörð Bjarmason
- [PATCH v2 01/10] cat-file tests: test for bogus type name handling, Ævar Arnfjörð Bjarmason
- [PATCH v2 03/10] mktree tests: add test for invalid object type, Ævar Arnfjörð Bjarmason
- [PATCH v2 04/10] object-file.c: take type id, not string, in read_object_with_reference(), Ævar Arnfjörð Bjarmason
- [PATCH v2 05/10] {commit,tree,blob,tag}.c: add a create_{commit,tree,blob,tag}(), Ævar Arnfjörð Bjarmason
- [PATCH v2 02/10] hash-object tests: more detailed test for invalid type, Ævar Arnfjörð Bjarmason
- [PATCH v2 06/10] blob.c: remove parse_blob_buffer(), Ævar Arnfjörð Bjarmason
- [PATCH v2 08/10] object.c: don't go past "len" under die() in type_from_string_gently(), Ævar Arnfjörð Bjarmason
- [PATCH v2 07/10] object.c: simplify return semantic of parse_object_buffer(), Ævar Arnfjörð Bjarmason
- [PATCH v2 09/10] mktree: stop setting *ntr++ to NIL, Ævar Arnfjörð Bjarmason
- [PATCH v2 10/10] mktree: emit a more detailed error when the <type> is invalid, Ævar Arnfjörð Bjarmason
[PATCH v2 0/2] rebase: don't override --no-reschedule-failed-exec with config,
Ævar Arnfjörð Bjarmason
[RFC PATCH v1 00/13][GSoC] doc: (monospace) apply CodingGuidelines on a large-scale,
Firmin Martin
- [RFC PATCH v1 01/13] doc: typeset command-line options in monospace, Firmin Martin
- [RFC PATCH v1 02/13] doc: typeset branches and remotes in monospace, Firmin Martin
- [RFC PATCH v1 03/13] doc: typeset configuration options in monospace, Firmin Martin
- [RFC PATCH v1 05/13] doc: typeset git-svn subcommands in monospace, Firmin Martin
- [RFC PATCH v1 06/13] doc: typeset dummy URLs and protocols in monospace, Firmin Martin
- [RFC PATCH v1 04/13] doc: typeset git-related commands in monospace, Firmin Martin
- [RFC PATCH v1 07/13] doc: typeset git dotfiles in monospace, Firmin Martin
- [RFC PATCH v1 08/13] doc: typeset filepath and $variables in monospace, Firmin Martin
- [RFC PATCH v1 11/13] doc: typeset config option entries in monospace, Firmin Martin
- [RFC PATCH v1 10/13] doc: typeset more command entries in monospace, Firmin Martin
- [RFC PATCH v1 09/13] doc: typeset command/option/value entries in monospace, Firmin Martin
- [RFC PATCH v1 12/13] doc: typeset environment vars without $ in monospace, Firmin Martin
- [RFC PATCH v1 13/13] doc: typeset common programs in monospace, Firmin Martin
- Re: [RFC PATCH v1 00/13][GSoC] doc: (monospace) apply CodingGuidelines on a large-scale, Jean-Noël Avila
[PATCH 0/6] Push negotiation,
Jonathan Tan
[RFC PATCH 0/2] share a config between submodule and superproject,
Emily Shaffer
What's cooking in git.git (Apr 2021, #02; Thu, 8),
Junio C Hamano
Re: [PATCH v13 5/5] bugreport: add compiler info,
Ævar Arnfjörð Bjarmason
Re: [PATCH v13 4/5] bugreport: add uname info,
Ævar Arnfjörð Bjarmason
Re: [PATCH v13 2/5] bugreport: add tool to generate debugging info, SZEDER Gábor
[PATCH] Makefile: add missing dependencies of 'config-list.h',
SZEDER Gábor
[PATCH v4 0/7] add/rm: honor sparse checkout and warn on sparse paths,
Matheus Tavares
git-p4 crashes on non UTF-8 output from p4,
Tzadik Vanderhoof
Re: [PATCH v5] gitweb: redacted e-mail addresses feature.,
Eric Wong
[PATCH v2 0/5] Parallel Checkout (part 2),
Matheus Tavares
[PATCH v5 0/9] userdiff: refactor + test improvements,
Ævar Arnfjörð Bjarmason
[PATCH] config: Introduce GIT_CONFIG_NOGLOBAL,
Patrick Steinhardt
[PATCH 0/5] config: support --type=bool-or-auto for "tristate" parsing,
Ævar Arnfjörð Bjarmason
[PATCH v2] config.c: remove last remnant of GIT_TEST_GETTEXT_POISON,
Ævar Arnfjörð Bjarmason
[PATCH] completion: audit and guard $GIT_* against unset use,
Ville Skyttä
[PATCH 0/9] git log: configurable default format for merge diffs,
Sergey Organov
- [PATCH 1/9] diff-merges: introduce --diff-merges=def, Sergey Organov
- [PATCH 2/9] diff-merges: refactor set_diff_merges(), Sergey Organov
- [PATCH 3/9] diff-merges: introduce log.diffMerges config variable, Sergey Organov
- [PATCH 4/9] diff-merges: adapt -m to enable default diff format, Sergey Organov
- [PATCH 5/9] t4013: add test for --diff-merges=def, Sergey Organov
- [PATCH 6/9] t4013: add tests for log.diffMerges config, Sergey Organov
- [PATCH 7/9] t9902: fix completion tests for log.d* to match log.diffMerges, Sergey Organov
- [PATCH 8/9] doc/diff-options: document new --diff-merges features, Sergey Organov
- [PATCH 9/9] doc/config: document log.diffMerges, Sergey Organov
- [PATCH v1 0/5] git log: configurable default format for merge diffs, Sergey Organov
- [PATCH v2 0/5] git log: configurable default format for merge diffs, Sergey Organov
Re: [PATCH] gitk: add option to perform 'git fetch' command,
Johannes Schindelin
No error when overwriting ignored files,
Horst von Brand
Re: exporting git commands in parsable format for constructing language-specific API for git CLI,
ama bamo
Can not list stash (git version 2.30.0),
Eugen Konkov
[PATCH v2 0/4] Finish converting git bisect to C part 4,
Miriam Rubio
Shell completion for branch names,
jost . schulte
signed-off-by not overwritten with GIT_AUTHOR_NAME...?,
Matthias Beyer
Re: Regarding the depreciation of ssh+git/git+ssh protocols,
Mark Lodato
There should have be git gc --repack-arguments,
Bagas Sanjaya
[PATCH] bash completion: complete CHERRY_PICK_HEAD,
Ævar Arnfjörð Bjarmason
Re: [PATCH v8 37/37] docs: unify githooks and git-hook manpages,
Junio C Hamano
[PATCH] completion: treat unset GIT_COMPLETION_SHOW_ALL gracefully,
Ville Skyttä
Re: [PATCH v2 0/8] rev-parse: implement object type filter,
Jeff King
Re: [PATCH v2 8/8] rev-list: allow filtering of provided items,
Jeff King
Re: [PATCH v2 7/8] pack-bitmap: implement combined filter,
Jeff King
Re: [PATCH v2 6/8] pack-bitmap: implement object type filter, Jeff King
Re: [PATCH v2 5/8] list-objects: implement object type filter, Jeff King
Re: [PATCH v2 3/8] list-objects: move tag processing into its own function, Jeff King
Re: [PATCH v2 2/8] revision: mark commit parents as NOT_USER_GIVEN,
Jeff King
Re: [PATCH v2 1/8] uploadpack.txt: document implication of `uploadpackfilter.allow`, Jeff King
Subject: Encoding of git diff --name-only stdout,
Andrey Bienkowski
[Bug report] diff.noprefix config is ignored for interactive `add`,
Nikita Bobko
[PATCH] git-apply: try threeway first when "--3way" is used,
Jerry Zhang
[PATCH] test-bloom: fix missing 'bloom' from usage string,
Christian Couder
What's cooking in git.git (Apr 2021, #01; Mon, 5),
Junio C Hamano
Re: [PATCH v6] gitweb: redacted e-mail addresses feature.,
Junio C Hamano
Re: [PATCH] hooks: propose repository owner configured hooks,
Albert Cui
[PATCH] doc: replace jargon word "impact" with "effect"/"affect",
Varun Varada
[Index of Archives]
[Linux Kernel]
[LKML Kernel FAQ]
[IETF Annouce]
[Security]
[Bugtraq]