On Sat, May 1, 2021 at 2:08 PM Christian Couder <christian.couder@xxxxxxxxx> wrote: > > On Fri, Apr 30, 2021 at 11:40 PM Matheus Tavares > <matheus.bernardino@xxxxxx> wrote: > > > > Pathspec-limited checkouts (like `git checkout *.txt`) are performed by > > a code path that doesn't yet support parallel checkout because it calls > > checkout_entry() directly, instead of unpack_trees(). Let's add parallel > > checkout support for this code path too. > > > > Note: the transient cache entries allocated in checkout_merged() are now > > s/Note: the/The/ Thanks > > allocated in a mem_pool which is only discarded after parallel checkout > > finishes. This is done because the entries need to be valid when > > run_parallel_checkout() is called. > > > -static int checkout_merged(int pos, const struct checkout *state, int *nr_checkouts) > > +static int checkout_merged(int pos, const struct checkout *state, > > + int *nr_checkouts, struct mem_pool *ce_mem_pool) > > For consistency with the previous patch, maybe: s/ce_mem_pool/ce_mp/ Yeah, I agree that it's a good idea to keep this consistent. In fact, instead of changing `ce_mem_pool` here, I think I should change `mp` in the previous patch to either `mem_pool` or `ce_mem_pool`. Those seem to be the most common names, at read-cache.c, for a memory pool struct holding cache entries.