Linux SCSI Development
[Prev Page][Next Page]
- [PATCH AUTOSEL 5.4 2/8] scsi: target: iscsi: Prevent login threads from racing between each other, Sasha Levin
- [PATCH AUTOSEL 5.15 02/10] scsi: target: iscsi: Prevent login threads from racing between each other, Sasha Levin
- [PATCH AUTOSEL 5.10 2/9] scsi: target: iscsi: Prevent login threads from racing between each other, Sasha Levin
- [PATCH AUTOSEL 6.1 03/16] scsi: target: iscsi: Prevent login threads from racing between each other, Sasha Levin
- [PATCH AUTOSEL 6.3 05/19] scsi: target: iscsi: Prevent login threads from racing between each other, Sasha Levin
- [PATCH AUTOSEL 6.3 04/19] scsi: target: iscsi: Remove unused transport_timer, Sasha Levin
- [PATCH AUTOSEL 6.3 03/19] scsi: target: iscsi: Fix hang in the iSCSI login code, Sasha Levin
- [PATCH] ata: libata-scsi: Avoid deadlock on rescan after device resume,
Damien Le Moal
- [PATCH] mpt3sas: Perform additional retries if Doorbell read returns 0,
Ranjan Kumar
- [PATCH] qla2xxx: Remove unused nvme_ls_waitq wait queue.,
Nilesh Javali
- [PATCH 1/1] lpfc: Fix incorrect big endian type assignment in bsg loopback path,
Justin Tee
- [PATCH v7 0/7] scsi: fixes for targets with many LUNs, and scsi_target_block rework,
mwilck
- [PATCH v7 1/7] bsg: increase number of devices, mwilck
- [PATCH v7 3/7] scsi: merge scsi_internal_device_block() and device_block(), mwilck
- [PATCH v7 2/7] scsi: sg: increase number of devices, mwilck
- [PATCH v7 4/7] scsi: don't wait for quiesce in scsi_stop_queue(), mwilck
- [PATCH v7 5/7] scsi: don't wait for quiesce in scsi_device_block(), mwilck
- [PATCH v7 6/7] scsi: replace scsi_target_block() by scsi_block_targets(), mwilck
- [PATCH v7 7/7] scsi: improve warning message in scsi_device_block(), mwilck
- Re: [PATCH v7 0/7] scsi: fixes for targets with many LUNs, and scsi_target_block rework, Martin K. Petersen
- Re: [PATCH v7 0/7] scsi: fixes for targets with many LUNs, and scsi_target_block rework, Martin K. Petersen
- [PATCH v8 00/33] scsi: Allow scsi_execute users to control retries,
Mike Christie
- [PATCH v8 01/33] scsi: Add helper to prep sense during error handling, Mike Christie
- [PATCH v8 02/33] scsi: Allow passthrough to override what errors to retry, Mike Christie
- [PATCH v8 06/33] scsi: sd: Fix sshdr use in read_capacity_16, Mike Christie
- [PATCH v8 10/33] scsi: Have scsi-ml retry sd_spinup_disk errors, Mike Christie
- [PATCH v8 12/33] scsi: hp_sw: Have scsi-ml retry scsi_exec_req errors, Mike Christie
- [PATCH v8 04/33] scsi: Have scsi-ml retry scsi_probe_lun errors, Mike Christie
- [PATCH v8 05/33] scsi: retry INQUIRY after timeout, Mike Christie
- [PATCH v8 07/33] scsi: sd: Have scsi-ml retry read_capacity_16 errors, Mike Christie
- [PATCH v8 03/33] scsi: Add scsi_failure field to scsi_exec_args, Mike Christie
- [PATCH v8 08/33] scsi: Use separate buf for START_STOP in sd_spinup_disk, Mike Christie
- [PATCH v8 09/33] scsi: sd: Fix sshdr use in sd_spinup_disk, Mike Christie
- [PATCH v8 11/33] scsi: hp_sw: Only access sshdr if res > 0, Mike Christie
- [PATCH v8 13/33] scsi: rdac: Fix sshdr use, Mike Christie
- [PATCH v8 15/33] scsi: spi: Fix sshdr use, Mike Christie
- [PATCH v8 14/33] scsi: rdac: Have scsi-ml retry send_mode_select errors, Mike Christie
- [PATCH v8 16/33] scsi: spi: Have scsi-ml retry spi_execute errors, Mike Christie
- [PATCH v8 18/33] scsi: sd: Have scsi-ml retry sd_sync_cache errors, Mike Christie
- [PATCH v8 19/33] scsi: ch: Remove unit_attention, Mike Christie
- [PATCH v8 20/33] scsi: ch: Have scsi-ml retry ch_do_scsi errors, Mike Christie
- [PATCH v8 23/33] scsi: Have scsi-ml retry scsi_report_lun_scan errors, Mike Christie
- [PATCH v8 22/33] scsi: sd: Fix scsi_mode_sense caller's sshdr use, Mike Christie
- [PATCH v8 17/33] scsi: sd: Fix sshdr use in sd_sync_cache, Mike Christie
- [PATCH v8 21/33] scsi: Have scsi-ml retry scsi_mode_sense UAs, Mike Christie
- [PATCH v8 24/33] scsi: sd: Have pr commands retry UAs, Mike Christie
- [PATCH v8 25/33] scsi: sd: Have scsi-ml retry read_capacity_10 errors, Mike Christie
- [PATCH v8 29/33] scsi: Fix sshdr use in scsi_test_unit_ready, Mike Christie
- [PATCH v8 26/33] scsi: ses: Have scsi-ml retry scsi_exec_req errors, Mike Christie
- [PATCH v8 27/33] scsi: sr: Have scsi-ml retry get_sectorsize errors, Mike Christie
- [PATCH v8 28/33] scsi: ufs: Have scsi-ml retry start stop errors, Mike Christie
- [PATCH v8 30/33] scsi: Fix sshdr use in scsi_cdl_enable, Mike Christie
- [PATCH v8 31/33] scsi: sd: Fix sshdr use in cache_type_store, Mike Christie
- [PATCH v8 32/33] scsi: sr: Fix sshdr use in sr_get_events, Mike Christie
- [PATCH v8 33/33] scsi: Add kunit tests for scsi_check_passthrough, Mike Christie
- [PATCH] scsi: myrs: Replacing snprintf with scnprintf,
wuyonggang001
- [PATCH] scsi: mpt3sas: Replacing snprintf with scnprintf, wuyonggang001
- [PATCH] drivers: message: fusion: Replacing snprintf with scnprintf, wuyonggang001
- [PATCH v4] ufs: poll pmc until another pa request is completed,
Kiwoong Kim
- [PATCH v3 0/2] change UIC command handling,
Kiwoong Kim
- Message not available
[PATCH v6 0/7] scsi: fixes for targets with many LUNs, and scsi_target_block rework,
mwilck
[PATCH] scsi: ufs: ufs-pci: Add support for Intel Arrow Lake,
Adrian Hunter
[PATCH] drivers: target: Fix error path in target_setup_session,
Bob Pearson
[PATCH] scsi: sd_zbc: use PAGE_SECTORS_SHIFT,
Johannes Thumshirn
[PATCH v5] scsi: ufs: wb: Add explicit flush_threshold sysfs attribute,
Lu Hongfei
[RESEND v7 0/3] Add dedicated Qcom ICE driver,
Abel Vesa
[PATCH v5 0/7] scsi: fixes for targets with many LUNs, and scsi_target_block rework,
mwilck
Re: [PATCH v4 6/6] scsi: replace scsi_target_block() by scsi_block_targets(), Hannes Reinecke
Re: [PATCH v4 5/6] scsi: don't wait for quiesce in scsi_device_block(), Hannes Reinecke
Re: [PATCH v4 4/6] scsi: don't wait for quiesce in scsi_stop_queue(), Hannes Reinecke
Re: [PATCH v4 3/6] scsi: merge scsi_internal_device_block() and device_block(), Hannes Reinecke
[PATCH v4 0/6] scsi: fixes for targets with many LUNs, and scsi_target_block rework,
mwilck
[PATCH 6.1 001/132] scsi: megaraid_sas: Add flexible array member for SGLs, Greg Kroah-Hartman
[PATCH v1 0/4] ufs: Introduce MCQ Quirks for MediaTek host,
Po-Wen Kao
[PATCH] drivers: target: Fix the conversion to bool in iblock_execute_pr_out,
Lu Hongfei
[PATCH v3 0/2] Add MCQ support for MTK platform,
Po-Wen Kao
[PATCH v5 0/3] fix blktrace debugfs entries leakage,
Yu Kuai
[PATCH v2 0/2] ufs: mcq: Share first hwq for dev comamnd and IO request,
Po-Wen Kao
[PATCH 1/1] scsi: storvsc: Always set no_report_opcodes,
Michael Kelley
[linux-next:master] BUILD REGRESSION 53ab6975c12d1ad86c599a8927e8c698b144d669, kernel test robot
[PATCH v1 1/2] scsi: ufs: mcq: Fix the incorrect OCS value for the device command,
Po-Wen Kao
[PATCH] dt-bindings: ufs: samsung,exynos: drop unneeded quotes,
Krzysztof Kozlowski
Fwd: Waking up from resume locks up on sr device,
Bagas Sanjaya
[ANNOUNCE] Alpine Linux Persistence and Storage Summit 2023, Johannes Thumshirn
[PATCH v4] scsi: ufs: wb: Add explicit flush_threshold sysfs attribute,
Lu Hongfei
[PATCH v4 0/2] fix blktrace debugfs entries leakage,
Yu Kuai
[PATCH v3] scsi: ufs: wb: Add explicit flush_threshold sysfs attribute,
Lu Hongfei
[PATCH v2] scsi: ufs: wb: Add explicit flush_threshold sysfs attribute, Lu Hongfei
decouple block open flags from fmode_t v2,
Christoph Hellwig
- [PATCH 07/30] block: pass a gendisk on bdev_check_media_change, Christoph Hellwig
- [PATCH 04/30] cdrom: remove the unused cdrom_close_write release code, Christoph Hellwig
- [PATCH 05/30] cdrom: track if a cdrom_device_info was opened for data, Christoph Hellwig
- [PATCH 01/30] block: also call ->open for incremental partition opens, Christoph Hellwig
- [PATCH 06/30] cdrom: remove the unused mode argument to cdrom_release, Christoph Hellwig
- [PATCH 03/30] cdrom: remove the unused mode argument to cdrom_ioctl, Christoph Hellwig
- [PATCH 08/30] block: pass a gendisk to ->open, Christoph Hellwig
- [PATCH 09/30] block: remove the unused mode argument to ->release, Christoph Hellwig
- [PATCH 02/30] cdrom: remove the unused bdev argument to cdrom_open, Christoph Hellwig
- [PATCH 14/30] btrfs: don't pass a holder for non-exclusive blkdev_get_by_path, Christoph Hellwig
- [PATCH 12/30] bcache: don't pass a stack address to blkdev_get_by_path, Christoph Hellwig
- [PATCH 15/30] block: use the holder as indication for exclusive opens, Christoph Hellwig
- [PATCH 17/30] fs: remove sb->s_mode, Christoph Hellwig
- [PATCH 10/30] block: rename blkdev_close to blkdev_release, Christoph Hellwig
- [PATCH 13/30] rnbd-srv: don't pass a holder for non-exclusive blkdev_get_by_path, Christoph Hellwig
- [PATCH 11/30] swsusp: don't pass a stack address to blkdev_get_by_path, Christoph Hellwig
- [PATCH 16/30] block: add a sb_open_mode helper, Christoph Hellwig
- [PATCH 21/30] nvme: replace the fmode_t argument to the nvme ioctl handlers with a simple bool, Christoph Hellwig
- [PATCH 19/30] scsi: replace the fmode_t argument to scsi_ioctl with a simple bool, Christoph Hellwig
- [PATCH 20/30] scsi: replace the fmode_t argument to ->sg_io_fn with a simple bool, Christoph Hellwig
- [PATCH 23/30] rnbd-srv: replace sess->open_flags with a "bool readonly", Christoph Hellwig
- [PATCH 22/30] mtd: block: use a simple bool to track open for write, Christoph Hellwig
- [PATCH 25/30] block: move a few internal definitions out of blkdev.h, Christoph Hellwig
- [PATCH 18/30] scsi: replace the fmode_t argument to scsi_cmd_allowed with a simple bool, Christoph Hellwig
- [PATCH 24/30] ubd: remove commented out code in ubd_open, Christoph Hellwig
- [PATCH 26/30] block: remove unused fmode_t arguments from ioctl handlers, Christoph Hellwig
- [PATCH 28/30] block: always use I_BDEV on file->f_mapping->host to find the bdev, Christoph Hellwig
- [PATCH 27/30] block: replace fmode_t with a block-specific type for block open flags, Christoph Hellwig
- [PATCH 30/30] fs: remove the now unused FMODE_* flags, Christoph Hellwig
- [PATCH 29/30] block: store the holder in file->private_data, Christoph Hellwig
- Re: decouple block open flags from fmode_t v2, Jens Axboe
[PATCH] scsi: ufs: wb: Add explicit flush_threshold sysfs attribute,
Lu Hongfei
[PATCH RESEND] block: improve ioprio value validity checks,
Damien Le Moal
[PATCH v3 0/2] fix blktrace debugfs entries leakage,
Yu Kuai
[PATCH v3 0/8] scsi: fixes for targets with many LUNs, and scsi_target_block rework,
mwilck
[PATCH v2 0/8] qla2xxx klocwork fixes,
Nilesh Javali
- [PATCH v2 1/8] qla2xxx: klocwork - Array index may go out of bound, Nilesh Javali
- [PATCH v2 2/8] qla2xxx: klocwork - Fix potential null pointer dereference, Nilesh Javali
- [PATCH v2 3/8] qla2xxx: klocwork - avoid fcport pointer dereference, Nilesh Javali
- [PATCH v2 4/8] qla2xxx: klocwork - Check valid rport returned by fc_bsg_to_rport, Nilesh Javali
- [PATCH v2 5/8] qla2xxx: klocwork - Fix buffer overrun, Nilesh Javali
- [PATCH v2 6/8] qla2xxx: klocwork - pointer may be dereferenced, Nilesh Javali
- [PATCH v2 7/8] qla2xxx: klocwork - correct the index of array, Nilesh Javali
- [PATCH v2 8/8] qla2xxx: Update version to 10.02.08.400-k, Nilesh Javali
- Re: [PATCH v2 0/8] qla2xxx klocwork fixes, Martin K. Petersen
- Re: [PATCH v2 0/8] qla2xxx klocwork fixes, Martin K. Petersen
[PATCH] scsi: efct: Add missing check for ioremap, Jiasheng Jiang
[PATCH v2] scsi: efct: Add missing check for ioremap, Jiasheng Jiang
[RESEND][PATCH][next] Replace one-element array with DECLARE_FLEX_ARRAY() helper,
Gustavo A. R. Silva
[PATCH v2 0/3] scsi: fixes for targets with many LUNs,
mwilck
decouple block open flags from fmode_t,
Christoph Hellwig
- [PATCH 02/31] cdrom: remove the unused bdev argument to cdrom_open, Christoph Hellwig
- [PATCH 03/31] cdrom: remove the unused mode argument to cdrom_ioctl, Christoph Hellwig
- [PATCH 01/31] block: also call ->open for incremental partition opens, Christoph Hellwig
- [PATCH 05/31] cdrom: track if a cdrom_device_info was opened for data, Christoph Hellwig
- [PATCH 08/31] block: share code between disk_check_media_change and disk_force_media_change, Christoph Hellwig
- [PATCH 04/31] cdrom: remove the unused cdrom_close_write release code, Christoph Hellwig
- [PATCH 07/31] block: pass a gendisk on bdev_check_media_change, Christoph Hellwig
- [PATCH 06/31] cdrom: remove the unused mode argument to cdrom_release, Christoph Hellwig
- [PATCH 09/31] block: pass a gendisk to ->open, Christoph Hellwig
- [PATCH 11/31] block: rename blkdev_close to blkdev_release, Christoph Hellwig
- [PATCH 10/31] block: remove the unused mode argument to ->release, Christoph Hellwig
- [PATCH 14/31] rnbd-srv: don't pass a holder for non-exclusive blkdev_get_by_path, Christoph Hellwig
- [PATCH 12/31] swsusp: don't pass a stack address to blkdev_get_by_path, Christoph Hellwig
- [PATCH 13/31] bcache: don't pass a stack address to blkdev_get_by_path, Christoph Hellwig
- [PATCH 15/31] btrfs: don't pass a holder for non-exclusive blkdev_get_by_path, Christoph Hellwig
- [PATCH 19/31] scsi: replace the fmode_t argument to scsi_cmd_allowed with a simple bool, Christoph Hellwig
- [PATCH 20/31] scsi: replace the fmode_t argument to scsi_ioctl with a simple bool, Christoph Hellwig
- [PATCH 18/31] fs: remove sb->s_mode, Christoph Hellwig
- [PATCH 17/31] block: add a sb_open_mode helper, Christoph Hellwig
- [PATCH 21/31] scsi: replace the fmode_t argument to ->sg_io_fn with a simple bool, Christoph Hellwig
- [PATCH 16/31] block: use the holder as indication for exclusive opens, Christoph Hellwig
- [PATCH 23/31] mtd: block: use a simple bool to track open for write, Christoph Hellwig
- [PATCH 22/31] nvme: replace the fmode_t argument to the nvme ioctl handlers with a simple bool, Christoph Hellwig
- [PATCH 30/31] block: store the holder in file->private_data, Christoph Hellwig
- [PATCH 31/31] fs: remove the now unused FMODE_* flags, Christoph Hellwig
- [PATCH 25/31] ubd: remove commented out code in ubd_open, Christoph Hellwig
- [PATCH 24/31] rnbd-srv: replace sess->open_flags with a "bool readonly", Christoph Hellwig
- [PATCH 26/31] block: move a few internal definitions out of blkdev.h, Christoph Hellwig
- [PATCH 27/31] block: remove unused fmode_t arguments from ioctl handlers, Christoph Hellwig
- [PATCH 29/31] block: always use I_BDEV on file->f_mapping->host to find the bdev, Christoph Hellwig
- [PATCH 28/31] block: replace fmode_t with a block-specific type for block open flags, Christoph Hellwig
- Re: decouple block open flags from fmode_t, Christian Brauner
[PATCH] scsi: sd: support specify probe type of build-in driver,
Jianlin Lv
[bug report] WARNING: CPU: 23 PID: 35995 at lib/refcount.c:28 refcount_warn_saturate+0xba/0x110,
Guangwu Zhang
[PATCH v12 0/9] Implement copy offload support,
Nitesh Shetty
Message not available
Message not available
Message not available
Message not available
Message not available
Message not available
Message not available
Message not available
[PATCH v2 0/3] Cleanups and improvements,
Damien Le Moal
[PATCH 0/3] Cleanups and improvements,
Damien Le Moal
[PATCH v2 0/3] change UIC command handling,
Kiwoong Kim
Message not available
Message not available
[PATCH] qla2xxx: Drop useless LIST_HEAD,
Christophe JAILLET
[GIT PULL] SCSI fixes for 6.4-rc4,
James Bottomley
[PATCH 0/3] scsi: fixes for targets with many LUNs,
mwilck
[PATCH v6] scsi: core: Wait until device is fully resumed before doing rescan,
Kai-Heng Feng
[PATCH] scsi: ufs-mediatek: add dependency for RESET_CONTROLLER,
Randy Dunlap
[PATCH v2][next] scsi: lpfc: Avoid -Wstringop-overflow warning,
Gustavo A. R. Silva
[PATCH v2] ufs: core: Combine ufshcd_mq_poll_cqe functions,
Stanley Chu
Re: [PATCH v2] ufs: core: Combine ufshcd_mq_poll_cqe functions, Bean Huo
Re: [PATCH v2] ufs: core: Combine ufshcd_mq_poll_cqe functions, Bart Van Assche
Re: [PATCH v2] ufs: core: Combine ufshcd_mq_poll_cqe functions, Martin K. Petersen
[PATCH] ata: libata-sata: Simplify ata_change_queue_depth(),
Damien Le Moal
[PATCH v5] scsi: core: Wait until device is fully resumed before doing rescan,
Kai-Heng Feng
[PATCH v2] scsi: ufs: core: Fix ufshcd_inc_sq_tail function bug,
Zhang Hui
[PATCH v1 1/1] ufs: mcq: Fix the sq_head_slot wrap around logic,
Bao D. Nguyen
[PATCH v1 1/1] scsi: ufs: core: Fix ufshcd_inc_sq_tail function bug,
Zhang Hui
[PATCH v1] ufs: core: Remove the nolock version of ufshcd_mcq_poll_cqe(),
Stanley Chu
[PATCH] scsi: ufs: Remove a ufshcd_add_command_trace() call,
Bart Van Assche
[PATCH] scsi: ufs: Include major and minor number in command tracing output,
Bart Van Assche
[PATCH v3][next] scsi: lpfc: Use struct_size() helper,
Justin Tee
[PATCH] mpi3mr: propagate sense data for admin queue SCSI IO,
Sumit Saxena
[PATCH] scsi: sr: Fix a potential uninit-value in sr_get_events(),
Shigeru Yoshida
[PATCH] scsi: megaraid: Fix uninitialized mbox in mega_cmd_done,
Maximilian Heyne
[PATCH v3] scsi: ufs: core: Do not open code SZ_x,
Avri Altman
[PATCH v2] scsi: ufs: core: Do not open code SZ_x,
Avri Altman
Re: [PATCH v2] scsi: ufs: core: Do not open code SZ_x, Bao D. Nguyen
[PATCH][next] scsi: lpfc: Avoid -Wstringop-overflow warning,
Gustavo A. R. Silva
[Index of Archives]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[Linux ATA RAID]
[IETF Annouce]
[Git]
[Security]
[Netfilter]
[Bugtraq]