On 8/15/23 02:57, Bart Van Assche wrote: > On 8/14/23 05:36, Damien Le Moal wrote: >> On 8/12/23 06:35, Bart Van Assche wrote: >>> + if (!rq->q->limits.use_zone_write_lock && blk_rq_is_seq_zoned_write(rq)) >> >> This condition could be written as a little inline helper >> blk_req_need_zone_write_lock(), which could be used in mq-dealine patch 2. > > Hi Damien, > > Since q->limits.use_zone_write_lock is being introduced, how about > modifying blk_req_needs_zone_write_lock() such that it tests that new member > variable instead of checking rq->q->disk->seq_zones_wlock? That would allow > me to leave out one change from block/mq-deadline.c. I do not have a strong > opinion about whether the name blk_req_needs_zone_write_lock() should be > retained or whether that function should be renamed into > blk_req_use_zone_write_lock(). Something like this ? diff --git a/block/blk-zoned.c b/block/blk-zoned.c index 619ee41a51cc..a3980a71c0ac 100644 --- a/block/blk-zoned.c +++ b/block/blk-zoned.c @@ -57,7 +57,12 @@ EXPORT_SYMBOL_GPL(blk_zone_cond_str); */ bool blk_req_needs_zone_write_lock(struct request *rq) { - if (!rq->q->disk->seq_zones_wlock) + struct request_queue *q = rq->q; + + if (!q->limits.use_zone_write_lock) + return false; + + if (!q->disk->seq_zones_wlock) return false; return blk_rq_is_seq_zoned_write(rq); I think that is fine and avoids adding yet another helper. I am OK with this. -- Damien Le Moal Western Digital Research