Linux Kbuild
[Prev Page][Next Page]
- [PATCH v11 02/24] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc, (continued)
- Automatic secondary intermediate target deduction,
Jason A. Donenfeld
- move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v4,
Christoph Hellwig
- [PATCH 1/9] arm: remove EISA kconfig option, Christoph Hellwig
- [PATCH 2/9] alpha: force PCI on for non-jensen configs, Christoph Hellwig
- [PATCH 7/9] pcmcia: allow PCMCIA support independent of the architecture, Christoph Hellwig
- [PATCH 8/9] rapidio: consolidate RAPIDIO config entry in drivers/rapidio, Christoph Hellwig
- [PATCH 9/9] eisa: consolidate EISA Kconfig entry in drivers/eisa, Christoph Hellwig
- [PATCH 4/9] PCI: consolidate PCI config entry in drivers/pci, Christoph Hellwig
- [PATCH 5/9] PCI: consolidate the PCI_DOMAINS and PCI_DOMAINS_GENERIC config options, Christoph Hellwig
- [PATCH 6/9] PCI: consolidate the PCI_SYSCALL symbol, Christoph Hellwig
- [PATCH 3/9] MIPS: remove the HT_PCI config option, Christoph Hellwig
- Re: move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v4, Masahiro Yamada
- [PATCH 0/8] kbuild: clean-up modversion, TRIM_UNUSED_KSYMS, if_changed_rule, etc.,
Masahiro Yamada
- [PATCH v2 0/2] x86: Asm macros fixes,
Nadav Amit
- [PATCH v2 0/2] modpost: skip section mismatch warnings on ELF local symbols by default,
Paul Walmsley
- hidden string Kconfig ?,
Daniel Walker
- [PATCH AUTOSEL 4.18 58/59] kbuild: deb-pkg: fix too low build version number, Sasha Levin
- builddeb: Missing arch/x86/kernel/macros.s when building modules with dkms,
Sedat Dilek
- [PATCH 0/2] x86: Asm macros fixes,
Nadav Amit
- [PATCH v3] scripts/kconfig/merge_config: don't redefine 'y' to 'm',
Anders Roxell
- [PATCH v2 0/2] powerpc/boot: Fix cross compiling with clang,
Joel Stanley
- [PATCH] kbuild: remove 'prepare' and 'scripts' dummies for external module build,
Masahiro Yamada
- [kbuild:kbuild 2/4] arch/openrisc/include/asm/spr.h:20:27: error: impossible constraint in 'asm',
kbuild test robot
[GIT PULL] Kbuild fixes for v4.20-rc2,
Masahiro Yamada
Re: .S_shipped unnecessary?,
Ard Biesheuvel
[PATCH] kbuild/builddeb: Fix building .deb packages out-of-tree, Borislav Petkov
[PATCH v2] scripts/kconfig/merge_config: don't redefine 'y' to 'm',
Anders Roxell
scripts/Makefile.modinst: removing module path M from module destination is not working for some cases,
Mikolaj Ch
Makefile:611: include/config/auto.conf: No such file or directory,
Mathieu Malaterre
[PATCH] builddeb: Fix inclusion of dtbs in debian package,
Rob Herring
[RFC PATCH 0/4] Minor improvements over handling dependency on GAS,
Vladimir Murzin
[PATCH v10 00/22] kasan: add software tag-based mode for arm64,
Andrey Konovalov
- [PATCH v10 02/22] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc, Andrey Konovalov
- [PATCH v10 04/22] kasan: rename source files to reflect the new naming scheme, Andrey Konovalov
- [PATCH v10 03/22] kasan: move common generic and tag-based code to common.c, Andrey Konovalov
- [PATCH v10 07/22] kasan: initialize shadow to 0xff for tag-based mode, Andrey Konovalov
- [PATCH v10 08/22] kasan, arm64: untag address in __kimg_to_phys and _virt_addr_is_linear, Andrey Konovalov
- [PATCH v10 17/22] kasan: add hooks implementation for tag-based mode, Andrey Konovalov
- [PATCH v10 22/22] kasan: add SPDX-License-Identifier mark to source files, Andrey Konovalov
- [PATCH v10 21/22] kasan: update documentation, Andrey Konovalov
- [PATCH v10 20/22] kasan: add __must_check annotations to kasan hooks, Andrey Konovalov
- [PATCH v10 19/22] kasan, mm, arm64: tag non slab memory allocated via pagealloc, Andrey Konovalov
- [PATCH v10 18/22] kasan, arm64: add brk handler for inline instrumentation, Andrey Konovalov
- [PATCH v10 16/22] kasan: add bug reporting routines for tag-based mode, Andrey Konovalov
- [PATCH v10 15/22] kasan: split out generic_report.c from report.c, Andrey Konovalov
- [PATCH v10 14/22] kasan, mm: perform untagged pointers comparison in krealloc, Andrey Konovalov
- [PATCH v10 11/22] mm: move obj_to_index to include/linux/slab_def.h, Andrey Konovalov
- [PATCH v10 12/22] kasan, arm64: fix up fault handling logic, Andrey Konovalov
- [PATCH v10 13/22] kasan, arm64: enable top byte ignore for the kernel, Andrey Konovalov
- [PATCH v10 10/22] kasan: preassign tags to objects with ctors or SLAB_TYPESAFE_BY_RCU, Andrey Konovalov
- [PATCH v10 09/22] kasan: add tag related helper functions, Andrey Konovalov
- [PATCH v10 05/22] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS, Andrey Konovalov
- [PATCH v10 06/22] kasan, arm64: adjust shadow size for tag-based mode, Andrey Konovalov
- [PATCH v10 01/22] kasan, mm: change hooks signatures, Andrey Konovalov
- Re: [PATCH v10 00/22] kasan: add software tag-based mode for arm64, Andrey Konovalov
[PATCH] kbuild: deb-pkg: fix too low build version number, Masahiro Yamada
[PATCH v2 1/2] kbuild: add -no-integrated-as Clang option unconditionally,
Masahiro Yamada
[PATCH] init/Kconfig: make CC_OPTIMIZE_FOR_DEBUGGING visible only for GCC,
Changbin Du
[RESEND] kernel version build number in .deb to low by 1. [REGRESSION][BISECTED],
Doug Smythies
[PATCH v2] kconfig: merge_config: avoid false positive matches from comment lines,
Masahiro Yamada
[PATCH] kbuild: deb-pkg: fix bindeb-pkg breakage when O= is used,
Masahiro Yamada
[PATCH] kbuild: rpm-pkg: fix binrpm-pkg breakage when O= is used,
Masahiro Yamada
[PATCH] kbuild: consolidate Clang compiler flags,
Masahiro Yamada
[kbuild:for-next 12/14] arch/openrisc/include/asm/spr.h:20:27: error: impossible constraint in 'asm', kbuild test robot
[PATCH 0/2] poewrpc/Boot: Fix cross compiling with clang,
Joel Stanley
[PATCH] Revert "kbuild: add --include-dir flag only for out-of-tree build",
Ard Biesheuvel
[GIT PULL] more Kbuild updates for v4.20,
Masahiro Yamada
[PATCH 4.14 096/143] compiler.h: Allow arch-specific asm/compiler.h, Greg Kroah-Hartman
[PATCH 4.18 079/150] compiler.h: Allow arch-specific asm/compiler.h, Greg Kroah-Hartman
[PATCH] scripts/kconfig/merge_config: don't redefine 'y' to 'm',
Anders Roxell
[PATCH] kbuild: rpm-pkg: fix two build breaks when O= is used,
Zhenzhong Duan
[PATCH] kconfig: merge_config: avoid false positive matches from comment lines,
Masahiro Yamada
[PATCH 1/1] modpost: Refactor and removes global variable *modules, Leonardo Bras
[PATCH 1/3] modpost: Refactor and removes global variable *modules, Leonardo Bras
[PATCH] remove old GCC version implementation,
Mathieu Malaterre
[PATCH v2 1/2] kbuild: replace cc-name test with CONFIG_CC_IS_CLANG,
Masahiro Yamada
Re: [PATCH] fs: proc: move linux_proc_banner to where it is used,
Rasmus Villemoes
[PATCH] kbuild: consolidate single targets,
Masahiro Yamada
[PATCH 1/2] kbuild: replace cc-name test with CONFIG_CC_IS_CLANG,
Masahiro Yamada
[PATCH v2 1/1] merge_config.sh: Allow to define config prefix,
Petr Vorel
[PATCH] kbuild: remove unused cc-fullversion variable,
Masahiro Yamada
[PATCH 1/2] kconfig: remove oldnoconfig target,
Masahiro Yamada
[kbuild:kbuild 2/4] drivers/tty/serial/qcom_geni_serial.c:1313:22: warning: 'drv' may be used uninitialized in this function,
kbuild test robot
[GIT PULL] VLA removal for v4.20-rc1,
Kees Cook
[GIT PULL] Kbuild updates for v4.20,
Masahiro Yamada
[PATCH v3 0/4] kernel hacking: GCC optimization for better debug experience (-Og),
Changbin Du
[PATCH 1/1] merge_config.sh: Replace prefix CONFIG_ with any prefix,
Petr Vorel
[PATCH v3 0/5] Adds -Wshadow on KBUILD_HOSTCFLAGS and fix warnings,
Leonardo Bras
[PATCH] modpost: validate symbol names also in find_elf_symbol,
Sami Tolvanen
[PATCH 1/1] Changes style to look more like list iteration., Leonardo Brás
[PATCH v2 0/5] Adds -Wshadow on KBUILD_HOSTCFLAGS, Leonardo Brás
[PATCH v2 5/5] Adds -Wshadow on KBUILD_HOSTCFLAGS, Leonardo Brás
[PATCH v2 4/5] modpost: Changes parameter name to avoid shadowing., Leonardo Brás
[PATCH v2 3/5] Creates macro to avoid variable shadowing,
Leonardo Brás
[PATCH v2 2/5] kbuild: Removes unnecessary shadowed local variable., Leonardo Brás
[PATCH v2 1/5] x86/vdso: Renames variable to fix shadow warning.,
Leonardo Brás
[GIT PULL] Compiler Attributes for v4.20-rc1,
Miguel Ojeda
[PATCH 0/2] Compiler Attributes: __fallthrough,
Miguel Ojeda
Re: [PATCH 0/2] Compiler Attributes: __fallthrough, Greg Kroah-Hartman
[PATCH 0/2] modpost: skip section mismatch warnings on ELF local symbols by default,
Paul Walmsley
[PATCH v2 0/4] kernel hacking: GCC optimization for better debug experience (-Og),
Du Changbin
move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v3,
Christoph Hellwig
[PATCH 0/4] kernel hacking: GCC optimization for better debug experience (-Og),
Du Changbin
[PATCH 0/3] Let sparse check for shadowed variables,
Sebastian Andrzej Siewior
move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v2,
Christoph Hellwig
- [PATCH 1/8] aha152x: rename the PCMCIA define, Christoph Hellwig
- [PATCH 2/8] powerpc: remove CONFIG_PCI_QSPAN, Christoph Hellwig
- [PATCH 3/8] powerpc: PCI_MSI needs PCI, Christoph Hellwig
- [PATCH 8/8] kconfig: remove CONFIG_MCA leftovers, Christoph Hellwig
- [PATCH 7/8] eisa: consolidate EISA Kconfig entry in drivers/eisa, Christoph Hellwig
- [PATCH 6/8] rapidio: consolidate RAPIDIO config entry in drivers/rapidio, Christoph Hellwig
- [PATCH 5/8] pcmcia: allow PCMCIA support independent of the architecture, Christoph Hellwig
- [PATCH 4/8] PCI: consolidate PCI config entry in drivers/pci, Christoph Hellwig
- Re: move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/ v2, Geert Uytterhoeven
[PATCH 4/4] Changes macro usage to avoid shadowing a variable.,
Leonardo Brás
[PATCH 3/4] kbuild: Removes unnecessary shadowed local variable and optimize testing.,
Leonardo Brás
[PATCH 2/4] Renames variable to fix shadow warning.,
Leonardo Brás
[PATCH 1/4] Adds -Wshadow=local on KBUILD_HOSTCFLAGS,
Leonardo Brás
[PATCH 0/4] Adds -Wshadow=local on KBUILD_HOSTCFLAGS,
Leonardo Brás
[PATCH 0/3] kbuild: add scripts/Makefile.toolcheck to check necessary host tools,
Masahiro Yamada
[PATCH 2/3] objtool: move libelf check out of top Makefile, Masahiro Yamada
[PATCH] Kbuild: Hide Clang's -Wempty-body behind W=1,
Nathan Chancellor
move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/,
Christoph Hellwig
- [PATCH 3/8] powerpc: PCI_MSI needs PCI, Christoph Hellwig
- [PATCH 8/8] kconfig: remove CONFIG_MCA leftovers, Christoph Hellwig
- [PATCH 7/8] eisa: consolidate EISA Kconfig entry in drivers/eisa, Christoph Hellwig
- [PATCH 6/8] rapidio: consolidate RAPIDIO config entry in drivers/rapidio, Christoph Hellwig
- [PATCH 5/8] pcmcia: allow PCMCIA support independent of the architecture, Christoph Hellwig
- [PATCH 4/8] pci: consolidate PCI config entry in drivers/pci, Christoph Hellwig
- [PATCH 2/8] powerpc: simplify CONFIG_PCI_QSPAN Kconfig magic, Christoph Hellwig
- [PATCH 1/8] aha152x: rename the PCMCIA define, Christoph Hellwig
- Re: move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/, Thomas Gleixner
- Re: move bus (PCI, PCMCIA, EISA, rapdio) config to drivers/, Masahiro Yamada
[GIT PULL] Kbuild fixes for v4.19-rc8,
Masahiro Yamada
[PATCH] kbuild: Fail the build early when no lz4 present,
Borislav Petkov
[PATCH] kbuild: use 'else ifeq' for checksrc to improve readability, Masahiro Yamada
Fwd: Update of SAT solver in kconfig, Mate Soos
[PATCH 07/36] kbuild: Add support for DT binding schema checks, Rob Herring
[GIT PULL linux-next] Add Compiler Attributes (v6) tree,
Miguel Ojeda
[PATCH] kbuild: fix kernel/bounds.c 'W=1' warning,
Arnd Bergmann
[ANN] init-kconfig - easy way to embrace Linux's kconfig,
Luis Chamberlain
[PATCH v2] kbuild: remove unneeded link_multi_deps,
Masahiro Yamada
[PATCH v9 02/10] Makefile: Prepare for using macros for inline asm,
Nadav Amit
[GIT PULL linux-next] Add Compiler Attributes tree,
Miguel Ojeda
[PATCH v2] kbuild: add -Wno-unused-but-set-variable flag unconditionally,
Masahiro Yamada
[PATCH v4 0/9] Devicetree build consolidation,
Rob Herring
[PATCH 1/3] kbuild: add -Wno-pointer-sign flag unconditionally,
Masahiro Yamada
[PATCH] samples: run headers_install for host arch instead of target arch,
Masahiro Yamada
[PATCH] modpost: remove leftover symbol prefix handling for module device table,
Masahiro Yamada
[ANNOUNCE] Kconfiglib menuconfig and documentation generation updates, Ulf Magnusson
[PATCH v9 00/20] kasan: add software tag-based mode for arm64,
Andrey Konovalov
- [PATCH v9 01/20] kasan, mm: change hooks signatures, Andrey Konovalov
- [PATCH v9 06/20] kasan: initialize shadow to 0xff for tag-based mode, Andrey Konovalov
- [PATCH v9 10/20] mm: move obj_to_index to include/linux/slab_def.h, Andrey Konovalov
- [PATCH v9 15/20] kasan: add bug reporting routines for tag-based mode, Andrey Konovalov
- [PATCH v9 16/20] kasan: add hooks implementation for tag-based mode, Andrey Konovalov
- [PATCH v9 18/20] kasan, mm, arm64: tag non slab memory allocated via pagealloc, Andrey Konovalov
- [PATCH v9 19/20] kasan: update documentation, Andrey Konovalov
- [PATCH v9 20/20] kasan: add SPDX-License-Identifier mark to source files, Andrey Konovalov
[Index of Archives]
[Linux USB Devel]
[Linux Media]
[Linux SCSI]
[Scanners]
[Yosemite Secret&nsp;Places]