Linux RDMA and InfiniBand Development
[Prev Page][Next Page]
- Re: [PATCH v2 hmm 00/11] Various revisions from a locking/code review, (continued)
- Re: [PATCH RFC 00/10] RDMA/FS DAX truncate proposal,
Ira Weiny
- [PATCH rdma-next 0/3] Expose ENCAP mode to mlx5_ib,
Leon Romanovsky
- [PATCH rdma-next v3 00/17] Statistics counter support,
Leon Romanovsky
- [PATCH rdma-next v3 02/17] RDMA/restrack: Introduce statistic counter, Leon Romanovsky
- [PATCH rdma-next v3 03/17] RDMA/restrack: Add an API to attach a task to a resource, Leon Romanovsky
- [PATCH rdma-next v3 04/17] RDMA/restrack: Make is_visible_in_pid_ns() as an API, Leon Romanovsky
- [PATCH rdma-next v3 01/17] net/mlx5: Add rts2rts_qp_counters_set_id field in hca cap, Leon Romanovsky
- [PATCH rdma-next v3 06/17] RDMA/counter: Add "auto" configuration mode support, Leon Romanovsky
- [PATCH rdma-next v3 07/17] IB/mlx5: Support set qp counter, Leon Romanovsky
- [PATCH rdma-next v3 08/17] IB/mlx5: Add counter set id as a parameter for mlx5_ib_query_q_counters(), Leon Romanovsky
- [PATCH rdma-next v3 09/17] IB/mlx5: Support statistic q counter configuration, Leon Romanovsky
- [PATCH rdma-next v3 05/17] RDMA/counter: Add set/clear per-port auto mode support, Leon Romanovsky
- [PATCH rdma-next v3 11/17] RDMA/netlink: Implement counter dumpit calback, Leon Romanovsky
- [PATCH rdma-next v3 12/17] IB/mlx5: Add counter_alloc_stats() and counter_update_stats() support, Leon Romanovsky
- [PATCH rdma-next v3 13/17] RDMA/core: Get sum value of all counters when perform a sysfs stat read, Leon Romanovsky
- [PATCH rdma-next v3 10/17] RDMA/nldev: Allow counter auto mode configration through RDMA netlink, Leon Romanovsky
- [PATCH rdma-next v3 15/17] RDMA/nldev: Allow counter manual mode configration through RDMA netlink, Leon Romanovsky
- [PATCH rdma-next v3 16/17] RDMA/nldev: Allow get counter mode through RDMA netlink, Leon Romanovsky
- [PATCH rdma-next v3 14/17] RDMA/counter: Allow manual mode configuration support, Leon Romanovsky
- [PATCH rdma-next v3 17/17] RDMA/nldev: Allow get default counter statistics through RDMA netlink, Leon Romanovsky
- [PATCH v4 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH 1/1] net: rds: fix memory leak in rds_ib_flush_mr_pool,
Zhu Yanjun
- [PATCH] IB/iser: explicitly set shost max_segment_size,
Sagi Grimberg
- [pull request][for-next 0/9] Generic DIM lib for netdev and RDMA,
Saeed Mahameed
- [for-next 1/9] linux/dim: Move logic to dim.h, Saeed Mahameed
- [for-next 2/9] linux/dim: Remove "net" prefix from internal DIM members, Saeed Mahameed
- [for-next 3/9] linux/dim: Rename externally exposed macros, Saeed Mahameed
- [for-next 4/9] linux/dim: Rename net_dim_sample() to net_dim_update_sample(), Saeed Mahameed
- [for-next 5/9] linux/dim: Rename externally used net_dim members, Saeed Mahameed
- [for-next 6/9] linux/dim: Move implementation to .c files, Saeed Mahameed
- [for-next 7/9] linux/dim: Add completions count to dim_sample, Saeed Mahameed
- [for-next 8/9] linux/dim: Implement rdma_dim, Saeed Mahameed
- [for-next 9/9] RDMA/core: Provide RDMA DIM support for ULPs, Saeed Mahameed
- Re: [pull request][for-next 0/9] Generic DIM lib for netdev and RDMA, Leon Romanovsky
- properly communicate queue limits to the DMA layer,
Christoph Hellwig
- [PATCH 02/13] rsxx: don't call dma_set_max_seg_size, Christoph Hellwig
- [PATCH 04/13] mmc: also set max_segment_size in the device, Christoph Hellwig
- [PATCH 03/13] mtip32xx: also set max_segment_size in the device, Christoph Hellwig
- [PATCH 07/13] storvsc: set virt_boundary_mask in the scsi host template, Christoph Hellwig
- [PATCH 10/13] megaraid_sas: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 06/13] ufshcd: set max_segment_size in the scsi host template, Christoph Hellwig
- [PATCH 11/13] mpt3sas: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 13/13] uas: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 05/13] scsi: add a host / host template field for the virt boundary, Christoph Hellwig
- [PATCH 09/13] IB/srp: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 12/13] usb-storage: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 08/13] IB/iser: set virt_boundary_mask in the scsi host, Christoph Hellwig
- [PATCH 01/13] nvme-pci: don't limit DMA segement size, Christoph Hellwig
- Re: properly communicate queue limits to the DMA layer, Jens Axboe
- [PATCH 0/3] Add RDMA_NLDEV_GET_CHARDEV,
Jason Gunthorpe
- [PATCH 0/3] Move more constant stuff into struct ib_device_ops,
Jason Gunthorpe
- [PATCH RFC] svcrdma: Ignore source port when computing DRC hash,
Chuck Lever
- cma::addr_handler,
Håkon Bugge
- [PATCH] RDMA/ucma: Use struct_size() helper,
Gustavo A. R. Silva
- WARNING: suspicious RCU usage in in_dev_dump_addr, syzbot
- [PATCH v16 00/16] arm64: untag user pointers passed to the kernel,
Andrey Konovalov
- [PATCH v16 01/16] uaccess: add untagged_addr definition for other arches, Andrey Konovalov
- [PATCH v16 02/16] arm64: untag user pointers in access_ok and __uaccess_mask_ptr, Andrey Konovalov
- [PATCH v16 07/16] mm, arm64: untag user pointers in get_vaddr_frames, Andrey Konovalov
- [PATCH v16 10/16] drm/amdgpu, arm64: untag user pointers, Andrey Konovalov
- [PATCH v16 11/16] drm/radeon, arm64: untag user pointers in radeon_gem_userptr_ioctl, Andrey Konovalov
- [PATCH v16 14/16] tee, arm64: untag user pointers in tee_shm_register, Andrey Konovalov
- [PATCH v16 16/16] selftests, arm64: add a selftest for passing tagged pointers to kernel, Andrey Konovalov
- [PATCH v16 15/16] vfio/type1, arm64: untag user pointers in vaddr_get_pfn, Andrey Konovalov
- [PATCH v16 13/16] media/v4l2-core, arm64: untag user pointers in videobuf_dma_contig_user_get, Andrey Konovalov
- [PATCH v16 12/16] IB, arm64: untag user pointers in ib_uverbs_(re)reg_mr(), Andrey Konovalov
- [PATCH v16 08/16] fs, arm64: untag user pointers in copy_mount_options, Andrey Konovalov
- [PATCH v16 09/16] fs, arm64: untag user pointers in fs/userfaultfd.c, Andrey Konovalov
- [PATCH v16 05/16] arm64: untag user pointers passed to memory syscalls, Andrey Konovalov
- [PATCH v16 06/16] mm, arm64: untag user pointers in mm/gup.c, Andrey Konovalov
- [PATCH v16 04/16] mm: untag user pointers in do_pages_move, Andrey Konovalov
- [PATCH v16 03/16] lib, arm64: untag user pointers in strn*_user, Andrey Konovalov
- try_module_get in hfi1,
Jason Gunthorpe
- [PATCH 1/1] net: rds: fix memory leak when unload rds_rdma,
Zhu Yanjun
- [PATCHv2 1/1] net: rds: add per rds connection cache statistics,
Zhu Yanjun
- Difference: VPI verbs API & RDMA_CM verbs API,
Liu, Changcheng
- [PATCH 1/1] net: rds: add per rds connection cache statistics, Zhu Yanjun
- [PATCH for-next 0/2] Two srq bugfixes,
Lijun Ou
- [PATCH 1/2][next] RDMA/hns: fix comparison of unsigned long variable 'end' with less than zero,
Colin King
- [PATCH V4 for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH iproute2-next v1 0/4] Enrich rdma tool for net namespace commands,
Parav Pandit
- [PATCH V2 for-next] RDMA/hns: Bugfix for posting multiple srq work request,
Lijun Ou
- [PATCH V3 for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH 00/20 V5] Introduce new API for T10-PI offload,
Max Gurtovoy
- [PATCH 03/20] RDMA/core: Introduce IB_MR_TYPE_INTEGRITY and ib_alloc_mr_integrity API, Max Gurtovoy
- [PATCH 02/20] RDMA/core: Save the MR type in the ib_mr structure, Max Gurtovoy
- [PATCH 05/20] RDMA/core: Add signature attrs element for ib_mr structure, Max Gurtovoy
- [PATCH 04/20] RDMA/core: Introduce ib_map_mr_sg_pi to map data/protection sgl's, Max Gurtovoy
- [PATCH 01/20] RDMA/core: Introduce new header file for signature operations, Max Gurtovoy
- [PATCH 06/20] RDMA/mlx5: Implement mlx5_ib_map_mr_sg_pi and mlx5_ib_alloc_mr_integrity, Max Gurtovoy
- [PATCH 07/20] RDMA/mlx5: Add attr for max number page list length for PI operation, Max Gurtovoy
- [PATCH 08/20] RDMA/mlx5: Pass UMR segment flags instead of boolean, Max Gurtovoy
- [PATCH 09/20] RDMA/mlx5: Update set_sig_data_segment attribute for new signature API, Max Gurtovoy
- [PATCH 10/20] RDMA/mlx5: Introduce and implement new IB_WR_REG_MR_INTEGRITY work request, Max Gurtovoy
- [PATCH 13/20] RDMA/core: Add an integrity MR pool support, Max Gurtovoy
- [PATCH 12/20] IB/iser: Unwind WR union at iser_tx_desc, Max Gurtovoy
- [PATCH 14/20] RDMA/mlx5: Move signature_en attribute from mlx5_qp to ib_qp, Max Gurtovoy
- [PATCH 15/20] RDMA/core: Validate signature handover device cap, Max Gurtovoy
- [PATCH 16/20] RDMA/rw: Use IB_WR_REG_MR_INTEGRITY for PI handover, Max Gurtovoy
- [PATCH 17/20] RDMA/core: Remove unused IB_WR_REG_SIG_MR code, Max Gurtovoy
- [PATCH 18/20] RDMA/mlx5: Improve PI handover performance, Max Gurtovoy
- [PATCH 11/20] IB/iser: Use IB_WR_REG_MR_INTEGRITY for PI handover, Max Gurtovoy
- [PATCH 19/20] RDMA/mlx5: Use PA mapping for PI handover, Max Gurtovoy
- [PATCH 20/20] RDMA/mlx5: Refactor MR descriptors allocation, Max Gurtovoy
- [PATCH for-next] RDMA/ipoib: Remove check for ETH_SS_TEST,
Kamal Heib
- [PATCH for-next v3 0/4] ib_pd should not have ib_uobject,
Shamir Rabinovitch
- [PATCH] IB/mlx5: Limit to 64-bit builds,
Guenter Roeck
- [bug report] IB/hfi1: Rework fault injection machinery,
Dan Carpenter
- [PATCH] RDMA/uverbs: check for allocation failure in uapi_add_elm(),
Dan Carpenter
- [PATCH v3 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH mlx5-next 0/6] Mellanox, mlx5-next minor updates 2019-05-29,
Saeed Mahameed
- [PATCH mlx5-next 1/6] net/mlx5: Add core dump register access HW bits, Saeed Mahameed
- [PATCH mlx5-next 2/6] net/mlx5: Introduce termination table bits, Saeed Mahameed
- [PATCH mlx5-next 3/6] net/mlx5: E-Switch, Replace host_params event with functions_changed event, Saeed Mahameed
- [PATCH mlx5-next 4/6] net/mlx5: E-Switch, Honor eswitch functions changed event cap, Saeed Mahameed
- [PATCH mlx5-next 5/6] {IB,net}/mlx5: No need to typecast from void* to mlx5_ib_dev*, Saeed Mahameed
- [PATCH mlx5-next 6/6] {IB,net}/mlx5: Constify rep ops functions pointers, Saeed Mahameed
- Re: [PATCH mlx5-next 0/6] Mellanox, mlx5-next minor updates 2019-05-29, Saeed Mahameed
- [PATCH, RESEND] RDMA/srp: Accept again source addresses that do not have a port number,
Bart Van Assche
- [PATCH][next] IB/hfi1: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH][next] IB/qib: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH][next] IB/rdmavt: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH] RDMA/ipoib: implement ethtool .get_link() callback,
Kamal Heib
- [PATCH v2 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [ANNOUNCE] rdma-core v24.0 has been tagged/released, Leon Romanovsky
- [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review,
Chuck Lever
- [PATCH RFC 01/12] xprtrdma: Fix use-after-free in rpcrdma_post_recvs, Chuck Lever
- [PATCH RFC 02/12] xprtrdma: Replace use of xdr_stream_pos in rpcrdma_marshal_req, Chuck Lever
- [PATCH RFC 03/12] xprtrdma: Fix occasional transport deadlock, Chuck Lever
- [PATCH RFC 04/12] xprtrdma: Remove the RPCRDMA_REQ_F_PENDING flag, Chuck Lever
- [PATCH RFC 05/12] xprtrdma: Remove fr_state, Chuck Lever
- [PATCH RFC 06/12] xprtrdma: Add mechanism to place MRs back on the free list, Chuck Lever
- [PATCH RFC 07/12] xprtrdma: Reduce context switching due to Local Invalidation, Chuck Lever
- [PATCH RFC 08/12] xprtrdma: Wake RPCs directly in rpcrdma_wc_send path, Chuck Lever
- [PATCH RFC 09/12] xprtrdma: Simplify rpcrdma_rep_create, Chuck Lever
- [PATCH RFC 10/12] xprtrdma: Streamline rpcrdma_post_recvs, Chuck Lever
- [PATCH RFC 11/12] xprtrdma: Refactor chunk encoding, Chuck Lever
- [PATCH RFC 12/12] xprtrdma: Remove rpcrdma_req::rl_buffer, Chuck Lever
- Re: [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review, Christoph Hellwig
- Re: [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review, Dennis Dalessandro
- [PATCH v1 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH for-rc 0/6] EFA updates 2019-05-28,
Gal Pressman
- [PATCH rdma-next v1 0/3] Convert CQ allocations,
Leon Romanovsky
- [PATCH v2 rdma-next 0/2] RDMA/qedr: Use the doorbell overflow recovery mechanism for RDMA,
Michal Kalderon
- [PATCH V2 for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH v2 net-next 00/11] qed*: Improve performance on 100G link for offload protocols,
Michal Kalderon
- [PATCH v2 net-next 01/11] qed: Modify api for performing a dmae to another PF, Michal Kalderon
- [PATCH v2 net-next 03/11] qed*: Change hwfn used for sb initialization, Michal Kalderon
- [PATCH v2 net-next 05/11] qedr: Change the MSI-X vectors selection to be based on affined engine, Michal Kalderon
- [PATCH v2 net-next 06/11] qed: Set the doorbell address correctly, Michal Kalderon
- [PATCH v2 net-next 04/11] qed: Modify offload protocols to use the affined engine, Michal Kalderon
- [PATCH v2 net-next 07/11] qed: Add qed devlink parameters table, Michal Kalderon
- [PATCH v2 net-next 09/11] Revert "scsi: qedi: Allocate IRQs based on msix_cnt", Michal Kalderon
- [PATCH v2 net-next 11/11] qedf: Use hwfns and affin_hwfn_idx to get MSI-X vector index to use, Michal Kalderon
- [PATCH v2 net-next 10/11] qedi: Use hwfns and affin_hwfn_idx to get MSI-X vector index, Michal Kalderon
- [PATCH v2 net-next 08/11] qed*: Add iWARP 100g support, Michal Kalderon
- [PATCH v2 net-next 02/11] qed: Add llh ppfid interface and 100g support for offload protocols, Michal Kalderon
- Re: [PATCH v2 net-next 00/11] qed*: Improve performance on 100G link for offload protocols, David Miller
- [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver,
Bernard Metzler
- [PATCH for-next v1 11/12] SIW debugging, Bernard Metzler
- [PATCH for-next v1 01/12] iWarp wire packet format, Bernard Metzler
- [PATCH for-next v1 03/12] SIW network and RDMA core interface, Bernard Metzler
- [PATCH for-next v1 10/12] SIW completion queue methods, Bernard Metzler
- [PATCH for-next v1 06/12] SIW application buffer management, Bernard Metzler
- [PATCH for-next v1 02/12] SIW main include file, Bernard Metzler
- [PATCH for-next v1 07/12] SIW queue pair methods, Bernard Metzler
- [PATCH for-next v1 09/12] SIW receive path, Bernard Metzler
- [PATCH for-next v1 04/12] SIW connection management, Bernard Metzler
- [PATCH for-next v1 12/12] SIW addition to kernel build environment, Bernard Metzler
- [PATCH for-next v1 08/12] SIW transmit path, Bernard Metzler
- [PATCH for-next v1 05/12] SIW application interface, Bernard Metzler
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Bernard Metzler
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Jason Gunthorpe
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Bernard Metzler
- [RFC] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH -next] IB/hfi1: remove set but not used variables 'offset' and 'fspsn',
YueHaibing
- [PATCH for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH v2 0/1] infiniband/mm: convert put_page() to put_user_page*(),
john . hubbard
- [PATCH for-rc 0/5] Patches for 5.2 rc cycle,
Dennis Dalessandro
- [PATCH for-next] RDMA/hns: Clear magic number,
Lijun Ou
- [PATCH V2 for-next 0/4] Fixes for hns,
Lijun Ou
- <infiniband/verbs.h> & ICC,
Gerd Rausch
- [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review,
Jason Gunthorpe
- [RFC PATCH 03/11] mm/hmm: Hold a mmgrab from hmm to mm, Jason Gunthorpe
- [RFC PATCH 01/11] mm/hmm: Fix use after free with struct hmm in the mmu notifiers, Jason Gunthorpe
- [RFC PATCH 02/11] mm/hmm: Use hmm_mirror not mm as an argument for hmm_register_range, Jason Gunthorpe
- [RFC PATCH 04/11] mm/hmm: Simplify hmm_get_or_create and make it reliable, Jason Gunthorpe
- [RFC PATCH 05/11] mm/hmm: Improve locking around hmm->dead, Jason Gunthorpe
- [RFC PATCH 06/11] mm/hmm: Remove duplicate condition test before wait_event_timeout, Jason Gunthorpe
- [RFC PATCH 08/11] mm/hmm: Use lockdep instead of comments, Jason Gunthorpe
- [RFC PATCH 09/11] mm/hmm: Remove racy protection against double-unregistration, Jason Gunthorpe
- [RFC PATCH 11/11] mm/hmm: Do not use list*_rcu() for hmm->ranges, Jason Gunthorpe
- [RFC PATCH 10/11] mm/hmm: Poison hmm_range during unregister, Jason Gunthorpe
- [RFC PATCH 07/11] mm/hmm: Delete hmm_mirror_mm_is_alive(), Jason Gunthorpe
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, John Hubbard
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, Jason Gunthorpe
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, Jason Gunthorpe
[Index of Archives]
[Linux USB Development]
[Video for Linux]
[Big List of Linux Books]
[Linux SCSI]
[Scanners]
[Yosemite Info]