Linux Kernel Janitors
[Prev Page][Next Page]
- [PATCH] io_uring: remove unnecessary NULL checks,
Dan Carpenter
- [PATCH v2] tty/serial: cleanup after ioc*_serial driver removal,
Lukas Bulwahn
- [PATCH] tty/serial: cleanup after ioc*_serial driver removal,
Lukas Bulwahn
- [PATCH] mailbox: Fix a typo in Kconfig, Christophe JAILLET
- [PATCH] firmware: tegra: Fix a typo in Kconfig,
Christophe JAILLET
- [PATCH] mfd: Kconfig: Fix some typo,
Christophe JAILLET
- [PATCH] Bluetooth: Fix a typo in Kconfig,
Christophe JAILLET
- [PATCH] platform/x86: Kconfig: Fix a typo, Christophe JAILLET
- [PATCH] MAINTAINERS: adjust to stm32 timer dt-bindings conversion,
Lukas Bulwahn
- [PATCH] tty: serial: Kconfig: Fix a typo, Christophe JAILLET
- [PATCH] dma-buf: Fix a typo in Kconfig,
Christophe JAILLET
- [PATCH] NFC: pn544: Fix a typo in a debug message,
Christophe JAILLET
- [PATCH] ACPICA: Fix a typo in acuuid.h,
Christophe JAILLET
- [PATCH] PM / devfreq: Fix a typo in a comment,
Christophe JAILLET
- [PATCH][next] RDMA/hns: fix spelling mistake: "attatch" -> "attach",
Colin King
- [PATCH] drm/amdgpu: return -EFAULT if copy_to_user() fails,
Dan Carpenter
- [PATCH][next] selftests/resctrl: fix spelling mistake "Errror" -> "Error", Colin King
- [bug report] net: aquantia: add support of rx-vlan-filter offload,
Dan Carpenter
- [PATCH] tee: amdtee: Fix error handling in amdtee_open_session(),
Dan Carpenter
- [PATCH][next] hwmon: axi-fan-control: fix uninitialized dereference of pointer res,
Colin King
- [PATCH][next] io_uring: fix return of an uninitialized variable ret,
Colin King
- [PATCH] gpio: siox: potentially enabling IRQs too early,
Dan Carpenter
- [PATCH] media: staging/imx: Missing assignment in imx_media_capture_device_register(),
Dan Carpenter
- [PATCH] media: dvb: return -EREMOTEIO on i2c transfer failure., Colin King
- [PATCH] media: lmedm04: remove redundant assignment to variable gate, Colin King
- [PATCH] media: tda10071: fix unsigned sign extension overflow,
Colin King
- [PATCH] usb: dwc3: debug: fix string position formatting mixup with ret and len,
Colin King
- [PATCH][V2] ASoC: ti: davinci-mcasp: remove redundant assignment to variable ret,
Colin King
- [PATCH] PCI/ACPI: make array pcie_to_hpx3_type static const, makes object smaller,
Colin King
- [PATCH] staging: exfat: Replace printk with pr_info,
JieunKim
- [PATCH] ALSA: info: remove redundant assignment to variable c,
Colin King
- [PATCH] ALSA: ali5451: remove redundant variable capture_flag,
Colin King
- [PATCH] ALSA: hda: remove redundant assignment to variable timeout,
Colin King
- [PATCH] ALSA: hdsp: remove redundant assignment to variable err,
Colin King
- [PATCH] ASoC: rt5659: remove redundant assignment to variable idx,
Colin King
- [PATCH] ASoC: Intel: mrfld: return error codes when an error occurs,
Colin King
- [PATCH] ASoC: ti: davinci-mcasp: remove redundant assignment to variable ret,
Colin King
- [PATCH] usb: typec: ucsi: remove redundant assignment to variable num,
Colin King
- [PATCH] USB: serial: digi_acceleport: remove redundant assignment to pointer priv,
Colin King
- [PATCH] usb: gadget: remove redundant assignment to variable status, Colin King
- [PATCH] usb: dwc3: debug: remove redundant call to strlen,
Colin King
- [PATCH] usb: cdns3: remove redundant assignment to pointer trb, Colin King
- [PATCH 2/2] powerpc/83xx: Add some error handling in 'quirk_mpc8360e_qe_enet10()',
Christophe JAILLET
- [PATCH 1/2] powerpc/83xx: Fix some typo in some warning message,
Christophe JAILLET
- [PATCH] mtd: fix spelling mistake "BlockMultiplerBits" -> "BlockMultiplierBits", Colin King
- [PATCH][next] ASoC: wcd934x: remove redundant null checks on rx_chs and tx_chs, Colin King
- [PATCH][next] KVM: x86: remove redundant WARN_ON check of an unsigned less than zero,
Colin King
- [PATCH v7] HID: random timeout failures tackle try.,
Lauri Jakku
- [PATCH] drm/amd/display: Fix some use after free bugs,
Dan Carpenter
- [PATCH v6] USB: HID: random timeout failures tackle try.,
Lauri Jakku
- [PATCH] get_maintainer: Prefer MAINTAINER address over S-o-b,
Dan Carpenter
- [PATCH] dmaengine: idxd: Fix error handling in idxd_wq_cdev_dev_setup(),
Dan Carpenter
- [PATCH] staging: greybus: use after free in gb_audio_manager_remove_all(),
Dan Carpenter
- [bug report] node: Add memory-side caching attributes,
Dan Carpenter
- [PATCH] USB HID random timeout failures fixed by trying 20 times,
Lauri Jakku
- [PATCH SECOND RESEND] MAINTAINERS: fix style in SAFESETID SECURITY MODULE, Lukas Bulwahn
- [PATCH net-next] qed: Remove set but not used variable 'p_link',
YueHaibing
- [PATCH][next] clk: ls1028a: fix a dereference of pointer 'parent' before a null check,
Colin King
- [PATCH -next] NFS: use correct 'verifier' in nfs_lookup_revalidate_dentry, YueHaibing
- [PATCH -next] crypto: ccree - remove set but not used variable 'du_size',
YueHaibing
- [PATCH -next] drm/panfrost: Remove set but not used variable 'bo',
YueHaibing
- [bug report] x86/intel_pstate: Handle runtime turbo disablement/enablement in frequency invariance, Dan Carpenter
- [PATCH net-next] rtw88: use kfree_skb() instead of kfree(),
Wei Yongjun
- [PATCH] MIPS: VPE: Fix a double free and a memory leak in 'release_vpe()',
Christophe JAILLET
- [PATCH] defxx: Fix a sentinel at the end of a 'eisa_device_id' structure,
Christophe JAILLET
- [PATCH -next] ASoC: Remove unused including <linux/version.h>, YueHaibing
- [PATCH net] net: sched: prevent a use after free,
Dan Carpenter
- [PATCH net] qed: Fix a error code in qed_hw_init(),
Dan Carpenter
- [PATCH net] octeontx2-pf: Fix an IS_ERR() vs NULL bug,
Dan Carpenter
- [PATCH net] device property: change device_get_phy_mode() to prevent signedess bugs,
Dan Carpenter
- [PATCH] drm/amd/display: Possible divide by zero in set_speed(),
Dan Carpenter
- [PATCH net] ice: Fix a couple off by one bugs,
Dan Carpenter
- [PATCH][next] thermal: stm32: fix spelling mistake "preprare" -> "prepare", Colin King
- [PATCH] rtw88: Use kfree_skb() instead of kfree(),
Dan Carpenter
- [PATCH] USB: serial: ir-usb: Silence harmless uninitialized variable warning,
Dan Carpenter
- [PATCH] drm/amd/display: fix spelling mistake link_integiry_check -> link_integrity_check,
Colin King
- [PATCH] Bluetooth: SMP: Fix SALT value in some comments,
Christophe JAILLET
- [PATCH] iio: imu: st_lsm6dsx: Fix mismatched comments,
JieunKim
- [PATCH][next][V3] i2c: xiic: fix indentation issue,
Colin King
- [PATCH][next][V2] i2c: xiic: fix indentation issue,
Colin King
- [PATCH] staging: rtl8723bs: fix copy of overlapping memory,
Colin King
- [PATCH] net/mlx5: Remove a useless 'drain_workqueue()' call in 'mlx5e_ipsec_cleanup()',
Christophe JAILLET
- [RFC] Simplify flush_workqueue/destroy_workqueue pattern,
Christophe JAILLET
- [PATCH][next] scsi: megaraid_sas: fix indentation issue,
Colin King
- [PATCH][next] i2c: xiic: fix indentation issue,
Colin King
- [PATCH] scsi: mvsas: ensure loop counter phy_no does not wrap and cause an infinite loop,
Colin King
- [PATCH v2] drivers: net: xgene: Fix the order of the arguments of 'alloc_etherdev_mqs()', Christophe JAILLET
- [PATCH] drivers: net: xgene: Fix the order,
Christophe JAILLET
- [PATCH] ionic: Fix rx queue allocation in 'ionic_lif_alloc()',
Christophe JAILLET
- [PATCH] gianfar: Allocate the correct number of rx queues in 'gfar_of_init()',
Christophe JAILLET
- [PATCH][next] iwlegacy: ensure loop counter addr does not wrap and cause an infinite loop,
Colin King
- [PATCH] mlxsw: minimal: Fix an error handling path in 'mlxsw_m_port_create()',
Christophe JAILLET
- [PATCH] i2c: parport: fix spelling mistake: "Atmost" -> "At most",
Colin King
- [PATCH] um: Fix some error handling in uml_vector_user_bpf(),
Dan Carpenter
- [PATCH] fs/adfs: bigdir: Fix an error code in adfs_fplus_read(),
Dan Carpenter
- [PATCH] dma-buf: fix locking in sync_print_obj(),
Dan Carpenter
- [PATCH][next] drm/i915/gem: fix null pointer dereference on vm,
Colin King
- [PATCH][V2] net/rose: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] dmaengine: fix spelling mistake "to" -> "too",
Colin King
- [PATCH][V2] iio: ad5755: fix spelling mistake "to" -> "too" and grammar,
Colin King
- [PATCH] media: allegro: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] staging: comedi: drivers: fix spelling mistake "to" -> "too", Colin King
- [PATCH] net/rose: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] scsi: pm80xx: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] MIPS: OCTEON: octeon-irq: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] wcn36xx: rockchip: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] ARM: rockchip: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] caif_usb: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] ipvs: fix spelling mistake "to" -> "too", Colin King
- [PATCH] partitions/ldm: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] w1: ds1wm: fix spelling mistake "to" -> "too", Colin King
- [PATCH] drm/amd/amdgpu: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] ar5523: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] i40e: fix spelling mistake "to" -> "too", Colin King
- [PATCH] staging: qlge: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] ALSA: cs46xx: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] iio: ad5755: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] media: rc: fix spelling mistake "to" -> "too", Colin King
- [PATCH] dmaengine: s3c24xx-dma: fix spelling mistake "to" -> "too",
Colin King
- [PATCH] usb: cdns3: fix spelling mistake and rework grammar in text,
Colin King
- [PATCH] USB: serial: cyberjack: fix spelling mistake "To" -> "Too",
Colin King
- [PATCH] leds: lm3697: fix spelling mistake "To" -> "Too",
Colin King
- [PATCH] rtlwifi: btcoex: fix spelling mistake "initilized" -> "initialized",
Colin King
- [PATCH][next] dmaengine: ti: k3-udma: fix spelling mistake "limted" -> "limited",
Colin King
- [PATCH][next] scsi: ufs: fix spelling mistake "initilized" -> "initialized",
Colin King
- [PATCH][next] iio: st_sensors: handle memory allocation failure to fix null pointer dereference,
Colin King
- Open tasks?,
Raymond Deng
- [PATCH] crypto: rng - Fix a refcounting bug in crypto_rng_reset(),
Dan Carpenter
- [bug report] netdevsim: fib: Add dummy implementation for FIB offload,
Dan Carpenter
- [PATCH -next] watch_queue: Fix error return code in watch_queue_set_size(),
Wei Yongjun
- [PATCH -next] PCI: brcmstb: Fix missing mutex_init(),
Wei Yongjun
- [PATCH][next] drm/amd/display: fix for-loop with incorrectly sized loop counter,
Colin King
- [PATCH][next] usb: musb: fix spelling mistake: "periperal" -> "peripheral",
Colin King
- [PATCH][next] crypto: hisilicon: fix spelling mistake "disgest" -> "digest",
Colin King
- [PATCH] btrfs: tests: Fix an NULL vs IS_ERR() test,
Dan Carpenter
- [PATCH] tracing/boot: Fix an IS_ERR() vs NULL bug,
Dan Carpenter
- [PATCH -next] ASoC: rt715: fix return value check in rt715_sdw_probe(),
Wei Yongjun
- [PATCH RESEND] MAINTAINERS: fix style in SAFESETID SECURITY MODULE, Lukas Bulwahn
- [PATCH][next] power: supply: bq25890_charger: fix incorrect error return when bq25890_field_read fails,
Colin King
- [PATCH RESEND] MAINTAINERS: fix style in RESET CONTROLLER FRAMEWORK,
Lukas Bulwahn
- [PATCH][next] driver core: platform: fix u32 greater or equal to zero comparison,
Colin King
- [PATCH][next][V2] tee: fix memory allocation failure checks on drv_data and amdtee,
Colin King
- [PATCH][next][resend] tee: fix memory allocation failure checks on drv_data and amdtee,
Colin King
- [PATCH] selftests: fix spelling mistaked "chaigned" -> "chained",
Colin King
- [PATCH][next] tools: bootconfig: fix spelling mistake "faile" -> "failed",
Colin King
- [PATCH -next] regulator: vqmmc-ipq4019: Fix platform_no_drv_owner.cocci warnings,
YueHaibing
- [PATCH net-next] sfc: remove duplicated include from efx.c,
YueHaibing
- [PATCH -next] ASoC: rt715: remove unused including <linux/version.h>,
YueHaibing
- [PATCH] HID: hiddev: Fix race in in hiddev_disconnect(),
Dan Carpenter
- [PATCH] ALSA: usb-audio: unlock on error in probe,
Dan Carpenter
- [PATCH] iio: accel: bma400: integer underflow setting accel scale,
Dan Carpenter
- [PATCH] EDAC/sifive: fix return value check in ecc_register(),
Wei Yongjun
- [PATCH -next] ASoC: rt711: fix return value check in rt711_sdw_probe(),
Wei Yongjun
- [PATCH -next] ASoC: rt700: fix return value check in rt700_sdw_probe(),
Wei Yongjun
- [PATCH] staging: wlan-ng: ensure error return is actually returned, Colin King
- [PATCH][next] staging: wilc1000: remove redundant assignment to variable result,
Colin King
- [PATCH][next] staging: vt6655: remove redundant assignment to variable ret, Colin King
- [PATCH] rtlwifi: rtl8188ee: remove redundant assignment to variable cond,
Colin King
- syzbot is quite fun,
Dan Carpenter
- [PATCH] ALSA: hda - fix out of bounds read on spec->smux_paths,
Colin King
- [PATCH] net/wan/fsl_ucc_hdlc: fix out of bounds write on array utdm_info,
Colin King
- [PATCH][next] drivers: ipmi: fix off-by-one bounds check that leads to a out-of-bounds write,
Colin King
- [PATCH] x86/microcode/amd: fix uninitalized structure cp,
Colin King
- [bug report] scripts/dtc: Update to upstream version v1.5.0-23-g87963ee20693, Dan Carpenter
- [PATCH] hwmon: (adm1177) Fix adm1177_write_alert_thr(),
Dan Carpenter
- [PATCH] media: c8sectpfe: clean up some indenting,
Dan Carpenter
- [PATCH] zswap: potential NULL dereference on error in init_zswap(), Dan Carpenter
- [PATCH -next] ASoC: rt700: remove unused including <linux/version.h>,
YueHaibing
- [PATCH] video: fbdev: nvidia: clean up indentation issues and comment block,
Colin King
- [PATCH][next] drm/gma500: clean up two indentation issues, Colin King
- [PATCH] ubi: Fix an error pointer dereference in error handling code,
Dan Carpenter
- [PATCH] nfsd4: fix double free in nfsd4_do_async_copy(),
Dan Carpenter
- [bug report] bpf: Introduce BPF_MAP_TYPE_STRUCT_OPS,
Dan Carpenter
- [PATCH] regulator: mpq7920: Check the correct variable in mpq7920_regulator_register(),
Dan Carpenter
- [PATCH][next][V2] drivers/misc: ti-st: remove redundant assignment to variables i and flags, Colin King
- [PATCH -next] ASoC: rt711: remove unused including <linux/version.h>,
YueHaibing
- [PATCH][next] ath11k: avoid null pointer dereference when pointer band is null,
Colin King
Re: [PATCH v3] coccinelle: semantic patch to check for inappropriate do_div() calls,
Markus Elfring
[PATCH][next] PM: hibernate: fix spelling mistake "shapshot" -> "snapshot",
Colin King
[PATCH] devices.txt: fix spelling mistake: "shapshot" -> "snapshot",
Colin King
[PATCH net-next] sfc: remove set but not used variable 'nic_data',
YueHaibing
[PATCH] regulator: mp8859: tidy up white space in probe,
Dan Carpenter
[PATCH] btrfs: Fix error code in btrfs_sysfs_add_mounted(),
Dan Carpenter
[PATCH] drm/v3d: Fix a double free in the ioctl, Dan Carpenter
[PATCH net-next] sfc: remove duplicated include from ef10.c,
YueHaibing
[PATCH -next] phy: ti: j721e-wiz: Fix return value check in wiz_probe(), Wei Yongjun
[PATCH -next] drm/mgag200: Fix typo in parameter description,
Wei Yongjun
[PATCH -next] pwm: sun4i: Fix wrong pointer passed to PTR_ERR(),
Wei Yongjun
Re: [PATCH] selinuxfs: use scnprintf to get real length in sel_read_class, Markus Elfring
[PATCH][next][V2] dmaengine: ti: omap-dma: don't allow a null od->plat pointer to be dereferenced,
Colin King
Re: [PATCH] trace: code optimization,
Markus Elfring
Re: [PATCH v2] coccinelle: semantic patch to check for inappropriate do_div() calls,
Markus Elfring
[PATCH] scsi: BusLogic: use %lX for unsigned long rather than %X,
Colin King
[PATCH] selftests: Uninitialized variable in test_cgcore_proc_migration(),
Dan Carpenter
[PATCH] nouveau/secboot/gm20b: initialize pointer in gm20b_secboot_new(),
Dan Carpenter
[PATCH] gpu/drm: clean up white space in drm_legacy_lock_master_cleanup(),
Dan Carpenter
[PATCH] ethtool: potential NULL dereference in strset_prepare_data(),
Dan Carpenter
[PATCH net-next] ethtool: fix ->reply_size() error handling,
Dan Carpenter
[PATCH net-next] ethtool: fix a memory leak in ethnl_default_start(),
Dan Carpenter
[PATCH] ALSA: control: potential uninitialized return value,
Dan Carpenter
[PATCH] media: hantro: remove a pointless NULL check,
Dan Carpenter
[PATCH] power: avs: qcom-cpr: Fix error code in cpr_fuse_corner_init(),
Dan Carpenter
[PATCH -next] ASoC: amd: acp3x: Fix return value check in acp3x_dai_probe(), Wei Yongjun
[PATCH -next] Bluetooth: hci_qca: Use vfree() instead of kfree(),
Wei Yongjun
[PATCH -next] hwmon: (w83627ehf) Remove set but not used variable 'fan4min',
YueHaibing
[PATCH -next] power: avs: qcom-cpr: remove duplicated include from qcom-cpr.c,
YueHaibing
[PATCH -next] Bluetooth: hci_qca: Remove set but not used variable 'opcode',
YueHaibing
[PATCH -next] leds: leds-bd2802: remove set but not used variable 'pdata',
YueHaibing
[PATCH] Bluetooth: remove redundant assignment to variable icid,
Colin King
[PATCH] misc: tsl2550: remove redundant initialization to variable r, Colin King
[PATCH] media: drxj: remove redundant assignments to variable rc, Colin King
[PATCH] net/rose: remove redundant assignment to variable failed,
Colin King
[PATCH][next] tee: fix memory allocation failure checks on drv_data and amdtee,
Colin King
[PATCH][next] media: v4l2-core: fix uninitialized structure fields being returned to userspace,
Colin King
[PATCH net-next] enetc: Fix an off by one in enetc_setup_tc_txtime(),
Dan Carpenter
[PATCH 1/2] cmd64x: potential buffer overflow in cmd64x_program_timings(),
Dan Carpenter
Re: [PATCH 1/2] cmd64x: potential buffer overflow in cmd64x_program_timings(), David Miller
[PATCH] drm/i915: fix an error code in intel_modeset_all_tiles(),
Dan Carpenter
[PATCH][next] phy: cadence: Sierra: remove redundant initialization of pointer regmap, Colin King
[PATCH][V3] usb: ohci-da8xx: ensure error return on variable error is set,
Colin King
[PATCH][V2] usb: ohci-da8xx: ensure error return on variable error is set,
Colin King
[PATCH][next] scsi: qla2xxx: fix null pointer dereference on null_fcport,
Colin King
[PATCH][next] NFS: Add missing null check for failed allocation, Colin King
[PATCH] usb: ohci-da8xx: ensure error return on variable error is set,
Colin King
[PATCH][next] dmaengine: ti: omap-dma: don't allow a null od->plat pointer to be dereferenced,
Colin King
[PATCH][next] power: avs: fix uninitialized error return on failed cpr_read_fuse_uV call,
Colin King
[PATCH][next] usb: typec: ucsi: fix spelling mistake "connetor" -> "connector",
Colin King
[PATCH] gtp: simplify error handling code in 'gtp_encap_enable()',
Christophe JAILLET
Re: [PATCH] coccinelle: semantic patch to check for inappropriate do_div() calls,
Markus Elfring
[PATCH net-next] ethtool: remove set but not used variable 'lsettings',
YueHaibing
[PATCH net-next] tcp: use REXMIT_NEW instead of magic number,
Mao Wenan
[PATCH 00/10] use resource_size,
Julia Lawall
- [PATCH 07/10] video: fbdev: use resource_size, Julia Lawall
- [PATCH 09/10] x86/crash: use resource_size, Julia Lawall
- [PATCH 08/10] MIPS: use resource_size, Julia Lawall
- [PATCH 06/10] ASoC: SOF: imx8: use resource_size, Julia Lawall
- [PATCH 10/10] powerpc/powernv: use resource_size, Julia Lawall
- [PATCH 05/10] powerpc/83xx: use resource_size, Julia Lawall
- [PATCH 03/10] fbdev: s1d13xxxfb: use resource_size, Julia Lawall
- [PATCH 04/10] fsl/fman: use resource_size, Julia Lawall
- [PATCH 01/10] USB: omap_udc: use resource_size, Julia Lawall
- [PATCH 02/10] ALSA: ml403-ac97cr: use resource_size, Julia Lawall
[PATCH 00/16] constify copied structure,
Julia Lawall
[Index of Archives]
[Kernel Development]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[Linux ATA RAID]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]