Linux Block Development
[Prev Page][Next Page]
- [PATCH] loop: Improve the hw_queue_depth kernel module parameter implementation,
Bart Van Assche
- [PATCH] block: Fix the blk_mq_destroy_queue() documentation,
Bart Van Assche
- [PATCH] block: Default to use cgroup support for BFQ,
Ulf Hansson
- [GIT PULL] iov_iter: Improve page extraction (pin or just list),
David Howells
- add bvec initialization helpers,
Christoph Hellwig
- [PATCH 01/23] block: factor out a bvec_set_page helper, Christoph Hellwig
- [PATCH 03/23] block: add a bvec_set_virt helper, Christoph Hellwig
- [PATCH 07/23] nvme: use bvec_set_virt to initialize special_vec, Christoph Hellwig
- [PATCH 05/23] target: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 02/23] block: add a bvec_set_folio helper, Christoph Hellwig
- [PATCH 04/23] sd: factor out a sd_set_special_bvec helper, Christoph Hellwig
- [PATCH 06/23] nvmet: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 08/23] rbd: use bvec_set_page to initialize the copy up bvec, Christoph Hellwig
- [PATCH 11/23] afs: use bvec_set_folio to initialize a bvec, Christoph Hellwig
- [PATCH 09/23] virtio_blk: use bvec_set_virt to initialize special_vec, Christoph Hellwig
- [PATCH 10/23] zram: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 13/23] cifs: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 14/23] coredump: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 16/23] orangefs: use bvec_set_{page,folio} to initialize bvecs, Christoph Hellwig
- [PATCH 12/23] ceph: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 18/23] io_uring: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 15/23] nfs: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 20/23] rxrpc: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 17/23] splice: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 19/23] swap: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 22/23] vring: use bvec_set_page to initialize a bvec, Christoph Hellwig
- [PATCH 21/23] sunrpc: use bvec_set_page to initialize bvecs, Christoph Hellwig
- [PATCH 23/23] net-ceph: use bvec_set_page to initialize bvecs, Christoph Hellwig
- Re: [PATCH 20/23] rxrpc: use bvec_set_page to initialize a bvec, David Howells
- Re: [PATCH 01/23] block: factor out a bvec_set_page helper, David Howells
- Re: [PATCH 20/23] rxrpc: use bvec_set_page to initialize a bvec, David Howells
- Re: [PATCH 11/23] afs: use bvec_set_folio to initialize a bvec, David Howells
- [PATCH v2 block-6.2] block, bfq: fix uaf for bfqq in bic_set_bfqq(),
Yu Kuai
- LSF/MM/BPF BoF: pains / goods with automation with kdevops,
Luis Chamberlain
- [PATCH v5.15.90 backport] block: don't allow multiple bios for IOCB_NOWAIT issue, Michael Kelley
- [PATCH-next v3] blk-mq: cleanup unused methods: blk_mq_hw_sysfs_store,
Zhong Jinghua
- [PATCH] null_blk: Support configuring the maximum segment size,
Bart Van Assche
- [GIT PULL] Block fixes for 6.2-rc6,
Jens Axboe
- [PATCH] block: Default to build the BFQ I/O scheduler,
Ulf Hansson
- [PATCH 00/35] Documentation: correct lots of spelling errors (series 1),
Randy Dunlap
- Re: [RFC] Live resize of bcache backing device, Eric Wheeler
- [PATCH v8 00/25] DEPT(Dependency Tracker),
Byungchul Park
- [PATCH v8 01/25] llist: Move llist_{head,node} definition to types.h, Byungchul Park
- [PATCH v8 03/25] dept: Add single event dependency tracker APIs, Byungchul Park
- [PATCH v8 11/25] dept: Apply sdt_might_sleep_{start,end}() to hashed-waitqueue wait, Byungchul Park
- [PATCH v8 14/25] dept: Add a mechanism to refill the internal memory pools on running out, Byungchul Park
- [PATCH v8 07/25] dept: Apply sdt_might_sleep_{start,end}() to wait_for_completion()/complete(), Byungchul Park
- [PATCH v8 09/25] dept: Apply sdt_might_sleep_{start,end}() to swait, Byungchul Park
- [PATCH v8 05/25] dept: Tie to Lockdep and IRQ tracing, Byungchul Park
- [PATCH v8 06/25] dept: Add proc knobs to show stats and dependency graph, Byungchul Park
- [PATCH v8 08/25] dept: Apply sdt_might_sleep_{start,end}() to PG_{locked,writeback} wait, Byungchul Park
- [PATCH v8 15/25] locking/lockdep, cpu/hotplus: Use a weaker annotation in AP thread, Byungchul Park
- [PATCH v8 16/25] dept: Apply sdt_might_sleep_{start,end}() to dma fence wait, Byungchul Park
- [PATCH v8 13/25] dept: Distinguish each work from another, Byungchul Park
- [PATCH v8 12/25] dept: Distinguish each syscall context from another, Byungchul Park
- [PATCH v8 04/25] dept: Add lock dependency tracker APIs, Byungchul Park
- [PATCH v8 10/25] dept: Apply sdt_might_sleep_{start,end}() to waitqueue wait, Byungchul Park
- [PATCH v8 02/25] dept: Implement Dept(Dependency Tracker), Byungchul Park
- [PATCH v8 24/25] dept: Make Dept able to work with an external wgen, Byungchul Park
- [PATCH v8 25/25] dept: Track the potential waits of PG_{locked,writeback}, Byungchul Park
- [PATCH v8 19/25] dept: Apply timeout consideration to swait, Byungchul Park
- [PATCH v8 21/25] dept: Apply timeout consideration to hashed-waitqueue wait, Byungchul Park
- [PATCH v8 17/25] dept: Track timeout waits separately with a new Kconfig, Byungchul Park
- [PATCH v8 23/25] dept: Record the latest one out of consecutive waits of the same class, Byungchul Park
- [PATCH v8 20/25] dept: Apply timeout consideration to waitqueue wait, Byungchul Park
- [PATCH v8 22/25] dept: Apply timeout consideration to dma fence wait, Byungchul Park
- [PATCH v8 18/25] dept: Apply timeout consideration to wait_for_completion()/complete(), Byungchul Park
- [LSF/MM/BPF TOPIC] State Of The Page,
Matthew Wilcox
- [PATCH v11 0/8] iov_iter: Improve page extraction (pin or just list),
David Howells
- [PATCH] block: ublk: move ublk_chr_class destroying after devices are removed,
Ming Lei
- [PATCH] loop: change fsync to fdatasync when update dio,
Huijin Park
- [RFC PATCH 0/7] Allow race-free block device handling,
Demi Marie Obenour
- [PATCH v10 0/8] iov_iter: Improve page extraction (pin or just list),
David Howells
- kernel oops when rmmod'ing ublk_drv w/ missing UBLK_CMD_START_DEV,
Harris, James R
- remove ->rw_page,
Christoph Hellwig
- [PATCH v3 00/18] Add Command Duration Limits support,
Niklas Cassel
- [PATCH v3 01/18] block: introduce duration-limits priority class, Niklas Cassel
- [PATCH v3 02/18] block: introduce BLK_STS_DURATION_LIMIT, Niklas Cassel
- [PATCH v3 03/18] scsi: core: allow libata to complete successful commands via EH, Niklas Cassel
- [PATCH v3 04/18] scsi: rename and move get_scsi_ml_byte(), Niklas Cassel
- [PATCH v3 05/18] scsi: support retrieving sub-pages of mode pages, Niklas Cassel
- [PATCH v3 06/18] scsi: support service action in scsi_report_opcode(), Niklas Cassel
- [PATCH v3 07/18] scsi: sd: detect support for command duration limits, Niklas Cassel
- [PATCH v3 08/18] scsi: sd: set read/write commands CDL index, Niklas Cassel
- [PATCH v3 09/18] scsi: sd: handle read/write CDL timeout failures, Niklas Cassel
- [PATCH v3 10/18] ata: libata-scsi: remove unnecessary !cmd checks, Niklas Cassel
- [PATCH v3 11/18] ata: libata: change ata_eh_request_sense() to not set CHECK_CONDITION, Niklas Cassel
- [PATCH v3 13/18] ata: libata-scsi: handle CDL bits in ata_scsiop_maint_in(), Niklas Cassel
- [PATCH v3 12/18] ata: libata: detect support for command duration limits, Niklas Cassel
- [PATCH v3 14/18] ata: libata-scsi: add support for CDL pages mode sense, Niklas Cassel
- [PATCH v3 15/18] ata: libata: add ATA feature control sub-page translation, Niklas Cassel
- [PATCH v3 16/18] ata: libata: set read/write commands CDL index, Niklas Cassel
- [PATCH v3 17/18] ata: libata: handle completion of CDL commands using policy 0xD, Niklas Cassel
- [PATCH v3 18/18] Documentation: sysfs-block-device: document command duration limits, Niklas Cassel
- [PATCH v9 0/8] iov_iter: Improve page extraction (pin or just list),
David Howells
- WARNING in get_floppy_geometry, Sanan Hasanov
- general protection fault in floppy_ready, Sanan Hasanov
- [PATCH AUTOSEL 5.4 4/6] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 5.15 10/14] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 5.10 6/8] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 6.1 16/35] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 6.1 19/35] block: fix hctx checks for batch allocation, Sasha Levin
- switch blk-cgroup to work on gendisk v2,
Christoph Hellwig
- [PATCH 01/15] blk-cgroup: don't defer blkg_free to a workqueue, Christoph Hellwig
- [PATCH 02/15] block: don't call blk_throtl_stat_add for non-READ/WRITE commands, Christoph Hellwig
- [PATCH 03/15] blk-cgroup: delay blk-cgroup initialization until add_disk, Christoph Hellwig
- [PATCH 04/15] blk-cgroup: pin the gendisk in struct blkcg_gq, Christoph Hellwig
- [PATCH 05/15] blk-cgroup: store a gendisk to throttle in struct task_struct, Christoph Hellwig
- [PATCH 06/15] blk-wbt: pass a gendisk to wbt_{enable,disable}_default, Christoph Hellwig
- [PATCH 07/15] blk-wbt: pass a gendisk to wbt_init, Christoph Hellwig
- [PATCH 08/15] blk-wbt: open code wbt_queue_depth_changed in wbt_update_limits, Christoph Hellwig
- [PATCH 09/15] blk-rq-qos: make rq_qos_add and rq_qos_del more useful, Christoph Hellwig
- [PATCH 10/15] blk-rq-qos: constify rq_qos_ops, Christoph Hellwig
- [PATCH 11/15] blk-rq-qos: store a gendisk instead of request_queue in struct rq_qos, Christoph Hellwig
- [PATCH 12/15] blk-cgroup: pass a gendisk to blkcg_{de,}activate_policy, Christoph Hellwig
- [PATCH 13/15] blk-cgroup: pass a gendisk to pd_alloc_fn, Christoph Hellwig
- [PATCH 14/15] blk-cgroup: pass a gendisk to blkg_lookup, Christoph Hellwig
- [PATCH 15/15] blk-cgroup: move the cgroup information to struct gendisk, Christoph Hellwig
- What would happen if the block device driver/firmware found some block of a bio is corrupted?,
Qu Wenruo
- [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list),
David Howells
- [PATCH v8 03/10] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v8 02/10] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v8 01/10] iov_iter: Define flags to qualify page extraction., David Howells
- [PATCH v8 06/10] block: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v8 07/10] block: Switch to pinning pages., David Howells
- [PATCH v8 08/10] block: Convert bio_iov_iter_get_pages to use iov_iter_extract_pages, David Howells
- [PATCH v8 04/10] iomap: don't get an reference on ZERO_PAGE for direct I/O block zeroing, David Howells
- [PATCH v8 05/10] block: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v8 09/10] block: convert bio_map_user_iov to use iov_iter_extract_pages, David Howells
- [PATCH v8 10/10] mm: Renumber FOLL_PIN and FOLL_GET down, David Howells
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), John Hubbard
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Hildenbrand
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Howells
- [PATCH] s390/dcssblk:: don't call bio_split_to_limits,
Christoph Hellwig
- [PATCH] ps3vram: remove bio splitting,
Christoph Hellwig
- [PATCH v2] paride/pcd: return earlier when an error happens in pcd_atapi(),
Tom Rix
- [PATCH v2] pata_parport: add driver (PARIDE replacement),
Ondrej Zary
- Re: [PATCH v2] pata_parport: add driver (PARIDE replacement), Ondrej Zary
Re: [PATCH v2] pata_parport: add driver (PARIDE replacement), Hannes Reinecke
[LSF/MM/BPF proposal]: Physr discussion,
Jason Gunthorpe
consolidate btrfs checksumming, repair and bio splitting v4,
Christoph Hellwig
- [PATCH 01/34] block: export bio_split_rw, Christoph Hellwig
- [PATCH 02/34] btrfs: better document struct btrfs_bio, Christoph Hellwig
- [PATCH 06/34] btrfs: slightly refactor btrfs_submit_bio, Christoph Hellwig
- [PATCH 03/34] btrfs: add a btrfs_inode pointer to struct btrfs_bio, Christoph Hellwig
- [PATCH 04/34] btrfs: remove the direct I/O read checksum lookup optimization, Christoph Hellwig
- [PATCH 07/34] btrfs: save the bio iter for checksum validation in common code, Christoph Hellwig
- [PATCH 08/34] btrfs: pre-load data checksum for reads in btrfs_submit_bio, Christoph Hellwig
- [PATCH 05/34] btrfs: simplify btrfs_lookup_bio_sums, Christoph Hellwig
- [PATCH 11/34] btrfs: remove btrfs_bio_free_csum, Christoph Hellwig
- [PATCH 10/34] btrfs: handle checksum validation and repair at the storage layer, Christoph Hellwig
- [PATCH 09/34] btrfs: add a btrfs_data_csum_ok helper, Christoph Hellwig
- [PATCH 12/34] btrfs: remove btrfs_bio_for_each_sector, Christoph Hellwig
- [PATCH 13/34] btrfs: remove now unused checksumming helpers, Christoph Hellwig
- [PATCH 14/34] btrfs: remove the device field in struct btrfs_bio, Christoph Hellwig
- [PATCH 16/34] btrfs: rename the iter field in struct btrfs_bio, Christoph Hellwig
- [PATCH 15/34] btrfs: remove the io_failure_record infrastructure, Christoph Hellwig
- [PATCH 17/34] btrfs: remove the is_metadata flag in struct btrfs_bio, Christoph Hellwig
- [PATCH 18/34] btrfs: remove the submit_bio_start helpers, Christoph Hellwig
- [PATCH 19/34] btrfs: simplify the btrfs_csum_one_bio calling convention, Christoph Hellwig
- [PATCH 20/34] btrfs: handle checksum generation in the storage layer, Christoph Hellwig
- [PATCH 21/34] btrfs: handle recording of zoned writes in the storage layer, Christoph Hellwig
- [PATCH 24/34] btrfs: pass the iomap bio to btrfs_submit_bio, Christoph Hellwig
- [PATCH 31/34] btrfs: remove now spurious bio submission helpers, Christoph Hellwig
- [PATCH 26/34] btrfs: remove stripe boundary calculation for compressed I/O, Christoph Hellwig
- [PATCH 29/34] btrfs: remove submit_encoded_read_bio, Christoph Hellwig
- [PATCH 23/34] btrfs: allow btrfs_submit_bio to split bios, Christoph Hellwig
- [PATCH 22/34] btrfs: support cloned bios in btree_csum_one_bio, Christoph Hellwig
- [PATCH 30/34] btrfs: remove the fs_info argument to btrfs_submit_bio, Christoph Hellwig
- [PATCH 28/34] btrfs: remove struct btrfs_io_geometry, Christoph Hellwig
- [PATCH 27/34] btrfs: remove stripe boundary calculation for encoded I/O, Christoph Hellwig
- [PATCH 25/34] btrfs: remove stripe boundary calculation for buffered I/O, Christoph Hellwig
- [PATCH 32/34] btrfs: calculate file system wide queue limit for zoned mode, Christoph Hellwig
- [PATCH 34/34] iomap: remove IOMAP_F_ZONE_APPEND, Christoph Hellwig
- [PATCH 33/34] btrfs: split zone append bios in btrfs_submit_bio, Christoph Hellwig
- Re: consolidate btrfs checksumming, repair and bio splitting v4, Christoph Hellwig
[PATCH] atari: stricter partition validation, Goldwyn Rodrigues
[GIT PULL] Block fixes for 6.2-rc5,
Jens Axboe
[PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list),
David Howells
[Index of Archives]
[Linux RAID]
[Linux SCSI]
[Linux ATA RAID]
[Linux Wireless]
[Linux Bluetooth]
[Kernel Announce]
[Kernel Newbies]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]