Linux Block Development
[Prev Page][Next Page]
- [PATCH AUTOSEL 5.4 4/6] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 5.15 10/14] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 5.10 6/8] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 6.1 16/35] blk-cgroup: fix missing pd_online_fn() while activating policy, Sasha Levin
- [PATCH AUTOSEL 6.1 19/35] block: fix hctx checks for batch allocation, Sasha Levin
- switch blk-cgroup to work on gendisk v2,
Christoph Hellwig
- [PATCH 01/15] blk-cgroup: don't defer blkg_free to a workqueue, Christoph Hellwig
- [PATCH 02/15] block: don't call blk_throtl_stat_add for non-READ/WRITE commands, Christoph Hellwig
- [PATCH 03/15] blk-cgroup: delay blk-cgroup initialization until add_disk, Christoph Hellwig
- [PATCH 04/15] blk-cgroup: pin the gendisk in struct blkcg_gq, Christoph Hellwig
- [PATCH 05/15] blk-cgroup: store a gendisk to throttle in struct task_struct, Christoph Hellwig
- [PATCH 06/15] blk-wbt: pass a gendisk to wbt_{enable,disable}_default, Christoph Hellwig
- [PATCH 07/15] blk-wbt: pass a gendisk to wbt_init, Christoph Hellwig
- [PATCH 08/15] blk-wbt: open code wbt_queue_depth_changed in wbt_update_limits, Christoph Hellwig
- [PATCH 09/15] blk-rq-qos: make rq_qos_add and rq_qos_del more useful, Christoph Hellwig
- [PATCH 10/15] blk-rq-qos: constify rq_qos_ops, Christoph Hellwig
- [PATCH 11/15] blk-rq-qos: store a gendisk instead of request_queue in struct rq_qos, Christoph Hellwig
- [PATCH 12/15] blk-cgroup: pass a gendisk to blkcg_{de,}activate_policy, Christoph Hellwig
- [PATCH 13/15] blk-cgroup: pass a gendisk to pd_alloc_fn, Christoph Hellwig
- [PATCH 14/15] blk-cgroup: pass a gendisk to blkg_lookup, Christoph Hellwig
- [PATCH 15/15] blk-cgroup: move the cgroup information to struct gendisk, Christoph Hellwig
- What would happen if the block device driver/firmware found some block of a bio is corrupted?,
Qu Wenruo
- [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list),
David Howells
- [PATCH v8 03/10] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v8 02/10] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v8 01/10] iov_iter: Define flags to qualify page extraction., David Howells
- [PATCH v8 06/10] block: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v8 07/10] block: Switch to pinning pages., David Howells
- [PATCH v8 08/10] block: Convert bio_iov_iter_get_pages to use iov_iter_extract_pages, David Howells
- [PATCH v8 04/10] iomap: don't get an reference on ZERO_PAGE for direct I/O block zeroing, David Howells
- [PATCH v8 05/10] block: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v8 09/10] block: convert bio_map_user_iov to use iov_iter_extract_pages, David Howells
- [PATCH v8 10/10] mm: Renumber FOLL_PIN and FOLL_GET down, David Howells
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), John Hubbard
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Hildenbrand
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Howells
- [PATCH] s390/dcssblk:: don't call bio_split_to_limits,
Christoph Hellwig
- [PATCH] ps3vram: remove bio splitting,
Christoph Hellwig
- [PATCH v2] paride/pcd: return earlier when an error happens in pcd_atapi(),
Tom Rix
- [PATCH v2] pata_parport: add driver (PARIDE replacement),
Ondrej Zary
- Re: [PATCH v2] pata_parport: add driver (PARIDE replacement), Ondrej Zary
Re: [PATCH v2] pata_parport: add driver (PARIDE replacement), Hannes Reinecke
[LSF/MM/BPF proposal]: Physr discussion,
Jason Gunthorpe
consolidate btrfs checksumming, repair and bio splitting v4,
Christoph Hellwig
- [PATCH 01/34] block: export bio_split_rw, Christoph Hellwig
- [PATCH 02/34] btrfs: better document struct btrfs_bio, Christoph Hellwig
- [PATCH 06/34] btrfs: slightly refactor btrfs_submit_bio, Christoph Hellwig
- [PATCH 03/34] btrfs: add a btrfs_inode pointer to struct btrfs_bio, Christoph Hellwig
- [PATCH 04/34] btrfs: remove the direct I/O read checksum lookup optimization, Christoph Hellwig
- [PATCH 07/34] btrfs: save the bio iter for checksum validation in common code, Christoph Hellwig
- [PATCH 08/34] btrfs: pre-load data checksum for reads in btrfs_submit_bio, Christoph Hellwig
- [PATCH 05/34] btrfs: simplify btrfs_lookup_bio_sums, Christoph Hellwig
- [PATCH 11/34] btrfs: remove btrfs_bio_free_csum, Christoph Hellwig
- [PATCH 10/34] btrfs: handle checksum validation and repair at the storage layer, Christoph Hellwig
- [PATCH 09/34] btrfs: add a btrfs_data_csum_ok helper, Christoph Hellwig
- [PATCH 12/34] btrfs: remove btrfs_bio_for_each_sector, Christoph Hellwig
- [PATCH 13/34] btrfs: remove now unused checksumming helpers, Christoph Hellwig
- [PATCH 14/34] btrfs: remove the device field in struct btrfs_bio, Christoph Hellwig
- [PATCH 16/34] btrfs: rename the iter field in struct btrfs_bio, Christoph Hellwig
- [PATCH 15/34] btrfs: remove the io_failure_record infrastructure, Christoph Hellwig
- [PATCH 17/34] btrfs: remove the is_metadata flag in struct btrfs_bio, Christoph Hellwig
- [PATCH 18/34] btrfs: remove the submit_bio_start helpers, Christoph Hellwig
- [PATCH 19/34] btrfs: simplify the btrfs_csum_one_bio calling convention, Christoph Hellwig
- [PATCH 20/34] btrfs: handle checksum generation in the storage layer, Christoph Hellwig
- [PATCH 21/34] btrfs: handle recording of zoned writes in the storage layer, Christoph Hellwig
- [PATCH 24/34] btrfs: pass the iomap bio to btrfs_submit_bio, Christoph Hellwig
- [PATCH 31/34] btrfs: remove now spurious bio submission helpers, Christoph Hellwig
- [PATCH 26/34] btrfs: remove stripe boundary calculation for compressed I/O, Christoph Hellwig
- [PATCH 29/34] btrfs: remove submit_encoded_read_bio, Christoph Hellwig
- [PATCH 23/34] btrfs: allow btrfs_submit_bio to split bios, Christoph Hellwig
- [PATCH 22/34] btrfs: support cloned bios in btree_csum_one_bio, Christoph Hellwig
- [PATCH 30/34] btrfs: remove the fs_info argument to btrfs_submit_bio, Christoph Hellwig
- [PATCH 28/34] btrfs: remove struct btrfs_io_geometry, Christoph Hellwig
- [PATCH 27/34] btrfs: remove stripe boundary calculation for encoded I/O, Christoph Hellwig
- [PATCH 25/34] btrfs: remove stripe boundary calculation for buffered I/O, Christoph Hellwig
- [PATCH 32/34] btrfs: calculate file system wide queue limit for zoned mode, Christoph Hellwig
- [PATCH 34/34] iomap: remove IOMAP_F_ZONE_APPEND, Christoph Hellwig
- [PATCH 33/34] btrfs: split zone append bios in btrfs_submit_bio, Christoph Hellwig
- Re: consolidate btrfs checksumming, repair and bio splitting v4, Christoph Hellwig
[PATCH] atari: stricter partition validation, Goldwyn Rodrigues
[GIT PULL] Block fixes for 6.2-rc5,
Jens Axboe
[PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list),
David Howells
- [PATCH v7 1/8] iov_iter: Define flags to qualify page extraction., David Howells
- [PATCH v7 3/8] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v7 2/8] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v7 5/8] block: Add BIO_PAGE_PINNED, David Howells
- [PATCH v7 4/8] block: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v7 7/8] block: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v7 8/8] mm: Renumber FOLL_GET and FOLL_PIN down, David Howells
- [PATCH v7 6/8] block: Make bio structs pin pages rather than ref'ing if appropriate, David Howells
- Re: [PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list), Matthew Wilcox
- Re: [PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list), David Howells
[PATCH] block: treat poll queue enter similarly to timeouts,
Jens Axboe
[PATCH-next v4] lib: parser: optimize match_NUMBER apis to use local array, Li Lingfeng
[PATCH-next v3] lib: parser: optimize match_NUMER apis to use local array,
Li Lingfeng
[PATCH v1 1/9] pktcdvd: Get rid of custom printing macros,
Andy Shevchenko
ublk-nbd: ublk-nbd is avaialbe,
Ming Lei
[PATCH -next v3 0/3] blk-cgroup: make sure pd_free_fn() is called in order,
Yu Kuai
[LSF/MM/BPF ATTEND][LSF/MM/BPF TOPIC] : blktests: status, an expansion plan for the storage stack test framework,
Chaitanya Kulkarni
[PATCH v3 0/9] Add support for segments smaller than one page,
Bart Van Assche
- [PATCH v3 1/9] block: Introduce QUEUE_FLAG_SUB_PAGE_SEGMENTS and CONFIG_BLK_SUB_PAGE_SEGMENTS, Bart Van Assche
- [PATCH v3 2/9] block: Support configuring limits below the page size, Bart Van Assche
- [PATCH v3 3/9] block: Support submitting passthrough requests with small segments, Bart Van Assche
- [PATCH v3 4/9] block: Add support for filesystem requests and small segments, Bart Van Assche
- [PATCH v3 5/9] block: Add support for small segments in blk_rq_map_user_iov(), Bart Van Assche
- [PATCH v3 6/9] scsi_debug: Support configuring the maximum segment size, Bart Van Assche
- [PATCH v3 7/9] null_blk: Support configuring the maximum segment size, Bart Van Assche
- [PATCH v3 8/9] scsi: core: Set BLK_SUB_PAGE_SEGMENTS for small max_segment_size values, Bart Van Assche
- [PATCH v3 9/9] scsi: ufs: exynos: Select CONFIG_BLK_SUB_PAGE_SEGMENTS for lage page sizes, Bart Van Assche
- Re: [PATCH v3 0/9] Add support for segments smaller than one page, Jens Axboe
[PATCH -next v2 0/3] blk-cgroup: make sure pd_free_fn() is called in order,
Yu Kuai
[PATCH] blk-iocost: avoid 64-bit division in ioc_timer_fn,
Arnd Bergmann
[PATCH] block: ublk: fix doc build warning,
Ming Lei
[PATCH v4 01/14] blk-mq: avoid sleep in blk_mq_alloc_request_hctx,
Kemeng Shi
- [PATCH v4 02/14] blk-mq: remove stale comment for blk_mq_sched_mark_restart_hctx, Kemeng Shi
- [PATCH v4 03/14] blk-mq: wait on correct sbitmap_queue in blk_mq_mark_tag_wait, Kemeng Shi
- [PATCH v4 04/14] blk-mq: Fix potential io hung for shared sbitmap per tagset, Kemeng Shi
- [PATCH v4 07/14] blk-mq: make blk_mq_commit_rqs a general function for all commits, Kemeng Shi
- [PATCH v4 06/14] blk-mq: remove unncessary from_schedule parameter in blk_mq_plug_issue_direct, Kemeng Shi
- [PATCH v4 10/14] blk-mq: simplify flush check in blk_mq_dispatch_rq_list, Kemeng Shi
- [PATCH v4 05/14] blk-mq: remove unnecessary list_empty check in blk_mq_try_issue_list_directly, Kemeng Shi
- [PATCH v4 09/14] blk-mq: use blk_mq_commit_rqs helper in blk_mq_try_issue_list_directly, Kemeng Shi
- [PATCH v4 13/14] blk-mq: use switch/case to improve readability in blk_mq_try_issue_list_directly, Kemeng Shi
- [PATCH v4 14/14] blk-mq: correct stale comment of .get_budget, Kemeng Shi
- [PATCH v4 12/14] blk-mq: remove set of bd->last when get driver tag for next request fails, Kemeng Shi
- [PATCH v4 11/14] blk-mq: remove unnecessary error count and check in blk_mq_dispatch_rq_list, Kemeng Shi
- [PATCH v4 08/14] blk-mq: remove unncessary error count and commit in blk_mq_plug_issue_direct, Kemeng Shi
- Re: [PATCH v4 01/14] blk-mq: avoid sleep in blk_mq_alloc_request_hctx, Jens Axboe
[PATCH v4 00/14] A few bugfix and cleanup patches for blk-mq, Kemeng Shi
[PATCH for-next v1 0/2] enable pcpu bio-cache for IRQ uring-passthru I/O,
Anuj Gupta
Message not available
Re: [PATCH for-next v1 0/2] enable pcpu bio-cache for IRQ uring-passthru I/O, Jens Axboe
Re: [PATCH for-next v1 0/2] enable pcpu bio-cache for IRQ uring-passthru I/O, Jens Axboe
[PATCH for-next] block: fix hctx checks for batch allocation,
Pavel Begunkov
switch blk-cgroup to work on gendisk,
Christoph Hellwig
- [PATCH 01/15] blk-cgroup: don't defer blkg_free to a workqueue, Christoph Hellwig
- [PATCH 07/15] blk-wbt: pass a gendisk to wbt_init, Christoph Hellwig
- [PATCH 05/15] blk-cgroup: store a gendisk to throttle in struct task_struct, Christoph Hellwig
- [PATCH 06/15] blk-wbt: pass a gendisk to wbt_{enable,disable}_default, Christoph Hellwig
- [PATCH 02/15] block: don't call blk_throtl_stat_add for non-READ/WRITE commands, Christoph Hellwig
- [PATCH 04/15] blk-cgroup: pin the gendisk in struct blkcg_gq, Christoph Hellwig
- [PATCH 03/15] blk-cgroup: delay blk-cgroup initialization until add_disk, Christoph Hellwig
- [PATCH 11/15] blk-rq-qos: store a gendisk instead of request_queue in struct rq_qos, Christoph Hellwig
- [PATCH 09/15] blk-rq-qos: make rq_qos_add and rq_qos_del more useful, Christoph Hellwig
- [PATCH 10/15] blk-rq-qos: constify rq_qos_ops, Christoph Hellwig
- [PATCH 08/15] blk-wbt: open code wbt_queue_depth_changed in wbt_update_limits, Christoph Hellwig
- [PATCH 12/15] blk-cgroup: pass a gendisk to blkcg_{de,}activate_policy, Christoph Hellwig
- [PATCH 15/15] blk-cgroup: move the cgroup information to struct gendisk, Christoph Hellwig
- [PATCH 14/15] blk-cgroup: pass a gendisk to blkg_lookup, Christoph Hellwig
- [PATCH 13/15] blk-cgroup: pass a gendisk to pd_alloc_fn, Christoph Hellwig
- Re: switch blk-cgroup to work on gendisk, Tejun Heo
[PATCH v4 0/5] blk-iocost: random bugfix,
Yu Kuai
[PATCH v6 00/34] iov_iter: Improve page extraction (ref, pin or just list),
David Howells
- [PATCH v6 01/34] vfs: Unconditionally set IOCB_WRITE in call_write_iter(), David Howells
- [PATCH v6 06/34] iov_iter: Use the direction in the iterator functions, David Howells
- [PATCH v6 02/34] iov_iter: Use IOCB/IOMAP_WRITE/op_is_write rather than iterator direction, David Howells
- [PATCH v6 03/34] iov_iter: Pass I/O direction into iov_iter_get_pages*(), David Howells
- [PATCH v6 05/34] iov_iter: Change the direction macros into an enum, David Howells
- [PATCH v6 04/34] iov_iter: Remove iov_iter_get_pages2/pages_alloc2(), David Howells
- [PATCH v6 07/34] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v6 11/34] iov_iter, block: Make bio structs pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 09/34] bio: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v6 10/34] mm, block: Make BIO_PAGE_REFFED/PINNED the same as FOLL_GET/PIN numerically, David Howells
- [PATCH v6 08/34] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v6 12/34] bio: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v6 13/34] netfs: Add a function to extract a UBUF or IOVEC into a BVEC iterator, David Howells
- [PATCH v6 14/34] netfs: Add a function to extract an iterator into a scatterlist, David Howells
- [PATCH v6 15/34] af_alg: Pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 16/34] af_alg: [RFC] Use netfs_extract_iter_to_sg() to create scatterlists, David Howells
- [PATCH v6 17/34] scsi: [RFC] Use netfs_extract_iter_to_sg(), David Howells
- [PATCH v6 18/34] dio: Pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 20/34] vfs: Make splice use iov_iter_extract_pages(), David Howells
- [PATCH v6 19/34] fuse: Pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 21/34] 9p: Pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 22/34] nfs: Pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v6 23/34] cifs: Implement splice_read to pass down ITER_BVEC not ITER_PIPE, David Howells
- [PATCH v6 24/34] cifs: Add a function to build an RDMA SGE list from an iterator, David Howells
- [PATCH v6 27/34] cifs: Add a function to read into an iter from a socket, David Howells
- [PATCH v6 26/34] cifs: Add some helper functions, David Howells
- [PATCH v6 25/34] cifs: Add a function to Hash the contents of an iterator, David Howells
- [PATCH v6 30/34] cifs: Remove unused code, David Howells
- [PATCH v6 31/34] cifs: Fix problem with encrypted RDMA data read, David Howells
- [PATCH v6 32/34] cifs: DIO to/from KVEC-type iterators should now work, David Howells
- [PATCH v6 29/34] cifs: Build the RDMA SGE list directly from an iterator, David Howells
- [PATCH v6 33/34] net: [RFC][WIP] Mark each skb_frags as to how they should be cleaned up, David Howells
- [PATCH v6 34/34] net: [RFC][WIP] Make __zerocopy_sg_from_iter() correctly pin or leave pages unref'd, David Howells
- Re: [PATCH v6 00/34] iov_iter: Improve page extraction (ref, pin or just list), Christoph Hellwig
- Re: [PATCH v6 09/34] bio: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
[PATCH 4.19] block: fix and cleanup bio_check_ro, Fedor Pchelkin
[PATCH 5.4] block: fix and cleanup bio_check_ro, Fedor Pchelkin
[PATCH v2] block: don't allow multiple bios for IOCB_NOWAIT issue,
Jens Axboe
[PATCH 5.10] block: fix and cleanup bio_check_ro, Fedor Pchelkin
[PATCH 5.15] block: fix and cleanup bio_check_ro, Fedor Pchelkin
Re: [PATCH] block: check disk flag before setting scan bit,
Jens Axboe
Is there a reason why REQ_OP_READ has to be 0?,
David Howells
[PATCH] block: don't allow multiple bios for IOCB_NOWAIT issue,
Jens Axboe
[PATCH v3 0/5] A few bugfix and cleanup patches for sbitmap,
Kemeng Shi
[PATCH] scripts: support GNU make 4.4 in jobserver-exec,
Martin Liška
[PATCH v4 0/8] A few bugfix and cleancode patch for bfq,
Kemeng Shi
- [PATCH v4 5/8] block, bfq: remove unnecessary dereference to get async_bfqq, Kemeng Shi
- [PATCH v4 3/8] block, bfq: initialize bfqq->decrease_time_jif correctly, Kemeng Shi
- [PATCH v4 2/8] block, bfq: remove unsed parameter reason in bfq_bfqq_is_slow, Kemeng Shi
- [PATCH v4 7/8] block, bfq: remove unnecessary goto tag in bfq_dispatch_rq_from_bfqq, Kemeng Shi
- [PATCH v4 6/8] block, bfq: remove redundant check in bfq_put_cooperator, Kemeng Shi
- [PATCH v4 8/8] block, bfq: remove unused bfq_wr_max_time in struct bfq_data, Kemeng Shi
- [PATCH v4 4/8] block, bfq: use helper macro RQ_BFQQ to get bfqq of request, Kemeng Shi
- [PATCH v4 1/8] block, bfq: correctly raise inject limit in bfq_choose_bfqq_for_injection, Kemeng Shi
- Re: [PATCH v4 0/8] A few bugfix and cleancode patch for bfq, Jens Axboe
Virtio-blk extended lifetime feature,
Alvaro Karsz
[PATCH 5.10 0/1] block: replace WARN_ONCE with pr_warn in bio_check_ro,
Fedor Pchelkin
[PATCH] paride/pcd: return earlier when an error happens in pcd_atapi(),
Tom Rix
[RFC] block, bfq: use-after-free with bfq <==> cgroup interactions,
Sasha Levin
[GIT PULL] Block fixes for 6.2-rc4,
Jens Axboe
[RESEND PATCH 0/8] Miscellaneous DRBD reorganization,
Christoph Böhmwalder
[RESEND PATCH 0/3] DRBD file structure reorganization,
Christoph Böhmwalder
[PATCH] block, bfq: fix uaf for bfqq in bic_set_bfqq(),
Yu Kuai
[Index of Archives]
[Linux RAID]
[Linux SCSI]
[Linux ATA RAID]
[Linux Wireless]
[Linux Bluetooth]
[Kernel Announce]
[Kernel Newbies]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]