Re: [PATCH v2 3/4] blk-integrity: register sysfs attributes on struct device

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> +static const struct attribute_group integrity_group  = {

Double whitespace before the =

> +	.name = "integrity", .attrs = integrity_attrs,
>  };

We generally put each field member on separate lines for readability.

>  int blk_integrity_add(struct gendisk *disk)
>  {
> +	return device_add_groups(disk_to_dev(disk), integrity_groups);
>  }
>  
>  void blk_integrity_del(struct gendisk *disk)
>  {
> +	device_remove_groups(disk_to_dev(disk), integrity_groups);

Can't we just add integrity_group to disk_attr_groups and remove these
calls entirely?




[Index of Archives]     [Linux RAID]     [Linux SCSI]     [Linux ATA RAID]     [IDE]     [Linux Wireless]     [Linux Kernel]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Device Mapper]

  Powered by Linux