On Wed, Mar 15, 2023 at 08:06:51AM -0700, Christoph Hellwig wrote: > > +static const struct attribute_group integrity_group = { > > Double whitespace before the = Ack. > > + .name = "integrity", .attrs = integrity_attrs, > > }; > > We generally put each field member on separate lines for readability. Ack. > > int blk_integrity_add(struct gendisk *disk) > > { > > + return device_add_groups(disk_to_dev(disk), integrity_groups); > > } > > > > void blk_integrity_del(struct gendisk *disk) > > { > > + device_remove_groups(disk_to_dev(disk), integrity_groups); > > Can't we just add integrity_group to disk_attr_groups and remove these > calls entirely? Thanks for the pointer. This works and is indeed nicer.