BPF - Berkeley Packet Filters
[Prev Page][Next Page]
- Re: [BPF Security] what security properties does verifier guarantee?, (continued)
- [PATCH bpf-next 0/4] bpf: make trusted args nullable,
Vadim Fedorenko
- [PATCH bpf-next] bpf: make list_for_each_entry portable,
Jose E. Marchesi
- [RFC PATCH bpf-next v7 0/3] Replace mono_delivery_time with tstamp_type,
Abhishek Chauhan
- [PATCH 0/4] Fix user stack traces captured from uprobes,
Andrii Nakryiko
- [linux-next:master] BUILD REGRESSION e7b4ef8fffaca247809337bb78daceb406659f2d, kernel test robot
- [PATCH bpf-next] bpf: avoid gcc overflow warning in test_xdp_vlan.c,
David Faust
- [PATCH net-next v2 1/1] net: intel: Use *-y instead of *-objs in Makefile,
Andy Shevchenko
- [PATCH bpf-next] selftests/bpf: Fix a few tests for GCC related warnings.,
Cupertino Miranda
- [PATCH net-next v3 00/13] First try to replace page_frag with page_frag_cache,
Yunsheng Lin
- [PATCH net-next v1 1/1] net: intel: Use *-y instead of *-objs in Makefile,
Andy Shevchenko
- [PATCH bpf v2] powerpc/bpf: enforce full ordering for ATOMIC operations with BPF_FETCH,
Puranjay Mohan
- [PATCH bpf-next] bpf: guard BPF_NO_PRESERVE_ACCESS_INDEX in skb_pkt_end.c,
Jose E. Marchesi
- [PATCH bpf-next] tools: remove redundant ethtool.h from tooling infra,
Tushar Vyavahare
- [PATCH bpf-next V3] bpf: avoid UB in usages of the __imm_insn macro,
Jose E. Marchesi
- [PATCH RFC HID 0/7] Use the new __s_async for HID-BPF,
Benjamin Tissoires
- [PATCH bpf-next V2] bpf: avoid uninitialized value in BPF_CORE_READ_BITFIELD,
Jose E. Marchesi
- [PATCH net-next 0/7] virtnet_net: prepare for af-xdp,
Xuan Zhuo
- [PATCH bpf-next v4 0/9] Enable BPF programs to declare arrays of kptr, bpf_rb_root, and bpf_list_head.,
Kui-Feng Lee
- [linux-next:master] BUILD REGRESSION 93a39e4766083050ca0ecd6a3548093a3b9eb60c, kernel test robot
- [PATCH bpf-next v3 1/2] net: netfilter: Make ct zone opts configurable for bpf ct helpers,
Brad Cowie
- [PATCH vhost 0/5] virtio_net: introduce api to enable/disable premapped mode for sq,
Xuan Zhuo
- [PATCH bpf-next v3 0/3] Support kCFI + BPF on arm64,
Maxwell Bland
- [PATCH AUTOSEL 5.15 13/15] x86/mm: Remove broken vsyscall emulation code from the page fault code, Sasha Levin
- [PATCH AUTOSEL 6.1 19/25] x86/mm: Remove broken vsyscall emulation code from the page fault code,
Sasha Levin
- [PATCH AUTOSEL 6.6 36/43] x86/mm: Remove broken vsyscall emulation code from the page fault code, Sasha Levin
- [PATCH AUTOSEL 6.6 18/43] bpf, x86: Fix PROBE_MEM runtime load check, Sasha Levin
- [PATCH AUTOSEL 6.8 44/52] x86/mm: Remove broken vsyscall emulation code from the page fault code, Sasha Levin
- [PATCH AUTOSEL 6.8 23/52] bpf, x86: Fix PROBE_MEM runtime load check, Sasha Levin
- [PATCH bpf-next v10 0/5] Reduce overhead of LSMs with static calls,
KP Singh
- [PATCH v2 0/5] Define _GNU_SOURCE for sources using,
Edward Liaw
- [PATCH bpf-next V2] bpf: avoid uninitialized warnings in verifier_global_subprogs.c,
Jose E. Marchesi
- [PATCH v4 00/12] PCI: imx6: Fix\rename\clean up and add lut information for imx95,
Frank Li
- [PATCH v4 01/12] PCI: imx6: Fix establish link failure in EP mode for iMX8MM and iMX8MP, Frank Li
- [PATCH v4 02/12] PCI: imx6: Fix i.MX8MP PCIe EP's occasional failure to trigger MSI, Frank Li
- [PATCH v4 03/12] PCI: imx6: Rename imx6_* with imx_*, Frank Li
- [PATCH v4 04/12] PCI: imx6: Introduce SoC specific callbacks for controlling REFCLK, Frank Li
- [PATCH v4 05/12] PCI: imx6: Simplify switch-case logic by involve core_reset callback, Frank Li
- [PATCH v4 06/12] PCI: imx6: Improve comment for workaround ERR010728, Frank Li
- [PATCH v4 07/12] PCI: imx6: Add help function imx_pcie_match_device(), Frank Li
- [PATCH v4 08/12] PCI: imx6: Config look up table(LUT) to support MSI ITS and IOMMU for i.MX95, Frank Li
- [PATCH v4 09/12] PCI: imx6: Consolidate redundant if-checks, Frank Li
- [PATCH v4 10/12] dt-bindings: imx6q-pcie: Add i.MX8Q pcie compatible string, Frank Li
- [PATCH v4 11/12] PCI: imx6: Call: Common PHY API to set mode, speed, and submode, Frank Li
- [PATCH v4 12/12] PCI: imx6: Add i.MX8Q PCIe root complex (RC) support, Frank Li
- Re: [PATCH v4 00/12] PCI: imx6: Fix\rename\clean up and add lut information for imx95, Frank Li
- [PATCH bpf] powerpc/bpf: enforce full ordering for ATOMIC operations with BPF_FETCH,
Puranjay Mohan
- [PATCH stable, 6.1 0/2] Fix for sockmap causing data stalls,
John Fastabend
- [PATCH v10 00/36] tracing: fprobe: function_graph: Multi-function graph and fprobe on fgraph,
Masami Hiramatsu (Google)
- [PATCH v10 01/36] tracing: Add a comment about ftrace_regs definition, Masami Hiramatsu (Google)
- [PATCH v10 02/36] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value, Masami Hiramatsu (Google)
- [PATCH v10 03/36] x86: tracing: Add ftrace_regs definition in the header, Masami Hiramatsu (Google)
- [PATCH v10 04/36] function_graph: Convert ret_stack to a series of longs, Masami Hiramatsu (Google)
- [PATCH v10 05/36] fgraph: Use BUILD_BUG_ON() to make sure we have structures divisible by long, Masami Hiramatsu (Google)
- [PATCH v10 06/36] function_graph: Add an array structure that will allow multiple callbacks, Masami Hiramatsu (Google)
- [PATCH v10 07/36] function_graph: Allow multiple users to attach to function graph, Masami Hiramatsu (Google)
- [PATCH v10 08/36] function_graph: Remove logic around ftrace_graph_entry and return, Masami Hiramatsu (Google)
- [PATCH v10 09/36] ftrace/function_graph: Pass fgraph_ops to function graph callbacks, Masami Hiramatsu (Google)
- [PATCH v10 12/36] function_graph: Have the instances use their own ftrace_ops for filtering, Masami Hiramatsu (Google)
- [PATCH v10 14/36] function_graph: Add "task variables" per task for fgraph_ops, Masami Hiramatsu (Google)
- [PATCH v10 16/36] function_graph: Move graph depth stored data to shadow stack global var, Masami Hiramatsu (Google)
- [PATCH v10 17/36] function_graph: Move graph notrace bit to shadow stack global var, Masami Hiramatsu (Google)
- [PATCH v10 18/36] function_graph: Implement fgraph_reserve_data() and fgraph_retrieve_data(), Masami Hiramatsu (Google)
- [PATCH v10 21/36] function_graph: Pass ftrace_regs to entryfunc, Masami Hiramatsu (Google)
- [PATCH v10 11/36] ftrace: Allow ftrace startup flags exist without dynamic ftrace, Masami Hiramatsu (Google)
- [PATCH v10 23/36] function_graph: Pass ftrace_regs to retfunc, Masami Hiramatsu (Google)
- [PATCH v10 24/36] fprobe: Use ftrace_regs in fprobe entry handler, Masami Hiramatsu (Google)
- [PATCH v10 25/36] fprobe: Use ftrace_regs in fprobe exit handler, Masami Hiramatsu (Google)
- [PATCH v10 10/36] ftrace: Allow function_graph tracer to be enabled in instances, Masami Hiramatsu (Google)
- [PATCH v10 26/36] tracing: Add ftrace_partial_regs() for converting ftrace_regs to pt_regs, Masami Hiramatsu (Google)
- [PATCH v10 22/36] function_graph: Replace fgraph_ret_regs with ftrace_regs, Masami Hiramatsu (Google)
- [PATCH v10 19/36] function_graph: Add selftest for passing local variables, Masami Hiramatsu (Google)
- [PATCH v10 27/36] tracing: Add ftrace_fill_perf_regs() for perf event, Masami Hiramatsu (Google)
- [PATCH v10 15/36] function_graph: Move set_graph_function tests to shadow stack global var, Masami Hiramatsu (Google)
- [PATCH v10 29/36] bpf: Enable kprobe_multi feature if CONFIG_FPROBE is enabled, Masami Hiramatsu (Google)
- [PATCH v10 13/36] function_graph: Use a simple LRU for fgraph_array index number, Masami Hiramatsu (Google)
- [PATCH v10 30/36] ftrace: Add CONFIG_HAVE_FTRACE_GRAPH_FUNC, Masami Hiramatsu (Google)
- [PATCH v10 31/36] fprobe: Rewrite fprobe on function-graph tracer, Masami Hiramatsu (Google)
- [PATCH v10 32/36] tracing/fprobe: Remove nr_maxactive from fprobe, Masami Hiramatsu (Google)
- [PATCH v10 33/36] selftests: ftrace: Remove obsolate maxactive syntax check, Masami Hiramatsu (Google)
- [PATCH v10 34/36] selftests/ftrace: Add a test case for repeating register/unregister fprobe, Masami Hiramatsu (Google)
- [PATCH v10 20/36] ftrace: Add multiple fgraph storage selftest, Masami Hiramatsu (Google)
- [PATCH v10 35/36] Documentation: probes: Update fprobe on function-graph tracer, Masami Hiramatsu (Google)
- [PATCH v10 36/36] fgraph: Skip recording calltime/rettime if it is not nneeded, Masami Hiramatsu (Google)
- [PATCH v10 28/36] tracing/fprobe: Enable fprobe events with CONFIG_DYNAMIC_FTRACE_WITH_ARGS, Masami Hiramatsu (Google)
- Re: [PATCH v10 00/36] tracing: fprobe: function_graph: Multi-function graph and fprobe on fgraph, Steven Rostedt
- [PATCH bpf-next] bpf: avoid uninitialized warnings in verifier_global_subprogs.c,
Jose E. Marchesi
- [PATCH v2 bpf-next] kbuild,bpf: switch to using --btf_features for pahole v1.26 and later,
Alan Maguire
- [PATCH RFC bpf-next 0/8] Implement generic bpf_async cb,
Benjamin Tissoires
- [PATCH bpf-next V2] bpf: avoid UB in usages of the __imm_insn macro,
Jose E. Marchesi
- [PATCH bpf-next v2 0/2] Fix number of arguments in test,
Cupertino Miranda
- [PATCH bpf-next] bpf: avoid uninitialized value in BPF_CORE_READ_BITFIELD,
Jose E. Marchesi
- [PATCH bpf-next] bpf: avoid UB in usages of the __imm_insn macro, Jose E. Marchesi
- [PATCH v6 0/7] dma: skip calling no-op sync ops when possible,
Alexander Lobakin
- [PATCH] riscv, bpf: Fix typo in comment,
Xiao Wang
- [PATCH bpf-next 0/4] selftests/bpf: new MPTCP subflow subtest & improvements,
Matthieu Baerts (NGI0)
- [PATCHv5 bpf-next 0/8] uprobe: uretprobe speed up,
Jiri Olsa
- [PATCH] riscv, bpf: Optimize zextw insn with Zba extension,
Xiao Wang
- [PATCH bpf-next] bpf: temporarily define BPF_NO_PRESEVE_ACCESS_INDEX for GCC,
Jose E. Marchesi
- [PATCH 15/48] bpf: Choose RCU Tasks based on TASKS_RCU rather than PREEMPTION, Uladzislau Rezki (Sony)
- [PATCH 11/48] bpf: Select new NEED_TASKS_RCU Kconfig option, Uladzislau Rezki (Sony)
- [PATCH bpf-next V2 0/2] bpf: avoid `attribute ignored' warnings in GCC,
Jose E. Marchesi
- [PATCH bpf-next v1] bpf,arena: Remove redundant page mask of vmf->address,
Haiyue Wang
- [PATCH bpf-next v2 0/6] Notify user space when a struct_ops object is detached/unregistered,
Kui-Feng Lee
- [PATCH bpf-next v1] bpf,arena: Rename the kfunc set variable,
Haiyue Wang
- [PATCH bpf-next 0/7] libbpf: further struct_ops fixes and improvements,
Andrii Nakryiko
- [PATCH bpf-next v2] s390/bpf: Emit a barrier for BPF_FETCH instructions,
Ilya Leoshkevich
- [PATCH] mm: Remove mm argument from mm_get_unmapped_area(),
Rick Edgecombe
- [PATCH bpf-next 0/2] selftests/bpf: Fix number of arguments in test,
Cupertino Miranda
- [PATCH net] selftests/bpf: fix pointer arithmetic in test_xdp_do_redirect,
Michal Schmidt
- [PATCH bpf-next v5 0/6] bpf/verifier: range computation improvements,
Cupertino Miranda
- [PATCH bpf-next] s390/bpf: Fully order atomic "add", "and", "or" and "xor",
Ilya Leoshkevich
- [PATCH bpf-next] bpftool: introduce btf c dump sorting,
Mykyta
- [PATCH net-next v5 0/7] dma: skip calling no-op sync ops when possible,
Alexander Lobakin
- [PATCH v7 bpf-next 0/2] bpf: Add a generic bits iterator,
Yafang Shao
- [PATCH v2] bpftool, selftests/hid/bpf: fix 29 clang warnings,
John Hubbard
- [PATCH] bpftool, selftests/hid/bpf: fix 29 clang warnings,
John Hubbard
- [PATCH bpf] riscv, bpf: make some atomic operations fully ordered,
Puranjay Mohan
- [syzbot] [bpf?] [trace?] general protection fault in bpf_get_attach_cookie_tracing,
syzbot
- [PATCH RESEND v8 00/16] mm: jit/text allocator,
Mike Rapoport
- [PATCH RESEND v8 01/16] arm64: module: remove unneeded call to kasan_alloc_module_shadow(), Mike Rapoport
- [PATCH RESEND v8 02/16] mips: module: rename MODULE_START to MODULES_VADDR, Mike Rapoport
- [PATCH RESEND v8 03/16] nios2: define virtual address space for modules, Mike Rapoport
- [PATCH RESEND v8 04/16] sparc: simplify module_alloc(), Mike Rapoport
- [PATCH RESEND v8 05/16] module: make module_memory_{alloc,free} more self-contained, Mike Rapoport
- [PATCH RESEND v8 06/16] mm: introduce execmem_alloc() and execmem_free(), Mike Rapoport
- [PATCH RESEND v8 07/16] mm/execmem, arch: convert simple overrides of module_alloc to execmem, Mike Rapoport
- [PATCH RESEND v8 08/16] mm/execmem, arch: convert remaining overrides of module_alloc to execmem, Mike Rapoport
- [PATCH RESEND v8 09/16] riscv: extend execmem_params for generated code allocations, Mike Rapoport
- [PATCH RESEND v8 10/16] arm64: extend execmem_info for generated code allocations, Mike Rapoport
- [PATCH RESEND v8 11/16] powerpc: extend execmem_params for kprobes allocations, Mike Rapoport
- [PATCH RESEND v8 12/16] arch: make execmem setup available regardless of CONFIG_MODULES, Mike Rapoport
- [PATCH RESEND v8 13/16] x86/ftrace: enable dynamic ftrace without CONFIG_MODULES, Mike Rapoport
- [PATCH RESEND v8 14/16] powerpc: use CONFIG_EXECMEM instead of CONFIG_MODULES where appropriate, Mike Rapoport
- [PATCH RESEND v8 15/16] kprobes: remove dependency on CONFIG_MODULES, Mike Rapoport
- [PATCH RESEND v8 16/16] bpf: remove CONFIG_BPF_JIT dependency on CONFIG_MODULES of, Mike Rapoport
- Re: [PATCH RESEND v8 00/16] mm: jit/text allocator, Luis Chamberlain
- [PATCH v8 00/17] mm: jit/text allocator,
Mike Rapoport
- [PATCH v8 01/17] arm64: module: remove unneeded call to kasan_alloc_module_shadow(), Mike Rapoport
- [PATCH v8 02/17] mips: module: rename MODULE_START to MODULES_VADDR, Mike Rapoport
- [PATCH v8 03/17] nios2: define virtual address space for modules, Mike Rapoport
- [PATCH v8 04/17] sparc: simplify module_alloc(), Mike Rapoport
- [PATCH v8 05/17] module: make module_memory_{alloc,free} more self-contained, Mike Rapoport
- [PATCH v8 06/17] mm: introduce execmem_alloc() and execmem_free(), Mike Rapoport
- [PATCH v8 07/17] mm/execmem, arch: convert simple overrides of module_alloc to execmem, Mike Rapoport
- [PATCH v8 08/17] mm/execmem, arch: convert remaining overrides of module_alloc to execmem, Mike Rapoport
- [PATCH v8 09/17] riscv: extend execmem_params for generated code allocations, Mike Rapoport
- [PATCH v8 10/17] arm64: extend execmem_info for generated code allocations, Mike Rapoport
- [PATCH v8 11/17] powerpc: extend execmem_params for kprobes allocations, Mike Rapoport
- [PATCH v8 12/17] arch: make execmem setup available regardless of CONFIG_MODULES, Mike Rapoport
- [PATCH v8 13/17] x86/ftrace: enable dynamic ftrace without CONFIG_MODULES, Mike Rapoport
- [PATCH v8 14/17] powerpc: use CONFIG_EXECMEM instead of CONFIG_MODULES where appropriate, Mike Rapoport
- [PATCH v8 15/17] kprobes: remove dependency on CONFIG_MODULES, Mike Rapoport
- [PATCH v8 16/17] bpf: remove CONFIG_BPF_JIT dependency on CONFIG_MODULES of, Mike Rapoport
- [PATCH v8 17/17] fixup: convert remaining archs: defaults handling, Mike Rapoport
- Re: [PATCH v8 00/17] mm: jit/text allocator, Mike Rapoport
- [PATCH bpf-next 0/6] use network helpers, part 4,
Geliang Tang
- [PATCH bpf-next] bpf: avoid clang-specific push/pop attribute pragmas in bpftool, Jose E. Marchesi
- [PATCH bpf-next 0/1] Fix for bpf_sysctl_set_new_value,
Raman Shukhau
- [syzbot] [bpf?] KASAN: slab-use-after-free Read in htab_map_alloc (2),
syzbot
- [RFC PATCH bpf-next v6 0/3] Replace mono_delivery_time with tstamp_type,
Abhishek Chauhan
- [PATCH bpf-next] selftests/bpf: Use bpf_tracing.h instead of bpf_tcp_helpers.h,
Martin KaFai Lau
- [PATCH 0/5] ioctl()-based API to query VMAs from /proc/<pid>/maps,
Andrii Nakryiko
- [PATCH net-next 15/15] net: Move per-CPU flush-lists to bpf_net_context on PREEMPT_RT., Sebastian Andrzej Siewior
- [PATCH net-next 14/15] net: Reference bpf_redirect_info via task_struct on PREEMPT_RT.,
Sebastian Andrzej Siewior
- [PATCH net-next 13/15] net: Use nested-BH locking for bpf_scratchpad., Sebastian Andrzej Siewior
- [PATCH net-next 12/15] seg6: Use nested-BH locking for seg6_bpf_srh_states., Sebastian Andrzej Siewior
- [PATCH net-next 11/15] lwt: Don't disable migration prio invoking BPF., Sebastian Andrzej Siewior
- [PATCH v3 1/2] arm64/arch_timer: include <linux/percpu.h>,
Puranjay Mohan
- [PATCH stable, 6.1] net: sockmap, fix missing MSG_MORE causing TCP disruptions,
John Fastabend
- [PATCH bpf-next] bpf: disable some `attribute ignored' warnings in GCC,
Jose E. Marchesi
- [RFC bpf-next] bpf: avoid clang-specific push/pop attribute pragmas in bpftool,
Jose E. Marchesi
[Index of Archives]
[Linux Samsung SoC]
[Linux Actions SoC]
[Linux Rockchip SoC]
[Linux for Synopsys ARC Processors]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]