Linux RDMA and InfiniBand Development
[Prev Page][Next Page]
- Re: [PATCH 05/20] RDMA/core: Add signature attrs element for ib_mr structure, (continued)
- [PATCH 04/20] RDMA/core: Introduce ib_map_mr_sg_pi to map data/protection sgl's, Max Gurtovoy
- [PATCH 01/20] RDMA/core: Introduce new header file for signature operations, Max Gurtovoy
- [PATCH 06/20] RDMA/mlx5: Implement mlx5_ib_map_mr_sg_pi and mlx5_ib_alloc_mr_integrity, Max Gurtovoy
- [PATCH 07/20] RDMA/mlx5: Add attr for max number page list length for PI operation, Max Gurtovoy
- [PATCH 08/20] RDMA/mlx5: Pass UMR segment flags instead of boolean, Max Gurtovoy
- [PATCH 09/20] RDMA/mlx5: Update set_sig_data_segment attribute for new signature API, Max Gurtovoy
- [PATCH 10/20] RDMA/mlx5: Introduce and implement new IB_WR_REG_MR_INTEGRITY work request, Max Gurtovoy
- [PATCH 13/20] RDMA/core: Add an integrity MR pool support, Max Gurtovoy
- [PATCH 12/20] IB/iser: Unwind WR union at iser_tx_desc, Max Gurtovoy
- [PATCH 14/20] RDMA/mlx5: Move signature_en attribute from mlx5_qp to ib_qp, Max Gurtovoy
- [PATCH 15/20] RDMA/core: Validate signature handover device cap, Max Gurtovoy
- [PATCH 16/20] RDMA/rw: Use IB_WR_REG_MR_INTEGRITY for PI handover, Max Gurtovoy
- [PATCH 17/20] RDMA/core: Remove unused IB_WR_REG_SIG_MR code, Max Gurtovoy
- [PATCH 18/20] RDMA/mlx5: Improve PI handover performance, Max Gurtovoy
- [PATCH 11/20] IB/iser: Use IB_WR_REG_MR_INTEGRITY for PI handover, Max Gurtovoy
- [PATCH 19/20] RDMA/mlx5: Use PA mapping for PI handover, Max Gurtovoy
- [PATCH 20/20] RDMA/mlx5: Refactor MR descriptors allocation, Max Gurtovoy
- [PATCH for-next] RDMA/ipoib: Remove check for ETH_SS_TEST,
Kamal Heib
- [PATCH for-next v3 0/4] ib_pd should not have ib_uobject,
Shamir Rabinovitch
- [PATCH] IB/mlx5: Limit to 64-bit builds,
Guenter Roeck
- [bug report] IB/hfi1: Rework fault injection machinery,
Dan Carpenter
- [PATCH] RDMA/uverbs: check for allocation failure in uapi_add_elm(),
Dan Carpenter
- [PATCH v3 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH mlx5-next 0/6] Mellanox, mlx5-next minor updates 2019-05-29,
Saeed Mahameed
- [PATCH mlx5-next 1/6] net/mlx5: Add core dump register access HW bits, Saeed Mahameed
- [PATCH mlx5-next 2/6] net/mlx5: Introduce termination table bits, Saeed Mahameed
- [PATCH mlx5-next 3/6] net/mlx5: E-Switch, Replace host_params event with functions_changed event, Saeed Mahameed
- [PATCH mlx5-next 4/6] net/mlx5: E-Switch, Honor eswitch functions changed event cap, Saeed Mahameed
- [PATCH mlx5-next 5/6] {IB,net}/mlx5: No need to typecast from void* to mlx5_ib_dev*, Saeed Mahameed
- [PATCH mlx5-next 6/6] {IB,net}/mlx5: Constify rep ops functions pointers, Saeed Mahameed
- Re: [PATCH mlx5-next 0/6] Mellanox, mlx5-next minor updates 2019-05-29, Saeed Mahameed
- [PATCH, RESEND] RDMA/srp: Accept again source addresses that do not have a port number,
Bart Van Assche
- [PATCH][next] IB/hfi1: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH][next] IB/qib: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH][next] IB/rdmavt: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH] RDMA/ipoib: implement ethtool .get_link() callback,
Kamal Heib
- [PATCH v2 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [ANNOUNCE] rdma-core v24.0 has been tagged/released, Leon Romanovsky
- [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review,
Chuck Lever
- [PATCH RFC 01/12] xprtrdma: Fix use-after-free in rpcrdma_post_recvs, Chuck Lever
- [PATCH RFC 02/12] xprtrdma: Replace use of xdr_stream_pos in rpcrdma_marshal_req, Chuck Lever
- [PATCH RFC 03/12] xprtrdma: Fix occasional transport deadlock, Chuck Lever
- [PATCH RFC 04/12] xprtrdma: Remove the RPCRDMA_REQ_F_PENDING flag, Chuck Lever
- [PATCH RFC 05/12] xprtrdma: Remove fr_state, Chuck Lever
- [PATCH RFC 06/12] xprtrdma: Add mechanism to place MRs back on the free list, Chuck Lever
- [PATCH RFC 07/12] xprtrdma: Reduce context switching due to Local Invalidation, Chuck Lever
- [PATCH RFC 08/12] xprtrdma: Wake RPCs directly in rpcrdma_wc_send path, Chuck Lever
- [PATCH RFC 09/12] xprtrdma: Simplify rpcrdma_rep_create, Chuck Lever
- [PATCH RFC 10/12] xprtrdma: Streamline rpcrdma_post_recvs, Chuck Lever
- [PATCH RFC 11/12] xprtrdma: Refactor chunk encoding, Chuck Lever
- [PATCH RFC 12/12] xprtrdma: Remove rpcrdma_req::rl_buffer, Chuck Lever
- Re: [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review, Christoph Hellwig
- Re: [PATCH RFC 00/12] for-5.3 NFS/RDMA patches for review, Dennis Dalessandro
- [PATCH v1 rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH for-rc 0/6] EFA updates 2019-05-28,
Gal Pressman
- [PATCH rdma-next v1 0/3] Convert CQ allocations,
Leon Romanovsky
- [PATCH v2 rdma-next 0/2] RDMA/qedr: Use the doorbell overflow recovery mechanism for RDMA,
Michal Kalderon
- [PATCH V2 for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH rdma-core] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH v2 net-next 00/11] qed*: Improve performance on 100G link for offload protocols,
Michal Kalderon
- [PATCH v2 net-next 01/11] qed: Modify api for performing a dmae to another PF, Michal Kalderon
- [PATCH v2 net-next 03/11] qed*: Change hwfn used for sb initialization, Michal Kalderon
- [PATCH v2 net-next 05/11] qedr: Change the MSI-X vectors selection to be based on affined engine, Michal Kalderon
- [PATCH v2 net-next 06/11] qed: Set the doorbell address correctly, Michal Kalderon
- [PATCH v2 net-next 04/11] qed: Modify offload protocols to use the affined engine, Michal Kalderon
- [PATCH v2 net-next 07/11] qed: Add qed devlink parameters table, Michal Kalderon
- [PATCH v2 net-next 09/11] Revert "scsi: qedi: Allocate IRQs based on msix_cnt", Michal Kalderon
- [PATCH v2 net-next 11/11] qedf: Use hwfns and affin_hwfn_idx to get MSI-X vector index to use, Michal Kalderon
- [PATCH v2 net-next 10/11] qedi: Use hwfns and affin_hwfn_idx to get MSI-X vector index, Michal Kalderon
- [PATCH v2 net-next 08/11] qed*: Add iWARP 100g support, Michal Kalderon
- [PATCH v2 net-next 02/11] qed: Add llh ppfid interface and 100g support for offload protocols, Michal Kalderon
- Re: [PATCH v2 net-next 00/11] qed*: Improve performance on 100G link for offload protocols, David Miller
- [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver,
Bernard Metzler
- [PATCH for-next v1 11/12] SIW debugging, Bernard Metzler
- [PATCH for-next v1 01/12] iWarp wire packet format, Bernard Metzler
- [PATCH for-next v1 03/12] SIW network and RDMA core interface, Bernard Metzler
- [PATCH for-next v1 10/12] SIW completion queue methods, Bernard Metzler
- [PATCH for-next v1 06/12] SIW application buffer management, Bernard Metzler
- [PATCH for-next v1 02/12] SIW main include file, Bernard Metzler
- [PATCH for-next v1 07/12] SIW queue pair methods, Bernard Metzler
- [PATCH for-next v1 09/12] SIW receive path, Bernard Metzler
- [PATCH for-next v1 04/12] SIW connection management, Bernard Metzler
- [PATCH for-next v1 12/12] SIW addition to kernel build environment, Bernard Metzler
- [PATCH for-next v1 08/12] SIW transmit path, Bernard Metzler
- [PATCH for-next v1 05/12] SIW application interface, Bernard Metzler
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Bernard Metzler
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Jason Gunthorpe
- Re: [PATCH for-next v1 00/12] SIW: Software iWarp RDMA (siw) driver, Bernard Metzler
- [RFC] verbs: Introduce a new reg_mr API for virtual address space,
Yuval Shaia
- [PATCH -next] IB/hfi1: remove set but not used variables 'offset' and 'fspsn',
YueHaibing
- [PATCH for-next 0/3] Add mix multihop addressing for supporting 32K,
Lijun Ou
- [PATCH v2 0/1] infiniband/mm: convert put_page() to put_user_page*(),
john . hubbard
- [PATCH for-rc 0/5] Patches for 5.2 rc cycle,
Dennis Dalessandro
- [PATCH for-next] RDMA/hns: Clear magic number,
Lijun Ou
- [PATCH V2 for-next 0/4] Fixes for hns,
Lijun Ou
- <infiniband/verbs.h> & ICC,
Gerd Rausch
- [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review,
Jason Gunthorpe
- [RFC PATCH 03/11] mm/hmm: Hold a mmgrab from hmm to mm, Jason Gunthorpe
- [RFC PATCH 01/11] mm/hmm: Fix use after free with struct hmm in the mmu notifiers, Jason Gunthorpe
- [RFC PATCH 02/11] mm/hmm: Use hmm_mirror not mm as an argument for hmm_register_range, Jason Gunthorpe
- [RFC PATCH 04/11] mm/hmm: Simplify hmm_get_or_create and make it reliable, Jason Gunthorpe
- [RFC PATCH 05/11] mm/hmm: Improve locking around hmm->dead, Jason Gunthorpe
- [RFC PATCH 06/11] mm/hmm: Remove duplicate condition test before wait_event_timeout, Jason Gunthorpe
- [RFC PATCH 08/11] mm/hmm: Use lockdep instead of comments, Jason Gunthorpe
- [RFC PATCH 09/11] mm/hmm: Remove racy protection against double-unregistration, Jason Gunthorpe
- [RFC PATCH 11/11] mm/hmm: Do not use list*_rcu() for hmm->ranges, Jason Gunthorpe
- [RFC PATCH 10/11] mm/hmm: Poison hmm_range during unregister, Jason Gunthorpe
- [RFC PATCH 07/11] mm/hmm: Delete hmm_mirror_mm_is_alive(), Jason Gunthorpe
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, John Hubbard
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, Jason Gunthorpe
- Re: [RFC PATCH 00/11] mm/hmm: Various revisions from a locking/code review, Jason Gunthorpe
- [RFC][PATCH] kernel.h: Add generic roundup_64() macro,
Steven Rostedt
- [PATCH 0/1] infiniband/mm: convert put_page() to put_user_page*(),
john . hubbard
- [PATCH for-rc] RDMA/core: Fix panic when port_data isn't initialized,
Kamal Heib
- [PATCH for-next v5] iw_cxgb4: Fix qpid leak,
Nirranjan Kirubaharan
- [PATCH AUTOSEL 5.1 007/375] IB/hfi1: Fix WQ_MEM_RECLAIM warning, Sasha Levin
- [PATCH AUTOSEL 5.1 040/375] net/mlx5: E-Switch, Use atomic rep state to serialize state change, Sasha Levin
- [PATCH AUTOSEL 5.0 006/317] IB/hfi1: Fix WQ_MEM_RECLAIM warning, Sasha Levin
- [PATCH AUTOSEL 5.0 088/317] RDMA/cma: Consider scope_id while binding to ipv6 ll address, Sasha Levin
- [PATCH AUTOSEL 4.19 004/244] IB/hfi1: Fix WQ_MEM_RECLAIM warning, Sasha Levin
- [PATCH AUTOSEL 4.19 071/244] RDMA/cma: Consider scope_id while binding to ipv6 ll address, Sasha Levin
- [PATCH AUTOSEL 4.14 004/167] IB/hfi1: Fix WQ_MEM_RECLAIM warning, Sasha Levin
- [PATCH AUTOSEL 4.14 047/167] RDMA/cma: Consider scope_id while binding to ipv6 ll address, Sasha Levin
- [PATCH AUTOSEL 4.9 032/114] RDMA/cma: Consider scope_id while binding to ipv6 ll address, Sasha Levin
- [PATCH AUTOSEL 4.4 22/92] RDMA/cma: Consider scope_id while binding to ipv6 ll address, Sasha Levin
- [PATCH] RDMA/mlx5: Use DIV_ROUND_UP_ULL macro to allow 32 bit to build,
Steven Rostedt
- [PATCH for-next v4] iw_cxgb4: Fix qpid leak,
Nirranjan Kirubaharan
- [rdma-core patch] ibacm: only open InfiniBand port,
Honggang Li
- [PATCH for-rc] RDMA/uverbs: Pass udata on uverbs error unwind,
Gal Pressman
- [PATCH for-next] RDMA/core: Avoid panic when port_data isn't initialized,
Kamal Heib
- [PATCH rdma-core] build: Set up CI with Azure Pipelines, Jason Gunthorpe
- [PATCH rdma-core 0/7] More fixes for building,
Jason Gunthorpe
- [PATCH for-rc] RDMA/core: Clear out the udata before error unwind,
Jason Gunthorpe
- [PATCH iproute2-next 0/4] Enrich rdma tool for net namespace commands,
Parav Pandit
- [PATCH for-next v3] iw_cxgb4: Fix qpid leak,
Nirranjan Kirubaharan
- [PATCH for-next] RDMA/core: Return void from ib_device_check_mandatory(),
Kamal Heib
- [PATCH] mlx5: avoid 64-bit division,
Michal Kubecek
- [PATCH v2 rdma] RDMA/qedr: Fix incorrect device rate.,
Michal Kalderon
- [PATCH rdma] RDMA/qedr: Fix incorrect device rate.,
Michal Kalderon
- [PATCH for-next v2 0/4] ib_pd should not have ib_uobject,
Shamir Rabinovitch
- [PATCH rdma-next 00/15] Convert CQ allocations,
Leon Romanovsky
- [PATCH rdma-next 01/15] rds: Don't check return value from destroy CQ, Leon Romanovsky
- [PATCH rdma-next 02/15] RDMA/ipoib: Remove check of destroy CQ, Leon Romanovsky
- [PATCH rdma-next 03/15] RDMA/core: Make ib_destroy_cq() void, Leon Romanovsky
- [PATCH rdma-next 04/15] RDMA/efa: Remove check that prevents destroy of resources in error flows, Leon Romanovsky
- [PATCH rdma-next 05/15] RDMA/nes: Remove useless NULL checks, Leon Romanovsky
- [PATCH rdma-next 07/15] RDMA/nes: Remove second wait queue initialization call, Leon Romanovsky
- [PATCH rdma-next 08/15] RDMA/nes: Avoid memory allocation during CQ destroy, Leon Romanovsky
- [PATCH rdma-next 09/15] RDMA: Clean destroy CQ in drivers do not return errors, Leon Romanovsky
- [PATCH rdma-next 10/15] RDMA/cxgb3: Use sizeof() notation instead of plain sizeof, Leon Romanovsky
- [PATCH rdma-next 11/15] RDMA/cxgb3: Don't expose DMA addresses, Leon Romanovsky
- [PATCH rdma-next 12/15] RDMA/cxgb3: Delete and properly mark unimplemented resize CQ function, Leon Romanovsky
- [PATCH rdma-next 06/15] RDMA/i40iw: Remove useless NULL checks, Leon Romanovsky
- [PATCH rdma-next 14/15] RDMA/cxgb4: Don't expose DMA addresses, Leon Romanovsky
- [PATCH rdma-next 15/15] RDMA: Convert CQ allocations to be under core responsibility, Leon Romanovsky
- [PATCH rdma-next 13/15] RDMA/cxgb4: Use sizeof() notation, Leon Romanovsky
- Re: [PATCH rdma-next 00/15] Convert CQ allocations, Jason Gunthorpe
- Re: [PATCH rdma-next 00/15] Convert CQ allocations, Jason Gunthorpe
- [PATCH rdma-next] RDMA/hns: Fix PD memory leak for internal allocation,
Leon Romanovsky
- [PATCH rdma-next] IB/mlx5: Avoid second synchronize_srcu in dereg_mr,
Leon Romanovsky
- [PATCH for-next] RDMA/core: Rename ib_device_check_mandatory,
Kamal Heib
- [PATCH] IB/mlx4: Delete unused func arg,
Yuval Shaia
- rdma-core debian packages,
Steve Wise
- [PATCH rdma-next v4] RDMA/srp: Rename SRP sysfs name after IB device rename trigger,
Leon Romanovsky
- [PATCH rdma-core] vmw_pvrdma: Use resource ids from physical device if available,
Adit Ranadive
- [PATCH for-next] RDMA/vmw_pvrdma: Use resource ids from physical device if available,
Adit Ranadive
- [PATCH] RDMA/nldev: add check for null return from call to nlmsg_put,
Colin King
- [PATCH for-next] RDMA/providers: Simplify ib_modify_port for RoCE providers,
Kamal Heib
- [PATCH for-next v2] iw_cxgb4: Fix qpid leak,
Nirranjan Kirubaharan
- [PATCH rdma-next v3] RDMA/srp: Rename SRP sysfs name after IB device rename trigger,
Leon Romanovsky
- [RFC PATCH rdma-next v2] RDMA/srp: Rename SRP sysfs name after IB device rename trigger,
Leon Romanovsky
- [RFC PATCH rdma-next v1] RDMA/srp: Rename SRP sysfs name after IB device rename trigger,
Leon Romanovsky
- [PATCH for-next] iw_cxgb4: Fix qpid leak,
Nirranjan Kirubaharan
- [PATCH 0/7] iser/isert/rw-api cleanups,
Max Gurtovoy
- [RFC PATCH rdma-next] RDMA/srp: Don't cache device name as part of sysfs name,
Leon Romanovsky
- [PATCH rdma-core 00/20] Incorporate infiniband-diags into rdma-core,
Jason Gunthorpe
- [PATCH rdma-core 04/20] ibdiags: Remove config.h and HAVE_CONFIG_H, Jason Gunthorpe
- [PATCH rdma-core 02/20] ibdiags: Add required definitions to rdma-core config.h, Jason Gunthorpe
- [PATCH rdma-core 05/20] ibdiags: Don't use __DATE__ and __TIME__, Jason Gunthorpe
- [PATCH rdma-core 07/20] ibdiags: Add cmake files for ibdiags components, Jason Gunthorpe
- [PATCH rdma-core 06/20] build: Support rst as a man page option, Jason Gunthorpe
- [PATCH rdma-core 12/20] ibdiags: Add Fedora packaging, Jason Gunthorpe
- [PATCH rdma-core 15/20] libibmad: Flatten libibmad into one directory, Jason Gunthorpe
- [PATCH rdma-core 13/20] ibdiags: Add suse packaging, Jason Gunthorpe
- [PATCH rdma-core 10/20] ibdiags: Provide the cl_nodenamemap interface, Jason Gunthorpe
- [PATCH rdma-core 11/20] ibdiags: Add Debian packaging, Jason Gunthorpe
- [PATCH rdma-core 17/20] ibdiags: Flatten the infiniband-diags tools into one directory, Jason Gunthorpe
- [PATCH rdma-core 18/20] ibdiags: Remove obsolete build system and related files, Jason Gunthorpe
- [PATCH rdma-core 03/20] ibdiags: Remove unneeded HAVE_ checks, Jason Gunthorpe
- [PATCH rdma-core 08/20] ibdiags: Copy the cl_qmap implementation from opensm, Jason Gunthorpe
- [PATCH rdma-core 19/20] ibdiags: Remove @BUILD_DATE@ from the man pages, Jason Gunthorpe
- [PATCH rdma-core 01/20] ibdiags: Add SWITCH_FALLTHROUGH, Jason Gunthorpe
- [PATCH rdma-core 20/20] ibdiags: Perform substitution on the RST include files as well, Jason Gunthorpe
- [PATCH rdma-core 09/20] ibdiags: Copy part of ib_types.h from opensm, Jason Gunthorpe
- [PATCH rdma-core 14/20] ibdiags: Obsolete mad_osd.h, Jason Gunthorpe
- [PATCH rdma-core 16/20] libibnetdiscover: Flatten libibnetdiscover into one directory, Jason Gunthorpe
- Re: [PATCH rdma-core 00/20] Incorporate infiniband-diags into rdma-core, Jason Gunthorpe
- [PATCH rdma-core 0/5] Build system updates,
Jason Gunthorpe
- undefined reference to `__aeabi_uldivmod' after 25c13324d03d ("IB/mlx5: Add steering SW ICM device memory type"),
Nathan Chancellor
- CFP: 4th RDMA Mini-Summit at LPC 2019,
Leon Romanovsky
- [PATCH rdma-next 0/2] DevX fixes,
Leon Romanovsky
- [PATCH v2] RDMA: Directly cast the sockaddr union to sockaddr,
Jason Gunthorpe
- [PATCH rdma-rc] RDMA/core: Change system parameters callback from dumpit to doit,
Leon Romanovsky
- [PATCH rdma-core] kernel-boot: Fix build failure with ancient libnl3 versions,
Leon Romanovsky
- Annoying gcc / rdma / networking warnings,
Linus Torvalds
- [PATCH] infiniband/core: zero out bind_list pointer in cma_release_port(),
Hannes Reinecke
- [PATCH rdma-core 0/2] Update rdma-core to Fedora Core 30,
Jason Gunthorpe
- [PATCH 00/25 V4] Introduce new API for T10-PI offload,
Max Gurtovoy
[Index of Archives]
[Linux USB Development]
[Video for Linux]
[Big List of Linux Books]
[Linux SCSI]
[Scanners]
[Yosemite Info]