On 6/5/2019 10:40 PM, Sagi Grimberg wrote:
- if (qp_init_attr->rwq_ind_tbl &&
- (qp_init_attr->recv_cq ||
- qp_init_attr->srq || qp_init_attr->cap.max_recv_wr ||
- qp_init_attr->cap.max_recv_sge))
+ if ((qp_init_attr->rwq_ind_tbl &&
+ (qp_init_attr->recv_cq ||
+ qp_init_attr->srq || qp_init_attr->cap.max_recv_wr ||
+ qp_init_attr->cap.max_recv_sge)) ||
+ ((qp_init_attr->create_flags & IB_QP_CREATE_SIGNATURE_EN) &&
+ !(device->attrs.device_cap_flags &
IB_DEVICE_SIGNATURE_HANDOVER)))
Wouldn't it make sense to also change the qp create flag and the device
cap to be PI_EN/PI_HANDOVER while we're at it?
We're already standing on 20 patches in this series, so if Jason will
agree I'll do this renaming in a separate commit or we can stay with the
current naming.
Or INTEGRITY_EN/INTEGRITY_HANDOVER?