On Wed, May 29, 2019 at 10:15:28AM -0500, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace the following form: > > sizeof(struct opa_port_status_rsp) + num_vls * sizeof(struct _vls_pctrs) > > with: > > struct_size(rsp, vls, num_vls) > > and so on... > > Also, notice that variable size is unnecessary, hence it is removed. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Reviewed-by: Dennis Dalessandro <dennis.dalessandro@xxxxxxxxx> > --- > drivers/infiniband/hw/hfi1/mad.c | 9 +++------ > 1 file changed, 3 insertions(+), 6 deletions(-) Applied to for-next, thanks Jason