On Wed, May 29, 2019 at 10:13:26AM -0500, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace the following form: > > sizeof(*pkt) + sizeof(pkt->addr[0])*n > > with: > > struct_size(pkt, addr, n) > > Also, notice that variable size is unnecessary, hence it is removed. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Reviewed-by: Dennis Dalessandro <dennis.dalessandro@xxxxxxxxx> > --- > drivers/infiniband/hw/qib/qib_user_sdma.c | 5 +++-- > 1 file changed, 3 insertions(+), 2 deletions(-) Applied to for-next, thanks Jason