Linux Block Development
[Prev Page][Next Page]
- [PATCH 0/5] Some cleanup patches for block bfq,
Yuwei Guan
- [PATCH 1/5] block, bfq: remove unnecessary meta_pending count, Yuwei Guan
- [PATCH 2/5] block, bfq: remove unused bfq_log_bfqg, Yuwei Guan
- [PATCH 3/5] block, bfq: remove redundant max_t() in bfq_bfqq_charge_time(), Yuwei Guan
- [PATCH 4/5] block, bfq: change type for "prio_changed", Yuwei Guan
- [PATCH 5/5] block, bfq: change type for "bfq_large_burst_thresh", Yuwei Guan
- [PATCH 8/7] block: don't claim devices that are not live in bd_link_disk_holder,
Christoph Hellwig
- Regression: wrong DIO alignment check with dm-crypt,
Eric Biggers
- [PATCH v3 0/2] some random cleanups for blk-mq.c,
Jinlong Chen
- [PATCH V2 blktests 0/3] fix and improvement for xfs log size change from new xfsprogs version,
Yi Zhang
- [PATCH v2 0/2] some random cleanups for blk-mq.c,
Jinlong Chen
- [PATCH -next v4 0/5] multiple cleanup patches for bfqd,
Yu Kuai
- [PATCH -next v4 1/5] block, bfq: remove set but not used variable in __bfq_entity_update_weight_prio, Yu Kuai
- [PATCH -next v4 4/5] block, bfq: remove dead code for updating 'rq_in_driver', Yu Kuai
- [PATCH -next v4 3/5] block, bfq: cleanup bfq_activate_requeue_entity(), Yu Kuai
- [PATCH -next v4 2/5] block, bfq: factor out code to update 'active_entities', Yu Kuai
- [PATCH -next v4 5/5] block, bfq: don't declare 'bfqd' as type 'void *' in bfq_group, Yu Kuai
- Re: [PATCH -next v4 0/5] multiple cleanup patches for bfqd, Jens Axboe
- [PATCH 0/4] some random cleanups for blk-mq.c,
Jinlong Chen
- per-tagset SRCU struct and quiesce v3,
Christoph Hellwig
- [PATCH 07/14] nvme: split nvme_kill_queues, Christoph Hellwig
- [PATCH 03/14] nvme: don't remove namespaces in nvme_passthru_end, Christoph Hellwig
- [PATCH 13/14] blk-mq: add tagset quiesce interface, Christoph Hellwig
- [PATCH 09/14] nvme-apple: don't unquiesce the I/O queues in apple_nvme_reset_work, Christoph Hellwig
- [PATCH 05/14] nvme: remove the NVME_NS_DEAD check in nvme_validate_ns, Christoph Hellwig
- [PATCH 02/14] nvme-pci: refactor the tagset handling in nvme_reset_work, Christoph Hellwig
- [PATCH 06/14] nvme: don't unquiesce the admin queue in nvme_kill_queues, Christoph Hellwig
- [PATCH 10/14] blk-mq: skip non-mq queues in blk_mq_quiesce_queue, Christoph Hellwig
- [PATCH 12/14] blk-mq: pass a tagset to blk_mq_wait_quiesce_done, Christoph Hellwig
- [PATCH 04/14] nvme: remove the NVME_NS_DEAD check in nvme_remove_invalid_namespaces, Christoph Hellwig
- [PATCH 11/14] blk-mq: move the srcu_struct used for quiescing to the tagset, Christoph Hellwig
- [PATCH 14/14] nvme: use blk_mq_[un]quiesce_tagset, Christoph Hellwig
- [PATCH 01/14] block: set the disk capacity to 0 in blk_mark_disk_dead, Christoph Hellwig
- [PATCH 08/14] nvme-pci: don't unquiesce the I/O queues in nvme_remove_dead_ctrl, Christoph Hellwig
- Re: per-tagset SRCU struct and quiesce v3, Keith Busch
- Re: per-tagset SRCU struct and quiesce v3, Chao Leng
- Re: per-tagset SRCU struct and quiesce v3, Christoph Hellwig
- [syzbot] linux-next boot error: BUG: unable to handle kernel paging request in corrupted,
syzbot
- [PATCH AUTOSEL 6.0 34/34] bio: safeguard REQ_ALLOC_CACHE bio put, Sasha Levin
- [PATCH 00/20] A few bugfix and cleanup patches for bfq-iosched,
Kemeng Shi
- [PATCH 01/20] block, bfq: fix typo in comment, Kemeng Shi
- [PATCH 02/20] block, bfq: Update bfqd->max_budget with bfqd->lock held, Kemeng Shi
- [PATCH 03/20] block, bfq: correct bfq_max_budget and bfq_min_budget, Kemeng Shi
- [PATCH 04/20] block, bfq: simpfy computation of bfqd->budgets_assigned, Kemeng Shi
- [PATCH 05/20] block, bfq: recover the "service hole" if enough budget is left, Kemeng Shi
- [PATCH 06/20] block, bfq: correct interactive weight-raise check in bfq_set_budget_timeout, Kemeng Shi
- [PATCH 07/20] block, bfq: simpfy check for interactive bfqq in bfq_update_wr_data, Kemeng Shi
- [PATCH 08/20] block, bfq: do srt filtering for interactive queues in bfq_completed_request, Kemeng Shi
- [PATCH 09/20] block, bfq: remove redundant check if (bfqq->dispatched > 0), Kemeng Shi
- [PATCH 11/20] block, bfq: remove unnecessary "wr" part of wr_or_deserves_wr, Kemeng Shi
- [PATCH 14/20] block, bfq: remove redundant oom_bfqq check for bfqq from bfq_find_close_cooperator, Kemeng Shi
- [PATCH 12/20] block, bfq: start/restart service_from_wr accumulating correctly, Kemeng Shi
- [PATCH 13/20] block,bfq: remove redundant nonrot_with_queueing check in bfq_setup_cooperator, Kemeng Shi
- [PATCH 10/20] block, bfq: define and use soft_rt, in_burst and wr_or_deserves_wr only low_latency is enable, Kemeng Shi
- [PATCH 15/20] block, bfq: some cleanups for function bfq_pos_tree_add_move, Kemeng Shi
- [PATCH 16/20] block, bfq: remove unnecessary goto tag in __bfq_weights_tree_remove, Kemeng Shi
- [PATCH 18/20] block, bfq: remove unnecessary bfqq->next_rq = NULL in bfq_remove_request, Kemeng Shi
- [PATCH 19/20] block, bfq: remove unnecessary local variable __bfqq in bfq_setup_merge, Kemeng Shi
- [PATCH 20/20] block, bfq: remove unncessary process_ref check for merged queue in bfq_setup_merge, Kemeng Shi
- [PATCH 17/20] block, bfq: remove unnecessary traverse in bfq_add_to_burst, Kemeng Shi
- Why don't we always grab bfqd->lock for bio_bfqq?,
Khazhy Kumykov
- UAF in blk_add_rq_to_plug()?,
Al Viro
- [bisected] RAID1 direct IO redirecting sector loop since 6.0,
Dmitrii Tcvetkov
- Re: Re: [RESEND PATCH v2 3/3] block: hide back blk_freeze_queue_start and export its blk-mq alias, Jinlong Chen
- [PATCH] block/floppy: Fix memory leak in do_floppy_init(),
Yuan Can
- [PATCH] block/blk-iocost (gcc13): cast enum members to int in prints,
Jiri Slaby (SUSE)
- [PATCH] blk-mq: Fix kmemleak in blk_mq_init_allocated_queue,
Chen Jun
- [PATCH v4 0/7] Improve libata support for FUA,
Damien Le Moal
- [PATCH v4 0/7],
Damien Le Moal
- fix delayed holder tracking v2,
Christoph Hellwig
- INFO: rcu detected stall in blk_mq_requeue_work,
Wei Chen
- misc elevator code cleanups,
Christoph Hellwig
- [PATCH V5 0/8] block, bfq: extend bfq to support multi-actuator drives,
Paolo Valente
- [PATCH V5 5/8] block, bfq: split also async bfq_queues on a per-actuator basis, Paolo Valente
- [PATCH V5 7/8] block, bfq: inject I/O to underutilized actuators, Paolo Valente
- [PATCH V5 3/8] block, bfq: move io_cq-persistent bfqq data into a dedicated struct, Paolo Valente
- [PATCH V5 1/8] block, bfq: split sync bfq_queues on a per-actuator basis, Paolo Valente
- [PATCH V5 2/8] block, bfq: forbid stable merging of queues associated with different actuators, Paolo Valente
- [PATCH V5 4/8] block, bfq: turn bfqq_data into an array in bfq_io_cq, Paolo Valente
- [PATCH V5 6/8] block, bfq: retrieve independent access ranges from request queue, Paolo Valente
- [PATCH V5 8/8] block, bfq: balance I/O injection among underutilized actuators, Paolo Valente
- [PATCH] blk-mq: move queue_is_mq out of blk_mq_cancel_work_sync,
Jinlong Chen
- BUG: unable to handle kernel NULL pointer dereference in bio_associate_blkg_from_css,
Wei Chen
- [PATCH] blk-mq: remove redundant call to blk_freeze_queue_start in blk_mq_destroy_queue,
Jinlong Chen
- [RESEND PATCH v2 0/3] queue freezing improvement and cleanups,
Jinlong Chen
- [PATCH v3] block: simplify blksize_bits() implementation,
Dawei Li
- [PATCH v4 0/2] virtio-blk: support zoned block devices,
Dmitry Fomichev
- [PATCH v2 0/3] queue freezing improvement and cleanups,
Jinlong Chen
- [PATCH v2] block: simplify blksize_bits() implementation,
Dawei Li
- [PATCH 0/3] cleanups for queue freezing functions,
Jinlong Chen
- [PATCH] block: Fix possible memory leak for rq_wb on add_disk failure,
Chen Zhongjin
- [PATCH 0/4] ublk_drv: uring_cmd queueing improvement and cleanup,
Ming Lei
- [GIT PULL] Block fixes for 6.1-rc3,
Jens Axboe
- [bug?] blk_queue_may_bounce() has the comparison max_low_pfn and max_pfn wrong way,
Al Viro
- [bug report] block/bio: add pcpu caching for non-polling bio_put,
Dan Carpenter
- [PATCH -next 0/5] blk-iocost: random patches to improve configuration,
Yu Kuai
- blk_mq_init_sq_queue (deprecated) on 5.13 does not have any effect, why?,
Roberto A. Foglietta
- [PATCH v3 0/2] virtio-blk: support zoned block devices,
Dmitry Fomichev
- [PATCH for-6.1 0/2] iopoll bio pcpu cache fix,
Pavel Begunkov
- Re: [RFC][PATCH v2 04/31] timers: block: Use del_timer_shutdown() before freeing timer,
Steven Rostedt
- [PATCH] block: fix bio-allocation from per-cpu cache,
Kanchan Joshi
- [PATCH] rbd: fix possible memory leak in rbd_sysfs_init(),
Yang Yingliang
- [PATCH] blk-mq: don't add non-pt request with ->end_io to batch,
Ming Lei
- [PATCH v3 00/19] Use block pr_ops in LIO,
Mike Christie
- [PATCH v3 09/19] nvme: Add pr_ops read_keys support, Mike Christie
- [PATCH v3 01/19] block: Add PR callouts for read keys and reservation, Mike Christie
- [PATCH v3 03/19] scsi: Move sd_pr_type to header to share, Mike Christie
- [PATCH v3 02/19] scsi: Rename sd_pr_command, Mike Christie
- [PATCH v3 05/19] dm: Add support for block PR read keys/reservation, Mike Christie
- [PATCH v3 07/19] nvme: Don't hardcode the data len for pr commands, Mike Christie
- [PATCH v3 17/19] scsi: target: Allow backends to hook into PR handling, Mike Christie
- [PATCH v3 11/19] nvme: Add pr_ops read_reservation support, Mike Christie
- [PATCH v3 14/19] scsi: Export scsi_result_to_blk_status, Mike Christie
- [PATCH v3 18/19] scsi: target: Don't support SCSI-2 RESERVE/RELEASE, Mike Christie
- [PATCH v3 04/19] scsi: Add support for block PR read keys/reservation, Mike Christie
- [PATCH v3 15/19] scsi: Have sd pr_ops return a blk_status_t, Mike Christie
- [PATCH v3 06/19] nvme: Fix reservation status related structs, Mike Christie
- [PATCH v3 19/19] scsi: target: Add block PR support to iblock, Mike Christie
- [PATCH v3 13/19] nvme: Have NVMe pr_ops return a blk_status_t, Mike Christie
- [PATCH v3 08/19] nvme: Move pr code to it's own file, Mike Christie
- [PATCH v3 12/19] block,nvme,scsi,dm: Add blk_status to pr_ops callouts, Mike Christie
- [PATCH v3 10/19] nvme: Move NVMe and Block PR types to an array, Mike Christie
- [PATCH v3 16/19] scsi: target: Rename sbc_ops to exec_cmd_ops, Mike Christie
- [PATCH] block: simplify blksize_bits() implementation,
Dawei Li
- [bug report] blk-iocost: don't release 'ioc->lock' while updating params,
Dan Carpenter
- [PATCH v2] blk-mq: Properly init requests from blk_mq_alloc_request_hctx(),
John Garry
- [PATCH 2/3] mmc: block: Limit queue size for consecutive requeues,
Christian Löhle
- [PATCH 1/3] block: Requeue req as head if driver touched it,
Christian Löhle
- [PATCH 3/3] mmc: block: Requeue on block size restrictions,
Christian Löhle
- [PATCH 0/3] mmc: Improve block layer requeueing behavior,
Christian Löhle
- [PATCH] blktrace:use '__blk_trace_remove' helper in 'blk_trace_remove_queue', Ye Bin
- [PATCH V3 1/1] blk-mq: avoid double ->queue_rq() because of early timeout,
Ming Lei
- [PATCH V2 1/1] blk-mq: avoid double ->queue_rq() because of early timeout,
Ming Lei
- [PATCH 0/3] Block layer cleanup patches,
Bart Van Assche
- [PATCH] block: remove bio_start_io_acct_time,
Christoph Hellwig
- per-tagset SRCU struct and quiesce v2,
Christoph Hellwig
- [PATCH 01/17] block: set the disk capacity to 0 in blk_mark_disk_dead, Christoph Hellwig
- [PATCH 13/17] blk-mq: skip non-mq queues in blk_mq_quiesce_queue, Christoph Hellwig
- [PATCH 07/17] nvme: remove the NVME_NS_DEAD check in nvme_validate_ns, Christoph Hellwig
- [PATCH 06/17] nvme: remove the NVME_NS_DEAD check in nvme_remove_invalid_namespaces, Christoph Hellwig
- [PATCH 03/17] nvme-pci: don't warn about the lack of I/O queues for admin controllers, Christoph Hellwig
- [PATCH 16/17] blk-mq: add tagset quiesce interface, Christoph Hellwig
- [PATCH 10/17] nvme-pci: mark the namespaces dead earlier in nvme_remove, Christoph Hellwig
- [PATCH 02/17] nvme-pci: refactor the tagset handling in nvme_reset_work, Christoph Hellwig
- [PATCH 12/17] nvme-pci: don't unquiesce the I/O queues in apple_nvme_reset_work, Christoph Hellwig
- [PATCH 09/17] nvme: don't unquiesce the I/O queues in nvme_kill_queues, Christoph Hellwig
- [PATCH 17/17] nvme: use blk_mq_[un]quiesce_tagset, Christoph Hellwig
- [PATCH 15/17] blk-mq: pass a tagset to blk_mq_wait_quiesce_done, Christoph Hellwig
- [PATCH 04/17] nvme: don't call nvme_kill_queues from nvme_remove_namespaces, Christoph Hellwig
- [PATCH 05/17] nvme: don't remove namespaces in nvme_passthru_end, Christoph Hellwig
- [PATCH 11/17] nvme-pci: don't unquiesce the I/O queues in nvme_remove_dead_ctrl, Christoph Hellwig
- [PATCH 14/17] blk-mq: move the srcu_struct used for quiescing to the tagset, Christoph Hellwig
- [PATCH 08/17] nvme: don't unquiesce the admin queue in nvme_kill_queues, Christoph Hellwig
- [PATCH RFC v3 0/7] blk-mq/libata/scsi: SCSI driver tagging improvements Part II,
John Garry
- [PATCH RFC v3 00/22] blk-mq/libata/scsi: SCSI driver tagging improvements Part I,
John Garry
- [PATCH RFC v3 01/22] blk-mq: Don't get budget for reserved requests, John Garry
- [PATCH RFC v3 03/22] scsi: core: Implement reserved command handling, John Garry
- [PATCH RFC v3 02/22] scsi: core: Add scsi_get_dev(), John Garry
- [PATCH RFC v3 04/22] scsi: core: Add support to send reserved commands, John Garry
- [PATCH RFC v3 05/22] scsi: core: Add support for reserved command timeout handling, John Garry
- [PATCH RFC v3 08/22] scsi: scsi_transport_sas: Alloc sdev for expander, John Garry
- [PATCH RFC v3 06/22] scsi: libsas: Improve sas_ex_discover_expander() error handling, John Garry
- [PATCH RFC v3 07/22] scsi: libsas: Notify LLDD expander found before calling sas_rphy_add(), John Garry
- [PATCH RFC v3 13/22] scsi: scsi_transport_sas: Allocate end device target id in the rphy alloc, John Garry
- [PATCH RFC v3 12/22] scsi: core: Use SCSI_SCAN_RESCAN in __scsi_add_device(), John Garry
- [PATCH RFC v3 11/22] scsi: libsas: Add sas_internal_timeout(), John Garry
- [PATCH RFC v3 10/22] scsi: libsas: Add sas_queuecommand_internal(), John Garry
- [PATCH RFC v3 09/22] scsi: libsas: Add sas_alloc_slow_task_rq(), John Garry
- [PATCH RFC v3 14/22] ata: libata-scsi: Add ata_scsi_setup_sdev(), John Garry
- [PATCH RFC v3 15/22] scsi: libsas: Add sas_ata_setup_device(), John Garry
- [PATCH RFC v3 16/22] ata: libata-scsi: Allocate sdev early in port probe, John Garry
- [PATCH RFC v3 19/22] scsi: libsas: Queue TMF commands as requests, John Garry
- [PATCH RFC v3 18/22] scsi: libsas: Queue SMP commands as requests, John Garry
- [PATCH RFC v3 20/22] scsi: core: Add scsi_alloc_request_hwq(), John Garry
- [PATCH RFC v3 17/22] scsi: libsas drivers: Reserve tags, John Garry
- [PATCH RFC v3 22/22] scsi: libsas: Delete sas_task_slow.timer, John Garry
- [PATCH RFC v3 21/22] scsi: libsas: Queue internal abort commands as requests, John Garry
- Re: [PATCH RFC v3 00/22] blk-mq/libata/scsi: SCSI driver tagging improvements Part I, John Garry
- [PATCH] blk-mq: avoid double ->queue_rq() because of early timeout,
Ming Lei
- [RFC PATCH v3 00/14] mm/block: add bdi sysfs knobs,
Stefan Roesch
- [RFC PATCH v3 08/14] mm: add knob /sys/class/bdi/<bdi>/max_bytes, Stefan Roesch
- [RFC PATCH v3 01/14] mm: add bdi_set_strict_limit() function, Stefan Roesch
- [RFC PATCH v3 05/14] mm: add bdi_get_max_bytes() function, Stefan Roesch
- [RFC PATCH v3 09/14] mm: document /sys/class/bdi/<bdi>/max_bytes knob, Stefan Roesch
- [RFC PATCH v3 13/14] mm: add /sys/class/bdi/<bdi>/min_bytes knob, Stefan Roesch
- [RFC PATCH v3 03/14] mm: document /sys/class/bdi/<bdi>/strict_limit knob, Stefan Roesch
- [RFC PATCH v3 04/14] mm: use part per 1000 for bdi ratios., Stefan Roesch
- [RFC PATCH v3 12/14] mm: add bdi_set_min_bytes() function, Stefan Roesch
- [RFC PATCH v3 06/14] mm: split off __bdi_set_max_ratio() function, Stefan Roesch
- [RFC PATCH v3 02/14] mm: add knob /sys/class/bdi/<bdi>/strict_limit, Stefan Roesch
- [RFC PATCH v3 07/14] mm: add bdi_set_max_bytes() function., Stefan Roesch
- [RFC PATCH v3 11/14] mm: split off __bdi_set_min_ratio() function, Stefan Roesch
- [RFC PATCH v3 10/14] mm: add bdi_get_min_bytes() function., Stefan Roesch
- [RFC PATCH v3 14/14] mm: document /sys/class/bdi/<bdi>/min_bytes knob, Stefan Roesch
- Re: [RFC PATCH v3 00/14] mm/block: add bdi sysfs knobs, Jens Axboe
- [PATCH] block: fix Werror=format with GCC 13,
Martin Liška
- [PATCH v3] drbd: Store op in drbd_peer_request, Christoph Böhmwalder
- [PATCH blktests 0/3] fix for xfs log size change from new version of xfsprogs,
Yi Zhang
- [PATCH] ublk_drv: don't call task_work_add for queueing io commands,
Ming Lei
- Re: [PATCH v1 1/5] treewide: use get_random_u32_below() instead of deprecated function, SeongJae Park
- [PATCH] blk-mq: Properly init bios from blk_mq_alloc_request_hctx(),
John Garry
- [PATCH v2] block: fix memory leak for elevator on add_disk failure,
Yu Kuai
- [PATCH v1 0/5] convert tree to get_random_u32_{below,above,between}(),
Jason A. Donenfeld
- [PATCH v1 2/5] prandom: remove prandom_u32_max(), Jason A. Donenfeld
- [PATCH v1 4/5] treewide: use get_random_u32_{above,below}() instead of manual loop, Jason A. Donenfeld
- [PATCH v1 3/5] random: add helpers for random numbers with given floor or range, Jason A. Donenfeld
- [PATCH v1 5/5] treewide: use get_random_u32_between() when possible, Jason A. Donenfeld
- Re: [PATCH v1 0/5] convert tree to get_random_u32_{below,above,between}(), Jakub Kicinski
- Re: [PATCH v1 0/5] convert tree to get_random_u32_{below,above,between}(), Greg Kroah-Hartman
- Re: [PATCH v1 0/5] convert tree to get_random_u32_{below,above,between}(), Jason Gunthorpe
- [PATCH] virtio_blk: Fix signedness bug in virtblk_prep_rq(),
Rafael Mendonca
[Index of Archives]
[Linux RAID]
[Linux SCSI]
[Linux ATA RAID]
[Linux Wireless]
[Linux Bluetooth]
[Kernel Announce]
[Kernel Newbies]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]