Linux Block Development
[Prev Page][Next Page]
- Re: [RFC PATCH v2] iov_iter: Convert iterate*() to inline funcs, (continued)
- [PATCH] block: Remove special-casing of compound pages,
Matthew Wilcox (Oracle)
- [syzbot] [block?] general protection fault in start_motor (3), syzbot
- Libublk-rs v0.1.0,
Ming Lei
- [PATCH 0/3] bcachefs block layer prereqs,
Kent Overstreet
- [PATCH AUTOSEL 5.10 22/25] rbd: make get_lock_owner_info() return a single locker or NULL,
Sasha Levin
- [PATCH AUTOSEL 5.15 29/31] rbd: harden get_lock_owner_info() a bit, Sasha Levin
- [PATCH AUTOSEL 5.15 28/31] rbd: make get_lock_owner_info() return a single locker or NULL,
Sasha Levin
- [PATCH AUTOSEL 6.1 42/47] rbd: make get_lock_owner_info() return a single locker or NULL, Sasha Levin
- [PATCH AUTOSEL 6.1 43/47] rbd: harden get_lock_owner_info() a bit, Sasha Levin
- [PATCH AUTOSEL 6.4 47/54] rbd: make get_lock_owner_info() return a single locker or NULL, Sasha Levin
- [PATCH AUTOSEL 6.4 48/54] rbd: harden get_lock_owner_info() a bit, Sasha Levin
- [PATCH v2] blk-mq: release scheduler resource when request complete,
chengming . zhou
- [PATCH] blk-mq: release scheduler resource when request complete,
chengming . zhou
- [PATCH 1/1] blk-throttle: fix throttle configuring not effective,
zhuxiaohui
- [PATCH v8 0/9] Improve performance for zoned UFS devices,
Bart Van Assche
- Timeouts and crash whilst running fio against nullb0, David Howells
- [GIT PULL] Block fixes for 6.5-rc6,
Jens Axboe
- [PATCH] block: BFQ: dispatch expired sync and async request first, Zhang Bo
- [PATCH v7 0/6] badblocks improvement for multiple bad block ranges,
Coly Li
- [PATCH v7 1/6] badblocks: add more helper structure and routines in badblocks.h, Coly Li
- [PATCH v7 3/6] badblocks: improve badblocks_set() for multiple ranges handling, Coly Li
- [PATCH v7 2/6] badblocks: add helper routines for badblock ranges handling, Coly Li
- [PATCH v7 4/6] badblocks: improve badblocks_clear() for multiple ranges handling, Coly Li
- [PATCH v7 5/6] badblocks: improve badblocks_check() for multiple ranges handling, Coly Li
- [PATCH v7 6/6] badblocks: switch to the improved badblock handling code, Coly Li
- [PATCH] test: user space code to test badblocks APIs, Coly Li
- Re: [PATCH v7 0/6] badblocks improvement for multiple bad block ranges, Geliang Tang
- Re: [PATCH v7 0/6] badblocks improvement for multiple bad block ranges, Jens Axboe
- Re: [PATCH v7 0/6] badblocks improvement for multiple bad block ranges, Ira Weiny
- [RFC PATCH] iov_iter: Convert iterate*() to inline funcs,
David Howells
- [PATCH] ublk: fix 'warn: variable dereferenced before check 'req'' from Smatch,
Ming Lei
- Re: [PATCH] nvme: core: don't hold rcu read lock in nvme_ns_chr_uring_cmd_iopoll, Guangwu Zhang
- [PATCH v14 00/11] Implement copy offload support,
Nitesh Shetty
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Message not available
- Re: [dm-devel] [PATCH v14 00/11] Implement copy offload support, Bart Van Assche
[PATCH v2 0/29] block: Make blkdev_get_by_*() return handle,
Jan Kara
- [PATCH 01/29] block: Provide bdev_open_* functions, Jan Kara
- [PATCH 04/29] drdb: Convert to use bdev_open_by_path(), Jan Kara
- [PATCH 03/29] block: Use bdev_open_by_dev() in disk_scan_partitions() and blkdev_bszset(), Jan Kara
- [PATCH 14/29] s390/dasd: Convert to bdev_open_by_path(), Jan Kara
- [PATCH 02/29] block: Use bdev_open_by_dev() in blkdev_open(), Jan Kara
- [PATCH 08/29] zram: Convert to use bdev_open_by_dev(), Jan Kara
- [PATCH 06/29] rnbd-srv: Convert to use bdev_open_by_path(), Jan Kara
- [PATCH 09/29] bcache: Convert to bdev_open_by_path(), Jan Kara
- [PATCH 05/29] pktcdvd: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 21/29] erofs: Convert to use bdev_open_by_path(), Jan Kara
- [PATCH 07/29] xen/blkback: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 17/29] PM: hibernate: Drop unused snapshot_test argument, Jan Kara
- [PATCH 20/29] btrfs: Convert to bdev_open_by_path(), Jan Kara
- [PATCH 10/29] dm: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 16/29] PM: hibernate: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 13/29] nvmet: Convert to bdev_open_by_path(), Jan Kara
- [PATCH 11/29] md: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 12/29] mtd: block2mtd: Convert to bdev_open_by_dev/path(), Jan Kara
- [PATCH 19/29] fs: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 15/29] scsi: target: Convert to bdev_open_by_path(), Jan Kara
- [PATCH 22/29] ext4: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 23/29] f2fs: Convert to bdev_open_by_dev/path(), Jan Kara
- [PATCH 25/29] nfs/blocklayout: Convert to use bdev_open_by_dev/path(), Jan Kara
- [PATCH 26/29] ocfs2: Convert to use bdev_open_by_dev(), Jan Kara
- [PATCH 27/29] reiserfs: Convert to bdev_open_by_dev/path(), Jan Kara
- [PATCH 18/29] mm/swap: Convert to use bdev_open_by_dev(), Jan Kara
- [PATCH 24/29] jfs: Convert to bdev_open_by_dev(), Jan Kara
- [PATCH 28/29] xfs: Convert to bdev_open_by_path(), Jan Kara
[PATCH 29/29] block: Remove blkdev_get_by_*() functions, Jan Kara
Re: [PATCH v2 0/29] block: Make blkdev_get_by_*() return handle, Christoph Hellwig
Re: [PATCH v2 0/29] block: Make blkdev_get_by_*() return handle, Al Viro
[PATCH 0/2] Small fixes for block t10-pi,
Ankit Kumar
Message not available
Re: [PATCH 0/2] Small fixes for block t10-pi, Ankit Kumar
remove get_super,
Christoph Hellwig
- [PATCH 01/17] FOLD: reverts part of "fs: use the super_block as holder when mounting file systems", Christoph Hellwig
- [PATCH 03/17] btrfs: call btrfs_close_devices from ->kill_sb, Christoph Hellwig
- [PATCH 02/17] btrfs: always open the device read-only in btrfs_scan_one_device, Christoph Hellwig
- [PATCH 04/17] btrfs: split btrfs_fs_devices.opened, Christoph Hellwig
- [PATCH 05/17] btrfs: open block devices after superblock creation, Christoph Hellwig
- [PATCH 09/17] floppy: call disk_force_media_change when changing the format, Christoph Hellwig
- [PATCH 07/17] nbd: call blk_mark_disk_dead in nbd_clear_sock_ioctl, Christoph Hellwig
- [PATCH 06/17] btrfs: use the super_block as holder when mounting file systems, Christoph Hellwig
- [PATCH 08/17] block: simplify the disk_force_media_change interface, Christoph Hellwig
- [PATCH 11/17] dasd: also call __invalidate_device when setting the device offline, Christoph Hellwig
- [PATCH 14/17] block: call into the file system for bdev_mark_dead, Christoph Hellwig
- [PATCH 16/17] fs: remove get_super, Christoph Hellwig
- [PATCH 13/17] block: consolidate __invalidate_device and fsync_bdev, Christoph Hellwig
- [PATCH 17/17] fs: simplify invalidate_inodes, Christoph Hellwig
- [PATCH 15/17] block: call into the file system for ioctl BLKFLSBUF, Christoph Hellwig
- [PATCH 10/17] amiflop: don't call fsync_bdev in FDFMTBEG, Christoph Hellwig
- [PATCH 12/17] block: drop the "busy inodes on changed media" log message, Christoph Hellwig
- Re: remove get_super, Josef Bacik
- Re: remove get_super, Josef Bacik
- Re: remove get_super, David Sterba
[PATCH blktests v3 00/13] Switch to allowed_host,
Daniel Wagner
- [PATCH blktests v3 04/13] nvme/rc: Add common subsystem nqn define, Daniel Wagner
- [PATCH blktests v3 03/13] nvme/043: Use hostnqn to generate DHCAP key, Daniel Wagner
- [PATCH blktests v3 02/13] nvme: Reorganize test preamble code section, Daniel Wagner
- [PATCH blktests v3 01/13] nvme/{003,004,005,013,046,049}: Group all variables declarations, Daniel Wagner
- [PATCH blktests v3 07/13] nvme/rc: Add common file_path name define, Daniel Wagner
- [PATCH blktests v3 06/13] nvme/{041,042,043,044,045,048}: Remove local variable hostnqn and hostid, Daniel Wagner
- [PATCH blktests v3 08/13] nvme: Use def_file_path variable instead local variable, Daniel Wagner
- [PATCH blktests v3 11/13] nvme/rc: Add helper for adding/removing to allow list, Daniel Wagner
- [PATCH blktests v3 09/13] nvme/rc: Add common def_subsys_uuid define, Daniel Wagner
- [PATCH blktests v3 10/13] nvme: Use def_subsys_uuid variable, Daniel Wagner
- [PATCH blktests v3 13/13] nvme: Introduce nvmet_target_{setup/cleanup} common code, Daniel Wagner
- [PATCH blktests v3 12/13] nvme: Add explicitly host to allow_host list, Daniel Wagner
- [PATCH blktests v3 05/13] nvme: Use def_subsysnqn variable instead local variable, Daniel Wagner
- Re: [PATCH blktests v3 00/13] Switch to allowed_host, Hannes Reinecke
- Re: [PATCH blktests v3 00/13] Switch to allowed_host, Sagi Grimberg
[PATCH blktests] nvme/rc: fix nvme device readiness check after _nvme_connect_subsys,
Shin'ichiro Kawasaki
[PATCH net-next v2 03/10] genetlink: remove userhdr from struct genl_info, Jakub Kicinski
[PATCH v4] blk-crypto: dynamically allocate fallback profile,
Sweet Tea Dorminy
[PATCH 00/17] -Wmissing-prototype warning fixes,
Arnd Bergmann
[PATCH v3] blk-crypto: dynamically allocate fallback profile, Sweet Tea Dorminy
[PATCH V2] ublk: zoned: support REQ_OP_ZONE_RESET_ALL,
Ming Lei
[PATCH blktests v2 00/12] Switch to allowed_host,
Daniel Wagner
- [PATCH blktests v2 01/12] nvme/{003,004,005,013,046,049}: Group all variables declarations, Daniel Wagner
- [PATCH blktests v2 02/12] nvme: Reorganize test preamble code section, Daniel Wagner
- [PATCH blktests v2 03/12] nvme/rc: Add common subsystem nqn define, Daniel Wagner
- [PATCH blktests v2 05/12] nvme/{041,042,043,044,045,048}: Remove local variable hostnqn and hostid, Daniel Wagner
- [PATCH blktests v2 06/12] nvme/rc: Add common file_path name define, Daniel Wagner
- [PATCH blktests v2 04/12] nvme: Use def_subsysnqn variable instead local variable, Daniel Wagner
- [PATCH blktests v2 08/12] nvme/rc: Add common def_subsys_uuid define, Daniel Wagner
- [PATCH blktests v2 07/12] nvme: Use def_file_path variable instead local variable, Daniel Wagner
- [PATCH blktests v2 11/12] nvme: Add explicitly host to allow_host list, Daniel Wagner
- [PATCH blktests v2 09/12] nvme: Use def_subsys_uuid variable, Daniel Wagner
- [PATCH blktests v2 10/12] nvme/rc: Add helper for adding/removing to allow list, Daniel Wagner
- [PATCH blktests v2 12/12] nvme: Introduce nvmet_target_{setup/cleanup} common code, Daniel Wagner
- Re: [PATCH blktests v2 00/12] Switch to allowed_host, Shinichiro Kawasaki
[bug report] ublk: enable zoned storage support, Dan Carpenter
[PATCH v3 0/4] brd discard patches,
Mikulas Patocka
[PATCH] ublk: zoned: support REQ_OP_ZONE_RESET_ALL,
Ming Lei
[PATCH -next] ublk: Fix signedness bug returning warning,
Li Zetao
[PATCH -next v3] block: remove init_mutex and open-code blk_iolatency_try_init,
Li Lingfeng
[PATCH v7 0/7] Improve performance for zoned UFS devices,
Bart Van Assche
[linux-next:master] BUILD REGRESSION 21ef7b1e17d039053edaeaf41142423810572741, kernel test robot
[PATCH net-next 03/10] genetlink: remove userhdr from struct genl_info,
Jakub Kicinski
[PATCH] block: pass a gendisk to the queue_sysfs_entry handlers, Christoph Hellwig
[PATCH RFC] block: Revert 615939a2ae73,
Chuck Lever
[PATCH v2] blk-crypto: dynamically allocate fallback profile,
Sweet Tea Dorminy
[PATCH -next v2] block: remove init_mutex and open-code blk_iolatency_try_init,
Li Lingfeng
[PATCH -next] block/swim: remove unnecessary check of res, Yang Yingliang
[PATCH -next] drbd: Use helper put_drbd_dev() and get_drbd_dev(),
Ruan Jinjie
[PATCH] blk-crypto: dynamically allocate fallback profile,
Sweet Tea Dorminy
[PATCH 0/2] Block nowait fix,
Jens Axboe
[PATCH 0/5] Some minor cleanups,
Damien Le Moal
[PATCH V3 0/14] blk-mq: fix wrong queue mapping for kdump kernel,
Ming Lei
- [PATCH V3 01/14] blk-mq: add blk_mq_max_nr_hw_queues(), Ming Lei
- [PATCH V3 03/14] ublk: limit max allowed nr_hw_queues, Ming Lei
- [PATCH V3 11/14] scsi: hisi: take blk_mq_max_nr_hw_queues() into account for calculating io vectors, Ming Lei
- [PATCH V3 14/14] blk-mq: add helpers for treating kdump kernel, Ming Lei
- [PATCH V3 10/14] scsi: pm8001: take blk_mq_max_nr_hw_queues() into account for calculating io vectors, Ming Lei
- [PATCH V3 02/14] nvme-pci: use blk_mq_max_nr_hw_queues() to calculate io queues, Ming Lei
- [PATCH V3 12/14] scsi: ufs: limit max allowed nr_hw_queues, Ming Lei
- [PATCH V3 09/14] scsi: mpt3sas: take blk_mq_max_nr_hw_queues() into account for calculating io vectors, Ming Lei
- [PATCH V3 06/14] scsi: lpfc: use blk_mq_max_nr_hw_queues() to calculate io vectors, Ming Lei
- [PATCH V3 08/14] scsi: megaraid: take blk_mq_max_nr_hw_queues() into account for calculating io vectors, Ming Lei
- [PATCH V3 07/14] scsi: mpi3mr: take blk_mq_max_nr_hw_queues() into account for calculating io vectors, Ming Lei
- [PATCH V3 04/14] virtio-blk: limit max allowed submit queues, Ming Lei
- [PATCH V3 05/14] scsi: core: add helper of scsi_max_nr_hw_queues(), Ming Lei
- [PATCH V3 13/14] scsi: storvsc: limit max allowed nr_hw_queues, Ming Lei
Re: ubiblock: null pointer dereference using scatterlist in work_queue,
Richard Weinberger
remove bdev->bd_super,
Christoph Hellwig
[PATCH for 6.5 regression] PM: hibernate: fix resume_store() return value when hibernation not available,
Vlastimil Babka
[syzbot] Monthly block report (Aug 2023), syzbot
[PATCH v1] drivers: block: Updates return value check,
Atul Kumar Pant
[PATCH] zram: take device and not only bvec offset into account,
Christoph Hellwig
[PATCH v6 0/7] Improve performance for zoned UFS devices,
Bart Van Assche
[RFC PATCH 00/18] ceph, rbd: Collapse all the I/O types down to something iov_iter-based,
David Howells
- [RFC PATCH 01/18] iov_iter: Add function to see if buffer is all zeros, David Howells
- [RFC PATCH 02/18] ceph: Rename alignment to offset, David Howells
- [RFC PATCH 03/18] ceph: Add a new data container type, ceph_databuf, David Howells
- [RFC PATCH 05/18] rbd: Use ceph_databuf for rbd_obj_read_sync(), David Howells
- [RFC PATCH 04/18] ceph: Convert ceph_mds_request::r_pagelist to a databuf, David Howells
- [RFC PATCH 08/18] ceph: Remove osd_req_op_cls_response_data_pages(), David Howells
- [RFC PATCH 07/18] ceph: Unexport osd_req_op_cls_request_data_pages(), David Howells
- [RFC PATCH 09/18] ceph: Convert notify_id_pages to a ceph_databuf, David Howells
- [RFC PATCH 06/18] ceph: Change ceph_osdc_call()'s reply to a ceph_databuf, David Howells
- [RFC PATCH 10/18] rbd: Switch from using bvec_iter to iov_iter, David Howells
- [RFC PATCH 11/18] ceph: Remove bvec and bio data container types, David Howells
- [RFC PATCH 12/18] ceph: Convert some page arrays to ceph_databuf, David Howells
- [RFC PATCH 16/18] ceph: Remove CEPH_OS_DATA_TYPE_PAGES and its attendant helpers, David Howells
- [RFC PATCH 13/18] ceph: Convert users of ceph_pagelist to ceph_databuf, David Howells
- [RFC PATCH 15/18] ceph: Convert ceph_osdc_notify() reply to ceph_databuf, David Howells
- [RFC PATCH 14/18] ceph: Remove ceph_pagelist, David Howells
- [RFC PATCH 18/18] ceph: Don't use data_pages, David Howells
- [RFC PATCH 17/18] ceph: Remove CEPH_MSG_DATA_PAGES and its helpers, David Howells
- Re: [RFC PATCH 00/18] ceph, rbd: Collapse all the I/O types down to something iov_iter-based, Xiubo Li
[PATCH blktests] block/004: reset zones of TEST_DEV before fio operation,
Shin'ichiro Kawasaki
[PATCH v11 0/3] ublk: enable zoned storage support,
Andreas Hindborg (Samsung)
[PATCH -next] block: remove init_mutex in blk_iolatency_try_init,
Li Lingfeng
[PATCH] romfs: only select BUFFER_HEAD for the block based path,
Christoph Hellwig
[linux mainline/master] [6.5.0-rc4] WARNING: CPU: 23 PID: 138 at arch/powerpc/kernel/eeh_pe.c:439 eeh_pe_tree_remove+0xd0/0x250, Tasmiya Nalatwad
[PATCH] blk-iocost: fix queue stats accounting,
chengming . zhou
[linux-next] [Mellanox] [6.5.0-rc4-next-20230803] Kernel crash while installing to upstream kernel, Tasmiya Nalatwad
Re: [PATCH -next] fs/Kconfig: Fix compile error for romfs, Jens Axboe
[PATCH blktests] src/Makefile: fix static linking of miniublk,
Theodore Ts'o
[PATCH v10 0/3] ublk: enable zoned storage support,
Andreas Hindborg (Samsung)
[PATCH AUTOSEL 6.1 2/5] scsi: block: Improve checks in blk_revalidate_disk_zones(), Sasha Levin
[PATCH AUTOSEL 6.4 4/7] scsi: block: Improve checks in blk_revalidate_disk_zones(), Sasha Levin
[PATCH] block/mq-deadline: use correct way to throttling write requests,
Zhiguo Niu
[PATCH v3 0/4] multi-page bvec configuration for integrity payload,
Jinyoung Choi
Message not available
Message not available
Message not available
Re: [PATCH v3 0/4] multi-page bvec configuration for integrity payload, Martin K. Petersen
Re: [PATCH v3 0/4] multi-page bvec configuration for integrity payload, Jens Axboe
more blkdev_get and holder work,
Christoph Hellwig
- [PATCH 02/12] nilfs2: use setup_bdev_super to de-duplicate the mount code, Christoph Hellwig
- [PATCH 03/12] btrfs: always open the device read-only in btrfs_scan_one_device, Christoph Hellwig
- [PATCH 05/12] ext4: make the IS_EXT2_SB/IS_EXT3_SB checks more robust, Christoph Hellwig
- [PATCH 01/12] fs: export setup_bdev_super, Christoph Hellwig
- [PATCH 04/12] btrfs: open block devices after superblock creation, Christoph Hellwig
- [PATCH 07/12] fs: stop using get_super in fs_mark_dead, Christoph Hellwig
- [PATCH 06/12] fs: use the super_block as holder when mounting file systems, Christoph Hellwig
- [PATCH 11/12] xfs: drop s_umount over opening the log and RT devices, Christoph Hellwig
- [PATCH 08/12] fs: export fs_holder_ops, Christoph Hellwig
- [PATCH 09/12] ext4: drop s_umount over opening the log device, Christoph Hellwig
- [PATCH 10/12] ext4: use fs_holder_ops for the log device, Christoph Hellwig
- [PATCH 12/12] xfs use fs_holder_ops for the log and RT devices, Christoph Hellwig
- Re: more blkdev_get and holder work, Christian Brauner
[PATCH -next] drbd: Remove unused function declarations, Yue Haibing
Re: [PATCH V2 1/1] pmem: set QUEUE_FLAG_NOWAIT,
Christoph Hellwig
XFS metadata CRC errors on zram block device on ppc64le architecture,
Dusty Mabe
allow building a kernel without buffer_heads v3,
Christoph Hellwig
[Index of Archives]
[Linux RAID]
[Linux SCSI]
[Linux ATA RAID]
[Linux Wireless]
[Linux Bluetooth]
[Kernel Announce]
[Kernel Newbies]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]