On Mon, Nov 20, 2023 at 02:40:55PM -0800, Keith Busch wrote: > +static void bio_integrity_unmap_user(struct bio_integrity_payload *bip) > +{ > + bool dirty = bio_data_dir(bip->bip_bio) == READ; > + struct bvec_iter iter; > + struct bio_vec bv; > + > + if (bip->bip_flags & BIP_COPY_USER) { > + unsigned short nr_vecs = bip->bip_max_vcnt - 1; > + struct bio_vec *copy = bvec_virt(&bip->bip_vec[nr_vecs]); > + size_t bytes = bip->bip_iter.bi_size; > + void *buf = bvec_virt(bip->bip_vec); > + > + if (dirty) { > + struct iov_iter iter; > + > + iov_iter_bvec(&iter, ITER_DEST, copy, nr_vecs, bytes); > + WARN_ON_ONCE(copy_to_iter(buf, bytes, &iter) != bytes); > + } > + > + memcpy(bip->bip_vec, copy, nr_vecs * sizeof(*copy)); > + kfree(copy); > + kfree(buf); Nit: but I'd probably just split the user copy version into a separate helper for clarity. Nice trick with the temporary iter, we could probably use this for the data path too. > +extern int bio_integrity_map_user(struct bio *, void __user *, ssize_t, u32); Can you drop the pointless extern and just spell out the paratmeters? I know this follows the existing style, but that style is pretty horrible :)