On Wed, Nov 22, 2023 at 06:28:14PM -0500, Kent Overstreet wrote: > +#define __bio_for_each_folio(bvl, bio, iter, start) \ > + for (iter = (start); \ > + (iter).bi_size && \ > + ((bvl = bio_iter_iovec_folio((bio), (iter))), 1); \ > + bio_advance_iter_single((bio), &(iter), (bvl).fv_len)) I know your just moving this macro, but perhaps now would be a good opportunity to rename 'bvl' to 'fv' to match the callers and have a different naming convention from the bio_vec macros.