Linux API
[Prev Page][Next Page]
- [patch v23 0/4] JTAG driver introduction,
Oleksandr Shamray
- [patch v22 0/4] JTAG driver introduction,
Oleksandr Shamray
- [PATCH 0/6 v1 resend] statfs: handle mount propagation,
Christian Brauner
- [PATCH -next 0/6] rhashtable: guarantee first allocation,
Davidlohr Bueso
- [RFC PATCH 0/5] kmalloc-reclaimable caches,
Vlastimil Babka
- [RFC PATCH 2/5] mm, slab: allocate off-slab freelists as reclaimable when appropriate, Vlastimil Babka
- [RFC PATCH 5/5] mm, proc: add NR_RECLAIMABLE to /proc/meminfo, Vlastimil Babka
- [RFC PATCH 3/5] dcache: allocate external names from reclaimable kmalloc caches, Vlastimil Babka
- [RFC PATCH 1/5] mm, slab/slub: introduce kmalloc-reclaimable caches, Vlastimil Babka
- [RFC PATCH 4/5] mm: rename and change semantics of nr_indirectly_reclaimable_bytes, Vlastimil Babka
- Re: [RFC PATCH 0/5] kmalloc-reclaimable caches, Matthew Wilcox
- Re: [RFC PATCH 0/5] kmalloc-reclaimable caches, Roman Gushchin
- Re: [RFC PATCH 0/5] kmalloc-reclaimable caches, Johannes Weiner
- aio poll and a new in-kernel poll API V13,
Christoph Hellwig
- [PATCH 18/33] net/dccp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 32/33] timerfd: convert to ->poll_mask, Christoph Hellwig
- [PATCH 33/33] random: convert to ->poll_mask, Christoph Hellwig
- [PATCH 29/33] crypto: af_alg: convert to ->poll_mask, Christoph Hellwig
- [PATCH 27/33] net/iucv: convert to ->poll_mask, Christoph Hellwig
- [PATCH 31/33] eventfd: switch to ->poll_mask, Christoph Hellwig
- [PATCH 30/33] pipe: convert to ->poll_mask, Christoph Hellwig
- [PATCH 28/33] net/rxrpc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 24/33] net/caif: convert to ->poll_mask, Christoph Hellwig
- [PATCH 26/33] net/phonet: convert to ->poll_mask, Christoph Hellwig
- [PATCH 25/33] net/nfc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 23/33] net/bluetooth: convert to ->poll_mask, Christoph Hellwig
- [PATCH 21/33] net/tipc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 22/33] net/sctp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 20/33] net/vmw_vsock: convert to ->poll_mask, Christoph Hellwig
- [PATCH 17/33] net: convert datagram_poll users tp ->poll_mask, Christoph Hellwig
- [PATCH 19/33] net/atm: convert to ->poll_mask, Christoph Hellwig
- [PATCH 16/33] net/unix: convert to ->poll_mask, Christoph Hellwig
- [PATCH 14/33] net: remove sock_no_poll, Christoph Hellwig
- [PATCH 15/33] net/tcp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 11/33] aio: try to complete poll iocbs without context switch, Christoph Hellwig
- [PATCH 10/33] aio: implement IOCB_CMD_POLL, Christoph Hellwig
- [PATCH 13/33] net: add support for ->poll_mask in proto_ops, Christoph Hellwig
- [PATCH 12/33] net: refactor socket_poll, Christoph Hellwig
- [PATCH 08/33] aio: simplify KIOCB_KEY handling, Christoph Hellwig
- [PATCH 09/33] aio: simplify cancellation, Christoph Hellwig
- [PATCH 07/33] fs: introduce new ->get_poll_head and ->poll_mask methods, Christoph Hellwig
- [PATCH 05/33] fs: update documentation to mention __poll_t and match the code, Christoph Hellwig
- [PATCH 06/33] fs: add new vfs_poll and file_can_poll helpers, Christoph Hellwig
- [PATCH 04/33] fs: cleanup do_pollfd, Christoph Hellwig
- [PATCH 02/33] uapi: turn __poll_t sparse checkin on by default, Christoph Hellwig
- [PATCH 01/33] fix io_destroy()/aio_complete() race, Christoph Hellwig
- [PATCH 03/33] fs: unexport poll_schedule_timeout, Christoph Hellwig
- Re: aio poll and a new in-kernel poll API V13, Al Viro
- semantics of rhashtable and sysvipc,
Davidlohr Bueso
- [PATCH v7 0/5] AIO add per-command iopriority,
adam . manzanares
- [PATCH v6 0/5] AIO add per-command iopriority,
adam . manzanares
- aio poll and a new in-kernel poll API V12,
Christoph Hellwig
- [PATCH 03/31] fs: update documentation to mention __poll_t and match the code, Christoph Hellwig
- [PATCH 06/31] aio: simplify KIOCB_KEY handling, Christoph Hellwig
- [PATCH 13/31] net/tcp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 25/31] net/iucv: convert to ->poll_mask, Christoph Hellwig
- [PATCH 30/31] timerfd: convert to ->poll_mask, Christoph Hellwig
- [PATCH 31/31] random: convert to ->poll_mask, Christoph Hellwig
- [PATCH 29/31] eventfd: switch to ->poll_mask, Christoph Hellwig
- [PATCH 28/31] pipe: convert to ->poll_mask, Christoph Hellwig
- [PATCH 26/31] net/rxrpc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 27/31] crypto: af_alg: convert to ->poll_mask, Christoph Hellwig
- [PATCH 23/31] net/nfc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 24/31] net/phonet: convert to ->poll_mask, Christoph Hellwig
- [PATCH 22/31] net/caif: convert to ->poll_mask, Christoph Hellwig
- [PATCH 21/31] net/bluetooth: convert to ->poll_mask, Christoph Hellwig
- [PATCH 19/31] net/tipc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 20/31] net/sctp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 18/31] net/vmw_vsock: convert to ->poll_mask, Christoph Hellwig
- [PATCH 16/31] net/dccp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 17/31] net/atm: convert to ->poll_mask, Christoph Hellwig
- [PATCH 15/31] net: convert datagram_poll users tp ->poll_mask, Christoph Hellwig
- [PATCH 14/31] net/unix: convert to ->poll_mask, Christoph Hellwig
- [PATCH 11/31] net: add support for ->poll_mask in proto_ops, Christoph Hellwig
- [PATCH 12/31] net: remove sock_no_poll, Christoph Hellwig
- [PATCH 10/31] net: refactor socket_poll, Christoph Hellwig
- [PATCH 08/31] aio: implement IOCB_CMD_POLL, Christoph Hellwig
- [PATCH 09/31] aio: try to complete poll iocbs without context switch, Christoph Hellwig
- [PATCH 07/31] aio: simplify cancellation, Christoph Hellwig
- [PATCH 05/31] fs: introduce new ->get_poll_head and ->poll_mask methods, Christoph Hellwig
- [PATCH 04/31] fs: add new vfs_poll and file_can_poll helpers, Christoph Hellwig
- [PATCH 02/31] fs: cleanup do_pollfd, Christoph Hellwig
- [PATCH 01/31] fs: unexport poll_schedule_timeout, Christoph Hellwig
- Re: aio poll and a new in-kernel poll API V12, Al Viro
- [PATCH v5 0/5] AIO add per-command iopriority,
adam . manzanares
- [PATCH v4 0/3] AIO add per-command iopriority,
adam . manzanares
- [PATCHSET] workqueue: Show the latest workqueue name in /proc/PID/{comm,stat,status},
Tejun Heo
- [PATCH] proc: Don't allow empty /proc/PID/cmdline for user tasks,
Tejun Heo
- [RFC] better visibility into kworkers,
Tejun Heo
- [RFC PATCH] UAPI: Document auxvec AT_* namespace policy and note reservations,
Dave Martin
- aio poll and a new in-kernel poll API V11,
Christoph Hellwig
- [PATCH 32/32] random: convert to ->poll_mask, Christoph Hellwig
- [PATCH 31/32] timerfd: convert to ->poll_mask, Christoph Hellwig
- [PATCH 30/32] eventfd: switch to ->poll_mask, Christoph Hellwig
- [PATCH 29/32] pipe: convert to ->poll_mask, Christoph Hellwig
- [PATCH 28/32] crypto: af_alg: convert to ->poll_mask, Christoph Hellwig
- [PATCH 27/32] net/rxrpc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 25/32] net/phonet: convert to ->poll_mask, Christoph Hellwig
- [PATCH 26/32] net/iucv: convert to ->poll_mask, Christoph Hellwig
- [PATCH 24/32] net/nfc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 23/32] net/caif: convert to ->poll_mask, Christoph Hellwig
- [PATCH 22/32] net/bluetooth: convert to ->poll_mask, Christoph Hellwig
- [PATCH 21/32] net/sctp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 20/32] net/tipc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 19/32] net/vmw_vsock: convert to ->poll_mask, Christoph Hellwig
- [PATCH 18/32] net/atm: convert to ->poll_mask, Christoph Hellwig
- [PATCH 17/32] net/dccp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 16/32] net: convert datagram_poll users tp ->poll_mask, Christoph Hellwig
- [PATCH 15/32] net/unix: convert to ->poll_mask, Christoph Hellwig
- [PATCH 14/32] net/tcp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 13/32] net: remove sock_no_poll, Christoph Hellwig
- [PATCH 12/32] net: add support for ->poll_mask in proto_ops, Christoph Hellwig
- [PATCH 11/32] net: refactor socket_poll, Christoph Hellwig
- [PATCH 10/32] aio: implement IOCB_CMD_POLL, Christoph Hellwig
- [PATCH 09/32] aio: add delayed cancel support, Christoph Hellwig
- [PATCH 08/32] aio: replace kiocb_set_cancel_fn with a cancel_kiocb file operation, Christoph Hellwig
- [PATCH 07/32] aio: simplify cancellation, Christoph Hellwig
- [PATCH 06/32] aio: simplify KIOCB_KEY handling, Christoph Hellwig
- [PATCH 05/32] fs: introduce new ->get_poll_head and ->poll_mask methods, Christoph Hellwig
- [PATCH 04/32] fs: add new vfs_poll and file_can_poll helpers, Christoph Hellwig
- [PATCH 03/32] fs: update documentation to mention __poll_t and match the code, Christoph Hellwig
- [PATCH 02/32] fs: cleanup do_pollfd, Christoph Hellwig
- [PATCH 01/32] fs: unexport poll_schedule_timeout, Christoph Hellwig
- [PATCH v9 00/24] ILP32 for ARM64,
Yury Norov
- [PATCH 01/24] arm64: signal: Make parse_user_sigframe() independent of rt_sigframe layout, Yury Norov
- [PATCH 02/24] ptrace: Add compat PTRACE_{G,S}ETSIGMASK handlers, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- <Possible follow-ups>
- [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- [PATCH 06/24] thread: move thread bits accessors to separated file, Yury Norov
- [PATCH 08/24] arm64: rename COMPAT to AARCH32_EL0 in Kconfig, Yury Norov
- [PATCH 13/24] arm64: introduce binfmt_elf32.c, Yury Norov
- [PATCH 18/24] arm64: signal: share lp64 signal structures and routines to ilp32, Yury Norov
- [PATCH 24/24] arm64: ilp32: Make the Kconfig option default y, Yury Norov
- [PATCH 23/24] arm64:ilp32: add ARM64_ILP32 to Kconfig, Yury Norov
- [PATCH 22/24] arm64:ilp32: add vdso-ilp32 and use for signal return, Yury Norov
- [PATCH 21/24] arm64: ptrace: handle ptrace_request differently for aarch32 and ilp32, Yury Norov
- [PATCH 20/24] arm64: ilp32: introduce ilp32-specific sigframe and ucontext, Yury Norov
- [PATCH 19/24] arm64: signal32: move ilp32 and aarch32 common code to separated file, Yury Norov
- [PATCH 17/24] arm64: ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it, Yury Norov
- [PATCH 15/24] arm64: ilp32: introduce binfmt_ilp32.c, Yury Norov
- [PATCH 16/24] arm64: ilp32: share aarch32 syscall handlers, Yury Norov
- [PATCH 14/24] arm64: change compat_elf_hwcap and compat_elf_hwcap2 prefix to a32, Yury Norov
- [PATCH 12/24] arm64: ilp32: add is_ilp32_compat_{task,thread} and TIF_32BIT_AARCH64, Yury Norov
- [PATCH 11/24] arm64: introduce is_a32_task and is_a32_thread (for AArch32 compat), Yury Norov
- [PATCH 09/24] arm64: rename functions that reference compat term, Yury Norov
- [PATCH 10/24] arm64: uapi: set __BITS_PER_LONG correctly for ILP32 and LP64, Yury Norov
- [PATCH 07/24] arm64: ilp32: add documentation on the ILP32 ABI for ARM64, Yury Norov
- [PATCH 04/24] 32-bit userspace ABI: introduce ARCH_32BIT_OFF_T config option, Yury Norov
- [PATCH 03/24] compat ABI: use non-compat openat and open_by_handle_at variants, Yury Norov
- [PATCH 02/24] ptrace: Add compat PTRACE_{G,S}ETSIGMASK handlers, Yury Norov
- [PATCH 01/24] arm64: signal: Make parse_user_sigframe() independent of rt_sigframe layout, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Andy Lutomirski
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yuri Norov
- [PATCH] arm64: introduce AUDIT_ARCH_AARCH64ILP32 for ilp32, Yuri Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
- Re: [PATCH v9 00/24] ILP32 for ARM64, Yury Norov
[patch v21 0/4] JTAG driver introduction,
Oleksandr Shamray
[patch v20 0/4] JTAG driver introduction,
Oleksandr Shamray
aio poll and a new in-kernel poll API V10,
Christoph Hellwig
- [PATCH 01/32] fs: unexport poll_schedule_timeout, Christoph Hellwig
- [PATCH 03/32] fs: update documentation to mention __poll_t and match the code, Christoph Hellwig
- [PATCH 32/32] random: convert to ->poll_mask, Christoph Hellwig
- [PATCH 31/32] timerfd: convert to ->poll_mask, Christoph Hellwig
- [PATCH 30/32] eventfd: switch to ->poll_mask, Christoph Hellwig
- [PATCH 29/32] pipe: convert to ->poll_mask, Christoph Hellwig
- [PATCH 28/32] crypto: af_alg: convert to ->poll_mask, Christoph Hellwig
- [PATCH 27/32] net/rxrpc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 26/32] net/iucv: convert to ->poll_mask, Christoph Hellwig
- [PATCH 24/32] net/nfc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 25/32] net/phonet: convert to ->poll_mask, Christoph Hellwig
- [PATCH 22/32] net/bluetooth: convert to ->poll_mask, Christoph Hellwig
- [PATCH 23/32] net/caif: convert to ->poll_mask, Christoph Hellwig
- [PATCH 21/32] net/sctp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 20/32] net/tipc: convert to ->poll_mask, Christoph Hellwig
- [PATCH 19/32] net/vmw_vsock: convert to ->poll_mask, Christoph Hellwig
- [PATCH 16/32] net: convert datagram_poll users tp ->poll_mask, Christoph Hellwig
- [PATCH 18/32] net/atm: convert to ->poll_mask, Christoph Hellwig
- [PATCH 17/32] net/dccp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 15/32] net/unix: convert to ->poll_mask, Christoph Hellwig
- [PATCH 14/32] net/tcp: convert to ->poll_mask, Christoph Hellwig
- [PATCH 12/32] net: add support for ->poll_mask in proto_ops, Christoph Hellwig
- [PATCH 13/32] net: remove sock_no_poll, Christoph Hellwig
- [PATCH 11/32] net: refactor socket_poll, Christoph Hellwig
- [PATCH 10/32] aio: implement IOCB_CMD_POLL, Christoph Hellwig
- [PATCH 09/32] aio: add delayed cancel support, Christoph Hellwig
- [PATCH 08/32] aio: replace kiocb_set_cancel_fn with a cancel_kiocb file operation, Christoph Hellwig
- [PATCH 07/32] aio: simplify cancellation, Christoph Hellwig
- [PATCH 06/32] aio: simplify KIOCB_KEY handling, Christoph Hellwig
- [PATCH 05/32] fs: introduce new ->get_poll_head and ->poll_mask methods, Christoph Hellwig
- [PATCH 04/32] fs: add new vfs_poll and file_can_poll helpers, Christoph Hellwig
- [PATCH 02/32] fs: cleanup do_pollfd, Christoph Hellwig
[PATCH v5 3/7] proc: add helpers to set and get proc hidepid and gid mount options,
Alexey Gladkov
[PATCH v5 4/7] proc: support mounting private procfs instances inside same pid namespace, Alexey Gladkov
[PATCH v5 7/7] proc: add option to mount only a pids subset,
Alexey Gladkov
[PATCH v5 2/7] proc: move /proc/{self|thread-self} dentries to proc_fs_info, Alexey Gladkov
[PATCH v5 6/7] proc: flush task dcache entries from all procfs instances, Alexey Gladkov
[PATCH v5 5/7] proc: instantiate only pids that we can ptrace on 'limit_pids=1' mount option,
Alexey Gladkov
[PATCH v5 0/7] proc: modernize proc to support multiple private instances,
Alexey Gladkov
[PATCH v5 1/7] proc: add proc_fs_info struct to store proc information,
Alexey Gladkov
[RFC v2 0/4] vfs: detect symlink corruption with attributes,
Luis R. Rodriguez
[patch v19 0/4] JTAG driver introduction,
Oleksandr Shamray
[PATCH 0/2] hoist btrfs' label set/get ioctls to vfs, and document,
Eric Sandeen
[PATCH v3 0/3] AIO add per-command iopriority,
adam . manzanares
[PATCH 0/6 v1] statfs: handle mount propagation,
Christian Brauner
[PATCH v2 0/4] Interface for higher order contiguous allocations,
Mike Kravetz
[PATCH v2] fs: Add aio iopriority support for block_dev,
adam . manzanares
io_pgetevents & aio fsync V4,
Christoph Hellwig
Re: [PATCH 0/6 resend] statfs: handle mount propagation,
Al Viro
[PATCH] pkeys: Introduce PKEY_ALLOC_SIGNALINHERIT and change signal semantics,
Florian Weimer
[RFC PATCH] Add /proc/<pid>/numa_vamaps for numa node information,
Prakash Sangappa
[PATCH v5 00/28] FPGA Device Feature List (DFL) Device Drivers,
Wu Hao
- [PATCH v5 01/28] docs: fpga: add a document for FPGA Device Feature List (DFL) Framework Overview, Wu Hao
- [PATCH v5 02/28] fpga: mgr: add region_id to fpga_image_info, Wu Hao
- [PATCH v5 03/28] fpga: mgr: add status for fpga-manager, Wu Hao
- [PATCH v5 16/28] fpga: dfl: fme: add DFL_FPGA_GET_API_VERSION/CHECK_EXTENSION ioctls support, Wu Hao
- [PATCH v5 18/28] fpga: dfl: add fpga manager platform driver for FME, Wu Hao
- [PATCH v5 20/28] fpga: dfl: add fpga bridge platform driver for FME, Wu Hao
- [PATCH v5 27/28] fpga: dfl: afu: add afu sub feature support, Wu Hao
- [PATCH v5 28/28] fpga: dfl: afu: add DFL_FPGA_PORT_DMA_MAP/UNMAP ioctls support, Wu Hao
- [PATCH v5 26/28] fpga: dfl: afu: add DFL_FPGA_GET_API_VERSION/CHECK_EXTENSION ioctls support, Wu Hao
- [PATCH v5 21/28] fpga: dfl: add fpga region platform driver for FME, Wu Hao
- [PATCH v5 22/28] fpga: dfl: fme-region: add support for compat_id, Wu Hao
- [PATCH v5 23/28] fpga: dfl: add FPGA Accelerated Function Unit driver basic framework, Wu Hao
- [PATCH v5 25/28] fpga: dfl: afu: add header sub feature support, Wu Hao
- [PATCH v5 24/28] fpga: dfl: afu: add port ops support, Wu Hao
- [PATCH v5 17/28] fpga: dfl: fme: add partial reconfiguration sub feature support, Wu Hao
- [PATCH v5 19/28] fpga: dfl: fme-mgr: add compat_id support, Wu Hao
- [PATCH v5 15/28] fpga: dfl: fme: add header sub feature support, Wu Hao
- [PATCH v5 12/28] fpga: add FPGA DFL PCIe device driver, Wu Hao
- [PATCH v5 09/28] fpga: dfl: add feature device infrastructure, Wu Hao
[Index of Archives]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]