Linux API
[Prev Page][Next Page]
- Re: [PATCH 1/1] selftest/net: fix protocol family to work for IPv4., (continued)
- [PATCH 0/5] VFS: Introduce filesystem information query syscall,
David Howells
- [PATCH 00/33] VFS: Introduce filesystem context [ver #11],
David Howells
- [PATCH ghak90 (was ghak32) V4 00/10] audit: implement container identifier,
Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 09/10] audit: NETFILTER_PKT: record each container ID associated with a netNS, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 10/10] debug audit: read container ID of a process, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 07/10] audit: add containerid filtering, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 08/10] audit: add support for containerid to network namespaces, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 06/10] audit: add containerid support for tty_audit, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 05/10] audit: add support for non-syscall auxiliary records, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 04/10] audit: add containerid support for ptrace and signals, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 01/10] audit: collect audit task parameters, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 02/10] audit: add container id, Richard Guy Briggs
- [PATCH ghak90 (was ghak32) V4 03/10] audit: log container info of syscalls, Richard Guy Briggs
- Re: [PATCH ghak90 (was ghak32) V4 00/10] audit: implement container identifier, Guenter Roeck
- [PATCH v4 0/6] kmalloc-reclaimable caches,
Vlastimil Babka
- [PATCH v4 6/6] mm, slab: shorten kmalloc cache names for large sizes, Vlastimil Babka
- [PATCH v4 4/6] mm: rename and change semantics of nr_indirectly_reclaimable_bytes, Vlastimil Babka
- [PATCH v4 1/6] mm, slab: combine kmalloc_caches and kmalloc_dma_caches, Vlastimil Babka
- [PATCH v4 3/6] dcache: allocate external names from reclaimable kmalloc caches, Vlastimil Babka
- [PATCH v4 5/6] mm, proc: add KReclaimable to /proc/meminfo, Vlastimil Babka
- [PATCH v4 2/6] mm, slab/slub: introduce kmalloc-reclaimable caches, Vlastimil Babka
- [PATCH] prctl: add PR_[GS]ET_KILLABLE,
Jürg Billeter
- [PATCH 00/38] VFS: Introduce filesystem context [ver #10],
David Howells
- [PATCH 01/38] vfs: syscall: Add open_tree(2) to reference or clone a mount [ver #10], David Howells
- [PATCH 29/38] vfs: syscall: Add fsconfig() for configuring and managing a context [ver #10], David Howells
- [PATCH 30/38] vfs: syscall: Add fsmount() to create a mount for a superblock [ver #10], David Howells
- [PATCH 31/38] vfs: syscall: Add fspick() to select a superblock for reconfiguration [ver #10], David Howells
- [PATCH 26/38] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #10], David Howells
- [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], Andy Lutomirski
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], Jann Horn
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], Al Viro
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], Darrick J. Wong
- Re: [PATCH 34/38] vfs: syscall: Add fsinfo() to query filesystem information [ver #10], David Howells
- [PATCH 02/38] vfs: syscall: Add move_mount(2) to move mounts around [ver #10], David Howells
- [PATCH 0/4] cleanups and refactor of /proc/pid/smaps*,
Vlastimil Babka
- [PATCH v3 0/7] kmalloc-reclaimable caches,
Vlastimil Babka
- [PATCH v3 4/7] dcache: allocate external names from reclaimable kmalloc caches, Vlastimil Babka
- [PATCH v3 6/7] mm, proc: add KReclaimable to /proc/meminfo, Vlastimil Babka
- [PATCH v3 5/7] mm: rename and change semantics of nr_indirectly_reclaimable_bytes, Vlastimil Babka
- [PATCH v3 3/7] mm, slab: allocate off-slab freelists as reclaimable when appropriate, Vlastimil Babka
- [PATCH v3 2/7] mm, slab/slub: introduce kmalloc-reclaimable caches, Vlastimil Babka
- [PATCH v3 1/7] mm, slab: combine kmalloc_caches and kmalloc_dma_caches, Vlastimil Babka
- [PATCH v3 7/7] mm, slab: shorten kmalloc cache names for large sizes, Vlastimil Babka
- Re: [PATCH v3 0/7] kmalloc-reclaimable caches, Roman Gushchin
- [PATCHSET v3] block: Separating discards from writes in Linux IO statistics,
Tejun Heo
- Re: [RESEND][PATCH v4 0/2] vfs: better dedupe permission check, Mark Fasheh
- [PATCH v2 00/17] y2038: system calls, part 3,
Arnd Bergmann
- [PATCH v2 06/17] y2038: Change sys_utimensat() to use __kernel_timespec, Arnd Bergmann
- [PATCH v2 11/17] y2038: Prepare sched_rr_get_interval for __kernel_timespec, Arnd Bergmann
- [PATCH v2 15/17] y2038: signal: Change rt_sigtimedwait to use __kernel_timespec, Arnd Bergmann
- [PATCH v2 13/17] y2038: socket: Convert recvmmsg to __kernel_timespec, Arnd Bergmann
- [PATCH v2 09/17] y2038: futex: Move compat implementation into futex.c, Arnd Bergmann
- [PATCH v2 02/17] y2038: Remove newstat family from default syscall set, Arnd Bergmann
- [PATCH v2 14/17] y2038: socket: Add compat_sys_recvmmsg_time64, Arnd Bergmann
- [PATCH v2 12/17] y2038: aio: Prepare sys_io_{p,}getevents for __kernel_timespec, Arnd Bergmann
- [PATCH v2 01/17] y2038: compat: Move common compat types to asm-generic/compat.h, Arnd Bergmann
- [PATCH v2 08/17] y2038: utimes: Rework #ifdef guards for compat syscalls, Arnd Bergmann
- [PATCH v2 10/17] y2038: futex: Add support for __kernel_timespec, Arnd Bergmann
- [PATCH v2 07/17] y2038: Compile utimes()/futimesat() conditionally, Arnd Bergmann
- [PATCH v2 16/17] y2038: Make compat_sys_rt_sigtimedwait usable on 32-bit, Arnd Bergmann
- [PATCH v2 04/17] asm-generic: Remove unneeded __ARCH_WANT_SYS_LLSEEK macro, Arnd Bergmann
- [PATCH v2 05/17] asm-generic: Remove empty asm/unistd.h, Arnd Bergmann
- [PATCH v2 17/17] y2038: signal: Add compat_sys_rt_sigtimedwait_time64, Arnd Bergmann
- [PATCH v2 03/17] y2038: Remove stat64 family from default syscall set, Arnd Bergmann
- [PATCH] [RFC] y2038: globally rename compat_time to old_time32,
Arnd Bergmann
- [patch v27 0/4] JTAG driver introduction,
Oleksandr Shamray
- [PATCH 25/32] vfs: syscall: Add fsmount() to create a mount for a superblock [ver #9], David Howells
- [PATCH 31/32] vfs: syscall: Add fsinfo() to query filesystem information [ver #9],
David Howells
[PATCH 26/32] vfs: syscall: Add fspick() to select a superblock for reconfiguration [ver #9], David Howells
[PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9],
David Howells
Re: [PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9], Andy Lutomirski
Re: [PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9], David Howells
Re: [PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9], Jonathan Corbet
Re: [PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9], David Howells
Re: [PATCH 24/32] vfs: syscall: Add fsopen() to prepare for superblock creation [ver #9], Greg KH
[PATCH 02/32] vfs: syscall: Add move_mount(2) to move mounts around [ver #9], David Howells
[PATCH 01/32] vfs: syscall: Add open_tree(2) to reference or clone a mount [ver #9],
David Howells
[PATCH 01/32] vfs: syscall: Add open_tree(2) to reference or clone a mount,
David Howells
[RFC PATCH v2 00/27] Control Flow Enforcement (CET),
Yu-cheng Yu
- [RFC PATCH v2 01/27] x86/cpufeatures: Add CPUIDs for Control-flow Enforcement Technology (CET), Yu-cheng Yu
- [RFC PATCH v2 22/27] x86/cet/ibt: User-mode indirect branch tracking support, Yu-cheng Yu
- [RFC PATCH v2 25/27] x86/cet: Add PTRACE interface for CET, Yu-cheng Yu
- [RFC PATCH v2 27/27] x86/cet: Add arch_prctl functions for CET, Yu-cheng Yu
- [RFC PATCH v2 26/27] x86/cet/shstk: Handle thread shadow stack, Yu-cheng Yu
- [RFC PATCH v2 24/27] x86: Insert endbr32/endbr64 to vDSO, Yu-cheng Yu
- [RFC PATCH v2 23/27] mm/mmap: Add IBT bitmap size to address space limit check, Yu-cheng Yu
- [RFC PATCH v2 18/27] x86/cet/shstk: Introduce WRUSS instruction, Yu-cheng Yu
- [RFC PATCH v2 20/27] x86/cet/shstk: ELF header parsing of CET, Yu-cheng Yu
- [RFC PATCH v2 21/27] x86/cet/ibt: Add Kconfig option for user-mode Indirect Branch Tracking, Yu-cheng Yu
- [RFC PATCH v2 19/27] x86/cet/shstk: Signal handling for shadow stack, Yu-cheng Yu
- [RFC PATCH v2 08/27] mm: Introduce VM_SHSTK for shadow stack memory, Yu-cheng Yu
- [RFC PATCH v2 17/27] x86/cet/shstk: User-mode shadow stack support, Yu-cheng Yu
- [RFC PATCH v2 11/27] x86/mm: Modify ptep_set_wrprotect and pmdp_set_wrprotect for _PAGE_DIRTY_SW, Yu-cheng Yu
- [RFC PATCH v2 16/27] mm: Modify can_follow_write_pte/pmd for shadow stack, Yu-cheng Yu
- [RFC PATCH v2 14/27] mm: Handle THP/HugeTLB shadow stack page fault, Yu-cheng Yu
- [RFC PATCH v2 13/27] mm: Handle shadow stack page fault, Yu-cheng Yu
- [RFC PATCH v2 12/27] x86/mm: Shadow stack page fault error checking, Yu-cheng Yu
- [RFC PATCH v2 15/27] mm/mprotect: Prevent mprotect from changing shadow stack, Yu-cheng Yu
- [RFC PATCH v2 07/27] x86/cet/shstk: Add Kconfig option for user-mode shadow stack, Yu-cheng Yu
- [RFC PATCH v2 02/27] x86/fpu/xstate: Change some names to separate XSAVES system and user states, Yu-cheng Yu
- [RFC PATCH v2 05/27] Documentation/x86: Add CET description, Yu-cheng Yu
- [RFC PATCH v2 06/27] x86/cet: Control protection exception handler, Yu-cheng Yu
- [RFC PATCH v2 10/27] x86/mm: Introduce _PAGE_DIRTY_SW, Yu-cheng Yu
- [RFC PATCH v2 03/27] x86/fpu/xstate: Enable XSAVES system states, Yu-cheng Yu
- [RFC PATCH v2 09/27] x86/mm: Change _PAGE_DIRTY to _PAGE_DIRTY_HW, Yu-cheng Yu
- [RFC PATCH v2 04/27] x86/fpu/xstate: Add XSAVES system states for shadow stack, Yu-cheng Yu
[PATCH v2 for 4.18 0/6] Restartable Sequences updates,
Mathieu Desnoyers
[PATCH for 4.18 0/6] Restartable Sequences updates,
Mathieu Desnoyers
- [PATCH for 4.18 2/6] rseq: use get_user/put_user rather than __get_user/__put_user, Mathieu Desnoyers
- [PATCH for 4.18 3/6] rseq: uapi: update uapi comments, Mathieu Desnoyers
- [PATCH for 4.18 6/6] rseq/selftests: cleanup: update comment above rseq_prepare_unload, Mathieu Desnoyers
- [PATCH for 4.18 1/6] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- [PATCH for 4.18 4/6] rseq: uapi: declare rseq_cs field as union, update includes, Mathieu Desnoyers
- [PATCH for 4.18 5/6] rseq: remove unused types_32_64.h uapi header, Mathieu Desnoyers
- Re: [PATCH for 4.18 0/6] Restartable Sequences updates, Linus Torvalds
- Re: [PATCH for 4.18 0/6] Restartable Sequences updates, Mathieu Desnoyers
Re: [PATCH] mtdchar: fix overflows in adjustment of `count`,
Jann Horn
[PATCH v3 0/7] Introduce struct __kernel_timex,
Deepa Dinamani
[PATCH v2 0/7] Introduce struct __kernel_timex,
Deepa Dinamani
[RFC PATCH for 4.18 0/5] Restartable Sequences updates,
Mathieu Desnoyers
Review request for glibc system call wrapper for statx, Florian Weimer
[PATCH 0/6] Introduce struct __kernel_timex,
Deepa Dinamani
[RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs,
Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Andy Lutomirski
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Andy Lutomirski
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Heiko Carstens
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Heiko Carstens
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Heiko Carstens
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Andi Kleen
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Andy Lutomirski
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Mathieu Desnoyers
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Peter Zijlstra
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Linus Torvalds
- Re: [RFC PATCH for 4.18] rseq: use __u64 for rseq_cs fields, validate user inputs, Christopher Lameter
[RFC PATCH for 4.18 1/2] rseq: use __u64 for rseq_cs fields, validate abort_ip < TASK_SIZE,
Mathieu Desnoyers
Re: [PATCH] Add renameat2 function [BZ #17662],
Yury Norov
[REGRESSION] "Locked" and "Pss" in /proc/*/smaps are the same,
Thomas Lindroth
[PATCH v7 00/29] FPGA Device Feature List (DFL) Device Drivers,
Wu Hao
- [PATCH v7 01/29] docs: fpga: add a document for FPGA Device Feature List (DFL) Framework Overview, Wu Hao
- [PATCH v7 06/29] fpga: add device feature list support, Wu Hao
- [PATCH v7 11/29] fpga: dfl: add dfl_fpga_check_port_id function., Wu Hao
- [PATCH v7 12/29] fpga: add FPGA DFL PCIe device driver, Wu Hao
- [PATCH v7 14/29] fpga: dfl: add FPGA Management Engine driver basic framework, Wu Hao
- [PATCH v7 28/29] fpga: dfl: afu: add DFL_FPGA_PORT_DMA_MAP/UNMAP ioctls support, Wu Hao
- [PATCH v7 29/29] MAINTAINERS: add entry for FPGA DFL drivers, Wu Hao
- [PATCH v7 27/29] fpga: dfl: afu: add afu sub feature support, Wu Hao
- [PATCH v7 26/29] fpga: dfl: afu: add DFL_FPGA_GET_API_VERSION/CHECK_EXTENSION ioctls support, Wu Hao
- [PATCH v7 23/29] fpga: dfl: add FPGA Accelerated Function Unit driver basic framework, Wu Hao
- [PATCH v7 25/29] fpga: dfl: afu: add header sub feature support, Wu Hao
- [PATCH v7 24/29] fpga: dfl: afu: add port ops support, Wu Hao
- [PATCH v7 22/29] fpga: dfl: fme-region: add support for compat_id, Wu Hao
- [PATCH v7 21/29] fpga: dfl: add fpga region platform driver for FME, Wu Hao
- [PATCH v7 20/29] fpga: dfl: add fpga bridge platform driver for FME, Wu Hao
- [PATCH v7 19/29] fpga: dfl: fme-mgr: add compat_id support, Wu Hao
- [PATCH v7 18/29] fpga: dfl: add fpga manager platform driver for FME, Wu Hao
- [PATCH v7 16/29] fpga: dfl: fme: add DFL_FPGA_GET_API_VERSION/CHECK_EXTENSION ioctls support, Wu Hao
- [PATCH v7 15/29] fpga: dfl: fme: add header sub feature support, Wu Hao
- [PATCH v7 17/29] fpga: dfl: fme: add partial reconfiguration sub feature support, Wu Hao
- [PATCH v7 13/29] fpga: dfl-pci: add enumeration for feature devices, Wu Hao
- [PATCH v7 08/29] fpga: dfl: add dfl_fpga_cdev_find_port, Wu Hao
- [PATCH v7 10/29] fpga: dfl: add dfl_fpga_port_ops support., Wu Hao
- [PATCH v7 09/29] fpga: dfl: add feature device infrastructure, Wu Hao
- [PATCH v7 07/29] fpga: dfl: add chardev support for feature devices, Wu Hao
- [PATCH v7 02/29] fpga: mgr: add region_id to fpga_image_info, Wu Hao
- [PATCH v7 05/29] fpga: region: add compat_id support, Wu Hao
- [PATCH v7 03/29] fpga: mgr: add status for fpga-manager, Wu Hao
- [PATCH v7 04/29] fpga: mgr: add compat_id support, Wu Hao
- Re: [PATCH v7 00/29] FPGA Device Feature List (DFL) Device Drivers, Alan Tull
- Re: [PATCH v7 00/29] FPGA Device Feature List (DFL) Device Drivers, Alan Tull
[RFC PATCH for 4.18 1/2] rseq: validate rseq_cs fields are < TASK_SIZE,
Mathieu Desnoyers
[PATCH] mm: reject MAP_SHARED_VALIDATE without new flags,
Eric Sandeen
[RFC PATCH for 4.18 1/2] compat: Introduce is_compat_frame,
Mathieu Desnoyers
Re: [PATCH 00/10] Control Flow Enforcement - Part (3),
Andy Lutomirski
[PATCH v4 0/4] seccomp trap to userspace,
Tycho Andersen
[Index of Archives]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]