Linux Filesystem Development
[Prev Page][Next Page]
- Re: [PATCH v3 01/14] xfs: only allow minlen allocations when near ENOSPC, (continued)
- [PATCH v3 02/14] xfs: always tail align maxlen allocations, John Garry
- [PATCH v3 09/14] xfs: Update xfs_setattr_size() for forcealign, John Garry
- [PATCH v3 10/14] xfs: Do not free EOF blocks for forcealign, John Garry
- [PATCH v3 04/14] xfs: make EOF allocation simpler, John Garry
- [PATCH v3 05/14] xfs: introduce forced allocation alignment, John Garry
- [PATCH v3 06/14] xfs: align args->minlen for forced allocation alignment, John Garry
- [PATCH v3 03/14] xfs: simplify extent allocation alignment, John Garry
- [PATCH v3 08/14] xfs: Update xfs_inode_alloc_unitsize() for forcealign, John Garry
- [PATCH v3 13/14] xfs: Don't revert allocated offset for forcealign, John Garry
- [PATCH v3 14/14] xfs: Enable file data forcealign feature, John Garry
- [PATCH v3 11/14] xfs: Only free full extents for forcealign, John Garry
- [PATCH v3 07/14] xfs: Introduce FORCEALIGN inode flag, John Garry
- [PATCH v3 12/14] xfs: Unmap blocks according to forcealign, John Garry
- [PATCH v10 00/40] arm64/gcs: Provide support for GCS in userspace,
Mark Brown
- [PATCH v10 01/40] arm64/mm: Restructure arch_validate_flags() for extensibility, Mark Brown
- [PATCH v10 02/40] prctl: arch-agnostic prctl for shadow stack, Mark Brown
- [PATCH v10 03/40] mman: Add map_shadow_stack() flags, Mark Brown
- [PATCH v10 04/40] arm64: Document boot requirements for Guarded Control Stacks, Mark Brown
- [PATCH v10 05/40] arm64/gcs: Document the ABI for Guarded Control Stacks, Mark Brown
- [PATCH v10 06/40] arm64/sysreg: Add definitions for architected GCS caps, Mark Brown
- [PATCH v10 07/40] arm64/gcs: Add manual encodings of GCS instructions, Mark Brown
- [PATCH v10 08/40] arm64/gcs: Provide put_user_gcs(), Mark Brown
- [PATCH v10 09/40] arm64/gcs: Provide basic EL2 setup to allow GCS usage at EL0 and EL1, Mark Brown
- [PATCH v10 10/40] arm64/cpufeature: Runtime detection of Guarded Control Stack (GCS), Mark Brown
- [PATCH v10 11/40] arm64/mm: Allocate PIE slots for EL0 guarded control stack, Mark Brown
- [PATCH v10 12/40] mm: Define VM_SHADOW_STACK for arm64 when we support GCS, Mark Brown
- [PATCH v10 13/40] arm64/mm: Map pages for guarded control stack, Mark Brown
- [PATCH v10 14/40] KVM: arm64: Manage GCS access and registers for guests, Mark Brown
- [PATCH v10 15/40] arm64/idreg: Add overrride for GCS, Mark Brown
- [PATCH v10 16/40] arm64/hwcap: Add hwcap for GCS, Mark Brown
- [PATCH v10 17/40] arm64/traps: Handle GCS exceptions, Mark Brown
- [PATCH v10 18/40] arm64/mm: Handle GCS data aborts, Mark Brown
- [PATCH v10 19/40] arm64/gcs: Context switch GCS state for EL0, Mark Brown
- [PATCH v10 20/40] arm64/gcs: Ensure that new threads have a GCS, Mark Brown
- [PATCH v10 21/40] arm64/gcs: Implement shadow stack prctl() interface, Mark Brown
- [PATCH v10 22/40] arm64/mm: Implement map_shadow_stack(), Mark Brown
- [PATCH v10 23/40] arm64/signal: Set up and restore the GCS context for signal handlers, Mark Brown
- [PATCH v10 24/40] arm64/signal: Expose GCS state in signal frames, Mark Brown
- [PATCH v10 25/40] arm64/ptrace: Expose GCS via ptrace and core files, Mark Brown
- [PATCH v10 26/40] arm64: Add Kconfig for Guarded Control Stack (GCS), Mark Brown
- [PATCH v10 27/40] kselftest/arm64: Verify the GCS hwcap, Mark Brown
- [PATCH v10 28/40] kselftest: Provide shadow stack enable helpers for arm64, Mark Brown
- [PATCH v10 29/40] selftests/clone3: Enable arm64 shadow stack testing, Mark Brown
- [PATCH v10 30/40] kselftest/arm64: Add GCS as a detected feature in the signal tests, Mark Brown
- [PATCH v10 31/40] kselftest/arm64: Add framework support for GCS to signal handling tests, Mark Brown
- [PATCH v10 32/40] kselftest/arm64: Allow signals tests to specify an expected si_code, Mark Brown
- [PATCH v10 33/40] kselftest/arm64: Always run signals tests with GCS enabled, Mark Brown
- [PATCH v10 34/40] kselftest/arm64: Add very basic GCS test program, Mark Brown
- [PATCH v10 35/40] kselftest/arm64: Add a GCS test program built with the system libc, Mark Brown
- [PATCH v10 36/40] kselftest/arm64: Add test coverage for GCS mode locking, Mark Brown
- [PATCH v10 37/40] kselftest/arm64: Add GCS signal tests, Mark Brown
- [PATCH v10 38/40] kselftest/arm64: Add a GCS stress test, Mark Brown
- [PATCH v10 39/40] kselftest/arm64: Enable GCS for the FP stress tests, Mark Brown
- [PATCH v10 40/40] KVM: selftests: arm64: Add GCS registers to get-reg-list, Mark Brown
- Re: [PATCH v10 00/40] arm64/gcs: Provide support for GCS in userspace, Anders Roxell
- Re: [PATCH v10 00/40] arm64/gcs: Provide support for GCS in userspace, Marc Zyngier
- [PATCH] kernel/fs: last check for exec credentials on NOEXEC mount,
Wojciech Gładysz
- [PATCH] Documentation: clean up warnings for multigrain timestamp docs,
Jeff Layton
- [PATCH RFC v3 0/2] fhandle: expose u64 mount id to name_to_handle_at(2),
Aleksa Sarai
- [PATCH AUTOSEL 4.19 06/14] ELF: fix kernel.randomize_va_space double read,
Sasha Levin
- [PATCH AUTOSEL 5.4 12/22] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [PATCH AUTOSEL 5.10 27/38] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [PATCH AUTOSEL 5.15 34/47] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [PATCH AUTOSEL 6.1 44/61] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [PATCH AUTOSEL 6.6 61/83] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [PATCH AUTOSEL 6.10 090/121] ELF: fix kernel.randomize_va_space double read, Sasha Levin
- [RFC PATCH] binfmt_elf: Dump smaller VMAs first in ELF cores,
Brian Mak
- fuse: slow cp performance with writeback cache enabled,
Frank Dinoff
- [PATCH v1] mm/hugetlb: remove hugetlb_follow_page_mask() leftover,
David Hildenbrand
- [ANNOUNCE] xfs-linux: for-next updated to 7bf888fa26e8, Chandan Babu R
- Re: [syzbot] [usb?] INFO: rcu detected stall in __run_timer_base,
syzbot
- [PATCH v4 bpf-next 0/3] bpf: introduce new VFS based BPF kfuncs,
Matt Bobrowski
- [PATCH] pidfd: prevent creation of pidfds for kthreads,
Christian Brauner
- [PATCH 0/6] iomap: some minor non-critical fixes and improvements when block size < folio size,
Zhang Yi
- [syzbot] [squashfs?] KMSAN: uninit-value in pick_link,
syzbot
- [PATCH] netfs: clean up after renaming FSCACHE_DEBUG config,
Lukas Bulwahn
- [RFC] why do we have lookup_fdget_rcu() and friends?,
Al Viro
- [PATCH] mm/filemap: In page fault retry path skip filemap_map_pages() if no read-ahead pages, Rong Qianfeng
- [PATCH] nsfs: fix ioctl declaration, Christian Brauner
- [PATCH] libfs: fix infinite directory reads for offset dir,
yangerkun
- [PATCH v3] exfat: check disk status during buffer write,
Dongliang Cui
- [PATCH v2 bpf-next 0/2] Add bpf_get_dentry_xattr,
Song Liu
- [no subject], Unknown
- [PATCH 6.10 765/809] netfs: Fix writeback that needs to go to both server and cache, Greg Kroah-Hartman
- [PATCH] fuse: fs-verity: aoid out-of-range comparison,
Arnd Bergmann
- [PATCH v4] proc: add config & param to block forcing mem writes,
Adrian Ratiu
- [PATCH AUTOSEL 6.6 7/7] vfs: Fix potential circular locking through setxattr() and removexattr(), Sasha Levin
- [PATCH AUTOSEL 6.10 7/7] vfs: Fix potential circular locking through setxattr() and removexattr(), Sasha Levin
- [PATCH] fs/aio: Fix __percpu annotation of *cpu pointer in struct kioctx,
Uros Bizjak
- Re: [PATCH v2] char: misc: add missing #ifdef CONFIG_PROC_FS, Arnd Bergmann
- [PATCH v1] mount: handle OOM on mnt_warn_timestamp_expiry,
Olaf Hering
- [RFC PATCH 17/18] mm: convert vmf.prealloc_pte to struct ptdesc pointer, alexs
- [RFC PATCH 16/18] mm/pgtable: pass ptdesc to pmd_install, alexs
- [RFC PATCH 14/18] mm/pgtable: use ptdesc in pgtable_trans_huge_deposit, alexs
- [RFC PATCH 10/18] mm/pgtable: pass ptdesc to pte_free(), alexs
- [RFC PATCH 09/18] mm/pgtable: fully use ptdesc in pte_alloc_one series functions, alexs
- [RFC PATCH 03/18] fs/dax: use ptdesc in dax_pmd_load_hole, alexs
- Forcing vmscan to drop more (related) pages?,
Qu Wenruo
- [PATCHSET][RFC] struct fd and memory safety,
Al Viro
- [PATCH 01/39] memcg_write_event_control(): fix a user-triggerable oops, viro
- [PATCH 02/39] introduce fd_file(), convert all accessors to it., viro
- [PATCH 03/39] struct fd: representation change, viro
- [PATCH 04/39] add struct fd constructors, get rid of __to_fd(), viro
- [PATCH 05/39] regularize emptiness checks in fini_module(2) and vfs_dedupe_file_range(), viro
- [PATCH 06/39] net/socket.c: switch to CLASS(fd), viro
- [PATCH 07/39] introduce struct fderr, convert overlayfs uses to that, viro
- [PATCH 08/39] experimental: convert fs/overlayfs/file.c to CLASS(...), viro
- [PATCH 09/39] timerfd: switch to CLASS(fd, ...), viro
- [PATCH 10/39] get rid of perf_fget_light(), convert kernel/events/core.c to CLASS(fd), viro
- [PATCH 11/39] switch netlink_getsockbyfilp() to taking descriptor, viro
- [PATCH 12/39] do_mq_notify(): saner skb freeing on failures, viro
- [PATCH 13/39] do_mq_notify(): switch to CLASS(fd, ...), viro
- [PATCH 14/39] simplify xfs_find_handle() a bit, viro
- [PATCH 15/39] convert vmsplice() to CLASS(fd, ...), viro
- [PATCH 16/39] convert __bpf_prog_get() to CLASS(fd, ...), viro
- [PATCH 17/39] bpf: resolve_pseudo_ldimm64(): take handling of a single ldimm64 insn into helper, viro
- [PATCH 18/39] bpf maps: switch to CLASS(fd, ...), viro
- [PATCH 19/39] fdget_raw() users: switch to CLASS(fd_raw, ...), viro
- [PATCH 20/39] introduce "fd_pos" class, convert fdget_pos() users to it., viro
- [PATCH 21/39] o2hb_region_dev_store(): avoid goto around fdget()/fdput(), viro
- [PATCH 22/39] privcmd_ioeventfd_assign(): don't open-code eventfd_ctx_fdget(), viro
- [PATCH 23/39] fdget(), trivial conversions, viro
- [PATCH 24/39] fdget(), more trivial conversions, viro
- [PATCH 25/39] convert do_preadv()/do_pwritev(), viro
- [PATCH 26/39] convert cachestat(2), viro
- [PATCH 27/39] switch spufs_calls_{get,put}() to CLASS() use, viro
- [PATCH 28/39] convert spu_run(2), viro
- [PATCH 29/39] convert media_request_get_by_fd(), viro
- [PATCH 30/39] convert coda_parse_fd(), viro
- [PATCH 31/39] convert cifs_ioctl_copychunk(), viro
- [PATCH 32/39] convert vfs_dedupe_file_range()., viro
- [PATCH 33/39] convert do_select(), viro
- [PATCH 34/39] do_pollfd(): convert to CLASS(fd), viro
- [PATCH 35/39] convert bpf_token_create(), viro
- [PATCH 36/39] assorted variants of irqfd setup: convert to CLASS(fd), viro
- [PATCH 37/39] memcg_write_event_control(): switch to CLASS(fd), viro
- [PATCH 38/39] css_set_fork(): switch to CLASS(fd_raw, ...), viro
- [PATCH 39/39] deal with the last remaing boolean uses of fd_file(), viro
- Re: [PATCH 01/39] memcg_write_event_control(): fix a user-triggerable oops, Michal Hocko
- Re: [PATCHSET][RFC] struct fd and memory safety, Al Viro
- Re: [PATCHSET][RFC] struct fd and memory safety, Josef Bacik
- Re: [PATCHSET][RFC] struct fd and memory safety, Al Viro
- Re: [PATCHSET][RFC] struct fd and memory safety, Jason Gunthorpe
- Re: [PATCHSET][RFC] struct fd and memory safety, Christian Brauner
- [PATCHSET v3] struct fd and memory safety, Al Viro
- [PATCH v3 01/28] net/socket.c: switch to CLASS(fd), Al Viro
- [PATCH v3 07/28] do_mq_notify(): switch to CLASS(fd), Al Viro
- [PATCH v3 05/28] switch netlink_getsockbyfilp() to taking descriptor, Al Viro
- [PATCH v3 12/28] o2hb_region_dev_store(): avoid goto around fdget()/fdput(), Al Viro
- [PATCH v3 09/28] convert vmsplice() to CLASS(fd), Al Viro
- [PATCH v3 11/28] introduce "fd_pos" class, convert fdget_pos() users to it., Al Viro
- [PATCH v3 08/28] simplify xfs_find_handle() a bit, Al Viro
- [PATCH v3 13/28] privcmd_ioeventfd_assign(): don't open-code eventfd_ctx_fdget(), Al Viro
- [PATCH v3 17/28] convert cachestat(2), Al Viro
- [PATCH v3 10/28] fdget_raw() users: switch to CLASS(fd_raw), Al Viro
- [PATCH v3 20/28] convert media_request_get_by_fd(), Al Viro
- [PATCH v3 19/28] convert spu_run(2), Al Viro
- [PATCH v3 21/28] convert cifs_ioctl_copychunk(), Al Viro
- [PATCH v3 22/28] convert vfs_dedupe_file_range()., Al Viro
- [PATCH v3 24/28] do_pollfd(): convert to CLASS(fd), Al Viro
- [PATCH v3 15/28] fdget(), more trivial conversions, Al Viro
- [PATCH v3 26/28] memcg_write_event_control(): switch to CLASS(fd), Al Viro
- [PATCH v3 18/28] switch spufs_calls_{get,put}() to CLASS() use, Al Viro
- [PATCH v3 14/28] fdget(), trivial conversions, Al Viro
- [PATCH v3 23/28] convert do_select(), Al Viro
- [PATCH v3 28/28] deal with the last remaing boolean uses of fd_file(), Al Viro
- [PATCH v3 16/28] convert do_preadv()/do_pwritev(), Al Viro
- [PATCH v3 27/28] css_set_fork(): switch to CLASS(fd_raw, ...), Al Viro
- [PATCH v3 25/28] assorted variants of irqfd setup: convert to CLASS(fd), Al Viro
- [PATCH v3 02/28] regularize emptiness checks in fini_module(2) and vfs_dedupe_file_range(), Al Viro
- [PATCH v3 04/28] get rid of perf_fget_light(), convert kernel/events/core.c to CLASS(fd), Al Viro
- [PATCH v3 03/28] timerfd: switch to CLASS(fd), Al Viro
- [PATCH v3 06/28] do_mq_notify(): saner skb freeing on failures, Al Viro
- Re: [PATCH v3 01/28] net/socket.c: switch to CLASS(fd), Simon Horman
- Are jump labels broken on 6.11-rc1?,
Darrick J. Wong
- [PATCH v2 0/2] fuse: add timeout option for requests,
Joanne Koong
- [PATCH] filelock: fix name of file_lease slab cache,
Omar Sandoval
- [PATCH] quotaio_xfs: Fix memory leak,
Pavel Reichl
- [PATCH 0/5] sysctl: prepare sysctl core for const struct ctl_table,
Thomas Weißschuh
- [PATCH] fs/procfs: remove build ID-related code duplication in PROCMAP_QUERY, Andrii Nakryiko
- [PATCH 00/24] netfs: Read/write improvements,
David Howells
- [PATCH 01/24] fs/netfs/fscache_cookie: add missing "n_accesses" check, David Howells
- [PATCH 02/24] cachefiles: Fix non-taking of sb_writers around set/removexattr, David Howells
- [PATCH 03/24] netfs: Adjust labels in /proc/fs/netfs/stats, David Howells
- [PATCH 04/24] netfs: Record contention stats for writeback lock, David Howells
- [PATCH 05/24] netfs: Reduce number of conditional branches in netfs_perform_write(), David Howells
- [PATCH 06/24] netfs, cifs: Move CIFS_INO_MODIFIED_ATTR to netfs_inode, David Howells
- [PATCH 07/24] netfs: Move max_len/max_nr_segs from netfs_io_subrequest to netfs_io_stream, David Howells
- [PATCH 08/24] netfs: Reserve netfs_sreq_source 0 as unset/unknown, David Howells
- [PATCH 09/24] netfs: Remove NETFS_COPY_TO_CACHE, David Howells
- [PATCH 10/24] netfs: Set the request work function upon allocation, David Howells
- [PATCH 11/24] netfs: Use bh-disabling spinlocks for rreq->lock, David Howells
- [PATCH 12/24] mm: Define struct folio_queue and ITER_FOLIOQ to handle a sequence of folios, David Howells
- [PATCH 13/24] cifs: Provide the capability to extract from ITER_FOLIOQ to RDMA SGEs, David Howells
- [PATCH 14/24] netfs: Use new folio_queue data type and iterator instead of xarray iter, David Howells
- [PATCH 15/24] netfs: Provide an iterator-reset function, David Howells
- [PATCH 16/24] netfs: Simplify the writeback code, David Howells
- [PATCH 17/24] afs: Make read subreqs async, David Howells
- [PATCH 18/24] netfs: Speed up buffered reading, David Howells
- [PATCH 19/24] netfs: Remove fs/netfs/io.c, David Howells
- [PATCH 20/24] cachefiles, netfs: Fix write to partial block at EOF, David Howells
- [PATCH 21/24] netfs: Cancel dirty folios that have no storage destination, David Howells
- [PATCH 22/24] cifs: Use iterate_and_advance*() routines directly for hashing, David Howells
- [PATCH 23/24] cifs: Switch crypto buffer to use a folio_queue rather than an xarray, David Howells
- [PATCH 24/24] cifs: Don't support ITER_XARRAY, David Howells
- Re: (subset) [PATCH 00/24] netfs: Read/write improvements, Christian Brauner
- Re: (subset) [PATCH 00/24] netfs: Read/write improvements, Christian Brauner
- [viro-vfs:work.fd 28/39] arch/powerpc/platforms/cell/spu_syscalls.c:59:1: error: a function declaration without a prototype is deprecated in all versions of C, kernel test robot
- [viro-vfs:work.fd 28/39] include/linux/cleanup.h:111:21: error: function declaration isn't a prototype,
kernel test robot
- exfat: slow write performance,
Vincent
- [PATCH v4 0/7] Make core VMA operations internal and testable,
Lorenzo Stoakes
- [PATCH v2] fs/netfs/fscache_io: remove the obsolete "using_pgpriv2" flag,
Max Kellermann
- [PATCH] fs/netfs/fscache_io: remove the obsolete "using_pgpriv2" flag,
Max Kellermann
- [PATCH] fs/ceph/addr: pass using_pgpriv2=false to fscache_write_to_cache(),
Max Kellermann
- Testing if two open descriptors refer to the same inode,
Florian Weimer
- [PATCH resend v4 00/11] Improve the copy of task comm,
Yafang Shao
- [PATCH v4 01/11] fs/exec: Drop task_lock() inside __get_task_comm(), Yafang Shao
- [PATCH v4 02/11] auditsc: Replace memcpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 03/11] security: Replace memcpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 04/11] bpftool: Ensure task comm is always NUL-terminated, Yafang Shao
- [PATCH v4 05/11] mm/util: Fix possible race condition in kstrdup(), Yafang Shao
- [PATCH v4 06/11] mm/util: Deduplicate code in {kstrdup,kstrndup,kmemdup_nul}, Yafang Shao
- [PATCH v4 07/11] mm/kmemleak: Replace strncpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 08/11] tsacct: Replace strncpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 09/11] tracing: Replace strncpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 10/11] net: Replace strcpy() with __get_task_comm(), Yafang Shao
- [PATCH v4 11/11] drm: Replace strcpy() with __get_task_comm(), Yafang Shao
- Re: [PATCH resend v4 00/11] Improve the copy of task comm, Jani Nikula
- Re: [PATCH resend v4 00/11] Improve the copy of task comm, Andrew Morton
- [PATCH] fs/writeback: fix kernel-doc warnings,
Haifeng Xu
- Why do very few filesystems have umount helpers,
Steve French
[Index of Archives]
[Linux Ext4 Filesystem]
[Union Filesystem]
[NTFS 3]
[Ceph Users]
[AutoFS]
[Kernel Announce]
[Kernel Newbies]
[Kernel Development]
[Linux RAID]
[IETF Annouce]
[Security]
[Netfilter]
[Bugtraq]