Lib Virt
[Prev Page][Next Page]
- [libvirt PATCH] API: discourage usage of non-ListAll APIs,
Ján Tomko
- [libvirt PATCH] API: virDomainLookupByID: s/UUId/UUID/,
Ján Tomko
- [libvirt PATCH 0/4] vz: use g_new0 (glib chronicles),
Ján Tomko
- [libvirt PATCH] vmware: use g_new0 instead of VIR_ALLOC (glib chronicles),
Ján Tomko
- [libvirt PATCH 0/4] vbox: use g_new0 (glib chronicles),
Ján Tomko
- [libvirt PATCH 0/8] build: lower maximum frame size to 1792,
Ján Tomko
- [libvirt PATCH] news: move section about downscript to v6.4.0,
Ján Tomko
- [PATCH] qemu: Taint cpu host-passthrough only after migration,
Cole Robinson
- [PATCH] tests: cover disk, interface <backenddomain>,
Cole Robinson
- [PATCH 0/4] docs: formatdomain: misc fixes,
Cole Robinson
- [PATCH] docs: bhyve: style improvements,
Roman Bogorodskiy
- [PATCH 0/1] qemu: Add support for free-page-reporting,
Nico Pache
restrictions for virtiofs (related to commit: 88957116c9 for libvirt 6.9.0),
Masayoshi Mizuma
[libvirt PATCH 0/5] misc spelling errors reported by codespell,
Daniel P. Berrangé
[PATCH] docs/submitting-patches: add reference to DCO,
Mauro Matteo Cascella
[PATCH v3 0/2] block: deprecate the sheepdog driver,
Daniel P. Berrangé
[PATCH] NEWS: mention CVE-2020-25637 in v6.8.0 release notes,
Mauro Matteo Cascella
[PATCH v2 0/4] Add support for QEMU's 'fmode' and 'dmode',
Brian Turek
[libvirt PATCH] tests: fix incorrect free of GVariant in our GLib mock functions,
Pavel Hrdina
[PATCH 0/5] GDBus and memleak fixes,
Michal Privoznik
[PATCH 00/20] qemu: migration_cookie: Refactor and modernize,
Peter Krempa
- [PATCH 03/20] qemuMigrationCookieXMLParse: Check domain element count more defensively,
Peter Krempa
- [PATCH 04/20] qemuMigrationCookieXMLParse: Decrease scope of 'nodes' and use automatic freeing,
Peter Krempa
- [PATCH 01/20] qemu: migration_cookie: Extract parsing/validation of mandatory features,
Peter Krempa
- [PATCH 05/20] qemuMigrationCookieXMLParse: Remove comment mentioning that error was already set,
Peter Krempa
- [PATCH 02/20] qemuMigrationCookieXMLParse: Switch to single-purpose temporary variables,
Peter Krempa
- [PATCH 12/20] qemuMigrationCookieGraphicsSpiceAlloc: Refactor memory handling,
Peter Krempa
- [PATCH 16/20] qemuMigrationCookieNBDXMLParse: Refactor memory handling,
Peter Krempa
- [PATCH 17/20] qemuMigrationCookieCapsXMLParse: Refactor memory handling,
Peter Krempa
- [PATCH 08/20] qemuMigrationCookieNetworkXMLFormat: Refactor XML formatting,
Peter Krempa
- [PATCH 14/20] qemuMigrationCookieXMLFormat: Refactor memory handling,
Peter Krempa
- [PATCH 13/20] qemuMigrationCookieNetworkAlloc: Refactor memory handling,
Peter Krempa
- [PATCH 07/20] qemuMigrationCookieGraphicsXMLFormat: Use 'virXMLFormatElement',
Peter Krempa
- [PATCH 06/20] qemuMigrationCookieXMLParse: Remove 'error' label,
Peter Krempa
- [PATCH 11/20] qemu: migration_cookie: Register 'autoptr' functions for internal types,
Peter Krempa
- [PATCH 09/20] qemuMigrationCookieXMLFormat: Extract formatting of NBD,
Peter Krempa
- [PATCH 10/20] qemuDomainExtractTLSSubject: Refactor memory handling,
Peter Krempa
- [PATCH 20/20] qemu: migration_cookie: s/VIR_FREE/g_free/,
Peter Krempa
- [PATCH 15/20] qemuMigrationCookieNetworkXMLParse: Refactor memory handling,
Peter Krempa
- [PATCH 19/20] qemuMigrationCookieXMLParse: Avoid VIR_FREE when parsing lockstate,
Peter Krempa
- [PATCH 18/20] qemuMigrationCookieAddCaps: Use 'g_new0' instead of VIR_ALLOC,
Peter Krempa
- Re: [PATCH 00/20] qemu: migration_cookie: Refactor and modernize,
Michal Prívozník
[PATCH 0/6] virBitmapCopy: Refactor to prevent failures,
Peter Krempa
[PATCH 00/15] virbitmap: Refactor bitmap allocation,
Peter Krempa
- [PATCH 01/15] virQEMUCapsFlagsString: Remove unused function,
Peter Krempa
- [PATCH 02/15] virBitmapToString: Remove unused 'prefix' and 'trim' arguments,
Peter Krempa
- [PATCH 04/15] virBitmapToString: Properly handle empty bitmaps,
Peter Krempa
- [PATCH 09/15] virbitmaptest: Add few more cases for virBitmapToString,
Peter Krempa
- [PATCH 03/15] virBitmapToString|virBitmapNewString: Clarify semantics of the 'string',
Peter Krempa
- [PATCH 11/15] util: bitmap: Remove virBitmapNewQuiet,
Peter Krempa
- [PATCH 05/15] virbitmaptest: test13: Refactor memory cleanup,
Peter Krempa
- [PATCH 08/15] util: virbitmap: Don't forbid 0 size bitmap,
Peter Krempa
- [PATCH 07/15] virbitmaptest: Remove unnecessary error/cleanup labels,
Peter Krempa
- [PATCH 12/15] virBitmapNew: Don't force return value check,
Peter Krempa
- [PATCH 10/15] virBitmapNewQuiet: Don't fail on unlikely overflow scenario,
Peter Krempa
- [PATCH 13/15] util: bitmp: Remove virBitmapNewEmpty,
Peter Krempa
- [PATCH 06/15] virbitmaptest: Use g_auto(free) for cleanup,
Peter Krempa
- [PATCH 14/15] qemuSlirpNew: Use g_new0 to allocate the slirp object,
Peter Krempa
- [PATCH 15/15] virBitmapNew: Don't check return value,
Peter Krempa
[libvirt PATCH] build: remove old macvtap and virtualport leftovers,
Pino Toscano
[PATCH 0/8] hyperv: implement new APIs & more,
mcoleman
- [PATCH 3/8] hyperv: break out common lookups into separate functions,
mcoleman
- [PATCH 2/8] hyperv: fix nodeGetInfo failures caused by long CPU names,
mcoleman
- [PATCH 1/8] hyperv: make Msvm_ComputerSystem WQL queries locale agnostic,
mcoleman
- [PATCH 7/8] hyperv: implement connectGetVersion,
mcoleman
- [PATCH 4/8] hyperv: replace generic WMI class list helpers with a macro,
mcoleman
- [PATCH 8/8] hyperv: implement domainGetAutostart,
mcoleman
- [PATCH 6/8] hyperv: implement connectGetMaxVcpus,
mcoleman
- [PATCH 5/8] hyperv: implement connectGetCapabilities,
mcoleman
- Re: [PATCH 0/8] hyperv: implement new APIs & more,
Neal Gompa
- Re: [PATCH 0/8] hyperv: implement new APIs & more,
Pino Toscano
virsystemdtest segfault on ppc64,
Cole Robinson
[libvirt PATCH] Revert "Also look for dmi information in /sys/class",
Ján Tomko
[PATCH 1/1] vircommand.c: write child pidfile before process tuning in virExec(),
Daniel Henrique Barboza
[PATCH 0/1] Add support for QEMU's 'fmode' and 'dmode',
Brian Turek
[rust PATCH] add list_volumes function,
rodolpheche
[PATCH v2 0/4] cpu_map: Add EPYC-Rome model,
Markus Schade
[PATCH] NEWS: Mention <transient/> disk support for qemu,
Peter Krempa
Release of libvirt-6.8.0,
Jiri Denemark
[PATCH] qemuxml2xmloutdata: Make more symlinks,
Michal Privoznik
[PATCH 0/9] various build flag related fixes,
Laine Stump
- [PATCH 2/9] util: remove extraneous defined(__linux__) when checking for WITH_LIBNL,
Laine Stump
- [PATCH 6/9] build: eliminate WITH_MACVTAP flag,
Laine Stump
- [PATCH 8/9] util: provide non-netlink/libnl alternative for virNetDevGetMaster(),
Laine Stump
- [PATCH 1/9] util: remove useless check for IFLA_VF_MAX,
Laine Stump
- [PATCH 7/9] util: fix Linux build when libnl-devel isn't available,
Laine Stump
- [PATCH 3/9] build: eliminate useless WITH_VIRTUALPORT check,
Laine Stump
- [PATCH 5/9] build: simplify check for WITH_MACVTAP,
Laine Stump
- [PATCH 9/9] build: remove duplicate check for GET_VLAN_VID_CMD,
Laine Stump
- [PATCH 4/9] build: remove check for MACVLAN_MODE_PASSTHRU,
Laine Stump
- Re: [PATCH 0/9] various build flag related fixes,
Michal Prívozník
[PATCH 0/3] get rid of virDomainNetDefClear(),
Laine Stump
[libvirt PATCH 0/3] Use g_new0 more (glib chronicles),
Ján Tomko
[libvirt PATCH v3 0/8] Make unknown XML elements fail CPU comparison,
Tim Wiederhake
[PATCH] virDomainNumaFillCPUsInNode: Skip over NUMA nodes without vCPUs,
Michal Privoznik
RFE - Add support for QEMU's 9pfs's fmode/dmode options,
Brian Turek
[libvirt PATCH 0/2] use g_new0 more: libxl, locking (glib chronicles),
Ján Tomko
Renaming the 'master' branch,
Ján Tomko
[PATCH 0/6] qemu: migration: Rename and refactor migration cookie/parser formatter,
Peter Krempa
[PULL v4 09/48] cphp: remove deprecated cpu-add command(s),
Michael S. Tsirkin
[PATCH] tests: qemucapabilities: Update capabilities for qemu-5.2 dev cycle,
Peter Krempa
[libvirt PATCH] cpu_map: Add EPYC-Rome model,
Markus Schade
[libvirt PATCH 0/2] fix compat with other rst2html5 tool impl,
Daniel P. Berrangé
[libvirt PATCH 0/7] use g_new0 more: volume two (glib chronicles),
Ján Tomko
[libvirt PATCH] gitdm: add more individual contributors,
Pino Toscano
[libvirt PATCH] meson: drop HTML4 variants of rst2html,
Daniel P. Berrangé
[PATCH] meson: don't check for libutil.h except on FreeBSD,
Daniel P. Berrangé
[PATCH v2 0/5] Hypervisor CPU Baseline Cleanups and Fixes,
Collin Walling
[libvirt PATCH v4 0/6] Add support for vDPA network devices,
Jonathon Jongsma
[PATCH] rpm: Simplify qemu+kvm conditionals and eliminate duplication,
Neal Gompa
[PATCH FOR 6.8.0] libxl: Don't free def member of virDomainObj,
Jim Fehlig
[PATCH] docs: bhyve: document sound device and VNC bits,
Roman Bogorodskiy
[libvirt PATCH] news: document recent esx API implementations,
Pino Toscano
[libvirt PATCH] news: add note about new virt-ssh-helper binary,
Daniel P. Berrangé
[PATCH V4] Modify virCPUarmCompare to perform compare actions,
Zhenyu Zheng
[PATCH 0/3] logging: fix a couple of issues,
Nikolay Shirokovskiy
Entering freeze for libvirt-6.8.0,
Jiri Denemark
[PATCH] NEWS: Mention qcow2 cluster size being preserved accross snapshots and iSCSI hostdev fixes,
Peter Krempa
[libvirt PATCH 0/6] Resurrect glib-adoption.rst,
Ján Tomko
[PATCH] util: remove compile time tests for IFF_VNET_HDR/IFF_MULTI_QUEUE,
Daniel P. Berrangé
[PATCH v4 00/11] qemu: Add <transient/> disk support,
Peter Krempa
- [PATCH v4 01/11] virDomainSnapshotDiskDefFree: Export and register as autoptr func,
Peter Krempa
- [PATCH v4 02/11] qemu: prepare cleanup for <transient/> disk overlays,
Peter Krempa
- [PATCH v4 11/11] TODO: Add news entry,
Peter Krempa
- [PATCH v4 03/11] qemu: snapshot: Introduce helpers for creating overlays on <transient/> disks,
Peter Krempa
- [PATCH v4 09/11] qemu: validate: Allow <transient/> disks,
Peter Krempa
- [PATCH v4 05/11] qemu: Block disk hotplug when transient disk option is enabled,
Peter Krempa
- [PATCH v4 06/11] qemu: Block migration when transient disk option is enabled,
Peter Krempa
- [PATCH v4 07/11] qemu: hotplug: Remove overlay of <transient> disk on disk unplug,
Peter Krempa
- [PATCH v4 10/11] tests: qemuxml2argv: Fix and enable 'disk-transient' case,
Peter Krempa
- [PATCH v4 08/11] qemu: process: Handle transient disks on VM startup,
Peter Krempa
- [PATCH v4 04/11] qemu: Block blockjobs when transient disk option is enabled,
Peter Krempa
- Re: [PATCH v4 00/11] qemu: Add <transient/> disk support,
Ján Tomko
[PATCH] qemuxml2argvtest: Append newline to tested error messages,
Peter Krempa
[PATCH] virDomainNetFindIdx: add support for CCW addresses,
Cornelia Huck
[PATCH 0/2] qemuSnapshotDiskContext(Cleanup|New): fix few bugs,
Peter Krempa
[PATCH] cpu_map: Add EPYC-Rome model,
Markus Schade
[PATCH] util: stop probing for IFF_VNET_HDR,
Daniel P. Berrangé
[RFC PATCH v2] fix error message in virMigrate3 if connection is broken,
Nikolay Shirokovskiy
Help on meson build,
Wei Wang
[PATCH] the leading space in volmode check will never match the leading tab output from zfs get,
richardburakowski
[PATCH v3] util: support PCI passthrough net device stats collection,
zhenwei pi
[PATCH 0/6] qemu: snapshot: Refactors prior to introduction of <transient> disk support,
Peter Krempa
Help on Meson build Error,
Wei Wang
[PATCH] tests: Adjust libxlxml2domconfigtest to work with Xen < 4.10,
Jim Fehlig
recommendations for handling Hyper-V version number,
Matt Coleman
[PATCH v1 1/2] qemu: driver: use model name "host" for mode "host-passthrough",
Collin Walling
handling Hyper-V automatic startup values,
Matt Coleman
[libvirt PATCH 0/5] Use g_new0 more (glib chronicles),
Ján Tomko
[libvirt PATCH 0/6] conf: split some funcs out of virDomainDefParseXML,
Ján Tomko
[libvirt PATCH 00/14] Various cleanups,
Ján Tomko
- [libvirt PATCH 03/14] vbox: StartMachine: overwrite ret less often,
Ján Tomko
- [libvirt PATCH 01/14] tools: virshCheckpointListCollect: remove unused names,
Ján Tomko
- [libvirt PATCH 06/14] virsh: virshStreamSourceSkip: remove unused 'off',
Ján Tomko
- [libvirt PATCH 04/14] Remove pointless assignments,
Ján Tomko
- [libvirt PATCH 05/14] Remove pointless initializations,
Ján Tomko
- [libvirt PATCH 07/14] Do not check whether unsigned variables are negative,
Ján Tomko
- [libvirt PATCH 09/14] api: virDomainMemoryStats: use 'ret' variable,
Ján Tomko
- [libvirt PATCH 10/14] storage: createFileDir: remove useless 'err' variable,
Ján Tomko
- [libvirt PATCH 13/14] storage: storageBackendWipeLocal: reduce variable scope,
Ján Tomko
- [libvirt PATCH 02/14] vbox: remove VBoxCGlueTerm,
Ján Tomko
- [libvirt PATCH 08/14] libxl: remove unused 'bits' from struct guest_arch,
Ján Tomko
- [libvirt PATCH 12/14] vbox: reduce variable scope in vboxDumpStorageControllers,
Ján Tomko
- [libvirt PATCH 14/14] Reduce scope of some variables,
Ján Tomko
- [libvirt PATCH 11/14] storage: createFileDir: use less ternary operators,
Ján Tomko
[libvirt PATCHv3] tests: build SELinux tests (glib chronicles?),
Ján Tomko
[libvirt PATCH] util: do not unref event thread after joining it,
Ján Tomko
[libvirt PATCH] virnetdaemon: fix memory leak in virNetDaemonCallInhibit,
Pavel Hrdina
[libvirt PATCH] util/virgdbus: fix memory leak in virGDBusIsServiceInList,
Pavel Hrdina
[libvirt PATCHv2 0/2] tests: switch to g_new0 (glib chronicles),
Ján Tomko
[PATCH 00/13] virStorageSourceNew failure handling and virDomainSnapshotAlignDisks refactors,
Peter Krempa
- [PATCH 02/13] virStorageVolDefParseXML: Use g_steal_pointer,
Peter Krempa
- [PATCH 05/13] virDomainSnapshotAlignDisks: Refactor cleanup,
Peter Krempa
- [PATCH 06/13] virDomainSnapshotAlignDisks: Rename 'def' -> 'snapdef',
Peter Krempa
- [PATCH 01/13] virStorageSourceNew: Abort on failure,
Peter Krempa
- [PATCH 04/13] qemuSnapshotCreateInactiveExternal: Don't access 'idx' of snapshot,
Peter Krempa
- [PATCH 11/13] virDomainSnapshotAlignDisks: clarify handing of snapshot location,
Peter Krempa
- [PATCH 13/13] virDomainSnapshotDiskDef: Remove 'idx' field,
Peter Krempa
- [PATCH 03/13] qemuDomainBlockRebase: Replace ternary operator with if/else,
Peter Krempa
- [PATCH 10/13] virDomainSnapshotAlignDisks: remove unnecessary 'tmp' variable,
Peter Krempa
- [PATCH 07/13] virDomainSnapshotAlignDisks: Rename 'disk' -> 'snapdisk',
Peter Krempa
- [PATCH 08/13] virDomainSnapshotAlignDisks: Add 'domdef' local variable,
Peter Krempa
- [PATCH 09/13] virDomainSnapshotAlignDisks: Extract domain disk definition to a local variable,
Peter Krempa
- [PATCH 12/13] virDomainSnapshotAlignDisks: refactor extension to all disks,
Peter Krempa
[PATCH] docs: manpages: Strip table of contents from manpages,
Peter Krempa
[libvirt PATCH] gdbus: fix virGDBusCallMethodWithFD stub for non-UNIX,
Ján Tomko
[libvirt PATCHv2 0/2] esx: fix race when building tests,
Ján Tomko
[libvirt PATCH 0/3] esx: fix race when building tests,
Ján Tomko
[libvirt PATCH v2] qemu: substitute missing model name for host-passthrough,
Tim Wiederhake
[PATCH] Remove redundant check when storage pool is mounted,
Yi Li
[PATCH v2] util: support PCI passthrough net device stats collection,
zhenwei pi
[libvirt PATCH 0/4] tests: switch to g_new0 (glib chronicles),
Ján Tomko
[PATCH] apparmor: Allow /usr/libexec for libxl-save-helper and pygrub,
Jim Fehlig
[libvirt PATCH 0/5] Various small fixes,
Ján Tomko
[PATCH v2 0/2] block: deprecate the sheepdog driver,
Daniel P. Berrangé
[Index of Archives]
[Libvirt Users]
[Fedora Users]
[Red Hat Install]
[Red Hat Sound]
[Red Hat Development]
[Linux Kernel]