[libvirt PATCH 00/14] refactor qemuAgentGetInterfaces

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Recently, I have spent some time trying to figure out what this
function does. Let me share that with you before I forget.

Ján Tomko (14):
  qemu: agent: remove redundant checks
  qemu: agent: split out qemuAgentGetInterfaceOneAddress
  qemu: agent: remove impossible errors
  qemu: agent: reduce scope of addrs_count
  qemu: agent: expand addrs upfront
  qemu: agent: use g_auto for ifname
  qemu: agent: use virHashNew
  qemu: agent: simplify access to ifaces_ret
  qemu: agent: split out qemuAgentGetInterfaceAddresses
  qemu: agent: use GetArray to remove a check
  qemu: agent: use g_auto in qemuAgentGetInterfaces
  qemu: agent: remove cleanup in qemuAgentGetInterfaces
  qemuAgentGetInterfaceAddresses: turn ifname into char*
  qemu: agent: rename tmp_iface to iface_obj

 src/qemu/qemu_agent.c | 291 +++++++++++++++++++-----------------------
 1 file changed, 134 insertions(+), 157 deletions(-)

-- 
2.26.2




[Index of Archives]     [Virt Tools]     [Libvirt Users]     [Lib OS Info]     [Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Big List of Linux Books]     [Yosemite News]     [KDE Users]     [Fedora Tools]

  Powered by Linux