Linux Spice Development
[Prev Page][Next Page]
- [PATCH spice-streaming-agent 1/1] rename the virtio port to com.redhat.spice.stream.0,
Lukáš Hrázký
- [PATCH spice-server v2] stream-channel: Implements monitors_config,
Frediano Ziglio
- [PATCH spice-protocol v3 1/4] stream-device: Define an enumeration to store capabilities constants,
Frediano Ziglio
- [PATCH spice-server] spice-char: Add some documentation to SpiceCharDeviceInterface,
Frediano Ziglio
- [spice-vdagnet (linux) PATCH] x11-randr: do not assume each output has ncrtc=1,
Uri Lublin
- [PATCH spice-common 1/2] Add --enable-extra-checks option,
Frediano Ziglio
- [PATCH spice-common 0/3] Fix some possible overflows in client,
Frediano Ziglio
- [PATCH spice-server] video-stream: Improve RedUpgradeItem documentation,
Frediano Ziglio
- [spice-gtk] build: Remove SPICE_GTK_LOCALEDIR,
Christophe Fergeau
- [PATCH spice-server 1/3] ci: Add glib-networking package,
Frediano Ziglio
- [PATCH spice-server] test-listen: Fix some use after free,
Frediano Ziglio
- [spice-gtk v1 00/11] misc improvements in channel-display,
Victor Toso
- [spice-gtk v1 01/11] channel-display: remove id parameter from helper function, Victor Toso
- [spice-gtk v1 03/11] channel-display: remove unneeded function, Victor Toso
- [spice-gtk v1 02/11] channel-display: rename display_stream_destroy(), Victor Toso
- [spice-gtk v1 06/11] channel-display: add spice_frame_new() helper, Victor Toso
- [spice-gtk v1 05/11] channel-display: add spice_frame_free() helper, Victor Toso
- [spice-gtk v1 04/11] channel-display: use GHashTable to keep stream's structure, Victor Toso
- [spice-gtk v1 08/11] channel-display: add display_stream_stats_debug() helper, Victor Toso
- [spice-gtk v1 07/11] channel-display: add display_stream_stats_save() helper, Victor Toso
- [spice-gtk v1 09/11] channel-display: don't debug latency for each frame, Victor Toso
- [spice-gtk v1 10/11] channel-display-gst: summarize number of frames dropped, Victor Toso
- [spice-gtk v1 11/11] channel-display-mjpeg: remove verbose logs, Victor Toso
- Re: [spice-gtk v1 00/11] misc improvements in channel-display, Victor Toso
- [PATCH spice-server] stream-channel: Implements monitors_config,
Frediano Ziglio
- [PATCH spice-server 1/2] Change ENABLE_EXTRA_CHECKS statements to #ifdef,
Eduardo Lima (Etrunko)
- [spice-server v2 0/7] Add test-listen test case,
Christophe Fergeau
- [PATCH spice-server] red-record-qxl: fix clang warning,
Frediano Ziglio
- [RFC spice-gtk 0/1] Direct rendering,
Snir Sheriber
- [PATCH spice-server] video-stream: Document the usage of RedUpgradeItem structure,
Frediano Ziglio
- [PATCH spice-streaming-agent] RFC: Handle endian in protocol, Frediano Ziglio
- [PATCH spice-protocol 1/2] macros: Use GCC built-ins to swap bytes,
Frediano Ziglio
- [PATCH] usbredirserver : enable TCP keepalive,
zhenwei.pi
- [PATCH spice-streaming-agent 1/2] Add name to an unnamed structure,
Frediano Ziglio
- [PATCH] Use scancode instead of keycode names,
Olivier Fourdan
- [PATCH spice-server] ci: Fix compiling of some functions,
Frediano Ziglio
- [PATCH spice-server] dcc: Remove unused channel parameter,
Frediano Ziglio
- [PATCH spice-server 2/2] stream-device: Handle capabilities,
Frediano Ziglio
- [PATCH spice-server v2] stream-channel: Send the full frame in a single message,
Frediano Ziglio
- [PATCH spice-common] protocol: Add some documentation for inval_all_pixmaps message,
Frediano Ziglio
- [PATCH spice-protocol] stream-device: Force proper packing of protocol structures,
Frediano Ziglio
- [PATCH spice-server v2 0/2] Preallocate streaming channels,
Frediano Ziglio
- qdh displays,
Peter Carlson
- [PATCH spice-server] build: Rename spice-server-enums.tmpl.[ch] to spice-server-enums.[ch].tmpl,
Eduardo Lima (Etrunko)
- [spice-server 0/8] Add test-listen test case,
Christophe Fergeau
- [spice-server PATCH] stream_device_partial_read: check once if whole hdr is read,
Uri Lublin
- [spice-streaming-agent PATCH] handle_stream_error: add comment for inheriting struct,
Uri Lublin
- [PATCH spice-common] build: Remove FIXME_SERVER_SMARTCARD hack,
Eduardo Lima (Etrunko)
- [spice-gtk v1 1/3] channel-display: remove id parameter from helper function,
Victor Toso
- [spice-streaming-agent 0/6] build: Misc configure.ac improvements,
Christophe Fergeau
- [PATCH spice-streaming-agent] mjpeg-fallback: Ignore not recognized options,
Frediano Ziglio
- [PATCH vdagent v3 1/2] vdagent: add new vdagent_clipboard_*() interface,
Jakub Janků
- [PATCH vdagent 1/2] build: make GTK+ optional,
Jakub Janků
- [PATCH usbredirserver] usbredirserver : enable TCP keepalive,
zhenwei.pi
- [spice-gtk v1] Don't exceed one statement per line,
Victor Toso
- [spice-gtk v1] spice-widget: Avoid promoting signed 1 on shift,
Victor Toso
- [spice-gtk v1] channel-usbredir: avoid calling memcpy() will NULL src,
Victor Toso
- [PATCH 00/22] streaming-agent: C++ refactoring,
Christophe de Dinechin
- [PATCH 01/22] Eliminate signed/unsigned warning, Christophe de Dinechin
- [PATCH 04/22] Use RAII to cleanup stream in case of exception or return, Christophe de Dinechin
- [PATCH 06/22] Get rid of C-style memset initializations, use C++ style aggregates, Christophe de Dinechin
- [PATCH 10/22] Remove client_codecs global variable, moved inside the 'Stream' class, Christophe de Dinechin
- [PATCH 03/22] Reformat 'if' statments according to style guide, Christophe de Dinechin
- [PATCH 07/22] Since we use a namespace, simplify name of local classes, Christophe de Dinechin
- [PATCH 16/22] Move the capture loop in the ConcreteAgent, Christophe de Dinechin
- [PATCH 12/22] Add exception handling classes, Christophe de Dinechin
- [PATCH 05/22] Replace C-style initialization with shorter C++-style, Christophe de Dinechin
- [PATCH 21/22] Moving FrameLog into a separate file, Christophe de Dinechin
- [PATCH 14/22] Create classes encapsulating the X11 display cursor capture, Christophe de Dinechin
- [PATCH 20/22] Move the X11CursorUpdater and X11CursorThread classes in a separate file, Christophe de Dinechin
- [PATCH 13/22] Convert message writing from C style to C++ style, Christophe de Dinechin
- [PATCH 22/22] Move capture loop into concrete-agent.cpp, Christophe de Dinechin
- [PATCH 02/22] Reorder headers according to style guide, Christophe de Dinechin
- [PATCH 15/22] Create FrameLog class to encapsulate logging of frames, Christophe de Dinechin
- [PATCH 19/22] Put Stream and Message classes in separate files, Christophe de Dinechin
- [PATCH 09/22] Move read, write, handle and locking into the 'Stream' class, Christophe de Dinechin
- [PATCH 18/22] Convert existing std::runtime_error to the new Error classes, Christophe de Dinechin
- [PATCH 08/22] Use C++ style for cursor message initialization instead of C style, Christophe de Dinechin
- [PATCH 17/22] Catch all std::exception derivatives, Christophe de Dinechin
- [PATCH 11/22] Make streaming_requested a method in Stream, Christophe de Dinechin
- [PATCH spice-streaming-agent v5 0/2] handle error messages from the server,
Lukáš Hrázký
- [PATCH spice-streaming-agent v4 0/2] handle error messages from the server,
Lukáš Hrázký
- [PATCH spice-streaming-agent v2] Remove useless warning,
Frediano Ziglio
- [PATCH spice-server v2 0/6] stream-device tests and stability patches,
Frediano Ziglio
- [PATCH spice-server] build: Update spice-common submodule,
Frediano Ziglio
- [PATCH spice-server v3] stream-device: Create channels before first non-main channel connection, Frediano Ziglio
- [PATCH spice-streaming-agent v3 0/2] handle error messages from the server,
Lukáš Hrázký
- [PATCH spice-server v2] stream-device: Create channels before first non-main channel connection,
Frediano Ziglio
- [PATCH vdagent v2 0/1] clipboard system redesign,
Jakub Janků
- [PATCH spice-streaming-agent] Only build unit tests when running make check,
Lukáš Hrázký
- [RFC PATCH spice-streaming-agent] Remove paranoid warning,
Frediano Ziglio
- [PATCH spice-protocol] stream-device: Specify how padding shoud be inside new structures,
Frediano Ziglio
- [RFC PATCH spice-server] stream-device: Create channels before first not main connection,
Frediano Ziglio
- [PATCH spice-streaming-agent v3] log_binary is really a boolean,
Frediano Ziglio
- [RFC PATCH spice-streaming-agent 0/2] handle error messages from the server,
Lukáš Hrázký
- [PATCH spice-streaming-agent 0/1] Adding gstreamer based plugin,
Snir Sheriber
- [PATCH spice-streaming-agent] log_binary is really a boolean,
Frediano Ziglio
- [PATCH spice-streaming-agent] Allow to set plugins directory via command line,
Snir Sheriber
- [PATCH v2 spice-streaming-agent] Allow to set plugins directory via command line,
Snir Sheriber
- [PATCH spice-streaming-agent v2 0/2] handle error messages from the server,
Lukáš Hrázký
- [PATCH v2 00/24] WIP: Refactor the streaming agent towards a more standard C++ style,
Christophe de Dinechin
- [PATCH v2 01/24] Add missing <string> header, Christophe de Dinechin
- [PATCH v2 02/24] log_binary is really a boolean, Christophe de Dinechin
- [PATCH v2 04/24] Do not create std::string for constants, Christophe de Dinechin
- [PATCH v2 03/24] Eliminate signed/unsigned warning, Christophe de Dinechin
- [PATCH v2 06/24] Replace inefficient C-style initialization with C++-style, Christophe de Dinechin
- [PATCH v2 17/24] Move the capture loop in the ConcreteAgent, get rid of global agent variable, Christophe de Dinechin
- [PATCH v2 11/24] Move read, write and locking into the 'Stream' class, Christophe de Dinechin
- [PATCH v2 19/24] Make streaming_requested a method in Stream, Christophe de Dinechin
- [PATCH v2 15/24] Create FrameLog class to abstract logging of frames, Christophe de Dinechin
- [PATCH v2 22/24] Throw exception in case of write failure, Christophe de Dinechin
- [PATCH v2 12/24] Convert message writing from C style to C++ style, Christophe de Dinechin
- [PATCH v2 18/24] Catch all std::exception derivatives (including std::bad_alloc, not a std::bad_alloc), Christophe de Dinechin
- [PATCH v2 07/24] Get rid of C-style memset initializations, use C++ style aggregates, Christophe de Dinechin
- [PATCH v2 14/24] Create a class encapsulating the X11 display cursor capture, Christophe de Dinechin
- [PATCH v2 24/24] Rename 'Stream' to 'IOChannel', Christophe de Dinechin
- [PATCH v2 16/24] Remove client_codecs global variable, moved inside the 'Stream' class, Christophe de Dinechin
- [PATCH v2 21/24] Reformat 'if' statments according to style guide, Christophe de Dinechin
- [PATCH v2 13/24] Add more meaningful syslog reporting, Christophe de Dinechin
- [PATCH v2 23/24] Rename 'streamfd' variable to 'stream', no longer a file descriptor, Christophe de Dinechin
- [PATCH v2 05/24] Use RAII to cleanup stream in case of exception or return, Christophe de Dinechin
- [PATCH v2 10/24] Since we use a namespace, simplify name of local classes, Christophe de Dinechin
- [PATCH v2 09/24] Reorder headers according to style guide, Christophe de Dinechin
- [PATCH v2 08/24] Use C++ style for cursor message initialization instead of C style, Christophe de Dinechin
- [PATCH v2 20/24] Throw an exception in case we can't write a complete packet., Christophe de Dinechin
- [PATCH spice-streaming-agent v4 0/4] Handle more completely device messages,
Frediano Ziglio
- Re: aSPICE keyboard layout problems, i iordanov
- broken spice dependancy,
Bat Man
- [PATCH spice-streaming-agent v3 0/4] Handle more completely device messages,
Frediano Ziglio
[Index of Archives]
[Linux Virtualization]
[KVM]
[Linux Kernel Development]
[Computer Security]
[Linux ARM Kernel]
[Linux MIPS]
[Linux S390]
[Bugtraq]
[Share Photos]>
[Fedora ARM]
[Hot Springs Forum]