Linux Modules
[Prev Page][Next Page]
- Re: [PATCH v3] module: replace module_layout with module_memory, (continued)
- [PATCH v11 1/2] x86/module: remove unused code in __apply_relocate_add,
Song Liu
- [PATCH v2] module: replace module_layout with module_memory,
Song Liu
- [GIT PULL] modules changes for v6.2-rc6,
Luis Chamberlain
- [PATCH] module.h: Fix full name of the GPL,
Diederik de Haas
- [PATCH v10 1/2] x86/module: remove unused code in __apply_relocate_add,
Song Liu
- [PATCH v9] livepatch: Clear relocation targets on a module removal,
Song Liu
- When adding a module, what does "Exec format error" / "Skipping invalid relocation target" mean, and how to fix it?,
Chandler Sobel-Sorenson
- [PATCHv3 bpf-next 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Jiri Olsa
- [GIT PULL] modules changes for v6.2-rc4,
Luis Chamberlain
- [PATCHv2 bpf-next 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Jiri Olsa
- [PATCH v3] kmod: harden user namespaces with new kernel.ns_modules_allowed sysctl,
Vegard Nossum
- [PATCH] modpost: support arbitrary symbol length in modversion,
Gary Guo
- [PATCH 0/2] Allow passing module files to modprobe,
Gustavo Sousa
- [PATCH v3] kallsyms: Remove the performance test from kallsyms_selftest.c,
Zhen Lei
- [PATCH/RFC] module: replace module_layout with module_memory,
Song Liu
- [PATCH] test_kmod: stop kernel-doc warnings,
Randy Dunlap
- [PATCH 0/3] kallsyms: Optimize the search for module symbols by livepatch and bpf,
Zhen Lei
- [PATCH v2] kallsyms: Fix sleeping function called from invalid context when CONFIG_KALLSYMS_SELFTEST=y,
Zhen Lei
- [PATCH] module: main: remove unnecessary ‘0’ values from err,
Li kunyu
- [PATCH] kallsyms: Fix sleeping function called from invalid context when CONFIG_KALLSYMS_SELFTEST=y,
Zhen Lei
- [PATCH] kmod: configure.ac: In _Noreturn check, include <stdlib.h> for exit,
Florian Weimer
- [PATCH] kbuild: Modify default INSTALL_MOD_DIR from extra to updates,
Luis Chamberlain
- [GIT PULL] modules changes for v6.2-rc1,
Luis Chamberlain
- [PATCH 1/2] kbuild: change module.order to list *.o instead of *.ko,
Masahiro Yamada
- [PATCH] livepatch: Call klp_match_callback() in klp_find_callback() to avoid code duplication,
Zhen Lei
- [PATCH] module/decompress: Support zstd in-kernel decompression,
Stephen Boyd
- [PATCH modules-next v10 00/13] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms,
Nick Alcock
- [PATCH v10 01/13] kbuild: add modules.builtin.objs, Nick Alcock
- [PATCH v10 02/13] kbuild: bring back tristate.conf, Nick Alcock
- [PATCH v10 09/13] kallsyms: introduce sections needed to map symbols to built-in modules, Nick Alcock
- [PATCH v10 11/13] kallsyms: distinguish text symbols fully using object file names, Nick Alcock
- [PATCH v10 08/13] kbuild: make address ranges map work with IBT, Nick Alcock
- [PATCH v10 12/13] kallsyms: add /proc/kallmodsyms for text symbol disambiguation, Nick Alcock
- [PATCH v10 05/13] kbuild: remove MODULE_LICENSE/AUTHOR/DESCRIPTION in non-modules, Nick Alcock
- [PATCH v10 03/13] kbuild: add tristate checker, Nick Alcock
- [PATCH v10 04/13] kbuild: fix up substitutions in makefiles to allow for tristate checker, Nick Alcock
- [PATCH v10 13/13] perf: proof-of-concept kallmodsyms support, Nick Alcock
- [PATCH v10 07/13] kbuild: generate an address ranges map at vmlinux link time, Nick Alcock
- [PATCH v10 10/13] kallsyms: optimize .kallsyms_modules*, Nick Alcock
- [PATCH v10 06/13] build: add a simple iterator over modules.builtin.objs, Nick Alcock
- Re: [PING] [PATCH modules-next v10 00/13] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms, Nick Alcock
- Re: [PATCH modules-next v10 00/13] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms, Luis Chamberlain
- Re: [PATCH modules-next v10 00/13] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms, Josh Poimboeuf
- Re: [PATCH modules-next v10 00/13] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms, Steven Rostedt
- [PATCH v2] module: Don't wait for GOING modules,
Petr Pavlu
- [PATCH v5 1/1] modules: add modalias file to sysfs for modules.,
Allen Webb
- [PATCH v5 0/1] Fix CONFIG_USB=y && CONFIG_MODULES not set,
Allen Webb
- [PATCH v3] modules: add modalias file to sysfs for modules.,
Allen Webb
- Re: [PATCH v3] modules: add modalias file to sysfs for modules., Greg Kroah-Hartman
- Re: [PATCH v3] modules: add modalias file to sysfs for modules., Luis Chamberlain
- Re: [PATCH v3] modules: add modalias file to sysfs for modules., Allen Webb
- Re: [PATCH v3] modules: add modalias file to sysfs for modules., Greg Kroah-Hartman
- [PATCH v7 0/5] Generate modules.builtin.alias from match ids, Allen Webb
- [PATCH v7 5/5] build: Add modules.builtin.alias, Allen Webb
- [PATCH v7 4/5] file2alias.c: Implement builtin.alias generation, Allen Webb
- [PATCH v7 1/5] module.h: MODULE_DEVICE_TABLE for built-in modules, Allen Webb
- [PATCH v7 3/5] modpost: Add -b option for emitting built-in aliases, Allen Webb
- [PATCH v7 2/5] modpost: Track module name for built-in modules, Allen Webb
- [PATCH v8 0/9] Generate modules.builtin.alias from match ids, Allen Webb
- [PATCH v8 3/9] scsi/BusLogic: Always include device id table, Allen Webb
- [PATCH v8 7/9] modpost: Add -b option for emitting built-in aliases, Allen Webb
- [PATCH v8 1/9] imx: Fix typo, Allen Webb
- [PATCH v8 6/9] modpost: Track module name for built-in modules, Allen Webb
- [PATCH v8 8/9] file2alias.c: Implement builtin.alias generation, Allen Webb
- [PATCH v8 5/9] module.h: MODULE_DEVICE_TABLE for built-in modules, Allen Webb
- [PATCH v8 2/9] rockchip-mailbox: Fix typo, Allen Webb
- [PATCH v8 4/9] stmpe-spi: Fix typo, Allen Webb
- [PATCH v8 9/9] build: Add modules.builtin.alias, Allen Webb
- Re: [PATCH v8 0/9] Generate modules.builtin.alias from match ids, Luis Chamberlain
- [PATCH v9 00/10] Generate modules.builtin.alias from match ids, Allen Webb
- [PATCH v9 03/10] scsi/BusLogic: Always include device id table, Allen Webb
- [PATCH v9 01/10] imx: Fix typo, Allen Webb
- [PATCH v9 04/10] stmpe-spi: Fix typo, Allen Webb
- [PATCH v9 06/10] modpost: Track module name for built-in modules, Allen Webb
- [PATCH v9 02/10] rockchip-mailbox: Fix typo, Allen Webb
- [PATCH v9 05/10] module.h: MODULE_DEVICE_TABLE for built-in modules, Allen Webb
- [PATCH v9 08/10] file2alias.c: Implement builtin.alias generation, Allen Webb
- [PATCH v9 09/10] build: Add modules.builtin.alias, Allen Webb
- [PATCH v9 07/10] modpost: Add -b option for emitting built-in aliases, Allen Webb
- [PATCH v9 10/10] docs: Include modules.builtin.alias, Allen Webb
- [PATCH v9 10/10] Documentation: Include modules.builtin.alias, Allen Webb
- [PATCH v10 00/11] Generate modules.builtin.alias from match ids, Allen Webb
- [PATCH v10 05/11] modpost: Track module name for built-in modules, Allen Webb
- [PATCH v10 09/11] Documentation: Include modules.builtin.alias, Allen Webb
- [PATCH v10 06/11] modpost: Add -b option for emitting built-in aliases, Allen Webb
- [PATCH v10 03/11] stmpe-spi: Fix MODULE_DEVICE_TABLE entries, Allen Webb
- [PATCH v10 07/11] file2alias.c: Implement builtin.alias generation, Allen Webb
- [PATCH v10 02/11] scsi/BusLogic: Always include device id table, Allen Webb
- [PATCH v10 08/11] build: Add modules.builtin.alias, Allen Webb
- [PATCH v10 01/11] rockchip-mailbox: Remove unneeded MODULE_DEVICE_TABLE, Allen Webb
- [PATCH v10 10/11] Documentation: Update writing_usb_driver for built-in modules, Allen Webb
- [PATCH v10 04/11] module.h: MODULE_DEVICE_TABLE for built-in modules, Allen Webb
- [PATCH v10 11/11] Documentation: add USB authorization document to driver-api, Allen Webb
- [PATCH] autogen.sh: remove --with-rootprefix, it is gone since kmod-11,
Adam Gołębiowski
- [PATCH] module: Don't wait for GOING modules,
Petr Pavlu
- [PATCH v9] kallsyms: Add self-test facility,
Zhen Lei
- Re: [PATCH v9] kallsyms: Add self-test facility, Luis Chamberlain
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- Re: [PATCH v9] kallsyms: Add self-test facility, Steven Rostedt
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Leizhen (ThunderTown)
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- Re: [PATCH v9] kallsyms: Add self-test facility, Geert Uytterhoeven
- RE: [PATCH v9] kallsyms: Add self-test facility, David Laight
- Re: [PATCH v9] kallsyms: Add self-test facility, Andreas Schwab
- Patch to exposing modalias'es for built in kernel modules (USB),
Allen Webb
- [PATCH] module: Fix NULL vs IS_ERR checking for module_get_next_page,
Miaoqian Lin
- [PATCH PING v9] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms,
Nick Alcock
- [PATCH] modpost: Join broken long printed messages,
Geert Uytterhoeven
- [PATCH v8 0/9] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
- [PATCH v8 1/9] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
- [PATCH v8 3/9] kallsyms: Correctly sequence symbols when CONFIG_LTO_CLANG=y, Zhen Lei
- [PATCH v8 9/9] kallsyms: Add self-test facility, Zhen Lei
- [PATCH v8 4/9] kallsyms: Reduce the memory occupied by kallsyms_seqs_of_names[], Zhen Lei
- [PATCH v8 5/9] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
- [PATCH v8 7/9] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v8 8/9] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v8 6/9] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
- [PATCH v8 2/9] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
- Re: [PATCH v8 0/9] kallsyms: Optimizes the performance of lookup symbols, Luis Chamberlain
- [PATCH 18/30] module: Use kstrtobool() instead of strtobool(),
Christophe JAILLET
- [PATCH v5 0/2] powerpc module arch checks,
Nicholas Piggin
- [PATCH v9] kallsyms: reliable symbol->address lookup with /proc/kallmodsyms,
Nick Alcock
- semantics of --ignore-install,
Marco d'Itri
- [PATCH v7 00/11] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
- [PATCH v7 08/11] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
- [PATCH v7 01/11] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
- [PATCH v7 10/11] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v7 07/11] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
- [PATCH v7 05/11] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
- [PATCH v7 02/11] scripts/kallsyms: don't compress symbol types, Zhen Lei
- [PATCH v7 09/11] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v7 04/11] kallsyms: Add helper kallsyms_compress_symbol_name(), Zhen Lei
- Re: [PATCH v7 00/11] kallsyms: Optimizes the performance of lookup symbols, Luis Chamberlain
[PATCH v3 0/4] module: Merge same-name module load requests,
Petr Pavlu
[PATCH v1] kernel/module: allocate module vmap space after making sure the module is unique,
David Hildenbrand
Unloaded tainted modules list with tcrypt,
Elliott, Robert (Servers)
[PATCH modules-next] module: tracking: Keep a record of tainted unloaded modules only,
Aaron Tomlin
[GIT PULL] Modules updates for v6.1-rc1,
Luis Chamberlain
Re: "Unloaded tainted modules:" prints repeated wrong value, Aaron Tomlin
[PATCH] module: remove redundant module_sysfs_initialized variable,
Rasmus Villemoes
[PATCH v3 0/8] Unify <linux/export.h> and <asm/export.h>, remove EXPORT_DATA_SYMBOL(), faster TRIM_UNUSED_KSYMS,
Masahiro Yamada
[PATCH v2 0/7] Unify <linux/export.h> and <asm/export.h>, remove EXPORT_DATA_SYMBOL(), faster TRIM_UNUSED_KSYMS,
Masahiro Yamada
[PATCH v6 00/11] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
- [PATCH v6 01/11] scripts/kallsyms: rename build_initial_tok_table(), Zhen Lei
- [PATCH v6 02/11] scripts/kallsyms: don't compress symbol types, Zhen Lei
- [PATCH v6 04/11] scripts/kallsyms: generate kallsyms_best_token_table[], Zhen Lei
- [PATCH v6 06/11] kallsyms: Add helper kallsyms_lookup_clang_name(), Zhen Lei
- [PATCH v6 05/11] kallsyms: Improve the performance of kallsyms_lookup_name(), Zhen Lei
- [PATCH v6 03/11] scripts/kallsyms: remove helper sym_name() and cleanup, Zhen Lei
- [PATCH v6 07/11] kallsyms: Add helper kallsyms_on_each_match_symbol(), Zhen Lei
- [PATCH v6 08/11] livepatch: Use kallsyms_on_each_match_symbol() to improve performance, Zhen Lei
- [PATCH v6 11/11] kallsyms: Add self-test facility, Zhen Lei
- [PATCH v6 09/11] livepatch: Improve the search performance of module_kallsyms_on_each_symbol(), Zhen Lei
- [PATCH v6 10/11] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol(), Zhen Lei
[PATCH -next] module: Remove unused macros module_addr_min/max,
Chen Zhongjin
[PATCH v5 00/10] kallsyms: Optimizes the performance of lookup symbols,
Zhen Lei
[Index of Archives]
[Linux USB Devel]
[Video for Linux]
[Big List of Linux Books]
[Linux SCSI]
[Yosemite Forum]