Linux Kernel Memory Management
[Prev Page][Next Page]
- Re: [PATCH 6.10 000/809] 6.10.3-rc3 review, (continued)
Message not available
Message not available
Re: [PATCH 6.10 000/809] 6.10.3-rc3 review, Helge Deller
Re: [PATCH 6.10 000/809] 6.10.3-rc3 review, Guenter Roeck
[RFC PATCH 0/4] mm/arm64: re-enable HVO,
Yu Zhao
[PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool,
alexs
- [PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, alexs
- [PATCH v5 02/21] mm/zsmalloc: use zpdesc in trylock_zspage()/lock_zspage(), alexs
- [PATCH v5 03/21] mm/zsmalloc: convert __zs_map_object/__zs_unmap_object to use zpdesc, alexs
- [PATCH v5 04/21] mm/zsmalloc: add and use pfn/zpdesc seeking funcs, alexs
- [PATCH v5 06/21] mm/zsmalloc: convert create_page_chain() and its users to use zpdesc, alexs
- [PATCH v5 11/21] mm/zsmalloc: rename reset_page to reset_zpdesc and use zpdesc in it, alexs
- [PATCH v5 08/21] mm/zsmalloc: convert init_zspage() to use zpdesc, alexs
- [PATCH v5 13/21] mm/zsmalloc: convert location_to_obj() to take zpdesc, alexs
- [PATCH v5 12/21] mm/zsmalloc: convert __free_zspage() to use zdsesc, alexs
- [PATCH v5 14/21] mm/zsmalloc: convert migrate_zspage() to use zpdesc, alexs
- [PATCH v5 15/21] mm/zsmalloc: convert get_zspage() to take zpdesc, alexs
- [PATCH v5 05/21] mm/zsmalloc: convert obj_malloc() to use zpdesc, alexs
- [PATCH v5 01/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, alexs
- [PATCH v5 09/21] mm/zsmalloc: convert obj_to_page() and zs_free() to use zpdesc, alexs
- [PATCH v5 18/21] mm/zsmalloc: introduce __zpdesc_clear_movable, alexs
- [PATCH v5 19/21] mm/zsmalloc: introduce __zpdesc_clear/set_zsmalloc(), alexs
- [PATCH v5 10/21] mm/zsmalloc: add zpdesc_is_isolated()/zpdesc_zone() helper for zs_page_migrate(), alexs
- [PATCH v5 21/21] mm/zsmalloc: update comments for page->zpdesc changes, alexs
- [PATCH v5 16/21] mm/zsmalloc: convert SetZsPageMovable and remove unused funcs, alexs
- [PATCH v5 20/21] mm/zsmalloc: introduce zpdesc_clear_first() helper, alexs
- [PATCH v5 17/21] mm/zsmalloc: convert get/set_first_obj_offset() to take zpdesc, alexs
- [PATCH v5 07/21] mm/zsmalloc: convert obj_allocated() and related helpers to use zpdesc, alexs
- Re: [PATCH v5 00/21] mm/zsmalloc: add zpdesc memory descriptor for zswap.zpool, Andrew Morton
[PATCH] mm: attempt to batch free swap entries for zap_pte_range(),
Barry Song
[PATCH v4 1/5] memblock test: fix implicit declaration of function 'virt_to_phys',
Wei Yang
[PATCH v3 0/2] improving dynamic zswap shrinker protection scheme,
Nhat Pham
[linux-next:fs-current] BUILD SUCCESS a30bdcb59da63bfa89f6d03dbf4d17a6d747c1f0, kernel test robot
[PATCH net-next v18 06/14] page_pool: devmem support, Mina Almasry
[akpm-mm:mm-unstable 173/179] include/vdso/limits.h:16:25: warning: conversion from 'long long unsigned int' to 'phys_addr_t' {aka 'unsigned int'} changes value from '18446744073709551615' to '4294967295', kernel test robot
[linux-next:master] BUILD REGRESSION d6dbc9f56c3a70e915625b6f1887882c23dc5c91, kernel test robot
[linux-next:fs-next] BUILD SUCCESS b6b3ab6bae73b8ba1fefadea42f448f27591365b, kernel test robot
[RFC PATCH 0/3] Enable strict percpu address space checks,
Uros Bizjak
[PATCH RFC 0/4] mm: Introduce guest_memfd library,
Elliot Berman
Re: [PATCH 7/8] mm: Introduce promo_wmark_pages(),
Johannes Weiner
[PATCH 1/4] mm/mempolicy: Use folio_alloc_mpol_noprof() in alloc_pages_noprof(),
Aruna Ramakrishna
[PATCH] mm: swap: mTHP frees entries as a whole,
Zhiguo Jiang
[linux-next:master 568/3069] drivers/gpu/drm/xe/xe_migrate.c:304:52: error: result of comparison of constant 274877906944 with expression of type 'resource_size_t' (aka 'unsigned int') is always true, kernel test robot
[PATCH v3 0/2] mm: tlb swap entries batch async release,
Zhiguo Jiang
[PATCH v4 00/28] Generic `Allocator` support for Rust,
Danilo Krummrich
- [PATCH v4 01/28] rust: alloc: add `Allocator` trait, Danilo Krummrich
- [PATCH v4 02/28] rust: alloc: separate `aligned_size` from `krealloc_aligned`, Danilo Krummrich
- [PATCH v4 03/28] rust: alloc: rename `KernelAllocator` to `Kmalloc`, Danilo Krummrich
- [PATCH v4 05/28] rust: alloc: add module `allocator_test`, Danilo Krummrich
- [PATCH v4 18/28] rust: treewide: switch to the kernel `Vec` type, Danilo Krummrich
- [PATCH v4 17/28] rust: alloc: implement `collect` for `IntoIter`, Danilo Krummrich
- [PATCH v4 20/28] rust: alloc: add `Vec` to prelude, Danilo Krummrich
- [PATCH v4 19/28] rust: alloc: remove `VecExt` extension, Danilo Krummrich
- [PATCH v4 11/28] rust: alloc: remove `BoxExt` extension, Danilo Krummrich
- [PATCH v4 04/28] rust: alloc: implement `Allocator` for `Kmalloc`, Danilo Krummrich
- [PATCH v4 22/28] rust: error: use `core::alloc::LayoutError`, Danilo Krummrich
- [PATCH v4 23/28] rust: error: check for config `test` in `Error::name`, Danilo Krummrich
- [PATCH v4 14/28] rust: alloc: import kernel `Box` type in init.rs, Danilo Krummrich
- [PATCH v4 09/28] rust: alloc: implement kernel `Box`, Danilo Krummrich
- [PATCH v4 07/28] rust: alloc: implement `KVmalloc` allocator, Danilo Krummrich
- [PATCH v4 13/28] rust: alloc: import kernel `Box` type in types.rs, Danilo Krummrich
- [PATCH v4 27/28] rust: alloc: update module comment of alloc.rs, Danilo Krummrich
- [PATCH v4 06/28] rust: alloc: implement `Vmalloc` allocator, Danilo Krummrich
- [PATCH v4 21/28] rust: alloc: remove `GlobalAlloc` and `krealloc_aligned`, Danilo Krummrich
- [PATCH v4 08/28] rust: types: implement `Unique<T>`, Danilo Krummrich
[PATCH v4 12/28] rust: alloc: add `Box` to prelude, Danilo Krummrich
[PATCH v4 16/28] rust: alloc: implement `IntoIterator` for `Vec`, Danilo Krummrich
[PATCH v4 28/28] kbuild: rust: remove the `alloc` crate, Danilo Krummrich
[PATCH v4 25/28] rust: alloc: implement `Cmalloc` in module allocator_test, Danilo Krummrich
[PATCH v4 15/28] rust: alloc: implement kernel `Vec` type, Danilo Krummrich
[PATCH v4 26/28] rust: str: test: replace `alloc::format`, Danilo Krummrich
[PATCH v4 24/28] rust: alloc: implement `contains` for `Flags`, Danilo Krummrich
[PATCH v4 10/28] rust: treewide: switch to our kernel `Box` type, Danilo Krummrich
[RFC PATCH v2 0/7] synchronously scan and reclaim empty user PTE pages,
Qi Zheng
[PATCH] mm: fix (harmless) type confusion in lock_vma_under_rcu(),
Jann Horn
[PATCH] kfence: introduce burst mode,
Marco Elver
[PATCH 00/10] mm: remove vma_merge(),
Lorenzo Stoakes
- [PATCH 01/10] tools: improve vma test Makefile, Lorenzo Stoakes
- [PATCH 03/10] mm: abstract duplicated policy comparison, Lorenzo Stoakes
- [PATCH 04/10] mm: abstract parameters for vma_expand/shrink(), Lorenzo Stoakes
- [PATCH 07/10] mm: avoid using vma_merge() for new VMAs, Lorenzo Stoakes
- [PATCH 06/10] tools: add VMA merge tests, Lorenzo Stoakes
- [PATCH 02/10] mm: introduce vma_merge_struct and abstract merge parameters, Lorenzo Stoakes
- [PATCH 05/10] mm: abstract vma_merge_new_vma() to use vma_merge_struct, Lorenzo Stoakes
- [PATCH 10/10] mm: rework vm_ops->close() handling on VMA merge, Lorenzo Stoakes
- [PATCH 08/10] mm: introduce commit_merge(), abstracting merge operation, Lorenzo Stoakes
- [PATCH 09/10] mm: refactor vma_merge() into modify-only vma_merge_modified(), Lorenzo Stoakes
[linux-next:master /3069] ERROR: modpost: "tpm2_sessions_init" [drivers/char/tpm/tpm_ibmvtpm.ko] undefined!, kernel test robot
[PATCH v2 2/2] lib/htree: Modified Documentation/core-api/htree.rst, JaeJoon Jung
[PATCH v2 1/2] lib/htree: Add locking interface to new Hash Tree,
JaeJoon Jung
[GIT PULL] slab fixes for 6.11-rc2,
Vlastimil Babka
[PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem,
James Gowans
- [PATCH 02/10] guestmemfs: add inode store, files and dirs, James Gowans
- [PATCH 03/10] guestmemfs: add persistent data block allocator, James Gowans
- [PATCH 05/10] guestmemfs: add file mmap callback, James Gowans
- [PATCH 04/10] guestmemfs: support file truncation, James Gowans
- [PATCH 01/10] guestmemfs: Introduce filesystem skeleton, James Gowans
- [PATCH 06/10] kexec/kho: Add addr flag to not initialise memory, James Gowans
- [PATCH 07/10] guestmemfs: Persist filesystem metadata via KHO, James Gowans
- [PATCH 08/10] guestmemfs: Block modifications when serialised, James Gowans
- [PATCH 10/10] MAINTAINERS: Add maintainers for guestmemfs, James Gowans
- [PATCH 09/10] guestmemfs: Add documentation and usage instructions, James Gowans
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Theodore Ts'o
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Jan Kara
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, David Matlack
- Re: [PATCH 00/10] Introduce guestmemfs: persistent in-memory filesystem, Vishal Annapurve
[PATCH] vduse: avoid using __GFP_NOFAIL,
Jason Wang
[PATCH] slab: Error out on duplicate cache names when DEBUG_VM=y,
Pedro Falcato
[linus:master] [mm/slab] 2e8000b826: WARNING:at_mm/util.c:#__kvmalloc_node_noprof,
kernel test robot
[linus:master] [mseal] 8be7258aad: stress-ng.pagemove.page_remaps_per_sec -4.4% regression,
kernel test robot
[PATCH v3 0/3] mm: Introduce a new sysctl knob vm.pcp_batch_scale_max,
Yafang Shao
[PATCH v5 0/9] Improve the copy of task comm,
Yafang Shao
- [PATCH v5 3/9] security: Replace memcpy() with __get_task_comm(), Yafang Shao
- [PATCH v5 4/9] bpftool: Ensure task comm is always NUL-terminated, Yafang Shao
- [PATCH v5 5/9] mm/util: Fix possible race condition in kstrdup(), Yafang Shao
- [PATCH v5 6/9] mm/util: Deduplicate code in {kstrdup,kstrndup,kmemdup_nul}, Yafang Shao
- [PATCH v5 7/9] tracing: Replace strncpy() with __get_task_comm(), Yafang Shao
- [PATCH v5 1/9] fs/exec: Drop task_lock() inside __get_task_comm(), Yafang Shao
- [PATCH v5 8/9] net: Replace strcpy() with __get_task_comm(), Yafang Shao
- [PATCH v5 2/9] auditsc: Replace memcpy() with __get_task_comm(), Yafang Shao
- [PATCH v5 9/9] drm: Replace strcpy() with __get_task_comm(), Yafang Shao
- Re: [PATCH v5 0/9] Improve the copy of task comm, Linus Torvalds
- <Possible follow-ups>
- Re: [PATCH v5 0/9] Improve the copy of task comm, Alejandro Colomar
[PATCH] mm: kfence: print the age time for alloacted objectes to trace memleak,
Qiwu Chen
[linux-next:master 2209/2947] fs/proc/base.c:879:88: sparse: sparse: incompatible types in comparison expression (different address spaces):, kernel test robot
[PATCH RFC] mm: attempt to batch free swap entries for zap_pte_range(), Barry Song
[PATCH] mm: Only enforce minimum stack gap size if it's sensible,
David Gow
[PATCH] mm: zswap: make the lock critical section obvious in shrink_worker(),
Yosry Ahmed
[linux-next:fs-next] BUILD SUCCESS 812e4c94fe320e634d23a8c1bbc9b9d394c8d49a, kernel test robot
[linux-next:pending-fixes] BUILD SUCCESS 8f7f3d5bcf88c2269d326bd05114e3332d90e6ea, kernel test robot
[PATCH] memcg: protect concurrent access to mem_cgroup_idr,
Shakeel Butt
[no subject], Unknown
[PATCH v2] binfmt_elf: Dump smaller VMAs first in ELF cores,
Brian Mak
Re: [PATCH V2 2/3] riscv: mm: Add soft-dirty page tracking support,
kernel test robot
[PATCH v6 0/2] allow KASAN to detect UAF in SLAB_TYPESAFE_BY_RCU slabs,
Jann Horn
[linux-next:fs-current] BUILD SUCCESS 2f1187ed9a813a0e4485384ddaf87dd8bdaf052b, kernel test robot
[linux-next:master] BUILD REGRESSION f524a5e4dfb75b277c9a5ad819ca5f035f490f14, kernel test robot
[no subject], Unknown
[no subject], Unknown
[syzbot] Monthly mm report (Aug 2024), syzbot
[PATCH v1 00/11] mm: replace follow_page() by folio_walk,
David Hildenbrand
- [PATCH v1 03/11] mm/migrate: convert do_pages_stat_array() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 04/11] mm/migrate: convert add_page_for_migration() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 05/11] mm/ksm: convert get_mergeable_page() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 06/11] mm/ksm: convert scan_get_next_rmap_item() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 02/11] mm/pagewalk: introduce folio_walk_start() + folio_walk_end(), David Hildenbrand
- [PATCH v1 01/11] mm: provide vm_normal_(page|folio)_pmd() with CONFIG_PGTABLE_HAS_HUGE_LEAVES, David Hildenbrand
- [PATCH v1 07/11] mm/huge_memory: convert split_huge_pages_pid() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 10/11] mm: remove follow_page(), David Hildenbrand
- [PATCH v1 11/11] mm/ksm: convert break_ksm() from walk_page_range_vma() to folio_walk, David Hildenbrand
- [PATCH v1 08/11] s390/uv: convert gmap_destroy_page() from follow_page() to folio_walk, David Hildenbrand
- [PATCH v1 09/11] s390/mm/fault: convert do_secure_storage_access() from follow_page() to folio_walk, David Hildenbrand
- Re: [PATCH v1 00/11] mm: replace follow_page() by folio_walk, Andrew Morton
- Re: [PATCH v1 00/11] mm: replace follow_page() by folio_walk, Claudio Imbrenda
- Re: [PATCH v1 00/11] mm: replace follow_page() by folio_walk, Claudio Imbrenda
[PATCH v3 0/9] Merge arm64/riscv hugetlbfs contpte support,
Alexandre Ghiti
[linux-next:master 2441/2655] mm/util.c:670:17: sparse: sparse: cast from restricted gfp_t, kernel test robot
Re: [PATCH] KVM: x86: Use gfn_to_pfn_cache for steal_time,
David Woodhouse
[PATCH] percpu-rwsem: remove the unused parameter 'read',
Wang Long
[Index of Archives]
[Linux Kernel Development]
[Linux ARM Kernel]
[Linux MIPS]
[Linux S390]
[Bugtraq]
[Fedora ARM]