Linux Device-Mapper Development
[Prev Page][Next Page]
- Re: [lvm-devel] master - multipathd: fix fd leak when iscsi device logs in, (continued)
- [PATCH v2 0/7] crypto: add CRYPTO_ALG_ALLOCATES_MEMORY,
Eric Biggers
- [git pull] device mapper fixes for 5.8-rc5,
Mike Snitzer
- [PATCH 00/80] multipath-tools series part VI: incomplete udev initialization,
mwilck
- [PATCH 00/74] multipath-tools series part V: removed path handling,
mwilck
- [PATCH 65/74] libmultipath: add update_pathvec_from_dm(), mwilck
- [PATCH 58/74] libmultipath: verify_paths(): don't delete paths from pathvec, mwilck
- [PATCH 59/74] libmultipath: sync_paths(): handle INIT_REMOVED, mwilck
- [PATCH 55/74] libmultipath: add uninitialize_path(), mwilck
- [PATCH 56/74] multipath-tools: introduce INIT_REMOVED state, mwilck
- [PATCH 57/74] libmultipath: update_mpp_paths(): handle INIT_REMOVED, mwilck
- [PATCH 72/74] libmpathpersist: use update_pathvec_from_dm(), mwilck
- [PATCH 63/74] multipathd: deal with INIT_REMOVED during path addition, mwilck
- [PATCH 67/74] libmultipath: disassemble_map(): always search paths by dev_t, mwilck
- [PATCH 60/74] libmultipath: orphan_paths(): delete paths in INIT_REMOVED state, mwilck
- [PATCH 68/74] libmultipath: disassemble_map(): require non-NULL pathvec, mwilck
- [PATCH 54/74] libmultipath: protect use of pp->udev, mwilck
- [PATCH 74/74] libmultipath: dmparser: constify function arguments, mwilck
- [PATCH 61/74] libmultipath: adopt_paths(): skip removed paths, mwilck
- [PATCH 66/74] libmultipath: update_pathvec_from_dm: handle pp->mpp mismatch, mwilck
- [PATCH 62/74] multipathd: ev_remove_path(): use INIT_REMOVED, mwilck
- [PATCH 70/74] libmultipath: disassemble_map(): do not change pathvec and WWIDs, mwilck
- [PATCH 64/74] multipathd: check_path(): set retrigger_delay if necessary, mwilck
- [PATCH 71/74] multipath: use update_pathvec_from_dm(), mwilck
- [PATCH 69/74] libmultipath: disassemble_map(): get rid of "is_daemon" argument, mwilck
- [PATCH 73/74] libmultipath: decrease loglevel in store_path(), mwilck
- Re: [PATCH 00/74] multipath-tools series part V: removed path handling, Benjamin Marzinski
- [PATCH 00/54] multipath-tools series part IV: identify paths by dev_t,
mwilck
- [PATCH 49/54] libmultipath: get_refwwid(): get rid of "check" label, mwilck
- [PATCH 44/54] libmultipath: adopt_paths(): don't bail out on single path failure, mwilck
- [PATCH 45/54] libmultipath: path_discover(): use find_path_by_devt(), mwilck
- [PATCH 46/54] libmultipath: path_discover(): always set DI_BLACKLIST, mwilck
- [PATCH 47/54] libmultipath: get_refwwid(): use find_path_by_devt(), mwilck
- [PATCH 43/54] libmultipath: adopt_paths(): use find_path_by_devt(), mwilck
- [PATCH 51/54] libmultipath: get_refwwid(): use switch statement, mwilck
- [PATCH 54/54] libmultipath: get_refwwid(): skip strchop(), and constify dev parameter, mwilck
- [PATCH 48/54] libmultipath: get_refwwid(): call get_multipath_config() only once, mwilck
- [PATCH 52/54] libmultipath: constify get_mpe_wwid(), mwilck
- [PATCH 50/54] libmultipath: get_refwwid(): use symbolic return values, mwilck
- [PATCH 53/54] multipath: call strchop() on command line argument, mwilck
- Re: [PATCH 00/54] multipath-tools series part IV: identify paths by dev_t, Benjamin Marzinski
- [PATCH 00/42] multipath-tools series part III: duplicate alias,
mwilck
- [PATCH 00/39] multipath-tools series part II: dev_loss_tmo fixes,
mwilck
- [PATCH 00/35] multipath-tools series part I: minor changes,
mwilck
- [PATCH 03/35] tests: __wrap_dlog: use check_expected(), mwilck
- [PATCH 08/35] libmultipath: create bitfield abstraction, mwilck
- [PATCH 02/35] multipath-tools tests/directio: fix missing initializers, mwilck
- [PATCH 10/35] libmultipath: util: constify function arguments, mwilck
- [PATCH 05/35] libmultipath: improve strchop(), mwilck
- [PATCH 14/35] libmultipath: rlookup_binding(): remove newline in log message, mwilck
- [PATCH 06/35] multipath-tools tests: add test for devt2devname, mwilck
- [PATCH 12/35] libmultipath: strlcpy()/strlcat(): use restrict qualifier, mwilck
- [PATCH 13/35] libmultipath: constify blacklist code, mwilck
- [PATCH 22/35] libmultipath: get_uid(): improve log message on udev failure, mwilck
- [PATCH 20/35] libmultipath: decrease log level of "SCSI target" log message, mwilck
- [PATCH 28/35] libmultipath: snprint_devices(): use udev_enumerate, mwilck
- [PATCH 24/35] libmultipath: pathinfo(): improve a log message, mwilck
- [PATCH 18/35] libmultipath: uevent: use static linkage where possible, mwilck
- [PATCH 07/35] libmultipath: devt2devname(): simplify using libudev, mwilck
- [PATCH 17/35] libmultipath: remove uevent listener failback, mwilck
- [PATCH 23/35] libmultipath: make sysfs_pathinfo() static and use const, mwilck
- [PATCH 19/35] libmultipath: uevent: inline trivial functions, mwilck
- [PATCH 33/35] multipathd: remove set_multipath_wwid(), mwilck
- [PATCH 31/35] libmultipath: alloc_path_with_pathinfo(): treat devname overflow as error, mwilck
- [PATCH 21/35] libmultipath: get_udev_uid(): more appropriate error code, mwilck
- [PATCH 29/35] libmultipath: snprint_devices(): print hidden/foreign status, mwilck
- [PATCH 34/35] kpartx: print an error message if removing a partition fails, mwilck
- [PATCH 35/35] kpartx: add missing newline, mwilck
- [PATCH 01/35] multipath-tools tests/util: separate group for bitmask tests, mwilck
- [PATCH 09/35] libmultipath: use bitfields in group_by_match(), mwilck
- [PATCH 04/35] multipath tools tests: add strchop() test, mwilck
- [PATCH 11/35] multipath-tools tests: add unit tests for strlcat, mwilck
- [PATCH 25/35] libmultipath: pathinfo(): don't filter emtpy devnode names, mwilck
- [PATCH 30/35] libmultipath: alloc_path(): initialize pp->initialized, mwilck
- [PATCH 32/35] libmultipath: log table params in addmap(), mwilck
- [PATCH 15/35] libmultipath: fix missing initializer warning from clang 3.9, mwilck
- [PATCH 16/35] libmultipath: fix gcc -Wstringop-overflow warning, mwilck
- [PATCH 27/35] libmultipath: improve libdm logging, mwilck
- [PATCH 26/35] libmultipath: io_err_stat_handle_pathfail(): less error conditions, mwilck
- Re: [PATCH 00/35] multipath-tools series part I: minor changes, Benjamin Marzinski
- [dm-level] master - libmultipath: fix use after free when iscsi logs in,
lixiaokeng
- [dm:for-next 16/21] drivers/md/dm-dust.c:307:10: warning: zero-length gnu_printf format string, kernel test robot
- [PATCH] dm: use noio when sending kobject event,
Mikulas Patocka
- [PATCH] dm crypt: Enable zoned block device support, Damien Le Moal
- [PATCH 0/2] dm zoned fixes for 5.8,
Damien Le Moal
- [PATCH] multipath-tools: add info to man page for the historical-service-time path selector,
Xose Vazquez Perez
- [PATCH] blk-mq: consider non-idle request as "inflight" in blk_mq_rq_inflight(),
Mike Snitzer
- [PATCH]libmultipath/dmparser: add missing path with good status when sync state with dm kernel,
Chongyun Wu
- [PATCH] libmultipath: add device to hwtable.c,
Schremmer, Steven
- [PATCH v3] dm crypt: add flags to optionally bypass dm-crypt workqueues,
Ignat Korchagin
- [PATCH 00/13] Documentation/admin-guide: eliminate duplicated words,
Randy Dunlap
- [PATCH 13/13] Documentation/admin-guide: xfs: drop doubled word, Randy Dunlap
- [PATCH 09/13] Documentation/admin-guide: intel_pstate: drop doubled word, Randy Dunlap
- [PATCH 04/13] Documentation/admin-guide: media/building: drop doubled words, Randy Dunlap
- [PATCH 08/13] Documentation/admin-guide: arm-ccn: drop doubled word, Randy Dunlap
- [PATCH 01/13] Documentation/admin-guide: cgroup-v2: drop doubled word, Randy Dunlap
- [PATCH 10/13] Documentation/admin-guide: intel-speed-select: drop doubled words, Randy Dunlap
- [PATCH 11/13] Documentation/admin-guide: sysctl/kernel: drop doubled word, Randy Dunlap
- [PATCH 06/13] Documentation/admin-guide: pnfs-block-server: drop doubled word, Randy Dunlap
- [PATCH 03/13] Documentation/admin-guide: dm-integrity: drop doubled words, Randy Dunlap
- [PATCH 02/13] Documentation/admin-guide: cgroup-v1/rdma: drop doubled word, Randy Dunlap
- [PATCH 12/13] Documentation/admin-guide: tainted-kernels: drop doubled word, Randy Dunlap
- [PATCH 05/13] Documentation/admin-guide: mm/ksm: drop doubled word, Randy Dunlap
- [PATCH 07/13] Documentation/admin-guide: pnfs-scsi-server: drop doubled word, Randy Dunlap
- Re: [PATCH 00/13] Documentation/admin-guide: eliminate duplicated words, Jonathan Corbet
- a crash in md-raid, Mikulas Patocka
- [PATCH -next] dm zoned: fix unused but set variable warnings, Wei Yongjun
- [PATCH -next] dm: remove unused variable 'md', Wei Yongjun
- [PATCH v2 0/4] misc patches,
Benjamin Marzinski
- [PATCH v3 0/7] Fix muitpath/multipathd flush issue,
Benjamin Marzinski
- [PATCH 0/4] misc patches,
Benjamin Marzinski
- Re: [willy@xxxxxxxxxxxxx: Re: [PATCH 6/6] mm: Add memalloc_nowait], Jonathan Corbet
- NVMe regression, NVMe no longer uses blk_path_error(), Mike Snitzer
- remove dead bdi congestion leftovers,
Christoph Hellwig
- rename ->make_request_fn and move it to the block_device_operations v2,
Christoph Hellwig
- [PATCH 05/20] ps3vram: stop using ->queuedata, Christoph Hellwig
- [PATCH 01/20] nfblock: stop using ->queuedata, Christoph Hellwig
- [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers, Christoph Hellwig
- [PATCH 04/20] null_blk: stop using ->queuedata for bio mode, Christoph Hellwig
- [PATCH 06/20] rsxx: stop using ->queuedata, Christoph Hellwig
- [PATCH 18/20] block: refator submit_bio_noacct, Christoph Hellwig
- [PATCH 20/20] block: remove direct_make_request, Christoph Hellwig
- [PATCH 03/20] drbd: stop using ->queuedata, Christoph Hellwig
- [PATCH 07/20] umem: stop using ->queuedata, Christoph Hellwig
- [PATCH 08/20] zram: stop using ->queuedata, Christoph Hellwig
- [PATCH 15/20] block: remove the nr_sectors variable in generic_make_request_checks, Christoph Hellwig
- [PATCH 09/20] bcache: stop setting ->queuedata, Christoph Hellwig
- [PATCH 13/20] block: tidy up a warning in bio_check_ro, Christoph Hellwig
- [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc, Christoph Hellwig
- [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations, Christoph Hellwig
- [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks, Christoph Hellwig
- [PATCH 02/20] simdisk: stop using ->queuedata, Christoph Hellwig
- [PATCH 12/20] block: remove the request_queue argument from blk_queue_split, Christoph Hellwig
- [PATCH 10/20] dm: stop using ->queuedata, Christoph Hellwig
- [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct, Christoph Hellwig
- Re: rename ->make_request_fn and move it to the block_device_operations v2, Jens Axboe
- [PATCH 0/6] crypto: add CRYPTO_ALG_ALLOCATES_MEMORY,
Eric Biggers
- [PATCH] dm writecache: reject asynchronous pmem.,
Michal Suchanek
- [PATCH 00/10] block: blktrace framework cleanup,
Chaitanya Kulkarni
- Re: [PATCH 00/10] block: blktrace framework cleanup, Steven Rostedt
- [PATCH 07/11] block: get rid of blk_trace_request_get_cgid(), Chaitanya Kulkarni
- [PATCH 08/11] block: fix the comments in the trace event block.h, Chaitanya Kulkarni
- [PATCH 06/11] block: remove extra param for trace_block_getrq(), Chaitanya Kulkarni
- [PATCH 02/11] block: rename block_bio_merge class to block_bio, Chaitanya Kulkarni
- [PATCH 03/11] block: use block_bio event class for bio_queue, Chaitanya Kulkarni
- [PATCH 09/11] block: remove unsed param in blk_fill_rwbs(), Chaitanya Kulkarni
- [PATCH 04/11] block: use block_bio event class for bio_bounce, Chaitanya Kulkarni
- [PATCH 05/11] block: get rid of the trace rq insert wrapper, Chaitanya Kulkarni
- [PATCH 11/11] block: remove block_get_rq event class, Chaitanya Kulkarni
- [PATCH 10/11] block: use block_bio class for getrq and sleeprq, Chaitanya Kulkarni
- [PATCH 01/11] block: blktrace framework cleanup, Chaitanya Kulkarni
- rename ->make_request_fn and move it to the block_device_operations,
Christoph Hellwig
- [PATCH 12/20] block: remove the request_queue argument from blk_queue_split, Christoph Hellwig
- [PATCH 13/20] block: tidy up a warning in bio_check_ro, Christoph Hellwig
- [PATCH 19/20] block: shortcut __submit_bio_noacct for blk-mq drivers, Christoph Hellwig
- [PATCH 15/20] block: remove the nr_sectors variable in generic_make_request_checks, Christoph Hellwig
- [PATCH 01/20] nfblock: stop using ->queuedata, Christoph Hellwig
- [PATCH 05/20] ps3vram: stop using ->queuedata, Christoph Hellwig
- [PATCH 08/20] zram: stop using ->queuedata, Christoph Hellwig
- [PATCH 16/20] block: move ->make_request_fn to struct block_device_operations, Christoph Hellwig
- [PATCH 11/20] fs: remove a weird comment in submit_bh_wbc, Christoph Hellwig
- [PATCH 17/20] block: rename generic_make_request to submit_bio_noacct, Christoph Hellwig
- [PATCH 18/20] block: refator submit_bio_noacct, Christoph Hellwig
- [PATCH 02/20] simdisk: stop using ->queuedata, Christoph Hellwig
- [PATCH 09/20] bcache: stop setting ->queuedata, Christoph Hellwig
- [PATCH 07/20] umem: stop using ->queuedata, Christoph Hellwig
- [PATCH 06/20] rsxx: stop using ->queuedata, Christoph Hellwig
- [PATCH 03/20] drbd: stop using ->queuedata, Christoph Hellwig
- [PATCH 14/20] block: remove the NULL queue check in generic_make_request_checks, Christoph Hellwig
- [PATCH 10/20] dm: stop using ->queuedata, Christoph Hellwig
- [PATCH 04/20] null_blk: stop using ->queuedata for bio mode, Christoph Hellwig
- [PATCH 20/20] block: remove direct_make_request, Christoph Hellwig
- Re: rename ->make_request_fn and move it to the block_device_operations, Jens Axboe
- Need some advices on LUKS2 cryptsetup (performance issue with integrity), laurent cop
- [PATCH] Replace HTTP links with HTTPS ones: LVM,
Alexander A. Klimov
- [PATCH v2] dm crypt: add flags to optionally bypass dm-crypt workqueues,
Ignat Korchagin
- drive-by blk-cgroup cleanups,
Christoph Hellwig
- [PATCH 08/14] block: bypass blkg_tryget_closest for the root_blkg, Christoph Hellwig
- [PATCH 14/14] blk-cgroup: remove a dead check in blk_throtl_bio, Christoph Hellwig
- [PATCH 02/14] block: remove bio_disassociate_blkg, Christoph Hellwig
- [PATCH 06/14] block: move the bio cgroup associatation helpers to blk-cgroup.c, Christoph Hellwig
- [PATCH 05/14] block: move bio_associate_blkg_from_page to mm/page_io.c, Christoph Hellwig
- [PATCH 13/14] blk-cgroup: remove blkcg_bio_issue_check, Christoph Hellwig
- [PATCH 10/14] blk-cgroup: remove the !bio->bi_blkg check in blkcg_bio_issue_check, Christoph Hellwig
- [PATCH 11/14] cgroup: unexport cgroup_rstat_updated, Christoph Hellwig
- [PATCH 12/14] blk-cgroup: move rcu locking from blkcg_bio_issue_check to blk_throtl_bio, Christoph Hellwig
- [PATCH 03/14] block: really clone the block cgroup in bio_clone_blkg_association, Christoph Hellwig
- [PATCH 01/14] dm: use bio_uninit instead of bio_disassociate_blkg, Christoph Hellwig
- [PATCH 09/14] block: move the initial blkg lookup into blkg_tryget_closest, Christoph Hellwig
- [PATCH 04/14] block: merge __bio_associate_blkg into bio_associate_blkg_from_css, Christoph Hellwig
- [PATCH 07/14] block: merge blkg_lookup_create and __blkg_lookup_create, Christoph Hellwig
- Re: drive-by blk-cgroup cleanups, Tejun Heo
- Re: drive-by blk-cgroup cleanups, Jens Axboe
- Re: drive-by blk-cgroup cleanups, Johannes Thumshirn
- [git pull] device mapper fixes for 5.8-rc3,
Mike Snitzer
- dm-crypt hard lockup,
Artur Paszkiewicz
- [PATCH 0/6] Overhaul memalloc_no*,
Matthew Wilcox (Oracle)
- [PATCH v2 0/7] Fix muitpath/multipathd flush issue,
Benjamin Marzinski
- [RFC v2] Reed-Solomon Code: Update no_eras to the actual number of errors,
Aiden Leong
- [RFC] Reed-Solomon Code: Update no_eras to the actual number of errors,
Aiden Leong
- [PATCH RFC] block: blktrace framework cleanup,
Chaitanya Kulkarni
- [RFC PATCH 0/1] dm-crypt excessive overhead,
Ignat Korchagin
- [PATCH v4 4/4] dm dust: introduce listbadblocks in the rst, Bryan Gurney
- [PATCH v4 3/4] dm dust: add interface to list all badblocks, Bryan Gurney
- [PATCH v4 2/4] dm dust: update doc after message results report to user directly, Bryan Gurney
- [PATCH v4 1/4] dm dust: report some message results back to user directly,
Bryan Gurney
- [PATCH] dm dust: update documentation to reflect __func__ output, Bryan Gurney
- [PATCH] dm dust: add __func__ to queryblocks and clearbadblocks DMEMIT calls, Bryan Gurney
- [PATCH] dm-writecache: add cond_resched to a loop, Mikulas Patocka
- [PATCH v3 0/4] introduce interface to list badblocks,
yangerkun
- [PATCH v2 0/2] introduce interface to list all badblocks,
yangerkun
- [PATCH 0/2] Two fixes for device-mapper with REQ_OP_ZONE_APPEND,
Johannes Thumshirn
- [PATCH] dm-rq: don't call blk_mq_queue_stopped in dm_stop_queue(),
Ming Lei
- [patch] New mode DM-Verity error handling,
JeongHyeon Lee
- [PATCH] dm zoned: Fix metadata zone size check,
Shin'ichiro Kawasaki
- [PATCH AUTOSEL 4.14 069/108] dm zoned: return NULL if dmz_get_zone_for_reclaim() fails to find a zone, Sasha Levin
- [PATCH AUTOSEL 4.14 019/108] dm mpath: switch paths in dm_blk_ioctl() code path, Sasha Levin
- [PATCH AUTOSEL 4.19 107/172] dm zoned: return NULL if dmz_get_zone_for_reclaim() fails to find a zone, Sasha Levin
- [PATCH AUTOSEL 4.19 025/172] dm mpath: switch paths in dm_blk_ioctl() code path, Sasha Levin
- [PATCH AUTOSEL 5.4 172/266] dm zoned: return NULL if dmz_get_zone_for_reclaim() fails to find a zone, Sasha Levin
- [PATCH AUTOSEL 5.4 035/266] dm mpath: switch paths in dm_blk_ioctl() code path, Sasha Levin
- [PATCH AUTOSEL 5.7 047/388] dm mpath: switch paths in dm_blk_ioctl() code path, Sasha Levin
- [PATCH AUTOSEL 5.7 252/388] dm zoned: return NULL if dmz_get_zone_for_reclaim() fails to find a zone, Sasha Levin
- [PATCH 0/7] Fix muitpath/multipathd flush issue,
Benjamin Marzinski
- Re: [PATCH] dm ioctl: Use struct_size() helper,
Gustavo A. R. Silva
- [PATCH 00/29] Documentation fixes,
Mauro Carvalho Chehab
- [PATCH] dm writecache: skip writecache_wait when using pmem mode,
Huaisheng Ye
- [PATCH] dm writecache: correct uncommitted_block when discarding uncommitted entry,
Huaisheng Ye
- [PATCH] dm zoned: assign max_io_len correctly,
Hou Tao
- BUG: KASAN: use-after-free in tasklet_action_common on boot, Ivan Babrou
- [PATCH v2 0/3] multipath: change default devnode blacklist,
Benjamin Marzinski
- crypto API and GFP_ATOMIC,
Mikulas Patocka
[Index of Archives]
[DM Crypt]
[Fedora Docs]
[Fedora SELinux]
[Kernel]