CEPH Filesystem Development
[Prev Page][Next Page]
- [PATCH v2 07/19] netfs: Trace refcounting on the netfs_io_request struct, (continued)
- [PATCH v2] libceph: wait for con->work to finish when cancelling con,
xiubli
- [RFC PATCH] libceph: wait for con->work to finish when cancelling con,
xiubli
- [PATCH] ceph: uninitialized variable in debug output,
Dan Carpenter
- [PATCH v2] ceph: use ktime_to_timespec64() rather than jiffies_to_timespec64(),
Venky Shankar
- [PATCH v5] ceph: do not dencrypt the dentry name twice for readdir,
xiubli
- [PATCH v3] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH 0/3] ceph: minor fixes and encrypted snapshot names,
Luís Henriques
- [PATCH v4 0/2] ceph: misc fix for fscrypt,
xiubli
- [PATCH] libceph: fix last_piece calculation in ceph_msg_data_pages_advance,
Jeff Layton
- [PATCH 00/19] netfs: Prep for write helpers,
David Howells
- [PATCH 01/19] fscache: export fscache_end_operation(), David Howells
- [PATCH 02/19] netfs: Generate enums from trace symbol mapping lists, David Howells
- [PATCH 03/19] netfs: Add a netfs inode context, David Howells
- [PATCH 04/19] netfs: Rename netfs_read_*request to netfs_io_*request, David Howells
- [PATCH 05/19] netfs: Refactor arguments for netfs_alloc_read_request, David Howells
- [PATCH 06/19] netfs: Finish off rename of netfs_read_request to netfs_io_request, David Howells
- [PATCH 07/19] netfs: Split netfs_io_* object handling out, David Howells
- [PATCH 08/19] netfs: Adjust the netfs_rreq tracepoint slightly, David Howells
- [PATCH 09/19] netfs: Trace refcounting on the netfs_io_request struct, David Howells
- [PATCH 10/19] netfs: Trace refcounting on the netfs_io_subrequest struct, David Howells
- [PATCH 11/19] netfs: Adjust the netfs_failure tracepoint to indicate non-subreq lines, David Howells
- [PATCH 12/19] netfs: Prepare to split read_helper.c, David Howells
- [PATCH 13/19] netfs: Add a function to consolidate beginning a read, David Howells
- [PATCH 14/19] netfs: Split fs/netfs/read_helper.c, David Howells
- [PATCH 15/19] netfs: Split some core bits out into their own file, David Howells
- [PATCH 16/19] netfs: Rename rename read_helper.c to io.c, David Howells
- [PATCH 17/19] netfs: Change ->init_rreq() to return an error code, David Howells
- [PATCH 18/19] netfs: Keep track of the actual remote file size, David Howells
- [PATCH 19/19] afs: Maintain netfs_i_context::remote_i_size, David Howells
- [PATCH v3 0/6] ceph: encrypt the snapshot directories,
xiubli
- [PATCH 0/2] ceph: misc fixes,
xiubli
- [PATCH v3] ceph: skip the memories when received a higher version of message,
xiubli
- Making 3 ceph patches available to rebase netfslib patches on,
David Howells
- [PATCH v2] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH v2 0/7] ceph: encrypt the snapshot directories,
xiubli
- [PATCH] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH] ceph: fail the request when failing to decode dentry names,
xiubli
- [PATCH] ceph: increase the offset when fail to decode dentry names,
xiubli
- [PATCH 0/3] ceph: encrypt the snapshot directories,
xiubli
- [RFC PATCH] ceph: add support for encrypted snapshot names,
Luís Henriques
- [no subject], Unknown
- Benching ceph for high speed RBD,
Bartosz Rabiega
[PATCH v3 0/2] ceph: fix cephfs rsync kworker high load issue,
xiubli
[PATCH v2 0/2] ceph: create the global dummy snaprealm once,
xiubli
[PATCH 0/2] ceph: create the global dummy snaprealm once,
xiubli
[PATCH] MAINTAINERS: add Xiubo Li as cephfs co-maintainer,
Jeff Layton
[PATCH v2] ceph: eliminate the recursion when rebuilding the snap context,
xiubli
[PATCH v3] ceph: do not update snapshot context when there is no new snapshot,
xiubli
Kopie Ihres Marketing-Kontakt-Formulares, Kleinanzeigen.com
[PATCH v2] ceph: do not update snapshot context when there is no new snapshot,
xiubli
[PATCH] ceph: zero the dir_entries memory when allocating it,
xiubli
[ceph-client:testing 13/14] fs/ceph/snap.c:438:14: warning: variable '_realm' is uninitialized when used here,
kernel test robot
[PATCH] ceph: eliminate the recursion when rebuilding the snap context,
xiubli
[PATCH v2 0/2] ceph: fix cephfs rsync kworker high load issue,
xiubli
[RFC PATCH 0/5] libceph: add support for sparse reads to msgr2/crc,
Jeff Layton
[PATCH 0/3] ceph: fix cephfs rsync kworker high load issue,
xiubli
[PATCH 0/3] ceph: forward average read/write/metadata latency,
Venky Shankar
[PATCH] libceph: drop else branches in prepare_read_data{,_cont}, Jeff Layton
[PATCH v10 0/1] ceph: add getvxattr op,
Milind Changire
[PATCH v9 0/1] ceph: add getvxattr support,
Milind Changire
[PATCH] fs/ceph: fix comments mentioning i_mutex,
Hongnan Li
[ceph-client:testing 6/8] fs/ceph/addr.c:788:12: warning: stack frame size (2352) exceeds limit (2048) in 'ceph_writepages_start',
kernel test robot
[PATCH v8 0/1] mds: add getvxattr op support,
Milind Changire
[PATCH 00/11] Remove remaining parts of congestion tracking code.,
NeilBrown
- [PATCH 01/11] DOC: convert 'subsection' to 'section' in gfp.h, NeilBrown
- [PATCH 02/11] MM: document and polish read-ahead code., NeilBrown
- [PATCH 03/11] MM: improve cleanup when ->readpages doesn't process all pages., NeilBrown
- [PATCH 06/11] ceph: remove reliance on bdi congestion, NeilBrown
- [PATCH 05/11] nfs: remove reliance on bdi congestion, NeilBrown
- [PATCH 04/11] fuse: remove reliance on bdi congestion, NeilBrown
- [PATCH 07/11] Remove inode_congested(), NeilBrown
- [PATCH 08/11] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 09/11] f2fs: replace congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 11/11] Remove congestion tracking framework., NeilBrown
- [PATCH 10/11] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- <Possible follow-ups>
- [PATCH 00/11] Remove remaining parts of congestion tracking code., NeilBrown
- [PATCH 01/11] DOC: convert 'subsection' to 'section' in gfp.h, NeilBrown
- [PATCH 04/11] fuse: remove reliance on bdi congestion, NeilBrown
- [PATCH 11/11] Remove congestion tracking framework., NeilBrown
- [PATCH 03/11] MM: improve cleanup when ->readpages doesn't process all pages., NeilBrown
- [PATCH 05/11] nfs: remove reliance on bdi congestion, NeilBrown
- [PATCH 07/11] Remove inode_congested(), NeilBrown
- [PATCH 09/11] f2fs: replace congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 08/11] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 10/11] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- [PATCH 02/11] MM: document and polish read-ahead code., NeilBrown
- [PATCH 06/11] ceph: remove reliance on bdi congestion, NeilBrown
[PATCH v7 0/1] mds: add getvxattr support,
Milind Changire
[PATCH] ceph: use ktime_to_timespec64() rather than jiffies_to_timespec64(),
Venky Shankar
[PATCH] ceph: wake waiters after failed async create,
Jeff Layton
[PATCH] ceph: fail the request directly if handle_reply gets an ESTALE,
xiubli
[PATCH] ceph: wait for async create reply before sending any cap messages,
Jeff Layton
[GIT PULL] Ceph fixes for 5.17-rc3,
Ilya Dryomov
[PATCH] ceph: eliminate req->r_wait_for_completion from ceph_mds_request,
Jeff Layton
[PATCH] ceph: eliminate req->r_wait_for_completion, Jeff Layton
[PATCH 0/2] libceph: rxbounce support,
Ilya Dryomov
[PATCH 0/3] remove dependence of inode_congested(),
NeilBrown
[GIT PULL] Ceph fixes for 5.17-rc2,
Ilya Dryomov
[PATCH] ceph: wake waiters on any IMPORT that grants new caps,
Jeff Layton
[PATCH v6 0/1] ceph: add support for getvxattr op,
Milind Changire
[PATCH 0/9] Remove remaining parts of congestions tracking code.,
NeilBrown
- [PATCH 1/9] Remove inode_congested(), NeilBrown
- [PATCH 2/9] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 3/9] f2fs: change retry waiting for f2fs_write_single_data_page(), NeilBrown
- [PATCH 4/9] f2f2: replace some congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 5/9] cephfs: don't set/clear bdi_congestion, NeilBrown
- [PATCH 6/9] fuse: don't set/clear bdi_congested, NeilBrown
- [PATCH 7/9] NFS: remove congestion control., NeilBrown
- [PATCH 8/9] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- [PATCH 9/9] Remove congestion tracking framework., NeilBrown
- Re: [PATCH 0/9] Remove remaining parts of congestions tracking code., Andrew Morton
- Re: [PATCH 0/9] Remove remaining parts of congestions tracking code., Jens Axboe
[PATCH] security, lsm: dentry_init_security() Handle multi LSM registration,
Vivek Goyal
[PATCH v2] ceph: set pool_ns in new inode layout for async creates,
Jeff Layton
[PATCH] ceph: set pool_ns in new inode layout for async creates,
Jeff Layton
[PATCH] ceph: properly put ceph_string reference after async create attempt,
Jeff Layton
Re: "kernel NULL pointer dereference" crash when attempting a write,
Paul Moore
[PATCH v5 0/1] add getvxattr op,
Milind Changire
[PATCH AUTOSEL 5.10 4/9] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
[PATCH AUTOSEL 5.15 08/16] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
[PATCH AUTOSEL 5.16 08/19] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
Ceph build with old glibc version., mhnx
[GIT PULL] fscache: Fixes and minor updates for rewrite,
David Howells
[PATCH v3 0/3] ceph: uninline data on open instead of write,
Jeff Layton
[RFC][PATCH] cachefiles: Split and rename S_KERNEL_FILE and extend effects,
David Howells
[GIT PULL] Ceph updates for 5.17-rc1,
Ilya Dryomov
[PATCH 00/11] fscache, cachefiles: Rewrite fixes/updates,
David Howells
- [PATCH 01/11] fscache: Fix the volume collision wait condition, David Howells
- [PATCH 02/11] cachefiles: Calculate the blockshift in terms of bytes, not pages, David Howells
- [PATCH 03/11] cachefiles: set default tag name if it's unspecified, David Howells
- [PATCH 04/11] cachefiles: Make some tracepoint adjustments, David Howells
- [PATCH 05/11] cachefiles: Trace active-mark failure, David Howells
- [PATCH 06/11] cachefiles: Explain checks in a comment, David Howells
- [PATCH 07/11] cachefiles: Check that the backing filesystem supports tmpfiles, David Howells
- [PATCH 08/11] fscache: Add a comment explaining how page-release optimisation works, David Howells
- [PATCH 10/11] netfs: Make ops->init_rreq() optional, David Howells
- [PATCH 09/11] vfs, fscache: Add an IS_KERNEL_FILE() macro for the S_KERNEL_FILE flag, David Howells
- [PATCH 11/11] cifs: Support fscache indexing rewrite, David Howells
[PATCH 1/3] ceph: Make ceph_netfs_issue_op() handle inlined data (untested),
David Howells
[PATCH 1/3] ceph: Uninline the data on a file opened for writing,
David Howells
Out of order read() completion and buffer filling beyond returned amount,
David Howells
[PATCH v4 0/1] ceph: add support for getvxattr op,
Milind Changire
[PATCH v3 0/1] ceph: add support for getvxattr op,
Milind Changire
[PATCH v2 0/1] ceph: add getvxattr op support,
Milind Changire
[PATCH v7] cifs: Support fscache indexing rewrite, David Howells
[PATCH] ceph: put the requests/sessions when it fails to alloc memory,
xiubli
[PATCH v8] ceph: add truncate size handling support for fscrypt, xiubli
[GIT PULL] fscache, cachefiles: Rewrite,
David Howells
[RFC PATCH v10 00/48] ceph+fscrypt: full support,
Jeff Layton
- [RFC PATCH v10 01/48] vfs: export new_inode_pseudo, Jeff Layton
- [RFC PATCH v10 03/48] fscrypt: export fscrypt_fname_encrypt and fscrypt_fname_encrypted_size, Jeff Layton
- [RFC PATCH v10 02/48] fscrypt: export fscrypt_base64url_encode and fscrypt_base64url_decode, Jeff Layton
- [RFC PATCH v10 04/48] fscrypt: add fscrypt_context_for_new_inode, Jeff Layton
- [RFC PATCH v10 05/48] ceph: preallocate inode for ops that may create one, Jeff Layton
- [RFC PATCH v10 07/48] ceph: parse new fscrypt_auth and fscrypt_file fields in inode traces, Jeff Layton
- [RFC PATCH v10 06/48] ceph: crypto context handling for ceph, Jeff Layton
- [RFC PATCH v10 09/48] ceph: add ability to set fscrypt_auth via setattr, Jeff Layton
- [RFC PATCH v10 10/48] ceph: implement -o test_dummy_encryption mount option, Jeff Layton
- [RFC PATCH v10 08/48] ceph: add fscrypt_* handling to caps.c, Jeff Layton
- [RFC PATCH v10 12/48] ceph: add fscrypt ioctls, Jeff Layton
- [RFC PATCH v10 13/48] ceph: make ceph_msdc_build_path use ref-walk, Jeff Layton
- [RFC PATCH v10 14/48] ceph: add encrypted fname handling to ceph_mdsc_build_path, Jeff Layton
- [RFC PATCH v10 24/48] ceph: add a new ceph.fscrypt.auth vxattr, Jeff Layton
- [RFC PATCH v10 26/48] ceph: don't allow changing layout on encrypted files/directories, Jeff Layton
- [RFC PATCH v10 11/48] ceph: decode alternate_name in lease info, Jeff Layton
- [RFC PATCH v10 16/48] ceph: encode encrypted name in dentry release, Jeff Layton
- [RFC PATCH v10 17/48] ceph: properly set DCACHE_NOKEY_NAME flag in lookup, Jeff Layton
- [RFC PATCH v10 15/48] ceph: send altname in MClientRequest, Jeff Layton
- [RFC PATCH v10 47/48] ceph: add encryption support to writepage, Jeff Layton
- [RFC PATCH v10 21/48] ceph: add support to readdir for encrypted filenames, Jeff Layton
- [RFC PATCH v10 25/48] ceph: add some fscrypt guardrails, Jeff Layton
- [RFC PATCH v10 23/48] ceph: make ceph_get_name decrypt filenames, Jeff Layton
- [RFC PATCH v10 22/48] ceph: create symlinks with encrypted and base64-encoded targets, Jeff Layton
- [RFC PATCH v10 19/48] ceph: add helpers for converting names for userland presentation, Jeff Layton
- [RFC PATCH v10 18/48] ceph: make d_revalidate call fscrypt revalidator for encrypted dentries, Jeff Layton
- [RFC PATCH v10 20/48] ceph: add fscrypt support to ceph_fill_trace, Jeff Layton
- [RFC PATCH v10 28/48] ceph: size handling for encrypted inodes in cap updates, Jeff Layton
- [RFC PATCH v10 29/48] ceph: fscrypt_file field handling in MClientRequest messages, Jeff Layton
- [RFC PATCH v10 31/48] ceph: handle fscrypt fields in cap messages from MDS, Jeff Layton
- [RFC PATCH v10 30/48] ceph: get file size from fscrypt_file when present in inode traces, Jeff Layton
- [RFC PATCH v10 32/48] ceph: add __ceph_get_caps helper support, Jeff Layton
- [RFC PATCH v10 39/48] ceph: disable copy offload on encrypted inodes, Jeff Layton
- [RFC PATCH v10 41/48] ceph: set encryption context on open, Jeff Layton
- [RFC PATCH v10 43/48] ceph: add read/modify/write to ceph_sync_write, Jeff Layton
- [RFC PATCH v10 42/48] ceph: align data in pages in ceph_sync_write, Jeff Layton
- [RFC PATCH v10 44/48] ceph: plumb in decryption during sync reads, Jeff Layton
- [RFC PATCH v10 38/48] ceph: disable fallocate for encrypted inodes, Jeff Layton
- [RFC PATCH v10 40/48] ceph: don't use special DIO path for encrypted inodes, Jeff Layton
- [RFC PATCH v10 35/48] ceph: add infrastructure for file encryption and decryption, Jeff Layton
- [RFC PATCH v10 36/48] ceph: add truncate size handling support for fscrypt, Jeff Layton
- [RFC PATCH v10 34/48] ceph: add object version support for sync read, Jeff Layton
- [RFC PATCH v10 37/48] libceph: allow ceph_osdc_new_request to accept a multi-op read, Jeff Layton
- [RFC PATCH v10 33/48] ceph: add __ceph_sync_read helper support, Jeff Layton
- [RFC PATCH v10 27/48] libceph: add CEPH_OSD_OP_ASSERT_VER support, Jeff Layton
- [RFC PATCH v10 46/48] ceph: add fscrypt decryption support to ceph_netfs_issue_op, Jeff Layton
- [RFC PATCH v10 48/48] ceph: fscrypt support for writepages, Jeff Layton
- [RFC PATCH v10 45/48] ceph: set i_blkbits to crypto block size for encrypted inodes, Jeff Layton
- Re: [RFC PATCH v10 00/48] ceph+fscrypt: full support, Jeff Layton
- Re: [RFC PATCH v10 00/48] ceph+fscrypt: full support, Eric Biggers
- Re: [RFC PATCH v10 00/48] ceph+fscrypt: full support, Xiubo Li
- Re: [RFC PATCH v10 00/48] ceph+fscrypt: full support, Luís Henriques
[PATCH 0/1] ceph: add getvxattr support,
Milind Changire
Re: [PATCH] ceph: add getvxattr op support, Jeff Layton
[PATCH] ceph: move CEPH_SUPER_MAGIC definition to magic.h, Jeff Layton
dmesg: mdsc_handle_reply got x on session mds1 not mds0,
胡玮文
[PATCH] ceph: remove redundant Lsx caps check,
xiubli
[RFC PATCH] ceph: add new "nopagecache" option,
Jeff Layton
[PATCH 00/12] ceph: support idmapped mounts,
Christian Brauner
- [PATCH 01/12] ceph: stash idmapping in mdsc request, Christian Brauner
- [PATCH 02/12] ceph: handle idmapped mounts in create_request_message(), Christian Brauner
- [PATCH 03/12] ceph: allow idmapped mknod inode op, Christian Brauner
- [PATCH 04/12] ceph: allow idmapped symlink inode op, Christian Brauner
- [PATCH 05/12] ceph: allow idmapped mkdir inode op, Christian Brauner
- [PATCH 06/12] ceph: allow idmapped rename inode op, Christian Brauner
- [PATCH 07/12] ceph: allow idmapped getattr inode op, Christian Brauner
- [PATCH 08/12] ceph: allow idmapped permission inode op, Christian Brauner
- [PATCH 09/12] ceph: allow idmapped setattr inode op, Christian Brauner
- [PATCH 10/12] ceph/acl: allow idmapped set_acl inode op, Christian Brauner
- [PATCH 11/12] ceph/file: allow idmapped atomic_open inode op, Christian Brauner
- [PATCH 12/12] ceph: allow idmapped mounts, Christian Brauner
PROBLEM: SLAB use-after-free with ceph(fs),
Bastian Blank
[RFC PATCH 0/8] signals: Support more than 64 signals,
Walt Drummond
[Index of Archives]
[Ceph Users]
[Ceph Dev]
[Ceph Large]
[Linux USB Devel]
[Big List of Linux Books]
[Linux SCSI]
[Yosemite Forum]