CEPH Filesystem Development
[Prev Page][Next Page]
- Re: [PATCH] ceph: fix the buf size and use NAME_SIZE instead, (continued)
- [RFC PATCH v2 0/3] ceph: add support for snapshot names encryption,
Luís Henriques
- [PATCH v2] ceph: get snap_rwsem read lock in handle_cap_export for ceph_add_cap,
Niels Dossche
- [PATCH v2] ceph: send the fscrypt_auth to MDS via request,
xiubli
- [PATCH] ceph: send the fscrypt_auth to MDS via request,
xiubli
- [PATCH] ceph: get snap_rwsem read lock in handle_cap_export for ceph_add_cap,
Niels Dossche
- [PATCH v2 0/4] ceph: dencrypt the dentry names early and once for readdir,
xiubli
- [PATCH 0/4] ceph: dencrypt the dentry names early and once for readdir,
xiubli
- [PATCH] ceph: fix base64 encoded name's length check in ceph_fname_to_usr(),
xiubli
- [RFC PATCH 0/2] Add support for snapshot names encryption,
Luís Henriques
- [PATCH v3 00/20] netfs: Prep for write helpers,
David Howells
- [PATCH v3 03/20] netfs: Rename netfs_read_*request to netfs_io_*request, David Howells
- [PATCH v3 05/20] netfs: Split netfs_io_* object handling out, David Howells
- [PATCH v3 02/20] netfs: Generate enums from trace symbol mapping lists, David Howells
- [PATCH v3 01/20] fscache: export fscache_end_operation(), David Howells
- [PATCH v3 06/20] netfs: Adjust the netfs_rreq tracepoint slightly, David Howells
- [PATCH v3 09/20] netfs: Adjust the netfs_failure tracepoint to indicate non-subreq lines, David Howells
- [PATCH v3 08/20] netfs: Trace refcounting on the netfs_io_subrequest struct, David Howells
- [PATCH v3 07/20] netfs: Trace refcounting on the netfs_io_request struct, David Howells
- [PATCH v3 04/20] netfs: Finish off rename of netfs_read_request to netfs_io_request, David Howells
- [PATCH v3 10/20] netfs: Refactor arguments for netfs_alloc_read_request, David Howells
- [PATCH v3 17/20] netfs: Split fs/netfs/read_helper.c, David Howells
- [PATCH v3 14/20] netfs: Add a function to consolidate beginning a read, David Howells
- [PATCH v3 19/20] netfs: Keep track of the actual remote file size, David Howells
- [PATCH v3 15/20] netfs: Prepare to split read_helper.c, David Howells
- [PATCH v3 16/20] netfs: Rename read_helper.c to io.c, David Howells
- [PATCH v3 12/20] ceph: Make ceph_init_request() check caps on readahead, David Howells
- [PATCH v3 13/20] netfs: Add a netfs inode context, David Howells
- [PATCH v3 20/20] afs: Maintain netfs_i_context::remote_i_size, David Howells
- [PATCH v3 11/20] netfs: Change ->init_request() to return an error code, David Howells
- [PATCH v3 18/20] netfs: Split some core bits out into their own file, David Howells
- Re: [PATCH v3 00/20] netfs: Prep for write helpers, Jeff Layton
- Re: [PATCH v3 00/20] netfs: Prep for write helpers, Dominique Martinet
- Re: [PATCH v3 13/20] netfs: Add a netfs inode context, David Howells
- [PATCH v4 13/20] netfs: Add a netfs inode context, David Howells
- [PATCH] ceph: allow `ceph.dir.rctime' xattr to be updatable,
Venky Shankar
- [PATCH V8] ceph: do not dencrypt the dentry name twice for readdir, xiubli
- [PATCH V7] ceph: do not dencrypt the dentry name twice for readdir,
xiubli
- [PATCH 0/3] ceph: support for sparse read in msgr2 crc path,
Jeff Layton
- [PATCH v6] ceph: do not dencrypt the dentry name twice for readdir,
xiubli
- [PATCH v2] libceph: print fsid and client gid with mon id and osd id,
Daichi Mukai
- [PATCH v2 00/19] netfs: Prep for write helpers,
David Howells
- [PATCH v2 15/19] netfs: Rename read_helper.c to io.c, David Howells
- [PATCH v2 09/19] netfs: Adjust the netfs_failure tracepoint to indicate non-subreq lines, David Howells
- [PATCH v2 16/19] netfs: Split fs/netfs/read_helper.c, David Howells
- [PATCH v2 14/19] netfs: Prepare to split read_helper.c, David Howells
- [PATCH v2 12/19] netfs: Add a netfs inode context, David Howells
- [PATCH v2 18/19] netfs: Keep track of the actual remote file size, David Howells
- [PATCH v2 13/19] netfs: Add a function to consolidate beginning a read, David Howells
- [PATCH v2 17/19] netfs: Split some core bits out into their own file, David Howells
- [PATCH v2 11/19] netfs: Change ->init_request() to return an error code, David Howells
- [PATCH v2 19/19] afs: Maintain netfs_i_context::remote_i_size, David Howells
- [PATCH v2 10/19] netfs: Refactor arguments for netfs_alloc_read_request, David Howells
- [PATCH v2 05/19] netfs: Split netfs_io_* object handling out, David Howells
- [PATCH v2 02/19] netfs: Generate enums from trace symbol mapping lists, David Howells
- [PATCH v2 06/19] netfs: Adjust the netfs_rreq tracepoint slightly, David Howells
- [PATCH v2 03/19] netfs: Rename netfs_read_*request to netfs_io_*request, David Howells
- [PATCH v2 04/19] netfs: Finish off rename of netfs_read_request to netfs_io_request, David Howells
- [PATCH v2 01/19] fscache: export fscache_end_operation(), David Howells
- [PATCH v2 07/19] netfs: Trace refcounting on the netfs_io_request struct, David Howells
- [PATCH v2 08/19] netfs: Trace refcounting on the netfs_io_subrequest struct, David Howells
- [PATCH v2] libceph: wait for con->work to finish when cancelling con,
xiubli
- [RFC PATCH] libceph: wait for con->work to finish when cancelling con,
xiubli
- [PATCH] ceph: uninitialized variable in debug output,
Dan Carpenter
- [PATCH v2] ceph: use ktime_to_timespec64() rather than jiffies_to_timespec64(),
Venky Shankar
- [PATCH v5] ceph: do not dencrypt the dentry name twice for readdir,
xiubli
- [PATCH v3] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH 0/3] ceph: minor fixes and encrypted snapshot names,
Luís Henriques
- [PATCH v4 0/2] ceph: misc fix for fscrypt,
xiubli
- [PATCH] libceph: fix last_piece calculation in ceph_msg_data_pages_advance,
Jeff Layton
- [PATCH 00/19] netfs: Prep for write helpers,
David Howells
- [PATCH 01/19] fscache: export fscache_end_operation(), David Howells
- [PATCH 02/19] netfs: Generate enums from trace symbol mapping lists, David Howells
- [PATCH 03/19] netfs: Add a netfs inode context, David Howells
- [PATCH 04/19] netfs: Rename netfs_read_*request to netfs_io_*request, David Howells
- [PATCH 05/19] netfs: Refactor arguments for netfs_alloc_read_request, David Howells
- [PATCH 06/19] netfs: Finish off rename of netfs_read_request to netfs_io_request, David Howells
- [PATCH 07/19] netfs: Split netfs_io_* object handling out, David Howells
- [PATCH 08/19] netfs: Adjust the netfs_rreq tracepoint slightly, David Howells
- [PATCH 09/19] netfs: Trace refcounting on the netfs_io_request struct, David Howells
- [PATCH 10/19] netfs: Trace refcounting on the netfs_io_subrequest struct, David Howells
- [PATCH 11/19] netfs: Adjust the netfs_failure tracepoint to indicate non-subreq lines, David Howells
- [PATCH 12/19] netfs: Prepare to split read_helper.c, David Howells
- [PATCH 13/19] netfs: Add a function to consolidate beginning a read, David Howells
- [PATCH 14/19] netfs: Split fs/netfs/read_helper.c, David Howells
- [PATCH 15/19] netfs: Split some core bits out into their own file, David Howells
- [PATCH 16/19] netfs: Rename rename read_helper.c to io.c, David Howells
- [PATCH 17/19] netfs: Change ->init_rreq() to return an error code, David Howells
- [PATCH 18/19] netfs: Keep track of the actual remote file size, David Howells
- [PATCH 19/19] afs: Maintain netfs_i_context::remote_i_size, David Howells
- [PATCH v3 0/6] ceph: encrypt the snapshot directories,
xiubli
- [PATCH 0/2] ceph: misc fixes,
xiubli
- [PATCH v3] ceph: skip the memories when received a higher version of message,
xiubli
- Making 3 ceph patches available to rebase netfslib patches on,
David Howells
- [PATCH v2] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH v2 0/7] ceph: encrypt the snapshot directories,
xiubli
- [PATCH] ceph: fix memory leakage in ceph_readdir,
xiubli
- [PATCH] ceph: fail the request when failing to decode dentry names,
xiubli
- [PATCH] ceph: increase the offset when fail to decode dentry names,
xiubli
- [PATCH 0/3] ceph: encrypt the snapshot directories,
xiubli
- [RFC PATCH] ceph: add support for encrypted snapshot names,
Luís Henriques
- [no subject], Unknown
- Benching ceph for high speed RBD,
Bartosz Rabiega
[PATCH v3 0/2] ceph: fix cephfs rsync kworker high load issue,
xiubli
[PATCH v2 0/2] ceph: create the global dummy snaprealm once,
xiubli
[PATCH 0/2] ceph: create the global dummy snaprealm once,
xiubli
[PATCH] MAINTAINERS: add Xiubo Li as cephfs co-maintainer,
Jeff Layton
[PATCH v2] ceph: eliminate the recursion when rebuilding the snap context,
xiubli
[PATCH v3] ceph: do not update snapshot context when there is no new snapshot,
xiubli
Kopie Ihres Marketing-Kontakt-Formulares, Kleinanzeigen.com
[PATCH v2] ceph: do not update snapshot context when there is no new snapshot,
xiubli
[PATCH] ceph: zero the dir_entries memory when allocating it,
xiubli
[ceph-client:testing 13/14] fs/ceph/snap.c:438:14: warning: variable '_realm' is uninitialized when used here,
kernel test robot
[PATCH] ceph: eliminate the recursion when rebuilding the snap context,
xiubli
[PATCH v2 0/2] ceph: fix cephfs rsync kworker high load issue,
xiubli
[RFC PATCH 0/5] libceph: add support for sparse reads to msgr2/crc,
Jeff Layton
[PATCH 0/3] ceph: fix cephfs rsync kworker high load issue,
xiubli
[PATCH 0/3] ceph: forward average read/write/metadata latency,
Venky Shankar
[PATCH] libceph: drop else branches in prepare_read_data{,_cont}, Jeff Layton
[PATCH v10 0/1] ceph: add getvxattr op,
Milind Changire
[PATCH v9 0/1] ceph: add getvxattr support,
Milind Changire
[PATCH] fs/ceph: fix comments mentioning i_mutex,
Hongnan Li
[ceph-client:testing 6/8] fs/ceph/addr.c:788:12: warning: stack frame size (2352) exceeds limit (2048) in 'ceph_writepages_start',
kernel test robot
[PATCH v8 0/1] mds: add getvxattr op support,
Milind Changire
[PATCH 00/11] Remove remaining parts of congestion tracking code.,
NeilBrown
- [PATCH 01/11] DOC: convert 'subsection' to 'section' in gfp.h, NeilBrown
- [PATCH 02/11] MM: document and polish read-ahead code., NeilBrown
- [PATCH 03/11] MM: improve cleanup when ->readpages doesn't process all pages., NeilBrown
- [PATCH 06/11] ceph: remove reliance on bdi congestion, NeilBrown
- [PATCH 05/11] nfs: remove reliance on bdi congestion, NeilBrown
- [PATCH 04/11] fuse: remove reliance on bdi congestion, NeilBrown
- [PATCH 07/11] Remove inode_congested(), NeilBrown
- [PATCH 08/11] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 09/11] f2fs: replace congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 11/11] Remove congestion tracking framework., NeilBrown
- [PATCH 10/11] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- <Possible follow-ups>
- [PATCH 00/11] Remove remaining parts of congestion tracking code., NeilBrown
- [PATCH 01/11] DOC: convert 'subsection' to 'section' in gfp.h, NeilBrown
- [PATCH 04/11] fuse: remove reliance on bdi congestion, NeilBrown
- [PATCH 11/11] Remove congestion tracking framework., NeilBrown
- [PATCH 03/11] MM: improve cleanup when ->readpages doesn't process all pages., NeilBrown
- [PATCH 05/11] nfs: remove reliance on bdi congestion, NeilBrown
- [PATCH 07/11] Remove inode_congested(), NeilBrown
- [PATCH 09/11] f2fs: replace congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 08/11] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 10/11] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- [PATCH 02/11] MM: document and polish read-ahead code., NeilBrown
- [PATCH 06/11] ceph: remove reliance on bdi congestion, NeilBrown
[PATCH v7 0/1] mds: add getvxattr support,
Milind Changire
[PATCH] ceph: use ktime_to_timespec64() rather than jiffies_to_timespec64(),
Venky Shankar
[PATCH] ceph: wake waiters after failed async create,
Jeff Layton
[PATCH] ceph: fail the request directly if handle_reply gets an ESTALE,
xiubli
[PATCH] ceph: wait for async create reply before sending any cap messages,
Jeff Layton
[GIT PULL] Ceph fixes for 5.17-rc3,
Ilya Dryomov
[PATCH] ceph: eliminate req->r_wait_for_completion from ceph_mds_request,
Jeff Layton
[PATCH] ceph: eliminate req->r_wait_for_completion, Jeff Layton
[PATCH 0/2] libceph: rxbounce support,
Ilya Dryomov
[PATCH 0/3] remove dependence of inode_congested(),
NeilBrown
[GIT PULL] Ceph fixes for 5.17-rc2,
Ilya Dryomov
[PATCH] ceph: wake waiters on any IMPORT that grants new caps,
Jeff Layton
[PATCH v6 0/1] ceph: add support for getvxattr op,
Milind Changire
[PATCH 0/9] Remove remaining parts of congestions tracking code.,
NeilBrown
- [PATCH 1/9] Remove inode_congested(), NeilBrown
- [PATCH 2/9] Remove bdi_congested() and wb_congested() and related functions, NeilBrown
- [PATCH 3/9] f2fs: change retry waiting for f2fs_write_single_data_page(), NeilBrown
- [PATCH 4/9] f2f2: replace some congestion_wait() calls with io_schedule_timeout(), NeilBrown
- [PATCH 5/9] cephfs: don't set/clear bdi_congestion, NeilBrown
- [PATCH 6/9] fuse: don't set/clear bdi_congested, NeilBrown
- [PATCH 7/9] NFS: remove congestion control., NeilBrown
- [PATCH 8/9] block/bfq-iosched.c: use "false" rather than "BLK_RW_ASYNC", NeilBrown
- [PATCH 9/9] Remove congestion tracking framework., NeilBrown
- Re: [PATCH 0/9] Remove remaining parts of congestions tracking code., Andrew Morton
- Re: [PATCH 0/9] Remove remaining parts of congestions tracking code., Jens Axboe
[PATCH] security, lsm: dentry_init_security() Handle multi LSM registration,
Vivek Goyal
[PATCH v2] ceph: set pool_ns in new inode layout for async creates,
Jeff Layton
[PATCH] ceph: set pool_ns in new inode layout for async creates,
Jeff Layton
[PATCH] ceph: properly put ceph_string reference after async create attempt,
Jeff Layton
Re: "kernel NULL pointer dereference" crash when attempting a write,
Paul Moore
[PATCH v5 0/1] add getvxattr op,
Milind Changire
[PATCH AUTOSEL 5.10 4/9] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
[PATCH AUTOSEL 5.15 08/16] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
[PATCH AUTOSEL 5.16 08/19] ceph: don't check for quotas on MDS stray dirs, Sasha Levin
Ceph build with old glibc version., mhnx
[GIT PULL] fscache: Fixes and minor updates for rewrite,
David Howells
[PATCH v3 0/3] ceph: uninline data on open instead of write,
Jeff Layton
[RFC][PATCH] cachefiles: Split and rename S_KERNEL_FILE and extend effects,
David Howells
[GIT PULL] Ceph updates for 5.17-rc1,
Ilya Dryomov
[PATCH 00/11] fscache, cachefiles: Rewrite fixes/updates,
David Howells
- [PATCH 01/11] fscache: Fix the volume collision wait condition, David Howells
- [PATCH 02/11] cachefiles: Calculate the blockshift in terms of bytes, not pages, David Howells
- [PATCH 03/11] cachefiles: set default tag name if it's unspecified, David Howells
- [PATCH 04/11] cachefiles: Make some tracepoint adjustments, David Howells
- [PATCH 05/11] cachefiles: Trace active-mark failure, David Howells
- [PATCH 06/11] cachefiles: Explain checks in a comment, David Howells
- [PATCH 07/11] cachefiles: Check that the backing filesystem supports tmpfiles, David Howells
- [PATCH 08/11] fscache: Add a comment explaining how page-release optimisation works, David Howells
- [PATCH 10/11] netfs: Make ops->init_rreq() optional, David Howells
- [PATCH 09/11] vfs, fscache: Add an IS_KERNEL_FILE() macro for the S_KERNEL_FILE flag, David Howells
- [PATCH 11/11] cifs: Support fscache indexing rewrite, David Howells
[PATCH 1/3] ceph: Make ceph_netfs_issue_op() handle inlined data (untested),
David Howells
[PATCH 1/3] ceph: Uninline the data on a file opened for writing,
David Howells
[Index of Archives]
[Ceph Users]
[Ceph Dev]
[Ceph Large]
[Linux USB Devel]
[Big List of Linux Books]
[Linux SCSI]
[Yosemite Forum]