Linux Hyperv
[Prev Page][Next Page]
- [PATCH hyperv-next v2 1/5] hv_sock: Check hv_pkt_iter_first_raw()'s return value, (continued)
- [RFC PATCH 0/2] swiotlb: Introduce swiotlb device allocation function,
Tianyu Lan
- [PATCH 00/30] The panic notifiers refactor,
Guilherme G. Piccoli
- [PATCH 03/30] notifier: Add panic notifiers info and purge trailing whitespaces, Guilherme G. Piccoli
- [PATCH 04/30] firmware: google: Convert regular spinlock into trylock on panic path, Guilherme G. Piccoli
- [PATCH 06/30] soc: bcm: brcmstb: Document panic notifier action and remove useless header, Guilherme G. Piccoli
- [PATCH 05/30] misc/pvpanic: Convert regular spinlock into trylock on panic path, Guilherme G. Piccoli
- [PATCH 01/30] x86/crash,reboot: Avoid re-disabling VMX in all CPUs on crash/restart, Guilherme G. Piccoli
- [PATCH 08/30] powerpc/setup: Refactor/untangle panic notifiers, Guilherme G. Piccoli
- [PATCH 07/30] mips: ip22: Reword PANICED to PANICKED and remove useless header, Guilherme G. Piccoli
- [PATCH 02/30] ARM: kexec: Disable IRQs/FIQs also on crash CPUs shutdown path, Guilherme G. Piccoli
- [PATCH 10/30] alpha: Clean-up the panic notifier code, Guilherme G. Piccoli
- [PATCH 09/30] coresight: cpu-debug: Replace mutex with mutex_trylock on panic notifier, Guilherme G. Piccoli
- [PATCH 11/30] um: Improve panic notifiers consistency and ordering, Guilherme G. Piccoli
- [PATCH 12/30] parisc: Replace regular spinlock with spin_trylock on panic path, Guilherme G. Piccoli
- [PATCH 13/30] s390/consoles: Improve panic notifiers reliability, Guilherme G. Piccoli
- [PATCH 18/30] notifier: Show function names on notifier routines if DEBUG_NOTIFIERS is set, Guilherme G. Piccoli
- [PATCH 16/30] drivers/hv/vmbus, video/hyperv_fb: Untangle and refactor Hyper-V panic notifiers, Guilherme G. Piccoli
- [PATCH 20/30] panic: Add the panic informational notifier list, Guilherme G. Piccoli
- [PATCH 17/30] tracing: Improve panic/die notifiers, Guilherme G. Piccoli
- [PATCH 14/30] panic: Properly identify the panic event to the notifiers' callbacks, Guilherme G. Piccoli
- [PATCH 19/30] panic: Add the panic hypervisor notifier list, Guilherme G. Piccoli
- [PATCH 15/30] bus: brcmstb_gisb: Clean-up panic/die notifiers, Guilherme G. Piccoli
- [PATCH 21/30] panic: Introduce the panic pre-reboot notifier list, Guilherme G. Piccoli
- [PATCH 24/30] panic: Refactor the panic path, Guilherme G. Piccoli
- [PATCH 22/30] panic: Introduce the panic post-reboot notifier list, Guilherme G. Piccoli
- [PATCH 23/30] printk: kmsg_dump: Introduce helper to inform number of dumpers, Guilherme G. Piccoli
- [PATCH 27/30] powerpc: Do not force all panic notifiers to execute before kdump, Guilherme G. Piccoli
- [PATCH 25/30] panic, printk: Add console flush parameter and convert panic_print to a notifier, Guilherme G. Piccoli
- [PATCH 29/30] powerpc: ps3, pseries: Avoid duplicate call to kmsg_dump() on panic, Guilherme G. Piccoli
- [PATCH 28/30] panic: Unexport crash_kexec_post_notifiers, Guilherme G. Piccoli
- [PATCH 26/30] Drivers: hv: Do not force all panic notifiers to execute before kdump, Guilherme G. Piccoli
- [PATCH 30/30] um: Avoid duplicate call to kmsg_dump(), Guilherme G. Piccoli
- [PATCH v2 0/2] kernel: add new infrastructure for platform_has() support,
Juergen Gross
- [PATCH] PCI: hv: Fix hv_arch_irq_unmask() for multi-MSI,
Jeffrey Hugo
- [PATCH] video: hyperv_fb: Allow resolutions with size > 64 MB for Gen1,
Saurabh Sengar
- [PATCH v2 0/5] hv_sock: Hardening changes,
Andrea Parri (Microsoft)
- [PATCH 0/2] kernel: add new infrastructure for platform_has() support,
Juergen Gross
- [PATCH 0/5] hv_sock: Hardening changes,
Andrea Parri (Microsoft)
- [PATCH] PCI: hv: Do not set PCI_COMMAND_MEMORY to reduce VM boot time,
Dexuan Cui
- [PATCH v2 0/6] PCI: hv: VMbus requestor and related fixes,
Andrea Parri (Microsoft)
- [PATCH v7 00/12] Fix broken usage of driver_override (and kfree of static memory),
Krzysztof Kozlowski
- [PATCH v7 06/12] s390/cio: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v7 05/12] PCI: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v7 04/12] hv: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v7 02/12] amba: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v7 07/12] spi: Use helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v7 01/12] driver: platform: Add helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v7 09/12] clk: imx: scu: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v7 08/12] vdpa: Use helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v7 03/12] fsl-mc: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v7 10/12] slimbus: qcom-ngd: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v7 11/12] rpmsg: Constify local variable in field store macro, Krzysztof Kozlowski
- [PATCH v7 12/12] rpmsg: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- Re: [PATCH v7 00/12] Fix broken usage of driver_override (and kfree of static memory), Krzysztof Kozlowski
[PATCH 5.4 004/475] hv: utils: add PTP_1588_CLOCK to Kconfig to fix build,
Greg Kroah-Hartman
[PATCH v3 00/34] KVM: x86: hyper-v: Fine-grained TLB flush + L2 TLB flush feature,
Vitaly Kuznetsov
- [PATCH v3 06/34] KVM: x86: Prepare kvm_hv_flush_tlb() to handle L2's GPAs, Vitaly Kuznetsov
- [PATCH v3 32/34] KVM: selftests: Move Hyper-V VP assist page enablement out of evmcs.h, Vitaly Kuznetsov
- [PATCH v3 13/34] KVM: nSVM: Keep track of Hyper-V hv_vm_id/hv_vp_id, Vitaly Kuznetsov
- [PATCH v3 01/34] KVM: x86: hyper-v: Resurrect dedicated KVM_REQ_HV_TLB_FLUSH flag, Vitaly Kuznetsov
- [PATCH v3 07/34] x86/hyperv: Introduce HV_MAX_SPARSE_VCPU_BANKS/HV_VCPUS_PER_SPARSE_BANK constants, Vitaly Kuznetsov
- [PATCH v3 21/34] KVM: nSVM: hyper-v: Enable L2 TLB flush, Vitaly Kuznetsov
- [PATCH v3 05/34] KVM: x86: hyper-v: Expose support for extended gva ranges for flush hypercalls, Vitaly Kuznetsov
- [PATCH v3 19/34] KVM: nVMX: hyper-v: Enable L2 TLB flush, Vitaly Kuznetsov
- [PATCH v3 17/34] KVM: x86: hyper-v: Introduce fast kvm_hv_l2_tlb_flush_exposed() check, Vitaly Kuznetsov
- [PATCH v3 08/34] KVM: x86: hyper-v: Use HV_MAX_SPARSE_VCPU_BANKS/HV_VCPUS_PER_SPARSE_BANK instead of raw '64', Vitaly Kuznetsov
- [PATCH v3 24/34] KVM: selftests: Hyper-V PV IPI selftest, Vitaly Kuznetsov
- [PATCH v3 30/34] KVM: selftests: Sync 'struct hv_vp_assist_page' definition with hyperv-tlfs.h, Vitaly Kuznetsov
- [PATCH v3 14/34] KVM: x86: Introduce .post_hv_l2_tlb_flush() nested hook, Vitaly Kuznetsov
- [PATCH v3 31/34] KVM: selftests: evmcs_test: Introduce L2 TLB flush test, Vitaly Kuznetsov
- [PATCH v3 10/34] KVM: x86: hyper-v: Create a separate ring for L2 TLB flush, Vitaly Kuznetsov
- [PATCH v3 23/34] KVM: selftests: Better XMM read/write helpers, Vitaly Kuznetsov
- [PATCH v3 25/34] KVM: selftests: Make it possible to replace PTEs with __virt_pg_map(), Vitaly Kuznetsov
- [PATCH v3 12/34] KVM: nVMX: Keep track of hv_vm_id/hv_vp_id when eVMCS is in use, Vitaly Kuznetsov
- [PATCH v3 26/34] KVM: selftests: Hyper-V PV TLB flush selftest, Vitaly Kuznetsov
- [PATCH v3 27/34] KVM: selftests: Sync 'struct hv_enlightened_vmcs' definition with hyperv-tlfs.h, Vitaly Kuznetsov
- [PATCH v3 33/34] KVM: selftests: hyperv_svm_test: Introduce L2 TLB flush test, Vitaly Kuznetsov
- [PATCH v3 04/34] KVM: x86: hyper-v: Handle HVCALL_FLUSH_VIRTUAL_ADDRESS_LIST{,EX} calls gently, Vitaly Kuznetsov
- [PATCH v3 03/34] KVM: x86: hyper-v: Add helper to read hypercall data for array, Vitaly Kuznetsov
- [PATCH v3 22/34] KVM: x86: Expose Hyper-V L2 TLB flush feature, Vitaly Kuznetsov
- [PATCH v3 34/34] KVM: x86: Rename 'enable_direct_tlbflush' to 'enable_l2_tlb_flush', Vitaly Kuznetsov
- [PATCH v3 15/34] KVM: x86: hyper-v: Introduce kvm_hv_is_tlb_flush_hcall(), Vitaly Kuznetsov
- [PATCH v3 02/34] KVM: x86: hyper-v: Introduce TLB flush ring, Vitaly Kuznetsov
- [PATCH v3 20/34] KVM: x86: KVM_REQ_TLB_FLUSH_CURRENT is a superset of KVM_REQ_HV_TLB_FLUSH too, Vitaly Kuznetsov
- [PATCH v3 11/34] KVM: x86: hyper-v: Use preallocated buffer in 'struct kvm_vcpu_hv' instead of on-stack 'sparse_banks', Vitaly Kuznetsov
- [PATCH v3 18/34] x86/hyperv: Fix 'struct hv_enlightened_vmcs' definition, Vitaly Kuznetsov
- [PATCH v3 28/34] KVM: selftests: nVMX: Allocate Hyper-V partition assist page, Vitaly Kuznetsov
- [PATCH v3 16/34] KVM: x86: hyper-v: L2 TLB flush, Vitaly Kuznetsov
- [PATCH v3 29/34] KVM: selftests: nSVM: Allocate Hyper-V partition assist and VP assist pages, Vitaly Kuznetsov
- [PATCH v3 09/34] KVM: x86: hyper-v: Don't use sparse_set_to_vcpu_mask() in kvm_hv_send_ipi(), Vitaly Kuznetsov
- Re: [PATCH v3 00/34] KVM: x86: hyper-v: Fine-grained TLB flush + L2 TLB flush feature, Vitaly Kuznetsov
[PATCH 4.19 003/338] hv: utils: add PTP_1588_CLOCK to Kconfig to fix build,
Greg Kroah-Hartman
[RFC PATCH 0/6] hv_sock: Hardening changes,
Andrea Parri (Microsoft)
[PATCH v2] PCI: hv: Fix multi-MSI to allow more than one MSI vector,
Jeffrey Hugo
[PATCH 1/1] Drivers: hv: vmbus: Add VMbus IMC device to unsupported list,
Michael Kelley
[PATCH] PCI: hv: Fix multi-MSI to allow more than one MSI vector,
Jeffrey Hugo
[PATCH v4] drm/hyperv: Add error message for fb size greater than allocated,
Saurabh Sengar
[PATCH AUTOSEL 4.14 03/11] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH AUTOSEL 5.4 06/21] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH AUTOSEL 4.19 03/12] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH AUTOSEL 5.10 10/30] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH AUTOSEL 5.15 25/41] Drivers: hv: balloon: Disable balloon and hot-add accordingly, Sasha Levin
[PATCH AUTOSEL 5.15 13/41] PCI: hv: Propagate coherence from VMbus device to PCI device, Sasha Levin
[PATCH AUTOSEL 5.15 12/41] Drivers: hv: vmbus: Deactivate sysctl_record_panic_msg by default in isolated guests, Sasha Levin
[PATCH AUTOSEL 5.15 14/41] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH AUTOSEL 5.17 13/49] Drivers: hv: vmbus: Deactivate sysctl_record_panic_msg by default in isolated guests, Sasha Levin
[PATCH AUTOSEL 5.17 31/49] Drivers: hv: balloon: Disable balloon and hot-add accordingly, Sasha Levin
[PATCH AUTOSEL 5.17 14/49] Drivers: hv: vmbus: Propagate VMbus coherence to each VMbus device, Sasha Levin
[PATCH AUTOSEL 5.17 15/49] PCI: hv: Propagate coherence from VMbus device to PCI device, Sasha Levin
[PATCH AUTOSEL 5.17 16/49] Drivers: hv: vmbus: Prevent load re-ordering when reading ring buffer, Sasha Levin
[PATCH v3] drm/hyperv: Added error message for fb size greater than allocated,
Saurabh Sengar
[PATCH net-next] hv_netvsc: Add support for XDP_REDIRECT,
Haiyang Zhang
[GIT PULL] Hyper-V fixes for 5.18-rc2,
Wei Liu
[PATCH v2] drm/hyperv: Added error message for fb size greater then allocated,
Saurabh Sengar
[PATCH] drm/hyperv: Added error message for fb size greater then allocated, Saurabh Sengar
[PATCH 0/2] storvsc, netvsc: Improve logging,
Andrea Parri (Microsoft)
[PATCH 0/6] PCI: hv: VMbus requestor and related fixes,
Andrea Parri (Microsoft)
[PATCH net-next 1/3] net: hyperv: remove use of bpf_op_t,
Jakub Kicinski
[PATCH 5.10 004/599] hv: utils: add PTP_1588_CLOCK to Kconfig to fix build, Greg Kroah-Hartman
[PATCH 5.15 007/913] hv: utils: add PTP_1588_CLOCK to Kconfig to fix build, Greg Kroah-Hartman
cleanup swiotlb initialization v8,
Christoph Hellwig
- [PATCH 01/15] dma-direct: use is_swiotlb_active in dma_direct_map_page, Christoph Hellwig
- [PATCH 03/15] swiotlb: simplify swiotlb_max_segment, Christoph Hellwig
- [PATCH 02/15] swiotlb: make swiotlb_exit a no-op if SWIOTLB_FORCE is set, Christoph Hellwig
- [PATCH 04/15] swiotlb: rename swiotlb_late_init_with_default_size, Christoph Hellwig
- [PATCH 05/15] arm/xen: don't check for xen_initial_domain() in xen_create_contiguous_region, Christoph Hellwig
- [PATCH 07/15] x86: remove the IOMMU table infrastructure, Christoph Hellwig
- [PATCH 08/15] x86: centralize setting SWIOTLB_FORCE when guest memory encryption is enabled, Christoph Hellwig
- [PATCH 06/15] MIPS/octeon: use swiotlb_init instead of open coding it, Christoph Hellwig
- [PATCH 11/15] swiotlb: pass a gfp_mask argument to swiotlb_init_late, Christoph Hellwig
- [PATCH 09/15] swiotlb: make the swiotlb_init interface more useful, Christoph Hellwig
[PATCH 10/15] swiotlb: add a SWIOTLB_ANY flag to lift the low memory restriction, Christoph Hellwig
[PATCH 12/15] swiotlb: provide swiotlb_init variants that remap the buffer, Christoph Hellwig
[PATCH 14/15] swiotlb: remove swiotlb_init_with_tbl and swiotlb_init_late_with_tbl, Christoph Hellwig
[PATCH 13/15] swiotlb: merge swiotlb-xen initialization into swiotlb, Christoph Hellwig
[PATCH 15/15] x86: remove cruft from <asm/dma-mapping.h>, Christoph Hellwig
Message not available
Re: cleanup swiotlb initialization v8, Boris Ostrovsky
Re: cleanup swiotlb initialization v8, Konrad Rzeszutek Wilk
Re: cleanup swiotlb initialization v8, Christoph Hellwig
[PATCH v6 00/12] Fix broken usage of driver_override (and kfree of static memory),
Krzysztof Kozlowski
- [PATCH v6 01/12] driver: platform: Add helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v6 02/12] amba: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v6 03/12] fsl-mc: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v6 04/12] hv: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v6 05/12] PCI: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v6 06/12] s390/cio: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v6 07/12] spi: Use helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v6 08/12] vdpa: Use helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v6 12/12] rpmsg: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v6 11/12] rpmsg: Constify local variable in field store macro, Krzysztof Kozlowski
- [PATCH v6 09/12] clk: imx: scu: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v6 10/12] slimbus: qcom-ngd: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
[PATCH] Drivers: hv: vmbus: Replace smp_store_mb() with virt_store_mb(),
Andrea Parri (Microsoft)
[RFC PATCH 0/4] PCI: hv: Miscellaneous changes,
Andrea Parri (Microsoft)
Backport fix for 5.15: hv: utils: add PTP_1588_CLOCK to Kconfig to fix build,
Petr Štetiar
[PATCH 1/1] hv: drivers: vmbus: Prevent load re-ordering when reading ring buffer,
Michael Kelley
[PATCH v2 0/2] Drivers: hv: balloon: Temporary fixes for ARM64,
Boqun Feng
[PATCH v3 0/2] Fix coherence for VMbus and PCI pass-thru devices in Hyper-V VM,
Michael Kelley
[PATCH v2 0/2] Fix coherence for VMbus and PCI pass-thru devices in Hyper-V VM,
Michael Kelley
[GIT PULL] Hyper-V next for 5.18,
Wei Liu
[PATCH 0/2] PCI: hv: Miscellaneous changes,
Andrea Parri (Microsoft)
[PATCH 0/4 RESEND] Fix coherence for VMbus and PCI pass-thru devices in Hyper-V VM,
Michael Kelley
[PATCH 0/4] Fix coherence for VMbus and PCI pass-thru devices in Hyper-V VM,
Michael Kelley
[PATCH -next] PCI: hv: Remove unused function hv_set_msi_entry_from_desc(),
YueHaibing
[PATCH v5 00/11] Fix broken usage of driver_override (and kfree of static memory),
Krzysztof Kozlowski
- [PATCH v5 01/11] driver: platform: Add helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v5 04/11] hv: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v5 05/11] PCI: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v5 02/11] amba: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v5 03/11] fsl-mc: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v5 06/11] s390/cio: Use driver_set_override() instead of open-coding, Krzysztof Kozlowski
- [PATCH v5 07/11] spi: Use helper for safer setting of driver_override, Krzysztof Kozlowski
- [PATCH v5 09/11] clk: imx: scu: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v5 11/11] rpmsg: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v5 10/11] slimbus: qcom-ngd: Fix kfree() of static memory on setting driver_override, Krzysztof Kozlowski
- [PATCH v5 08/11] vdpa: Use helper for safer setting of driver_override, Krzysztof Kozlowski
[PATCH] Drivers: hv: vmbus: Fix potential crash on module unload,
Guilherme G. Piccoli
[PATCH v2] Drivers: hv: vmbus: Fix initialization of device object in vmbus_device_register(),
Andrea Parri (Microsoft)
swiotlb: remove swiotlb_init_with_tbl and swiotlb_init_late_with_tbl, Christoph Hellwig
cleanup swiotlb initialization v5,
Christoph Hellwig
[Index of Archives]
[Linux Samsung SoC]
[Linux Actions SoC]
[Linux Rockchip SoC]
[Linux for Synopsys ARC Processors]
[Linux USB Devel]
[Video for Linux]
[Linux SCSI]
[Yosemite Forum]