Linux SCSI Development
[Prev Page][Next Page]
[PATCH v3] scsi: target: tcmu: add compat mode for 32bit userspace on 64bit kernel, Bodo Stroesser
[PATCH] scsi: clear UAC before sending SG_IO,
Randall Huang
[PATCH] lpfc: drop nodelist reference on error in lpfc_gen_req(),
Hannes Reinecke
[PATCH V7] scsi: core: only re-run queue in scsi_end_request() if device queue is busy,
Ming Lei
[PATCH v2 0/3] Improve error handling,
Damien Le Moal
[PATCH 0/3] Improve error handling,
Damien Le Moal
[PATCH] scsi: ipr: Switch to using the new API kobj_to_dev(),
Tian Tao
[PATCH] scsi: ufs-mediatek: Fix build warnings with make W=1,
Stanley Chu
[PATCH v2] scsi: ufs: Fix 'unmet direct dependencies' config warning, Alim Akhtar
[trivial PATCH] treewide: Convert switch/case fallthrough; to break;,
Joe Perches
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Gustavo A. R. Silva
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Keith Busch
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Jason Gunthorpe
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Mauro Carvalho Chehab
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Wolfram Sang
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Nicolas.Ferre
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Felipe Balbi
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Steffen Maier
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Ilya Dryomov
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Matthias Brugger
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Robin Murphy
- Re: [Intel-gfx] [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Jani Nikula
- Re: [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Miquel Raynal
- Re: [oss-drivers] [trivial PATCH] treewide: Convert switch/case fallthrough; to break;, Simon Horman
[PATCH] scsi: aic7xxx: Use kmemdup in two places,
Alex Dewar
fix for kernel BUG at drivers/scsi/device_handler/scsi_dh_alua.c:662!,
Brian Bunker
[PATCH] MAINTAINERS: Drop megaraidlinux.pdl@xxxxxxxxxxxx from MEGARAID SCSI/SAS DRIVERS,
Bjorn Helgaas
[PATCH -next] scsi: aic94xx: Remove unused inline function,
YueHaibing
[PATCH] scsi: esas2r: prevent a potential NULL dereference in esas2r_probe(),
Jing Xiangfeng
[PATCH] scsi: lpfc: Remove set but not used 'qp', Ye Bin
[PATCH] scsi: gdth: Remove set but used 'cmd_index',
Ye Bin
[PATCH V6] scsi: core: only re-run queue in scsi_end_request() if device queue is busy,
Ming Lei
Using MPI2_TOOLBOX_BEACON_TOOL from userspace, Dmitry Antipov
Fwd: [RFC PATCH 00/39] blktrace: add block trace extension support, Chaitanya Kulkarni
[PATCH 1/3] scsi: aacraid: improve compat_ioctl handlers,
Arnd Bergmann
[GIT PULL] SCSI fixes for 5.9-rc4,
James Bottomley
rework check_disk_change() v2,
Christoph Hellwig
- [PATCH 06/19] swim: simplify media change handling, Christoph Hellwig
- [PATCH 04/19] floppy: use bdev_check_media_change, Christoph Hellwig
- [PATCH 01/19] block: add a bdev_check_media_change helper, Christoph Hellwig
- [PATCH 16/19] sd: use bdev_check_media_change, Christoph Hellwig
- [PATCH 17/19] sr: use bdev_check_media_change, Christoph Hellwig
- [PATCH 02/19] amiflop: use bdev_check_media_change, Christoph Hellwig
- [PATCH 10/19] paride/pcd: use bdev_check_media_change, Christoph Hellwig
- [PATCH 09/19] xsysace: simplify media change handling, Christoph Hellwig
- [PATCH 08/19] xsysace: use bdev_check_media_change, Christoph Hellwig
- [PATCH 14/19] ide-gd: stop using the disk events mechanism, Christoph Hellwig
- [PATCH 15/19] md: use bdev_check_media_change, Christoph Hellwig
- [PATCH 13/19] ide-cd: remove idecd_revalidate_disk, Christoph Hellwig
- [PATCH 03/19] ataflop: use bdev_check_media_change, Christoph Hellwig
- [PATCH 12/19] ide-cd: use bdev_check_media_changed, Christoph Hellwig
- [PATCH 18/19] sr: simplify sr_block_revalidate_disk, Christoph Hellwig
- [PATCH 07/19] swim3: use bdev_check_media_changed, Christoph Hellwig
- [PATCH 05/19] swim: use bdev_check_media_change, Christoph Hellwig
- [PATCH 19/19] block: remove check_disk_change, Christoph Hellwig
- [PATCH 11/19] gdrom: use bdev_check_media_change, Christoph Hellwig
- Re: rework check_disk_change() v2, Jens Axboe
[PATCH v2] scsi: hpsa: fix memory leak in hpsa_init_one, Keita Suzuki
[PATCH 0/2] Fix automatic CD tray loading for data reading via sr,
Thomas Schmitt
[PATCH] scsi: hpsa: fix memory leak in hpsa_init_one, Keita Suzuki
[PATCH v2 0/8] qedi: Misc bug fixes and enhancements,
Manish Rangankar
- [PATCH v2 1/8] qedi: Use qed count from set_fp_int in msix allocation., Manish Rangankar
- [PATCH v2 2/8] qedi: Skip f/w connection termination for pci shutdown handler., Manish Rangankar
- [PATCH v2 3/8] qedi: Fix list_del corruption while removing active IO, Manish Rangankar
- [PATCH v2 4/8] qedi: Protect active command list to avoid list corruption, Manish Rangankar
- [PATCH v2 5/8] qedi: Use snprintf instead of sprintf, Manish Rangankar
- [PATCH v2 6/8] qedi: Mark all connections for recovery on link down event, Manish Rangankar
- [PATCH v2 7/8] qedi: Add firmware error recovery invocation support., Manish Rangankar
- [PATCH v2 8/8] qedi: Add support for handling the pcie errors., Manish Rangankar
- Re: [PATCH v2 0/8] qedi: Misc bug fixes and enhancements, Martin K. Petersen
- Re: [PATCH v2 0/8] qedi: Misc bug fixes and enhancements, Martin K. Petersen
[PATCH v3 0/4] qla2xxx: A couple crash fixes,
Daniel Wagner
[PATCH 0/4] scsi: ufs-mediatek: Fixes for kernel v5.10,
Stanley Chu
[PATCH 0/8] qedi: Misc bug fixes and enhancements,
Manish Rangankar
[PATCH AUTOSEL 5.8 10/53] scsi: qedf: Fix null ptr reference in qedf_stag_change_work, Sasha Levin
[PATCH v7 0/3] Drivers: hv: vmbus: vmbus_requestor data structure for VMBus hardening,
Andrea Parri (Microsoft)
[PATCH] scsi: take module reference during async scan,
Tomas Henzl
[PATCH] scsi: ibmvfc: Fix error return in ibmvfc_probe(),
Jing Xiangfeng
[PATCH 0/4] scsi: qla1280: some code cleanups to shut up robots,
Jason Yan
[PATCH V5] scsi: core: only re-run queue in scsi_end_request() if device queue is busy,
Ming Lei
[PATCH 0/9] Rework runtime suspend and SCSI domain validation,
Bart Van Assche
- [PATCH 1/9] block: Fix a race in the runtime power management code, Bart Van Assche
- [PATCH 2/9] ide: Do not set the RQF_PREEMPT flag for sense requests, Bart Van Assche
- [PATCH 3/9] scsi: Pass a request queue pointer to __scsi_execute(), Bart Van Assche
- [PATCH 5/9] scsi: Do not wait for a request in scsi_eh_lock_door(), Bart Van Assche
- [PATCH 6/9] scsi_transport_spi: Make spi_execute() accept a request queue pointer, Bart Van Assche
- [PATCH 7/9] scsi_transport_spi: Freeze request queues instead of quiescing, Bart Van Assche
- [PATCH 4/9] scsi: Rework scsi_mq_alloc_queue(), Bart Van Assche
- [PATCH 9/9] block: Do not accept any requests while suspended, Bart Van Assche
- [PATCH 8/9] block, scsi, ide: Only process PM requests if rpm_status != RPM_ACTIVE, Bart Van Assche
- Re: [PATCH 0/9] Rework runtime suspend and SCSI domain validation, Alan Stern
- Re: [PATCH 0/9] Rework runtime suspend and SCSI domain validation, Bart Van Assche
[PATCH] scsi: docs: Remove obsolete scsi typedef text from scsi_mid_low_api,
Nícolas F. R. A. Prado
[PATCH] scsi: libsas: Fix error path in sas_notify_lldd_dev_found(),
Dan Carpenter
[PATCH v4 0/2] ufs: introduce skipping manual flush for wb,
Kiwoong Kim
Message not available
Re: [PATCH v4 0/2] ufs: introduce skipping manual flush for wb, Asutosh Das (asd)
Re: [PATCH v4 0/2] ufs: introduce skipping manual flush for wb, Martin K. Petersen
[PATCH v7 0/2] ufs: exynos: introduce the way to get cmd info,
Kiwoong Kim
Message not available
[PATCH v3 1/2] scsi: ibmvfc: use compiler attribute defines instead of __attribute__(),
Tyrel Datwyler
LSI 9201-16e regression ?, sgmihai
[PATCH v3 00/13] qla2xxx misc features and bug fixes,
Nilesh Javali
- [PATCH v3 01/13] qla2xxx: Fix I/O failures during remote port toggle testing, Nilesh Javali
- [PATCH v3 02/13] qla2xxx: Setup debugfs entries for remote ports, Nilesh Javali
- [PATCH v3 03/13] qla2xxx: Allow dev_loss_tmo setting for FC-NVMe devices, Nilesh Javali
- [PATCH v3 04/13] qla2xxx: Honor status qualifier in FCP_RSP per spec, Nilesh Javali
- [PATCH v3 05/13] qla2xxx: Reduce duplicate code in reporting speed, Nilesh Javali
- [PATCH v3 06/13] qla2xxx: Fix memory size truncation, Nilesh Javali
- [PATCH v3 07/13] qla2xxx: performance tweak, Nilesh Javali
- [PATCH v3 08/13] qla2xxx: Fix I/O errors during LIP reset tests, Nilesh Javali
- [PATCH v3 09/13] qla2xxx: Make tgt_port_database available in initiator mode, Nilesh Javali
- [PATCH v3 10/13] qla2xxx: Add rport fields in debugfs, Nilesh Javali
- [PATCH v3 11/13] qla2xxx: Add IOCB resource tracking, Nilesh Javali
- [PATCH v3 12/13] qla2xxx: Add SLER and PI control support, Nilesh Javali
- [PATCH v3 13/13] qla2xxx: Update version to 10.02.00.102-k, Nilesh Javali
- Re: [PATCH v3 00/13] qla2xxx misc features and bug fixes, Martin K. Petersen
About BLKSECTGET in sg,
Tom Yan
[PATCH v2] scsi: target: tcmu: add compat mode for 32bit userspace on 64bit kernel,
Bodo Stroesser
[RFC] add io_uring support in scsi layer,
Kashyap Desai
[PATCH RFC 0/3] scsi: mpt: Refactor and port to dma_* interface,
Alex Dewar
[PATCH] scsi: target: tcmu: add a missing newline when printing parameters,
Xiongfeng Wang
simplify gendisk lookup and remove struct block_device aliases v3,
Christoph Hellwig
- [PATCH 01/19] char_dev: replace cdev_map with an xarray, Christoph Hellwig
- [PATCH 05/19] block: rework requesting modules for unclaimed devices, Christoph Hellwig
- [PATCH 10/19] brd: use __register_blkdev to allocate devices on demand, Christoph Hellwig
- [PATCH 16/19] ataflop: use a separate gendisk for each media format, Christoph Hellwig
- [PATCH 18/19] z2ram: use separate gendisk for the different modes, Christoph Hellwig
- [PATCH 19/19] block: switch gendisk lookup to a simple xarray, Christoph Hellwig
- [PATCH 17/19] z2ram: reindent, Christoph Hellwig
- [PATCH 15/19] amiflop: use separate gendisks for Amiga vs MS-DOS mode, Christoph Hellwig
- [PATCH 14/19] floppy: use a separate gendisk for each media format, Christoph Hellwig
- [PATCH 13/19] ide: switch to __register_blkdev for command set probing, Christoph Hellwig
- [PATCH 12/19] md: use __register_blkdev to allocate devices on demand, Christoph Hellwig
- [PATCH 11/19] loop: use __register_blkdev to allocate devices on demand, Christoph Hellwig
- [PATCH 02/19] block: merge drivers/base/map.c into block/genhd.c, Christoph Hellwig
- [PATCH 09/19] sd: use __register_blkdev to avoid a modprobe for an unregistered dev_t, Christoph Hellwig
- [PATCH 08/19] swim: don't call blk_register_region, Christoph Hellwig
- [PATCH 07/19] ide: remove ide_{,un}register_region, Christoph Hellwig
- [PATCH 06/19] block: add an optional probe callback to major_names, Christoph Hellwig
- [PATCH 03/19] block: cleanup del_gendisk a bit, Christoph Hellwig
- [PATCH 04/19] block: split block_class_lock, Christoph Hellwig
clean up is partition checks,
Christoph Hellwig
- [PATCH 9/9] vsprintf: use bd_partno in bdev_name, Christoph Hellwig
- [PATCH 8/9] block: use bd_partno in bdevname, Christoph Hellwig
- [PATCH 6/9] drbd: don't set ->bd_contains, Christoph Hellwig
- [PATCH 7/9] target/iblock: fix holder printing in iblock_show_configfs_dev_params, Christoph Hellwig
- [PATCH 1/9] Documentation/hdio: fix up obscure bd_contains references, Christoph Hellwig
- [PATCH 5/9] drbd: don't detour through bd_contains for the gendisk, Christoph Hellwig
- [PATCH 4/9] md: don't detour through bd_contains for the gendisk, Christoph Hellwig
- [PATCH 2/9] block: add a bdev_is_partition helper, Christoph Hellwig
- [PATCH 3/9] md: compare bd_disk instead of bd_contains, Christoph Hellwig
- Re: clean up is partition checks, Christoph Hellwig
- Re: clean up is partition checks, Jens Axboe
[PATCH v4 1/3] scsi: 3w-9xxx: Use flexible array members to avoid struct padding,
Samuel Holland
SCSI staging branch,
Martin K. Petersen
[PATCH v2 0/2] Add UFS LINERESET handling,
Can Guo
[PATCH v2 0/3] scsi_debug: improve num_parts usage,
John Pittman
rework check_disk_change(),
Christoph Hellwig
- [PATCH 11/19] gdrom: use bdev_check_media_change, Christoph Hellwig
- [PATCH 13/19] ide-cd: remove idecd_revalidate_disk, Christoph Hellwig
- [PATCH 15/19] md: use bdev_check_media_change, Christoph Hellwig
- [PATCH 04/19] floppy: use bdev_check_media_change, Christoph Hellwig
- [PATCH 02/19] amiflop: use bdev_check_media_change, Christoph Hellwig
- [PATCH 16/19] sd: use bdev_check_media_change, Christoph Hellwig
- [PATCH 18/19] sr: simplify sr_block_revalidate_disk, Christoph Hellwig
- [PATCH 19/19] block: remove check_disk_change, Christoph Hellwig
- [PATCH 17/19] sr: use bdev_check_media_change, Christoph Hellwig
- [PATCH 07/19] swim3: use bdev_check_media_changed, Christoph Hellwig
- [PATCH 10/19] paride/pcd: use bdev_check_media_change, Christoph Hellwig
- [PATCH 05/19] swim: use bdev_check_media_change, Christoph Hellwig
- [PATCH 14/19] ide-gd: stop using the disk events mechanism, Christoph Hellwig
- [PATCH 03/19] ataflop: use bdev_check_media_change, Christoph Hellwig
- [PATCH 09/19] xsysace: simplify media change handling, Christoph Hellwig
- [PATCH 01/19] block: add a bdev_check_media_change helper, Christoph Hellwig
- [PATCH 12/19] ide-cd: use bdev_check_media_changed, Christoph Hellwig
- [PATCH 08/19] xsysace: use bdev_check_media_change, Christoph Hellwig
- [PATCH 06/19] swim: simplify media change handling, Christoph Hellwig
- Re: rework check_disk_change(), Douglas Gilbert
[PATCH] MAINTAINERS: update Marvell owned driver maintainers,
Nilesh Javali
[PATCH v2 00/13] qla2xxx misc features and bug fixes,
Nilesh Javali
- [PATCH v2 01/13] qla2xxx: Fix I/O failures during remote port toggle testing, Nilesh Javali
- [PATCH v2 02/13] qla2xxx: Setup debugfs entries for remote ports, Nilesh Javali
- [PATCH v2 03/13] qla2xxx: Allow dev_loss_tmo setting for FC-NVMe devices, Nilesh Javali
- [PATCH v2 04/13] qla2xxx: Honor status qualifier in FCP_RSP per spec, Nilesh Javali
- [PATCH v2 05/13] qla2xxx: Reduce duplicate code in reporting speed, Nilesh Javali
- [PATCH v2 06/13] qla2xxx: Fix memory size truncation, Nilesh Javali
- [PATCH v2 07/13] qla2xxx: performance tweak, Nilesh Javali
- [PATCH v2 08/13] qla2xxx: Fix I/O errors during LIP reset tests, Nilesh Javali
- [PATCH v2 09/13] qla2xxx: Make tgt_port_database available in initiator mode, Nilesh Javali
- [PATCH v2 10/13] qla2xxx: Add rport fields in debugfs, Nilesh Javali
- [PATCH v2 11/13] qla2xxx: Add IOCB resource tracking, Nilesh Javali
- [PATCH v2 12/13] qla2xxx: Add SLER and PI control support, Nilesh Javali
- [PATCH v2 13/13] qla2xxx: Update version to 10.02.00.102-k, Nilesh Javali
[PATCH] scsi: sym53c8xx_2: Delete useless if-else in sym_xerr_cam_status,
Ye Bin
[PATCH v11 0/4] scsi: ufs: Add Host Performance Booster Support,
Daejun Park
Message not available
Message not available
Message not available
Message not available
[PATCH] scsi: ufs: Fix NOP OUT timeout value,
Daejun Park
Re: [PATCH] scsi: ufs: Fix NOP OUT timeout value, Martin K. Petersen
Re: [PATCH] scsi: ufs: Fix NOP OUT timeout value, Martin K. Petersen
<Possible follow-ups>
RE: [PATCH] scsi: ufs: Fix NOP OUT timeout value, Daejun Park
[RFC v2 00/11] Hyper-V: Support PAGE_SIZE larger than 4K,
Boqun Feng
- [RFC v2 01/11] Drivers: hv: vmbus: Always use HV_HYP_PAGE_SIZE for gpadl, Boqun Feng
- [RFC v2 07/11] hv_netvsc: Use HV_HYP_PAGE_SIZE for Hyper-V communication, Boqun Feng
- [RFC v2 05/11] Drivers: hv: vmbus: Move virt_to_hvpfn() to hyperv header, Boqun Feng
- [RFC v2 06/11] hv: hyperv.h: Introduce some hvpfn helper functions, Boqun Feng
- [RFC v2 11/11] scsi: storvsc: Support PAGE_SIZE larger than 4K, Boqun Feng
- [RFC v2 10/11] Driver: hv: util: Make ringbuffer at least take two pages, Boqun Feng
- [RFC v2 09/11] HID: hyperv: Make ringbuffer at least take two pages, Boqun Feng
- [RFC v2 02/11] Drivers: hv: vmbus: Move __vmbus_open(), Boqun Feng
- [RFC v2 03/11] Drivers: hv: vmbus: Introduce types of GPADL, Boqun Feng
- [RFC v2 04/11] Drivers: hv: Use HV_HYP_PAGE in hv_synic_enable_regs(), Boqun Feng
- [RFC v2 08/11] Input: hyperv-keyboard: Make ringbuffer at least take two pages, Boqun Feng
KMSAN: uninit-value in scsi_mode_sense, syzbot
remove revalidate_disk(),
Christoph Hellwig
- [PATCH 7/9] sd: open code revalidate_disk, Christoph Hellwig
- [PATCH 5/9] block: use revalidate_disk_size in set_capacity_revalidate_and_notify, Christoph Hellwig
- [PATCH 8/9] nvdimm: simplify revalidate_disk handling, Christoph Hellwig
- [PATCH 9/9] block: remove revalidate_disk(), Christoph Hellwig
- [PATCH 6/9] nvme: opencode revalidate_disk in nvme_validate_ns, Christoph Hellwig
- [PATCH 3/9] block: rename bd_invalidated, Christoph Hellwig
- [PATCH 4/9] block: add a new revalidate_disk_size helper, Christoph Hellwig
- [PATCH 2/9] block: don't clear bd_invalidated in check_disk_size_change, Christoph Hellwig
- [PATCH 1/9] Documentation/filesystems/locking.rst: remove an incorrect sentence, Christoph Hellwig
- Re: remove revalidate_disk(), Josef Bacik
- Re: remove revalidate_disk(), Jens Axboe
[PATCH 0/8] hisi_sas: Misc patches,
John Garry
[PATCH] scsi: mpt3sas: Don't call disable_irq from IRQ poll handler,
Tomas Henzl
[PATCH v10 0/4] scsi: ufs: Add Host Performance Booster Support,
Daejun Park
Message not available
Message not available
Message not available
[PATCH v1 0/2] Supports Reading UFS's Vcc Voltage Levels from DT,
Bao D. Nguyen
[PATCH v1 1/1] scsi: ufshcd: Properly set the device Icc Level,
Bao D. Nguyen
Re: [PATCH v1 1/1] scsi: ufshcd: Properly set the device Icc Level, Bjorn Andersson
Re: [PATCH v1 1/1] scsi: ufshcd: Properly set the device Icc Level, nguyenb
Re: [PATCH v1 1/1] scsi: ufshcd: Properly set the device Icc Level, nguyenb
[PATCH v2] scsi: ibmvfc: interface updates for future FPIN and MQ support,
Tyrel Datwyler
[PATCH] scsi: add 256GBit speed setting to scsi fc transport,
James Smart
[PATCH] scsi: ibmvfc: interface updates for future FPIN and MQ support,
Tyrel Datwyler
[PATCH v2 0/4] qla2xxx: A couple crash fixes,
Daniel Wagner
"scheduling while atomic" BUG in iscsid since commit 1b66d253610c7, Marc Dionne
[PATCH 0/4] scsi: fnic: build warnings clean up,
Jason Yan
[PATCH RFC 0/6] Fix a deadlock in the SCSI power management code,
Bart Van Assche
simplify gendisk lookup and remove struct block_device aliases v2,
Christoph Hellwig
[Index of Archives]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[Linux ATA RAID]
[IETF Annouce]
[Git]
[Security]
[Netfilter]
[Bugtraq]