On 2020-09-21 11:23, Mike Christie wrote: > +bool vhost_vq_is_setup(struct vhost_virtqueue *vq) > +{ > + if (vq->avail && vq->desc && vq->used && vhost_vq_access_ok(vq)) > + return true; > + else > + return false; > +} Has it been considered changing the body of this function into "return vq->avail && vq->desc && vq->used && vhost_vq_access_ok(vq)"? I'm concerned otherwise one or another build bot will suggest to make that change. Thanks, Bart.