Re: Problem with dosemu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


No, you needed to create this file with the indicated content. Do you have
the sysctl.d directory? Actually, if you compile your kernel, you can
configure it so that it sets the fence pointer to the null pointer at
startup, I think,


On Tue, 22 Apr 2014, jankomEarthlink wrote:

Thanks Jegunn for your interest in helping with this issue.

On 04/21/2014 11:08 PM, Jegunn wrote:
Sorry to be so slow/indecisive, but is this not the old problem with
the memory fence pointer, which used to be fixable with the creation
of a file in /etc/sysctl.d/, say
I have an old, and somewhat mangled Fedora-3 distro and it does not have sysctl.d/90-low-memory-access.conf

Consequently I don't know how to make the mmap adjustment.

One also needed to
keep the kernel from randomizing virtual address space with

echo 0 > /proc/sys/kernel/randomize_va_space
I tried that but segfault is still there.

this with modern kernels because I run dosemu (1.4) on a 32-bit
My kernel is 2.6.20, configured and compiled by myself.

I just tried dosemu on the same box (32bit AMD) booted into xubuntu 12.04. I installed dosemu from ubuntu's software center. It was flawless, fast, and worked immediately.

CONCLUSION: there is nothing wrong with dosemu. My difficulty is probably due to kernel configuration.

I still would like to be able to compile and run it on my FC-3 boot environment as well. It is such a learning experience for me to discover and understand the inner workings of Unix/Linux/C world.


To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux