Re: Problem with dosemu

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Thank you, Franta, for getting back to this problem. In the meantime I ran strace and googled the issue and saw some bug reports on this segmentation fault. Here is the last part of the strace listing. (Btw., I'll try your rpm tomorrow, it is getting late here, and I have to clean up my system again before I install your rpm, and will let you know if it worked).

[apu@Andraslinux ~]$ strace dosemu
write(3, "PKT: Cannot open raw sockets: Pe"..., 48) = 48
statfs("/dev/shm/", {f_type=0x1021994, f_bsize=4096, f_blocks=129447, f_bfree=129447, f_bavail=129447, f_files=129447, f_ffree=129446, f_fsid={0, 0}, f_namelen=255, f_frsize=4096}) = 0
futex(0xd79258, FUTEX_WAKE, 2147483647) = 0
open("/dev/shm/dosemu_3778", O_RDWR|O_CREAT|O_TRUNC|O_NOFOLLOW, 0600) = 4
fcntl64(4, F_GETFD)                     = 0
fcntl64(4, F_SETFD, FD_CLOEXEC)         = 0
unlink("/dev/shm/dosemu_3778")          = 0
ftruncate64(4, 0)                       = 0
ftruncate64(4, 17891328)                = 0
mmap2(NULL, 17891328, PROT_READ|PROT_WRITE, MAP_SHARED, 4, 0) = 0xb6bbb000
mprotect(0xb6bbb000, 17891328, PROT_READ|PROT_WRITE|PROT_EXEC) = 0
mprotect(0xb6bbb000, 17891328, PROT_READ|PROT_WRITE) = 0
mprotect(0xb6bbb000, 1114112, PROT_READ|PROT_WRITE) = 0
mprotect(0, 655360, PROT_NONE)          = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

There is also an error just before the raw socket message about not finding file for messages in locale, but I don't think it is important. Interestingly, there is such a file in my /user/share/locale/ directories in many languages, including en_GB, but not in plain en.

I think the problem is with the mmap, mprotect stuff.

I hope this helps the developers.


On 04/21/2014 04:19 PM, Frantisek Hanzlik wrote:
Hi Janos, this reminded me of something similar that I have met cca three years ago. You can try to find my thread "same distro, svn1999 DOSEMU crashes on some PCs on SEGV, on others run fine" from 12/13/2010 in dosemu-users list - this was on Fedora 14, but this may be same problem which you see now on Fedora 3. But something better - I managed to compile almost last dosemu devel version on Fedora 3 i686, and this work well at me machine, both in console and under X (also both in terminal mode 'dosemu -t' and with native X (xdosemu). Because there was lots things corrected and improved, maybe it will run on Your system too. There is only one particularity: after installing RPM and first dosemu run must be copied kernel.sys to C:\ drive: cp /usr/share/dosemu/drive_z/kernel.sys ~/.dosemu/drives/c/ You can download RPM and SRPM package at: Good luck, Franta Hanzlik

To unsubscribe from this list: send the line "unsubscribe linux-msdos" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at

[Index of Archives]     [Linux Console]     [Linux Audio]     [Linux for Hams]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite Camping]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]     [Samba]     [Linux Media]     [Fedora Users]

  Powered by Linux