Linux Kernel Janitors
[Prev Page][Next Page]
- [PATCH] net: spider_net: Use non-atomic bitmap API when applicable,
Christophe JAILLET
- [PATCH] media: v4l2-dev: Use non-atomic bitmap API when applicable, Christophe JAILLET
- [PATCH] vsprintf: Use non-atomic bitmap API when applicable,
Christophe JAILLET
- [PATCH net-next] net/mlx5: SF, silence an uninitialized variable warning,
Dan Carpenter
- [PATCH] crypto: octeontx2 - uninitialized variable in kvf_limits_store(),
Dan Carpenter
- [PATCH] pinctrl: mediatek: add a check for error in mtk_pinconf_bias_get_rsel(),
Dan Carpenter
- [PATCH] pinctrl: mediatek: uninitialized variable in mtk_pctrl_show_one_pin(),
Dan Carpenter
- [PATCH 1/2] scsi: cxlflash: Use 'bitmap_set()' to simplify the code,
Christophe JAILLET
- [PATCH] block: Remove redundant initialization of variable ret,
Colin Ian King
- [PATCH] microblaze/mm/highmem: Remove redundant initialization of variable maxmem,
Colin Ian King
- [PATCH] x86/sev: clean up initialization of variables info and v,
Colin Ian King
- [PATCH] riscv: perf_event: Remove redundant initialization of variable ret,
Colin Ian King
- [PATCH] ARC: perf: Remove redundant initialization of variable idx,
Colin Ian King
- [PATCH] EDAC/sb_edac: Remove redundant initialization of variable rc,
Colin Ian King
- [PATCH] clk: stm32mp1: remove redundant assignment to pointer data,
Colin Ian King
- [PATCH 1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable,
Christophe JAILLET
- [PATCH][next] bfq: Fix spelling mistake "tenative" -> "tentative", Colin Ian King
- [PATCH] RDMA/bnxt_re: Use bitmap_zalloc() when applicable,
Christophe JAILLET
- [PATCH 1/2] RDMA/pvrdma: Use bitmap_zalloc() when applicable,
Christophe JAILLET
- [PATCH] IB/hfi1: Use bitmap_zalloc() when applicable,
Christophe JAILLET
- [PATCH] RDMA/mlx4: Use bitmap_alloc() when applicable,
Christophe JAILLET
- [PATCH 1/2] RDMA/ocrdma: Use bitmap_zalloc() when applicable,
Christophe JAILLET
- [PATCH 0/2] Kconfig symbol clean-up for sound,
Lukas Bulwahn
- [PATCH][next] hugetlb: Fix spelling mistake "hierarichal" -> "hierarchical",
Colin Ian King
- [PATCH][next] net: dsa: qca8k: Fix spelling mistake "Mismateched" -> "Mismatched",
Colin Ian King
- [PATCH 0/3] Cleanup and optimize a few bitmap operations,
Christophe JAILLET
- [PATCH 0/4] IB/mthca: Cleanup and optimize a few bitmap operation,
Christophe JAILLET
- [PATCH] tee: amdtee: fix an IS_ERR() vs NULL bug,
Dan Carpenter
[PATCH] drm/bridge: anx7625: fix an error code in anx7625_register_audio(),
Dan Carpenter
[PATCH] mailbox: imx: Fix an IS_ERR() vs NULL bug,
Dan Carpenter
[PATCH v3 net] can: sja1000: fix use after free in ems_pcmcia_add_card(),
Dan Carpenter
[PATCH] drm/i915/gvt: Prevent integer overflow in intel_vgpu_emulate_cfg_write(), Dan Carpenter
[PATCH v2 net] can: sja1000: fix use after free in ems_pcmcia_add_card(),
Dan Carpenter
[PATCH] dmaengine: sh: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH v2 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] media: media si2168: Fix spelling mistake "previsously" -> "previously", Colin Ian King
[PATCH] ath11k: Fix spelling mistake "detetction" -> "detection",
Colin Ian King
[PATCH v2] extcon: fix extcon_get_extcon_dev() error handling,
Dan Carpenter
[PATCH -next] firmware: arm_scmi: optee: Fix missing mutex_init(),
Wei Yongjun
[PATCH -next] ipmi: msghandler: Make symbol 'remove_work_wq' static,
Wei Yongjun
[PATCH -next] pinctrl: samsung: Make symbol 'exynos7885_pin_ctrl' static,
Wei Yongjun
[PATCH net-next] net/mlx5: Fix error return code in esw_qos_create(), Wei Yongjun
[PATCH net-next] can: sja1000: fix use after free in ems_pcmcia_add_card(),
Dan Carpenter
[PATCH] drm/i915/ttm: Fix error code in i915_ttm_eviction_valuable(),
Dan Carpenter
[PATCH] hv_netvsc: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] qed: Use the bitmap API to simplify some functions,
Christophe JAILLET
[PATCH] net-sysfs: Slightly optimize 'xps_queue_show()',
Christophe JAILLET
[PATCH 1/2] drm/amdkfd: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] mtd: gen_probe: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] rds: Fix a typo in a comment,
Christophe JAILLET
[PATCH 1/2] CacheFiles: Slightly simplify 'cachefiles_has_space()',
Christophe JAILLET
[git:media_stage/master] media: dvb-frontends/stv0367: remove redundant variable ADCClk_Hz, Mauro Carvalho Chehab
[git:media_stage/master] media: drivers: cx24113: remove redundant variable r, Mauro Carvalho Chehab
[PATCH] net: ipa: Use 'for_each_clear_bit' when possible,
Christophe JAILLET
[PATCH] dmaengine: ti: edma: Use 'for_each_set_bit' when possible,
Christophe JAILLET
[PATCH] RDMA: clean up usnic_ib_alloc_pd(),
Dan Carpenter
[PATCH] extcon: fix extcon_get_extcon_dev() error handling,
Dan Carpenter
[PATCH net] ptp: ocp: Fix a couple NULL vs IS_ERR() checks,
Dan Carpenter
[PATCH v2] drm/virtio: Fix an NULL vs IS_ERR() bug in virtio_gpu_object_shmem_init(),
Dan Carpenter
[PATCH] drm/ingenic: fix error code in ingenic_drm_gem_create_object(),
Dan Carpenter
[PATCH] drm/vc4: fix error code in vc4_create_object(),
Dan Carpenter
[PATCH] drm/nouveau/acr: fix a couple NULL vs IS_ERR() checks,
Dan Carpenter
[PATCH] drm/vboxvideo: fix a NULL vs IS_ERR() check,
Dan Carpenter
[PATCH] target/configfs: delete unnecessary checks for NULL,
Dan Carpenter
[PATCH] i3c/master: Fix a potentially infinite loop in 'hci_dat_v1_get_index()',
Christophe JAILLET
[PATCH] ice: Slightly simply ice_find_free_recp_res_idx,
Christophe JAILLET
[bug report] mfd: lp87565: Handle optional reset pin,
Dan Carpenter
Reference to the non-existing kconfig symbol SND_SOC_AC97_BUS_NEW, Lukas Bulwahn
[PATCH] usb: chipidea: ci_hdrc_imx: fix potential error pointer dereference in probe,
Dan Carpenter
[PATCH] phy: HiSilicon: Fix copy and paste bug in error handling,
Dan Carpenter
[PATCH net] octeontx2-af: debugfs: don't corrupt user memory,
Dan Carpenter
[PATCH] clk: versatile: clk-icst: use after free on error path,
Dan Carpenter
[PATCH net] dpaa2-eth: Fix use after free in dpaa2_eth_remove(), Dan Carpenter
[PATCH] staging: rtl8192e: Fix use after free in _rtl92e_pci_disconnect(), Dan Carpenter
[PATCH] btrfs: fix error pointer dereference in btrfs_ioctl_rm_dev_v2(),
Dan Carpenter
[PATCH] drm/i915/guc: fix NULL vs IS_ERR() checking,
Dan Carpenter
[PATCH] drm/i915: Fix error pointer dereference in i915_gem_do_execbuffer(),
Dan Carpenter
[PATCH] net: bridge: Slightly optimize 'find_portno()',
Christophe JAILLET
[PATCH] sched: Remove a useless #include, Christophe JAILLET
[PATCH] sched/rt: Slightly optimize 'init_rt_rq()',
Christophe JAILLET
[PATCH] nitro_enclaves: Remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] bcache: Remove redundant 'flush_workqueue()' calls, Christophe JAILLET
[PATCH] EDAC, wq: Remove redundant 'flush_workqueue()' calls, Christophe JAILLET
[PATCH] crypto: ccree - remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] scsi: Remove redundant 'flush_workqueue()' calls, Christophe JAILLET
[PATCH] usb: Remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] mei: Remove some dead code,
Christophe JAILLET
[PATCH] blk-iocost: drop selecting undefined BLK_RQ_IO_DATA_LEN,
Lukas Bulwahn
[PATCH] RDMA/bnxt_re: Scan the whole bitmap when checking if "disabling RCFW with pending cmd-bit",
Christophe JAILLET
Removal of config MACH_FSG and dead reference in LEDS_FSG,
Lukas Bulwahn
[bug report] net: ax88796c: ASIX AX88796C SPI Ethernet Adapter Driver,
Dan Carpenter
<Possible follow-ups>
[bug report] net: ax88796c: ASIX AX88796C SPI Ethernet Adapter Driver, Dan Carpenter
[PATCH] media: mtk-vcodec: Fix an error handling path in 'asid_allocator_init()',
Christophe JAILLET
[PATCH RESEND] pcmcia: clean up dead drivers for CompuLab CM-X255/CM-X270 boards, Lukas Bulwahn
[PATCH] iio: imx8qxp-adc: fix dependency to the intended ARCH_MXC config,
Lukas Bulwahn
[PATCH] media: uvcvideo: Fix a memory leak in an error handling path of 'uvc_ioctl_ctrl_map()',
Christophe JAILLET
[PATCH] fs/ntfs3: Fix some memory leaks in an error handling path of 'log_replay()',
Christophe JAILLET
[PATCH] iwlwifi: Fix memory leaks in error handling path,
Christophe JAILLET
[PATCH][V2] speakup: remove redundant assignment of variable i,
Colin Ian King
[PATCH][V2] MIPS: generic/yamon-dt: fix uninitialized variable error,
Colin Ian King
[PATCH] MIPS: generic/yamon-dt: fix uninitialized variable error,
Colin Ian King
[PATCH] speakup: remove redundant assignment of variable i,
Colin Ian King
[PATCH] scsi: qla2xxx: Fix memory leaks in the error handling path of 'qla2x00_mem_alloc()',
Christophe JAILLET
[PATCH] drm/v3d: pass null pointers using NULL,
Colin Ian King
[PATCH] btrfs: make 1-bit bit-fields unsigned int,
Colin Ian King
[PATCH net] iavf: missing unlocks in iavf_watchdog_task(),
Dan Carpenter
[PATCH] HID: nintendo: unlock on error in joycon_leds_create(),
Dan Carpenter
[PATCH net-next] gve: fix unmatched u64_stats_update_end(),
Dan Carpenter
[PATCH] iwlwifi: mvm: clean up indenting in iwl_mvm_tlc_update_notif(), Dan Carpenter
[PATCH] iwlwifi: mvm: fix a stray tab, Dan Carpenter
[PATCH net] net/mlx5: Lag, fix a potential Oops with mlx5_lag_create_definer(),
Dan Carpenter
[PATCH net-next] ice: Remove unnecessary casts,
Dan Carpenter
[PATCH] platform/mellanox: mlxreg-lc: fix error code in mlxreg_lc_create_static_devices(),
Dan Carpenter
[PATCH] spi: spi-geni-qcom: fix error handling in spi_geni_grab_gpi_chan(),
Dan Carpenter
[PATCH] dmaengine: dw-edma: Fix (and simplify) the probe broken since ecb8c88bd31c,
Christophe JAILLET
[PATCH] scsi: qla2xxx: edif: fix off by one bug in qla_edif_app_getfcinfo(),
Dan Carpenter
[PATCH] ubifs: fix snprintf() length check, Dan Carpenter
[PATCH] staging: r8188eu: fix a memory leak in rtw_wx_read32(), Dan Carpenter
[PATCH] drm/i915: pin: delete duplicate check in intel_pin_and_fence_fb_obj(),
Dan Carpenter
[PATCH net] gve: Fix off by one in gve_tx_timeout(),
Dan Carpenter
[PATCH net-next] net/mlx5e: Fix signedness bugs in mlx5e_build_shampo_hd_umr(),
Dan Carpenter
[PATCH] net: ethernet: ti: cpsw_ale: Fix access to un-initialized memory,
Christophe JAILLET
[PATCH] net: mana: Fix spelling mistake "calledd" -> "called",
Colin Ian King
[PATCH] tracing: Fix spelling mistake "aritmethic" -> "arithmetic",
Colin Ian King
[PATCH 1/2] gpu: host1x: Fix an error handling path in 'host1x_probe()',
Christophe JAILLET
[PATCH] litex_liteeth: Fix a double free in the remove function,
Christophe JAILLET
[PATCH] platform/x86: hp_accel: Fix an error handling path in 'lis3lv02d_probe()',
Christophe JAILLET
[PATCH] usb: gadget: udc-xilinx: Fix an error handling path in 'xudc_probe()',
Christophe JAILLET
[PATCH 1/2] eni_vdpa: Fix an error handling path in 'eni_vdpa_probe()',
Christophe JAILLET
[PATCH] ksmbd: Fix an error handling path in 'smb2_sess_setup()',
Christophe JAILLET
[PATCH] PCI: xilinx-nwl: Simplify code and fix a memory leak,
Christophe JAILLET
[PATCH] PCI: brcmstb: Declare a bitmap as a bitmap, not as a plain 'unsigned long',
Christophe JAILLET
[PATCH] PCI: qcom: Fix an error handling path in 'qcom_pcie_probe()',
Christophe JAILLET
[PATCH] nvdimm/pmem: Fix an error handling path in 'pmem_attach_disk()',
Christophe JAILLET
[PATCH] net/mlx5: Fix some error handling paths in 'mlx5e_tc_add_fdb_flow()',
Christophe JAILLET
[PATCH] iommu/vt-d: Fix an unbalanced rcu_read_lock/rcu_read_unlock(),
Christophe JAILLET
[PATCH] tpm_tis: Fix an error handling path in 'tpm_tis_core_init()',
Christophe JAILLET
[PATCH] ipv6: remove useless assignment to newinet in tcp_v6_syn_recv_sock(),
Nghia Le
[PATCH] mm/mremap_pages: Save a few cycles in 'get_dev_pagemap()',
Christophe JAILLET
[PATCH] aio: Save a few cycles in 'lookup_ioctx()',
Christophe JAILLET
[PATCH] scsi: target: Save a few cycles in 'transport_lookup_[cmd|tmr]_lun()',
Christophe JAILLET
[PATCH] PCI/P2PDMA: Save a few cycles in 'pci_alloc_p2pmem()',
Christophe JAILLET
[PATCH 1/2] soc: fsl: guts: Revert commit 3c0d64e867ed,
Christophe JAILLET
[PATCH] ASoC: codecs: Axe some dead code in 'wcd_mbhc_adc_hs_rem_irq()',
Christophe JAILLET
[PATCH v2] coresight: Use devm_bitmap_zalloc when applicable,
Christophe JAILLET
[PATCH] MAINTAINERS: rectify entry for INTEL KEEM BAY OCS ECC CRYPTO DRIVER,
Lukas Bulwahn
[PATCH] mailmap: update email address for Colin King, Colin Ian King
Re: [PATCH V2] message: fusion: switch from 'pci_' to 'dma_' API, Christophe JAILLET
Re: [PATCH V2] dma: dw-edma-pcie: switch from 'pci_' to 'dma_' API,
Christophe JAILLET
[PATCH] arm: remove zte zx platform left-over,
Lukas Bulwahn
[PATCH -next] i2c: xgene-slimpro: Fix wrong pointer passed to PTR_ERR(),
Wei Yongjun
[PATCH -next] mailbox: imx: Fix return value check in imx_mu_probe(), Wei Yongjun
[PATCH -next] crypto: keembay-ocs-ecc - Fix error return code in kmb_ocs_ecc_probe(),
Wei Yongjun
[PATCH -next] gpio: sim: fix missing unlock on error in gpio_sim_config_commit_item(),
Wei Yongjun
[PATCH][next] mm/damon: Fix a few spelling mistakes in comments and a pr_debug message,
Colin Ian King
[PATCH] speakup: Fix typo in documentation "boo" -> "boot",
Colin Ian King
[PATCH 00/13] Kconfig symbol clean-up on ./arch/arm{64},
Lukas Bulwahn
- [PATCH 01/13] arm: debug: remove obsolete debug code for DEBUG_ZTE_ZX, Lukas Bulwahn
- [PATCH 02/13] arm: debug: reuse the config DEBUG_OMAP2UART{1,2} for OMAP{3,4,5}, Lukas Bulwahn
- [PATCH 03/13] arm: Kconfig.debug: drop reference to removed ARCH_MSM, Lukas Bulwahn
- [PATCH 04/13] arm: drop an obsolete ifdef with the removed config PCI_HOST_ITE8152, Lukas Bulwahn
- [PATCH 05/13] arm: davinci: remove reference to obsolete BLK_DEV_PALMCHIP_BK3710, Lukas Bulwahn
- [PATCH 06/13] arm: ixp4xx: remove dead configs CPU_IXP43X and CPU_IXP46X, Lukas Bulwahn
- [PATCH 07/13] arm: imx: remove dead left-over from i.MX{27,31,35} removal, Lukas Bulwahn
- [PATCH 08/13] arm: imx: rename DEBUG_IMX21_IMX27_UART to DEBUG_IMX27_UART, Lukas Bulwahn
- [PATCH 09/13] arm: milbeaut: remove select of non-existing PINCTRL_MILBEAUT, Lukas Bulwahn
- [PATCH 10/13] arm: nomadik: drop selecting obsolete CLKSRC_NOMADIK_MTU_SCHED_CLOCK, Lukas Bulwahn
- [PATCH 11/13] arm: npcm: drop selecting non-existing ARM_ERRATA_794072, Lukas Bulwahn
- [PATCH 12/13] arm: socfpga: always select PL310_ERRATA_753970, Lukas Bulwahn
- [PATCH 13/13] arm: pgtable: refer to intended CONFIG_ARM_LPAE in comment, Lukas Bulwahn
[PATCH][next] mmc: dw_mmc: exynos: Fix spelling mistake "candiates" -> candidates,
Colin Ian King
[PATCH v5 0/4] Rectify file references for dt-bindings in MAINTAINERS,
Lukas Bulwahn
[PATCH] wireless: mac80211_hwsim: Fix spelling mistake "Droping" -> "Dropping", Colin Ian King
[PATCH][next] gve: Fix spelling mistake "droping" -> "dropping",
Colin Ian King
[PATCH] ext4: remove useless resetting io_end_size in mpage_process_page(),
Nghia Le
[PATCH][next] virtio_blk: Fix spelling mistake: "advertisted" -> "advertised",
Colin Ian King
[PATCH] scsi: elx: libefc_sli: Use 'bitmap_zalloc()' when applicable,
Christophe JAILLET
[PATCH] mlxsw: spectrum: Use 'bitmap_zalloc()' when applicable,
Christophe JAILLET
[PATCH] dma-mapping: Use 'bitmap_zalloc()' when applicable,
Christophe JAILLET
[PATCH 1/2] RDMA/rxe: Save a few bytes from struct rxe_pool,
Christophe JAILLET
[PATCH] gve: Fix a possible invalid memory access,
Christophe JAILLET
[PATCH] PCI: endpoint: Use 'bitmap_zalloc()' when applicable,
Christophe JAILLET
[PATCH] PCI: xgene-msi: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] iommu/vt-d: Use bitmap_zalloc() when applicable,
Christophe JAILLET
[PATCH] coresight: Use devm_bitmap_zalloc when applicable,
Christophe JAILLET
[PATCH][next] optee: Fix spelling mistake "reclain" -> "reclaim",
Colin Ian King
[PATCH][next] parisc: Fix spelling mistake "Plase" -> "Please",
Colin King
[PATCH] media: s5p-mfc: Use 'bitmap_zalloc()' when applicable, Christophe JAILLET
[PATCH] riscv: do not select non-existing config ANON_INODES,
Lukas Bulwahn
[PATCH] MAINTAINERS: drop obsolete file pattern in SDHCI DRIVER section,
Lukas Bulwahn
[PATCH] MAINTAINERS: rectify entry for PSTORE FILESYSTEM,
Lukas Bulwahn
[PATCH] net: dsa: Fix an error handling path in 'dsa_switch_parse_ports_of()',
Christophe JAILLET
[PATCH] ASoC: rsnd: Fix an error handling path in 'rsnd_node_count()',
Christophe JAILLET
[PATCH] ASoC: codecs: Fix WCD_MBHC_HPH_PA_EN usage,
Christophe JAILLET
offline for the next two weeks, Dan Carpenter
[PATCH] i2c: thunderx: Fix some resource leak,
Christophe JAILLET
[PATCH] media: tw5864: Simplify 'tw5864_finidev()',
Christophe JAILLET
[PATCH] remoteproc: imx_rproc: Fix a resource leak in the remove function,
Christophe JAILLET
[PATCH] mmc: mxs-mmc: disable regulator on error and in the remove function,
Christophe JAILLET
[PATCH] MAINTAINERS: adjust file entry for of_net.c after movement, Lukas Bulwahn
[PATCH][next] rtw89: Fix potential dereference of the null pointer sta,
Colin King
[PATCH][next] iio: Fix uninitialized variable ret,
Colin King
[PATCH][next] rtw89: Remove redundant check of ret after call to rtw89_mac_enable_bb_rf,
Colin King
[PATCH] dmaengine: Remove redundant initialization of variable err,
Colin King
[PATCH][next] rtw89: Fix two spelling mistakes in debug messages,
Colin King
[PATCH][next] lib/stackdepot: Fix spelling mistake and grammar in pr_err message, Colin King
[PATCH] xen/pvcalls-back: Remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] ieee802154: Remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] media: mtk-vpu: Remove redundant 'flush_workqueue()' calls, Christophe JAILLET
[PATCH] media: mtk-vcodec: Remove redundant 'flush_workqueue()' calls, Christophe JAILLET
[PATCH] mtip32xx: Remove redundant 'flush_workqueue()' calls,
Christophe JAILLET
[PATCH] media: dvb-frontends/stv0367: remove redundant variable ADCClk_Hz,
Colin King
[PATCH] media: drivers: cx24113: remove redundant variable r,
Colin King
[RFC PATCH] net: stmmac: remove rtnl unlock/lock sequence from stmmac_resume,
Edmundo Carmona Antoranz
[PATCH] scsi: 3w-xxx: Remove redundant initialization of variable retval,
Colin King
[PATCH] xen-netback: Remove redundant initialization of variable err,
Colin King
[PATCH][next] mmc: moxart: Fix null pointer dereference on pointer host,
Colin King
[PATCH -next] power: supply: axp288_charger: Fix missing mutex_init(),
Wei Yongjun
[PATCH] scsi: mpi3mr: use scnprintf() instead of snprintf(),
Dan Carpenter
[PATCH 1/2] drm/msm: fix potential NULL dereference in cleanup,
Dan Carpenter
[PATCH] drm/bridge: display-connector: fix an uninitialized pointer in probe(), Dan Carpenter
[PATCH] RDMA/rdmavt: fix error code in rvt_create_qp(),
Dan Carpenter
[PATCH net-next] net: enetc: fix check for allocation failure,
Dan Carpenter
[Index of Archives]
[Kernel Development]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[Linux ATA RAID]
[IETF Annouce]
[Git]
[Security]
[Linux Netdev]
[Netfilter]
[Bugtraq]