Linux Filesystem Development
[Prev Page][Next Page]
- [PATCH v3 1/2] capability: add cap_isidentical,
Mateusz Guzik
- [RFC PATCH v1 0/6] proc: Add allowlist for procfs files,
Alexey Gladkov
- remove ->rw_page,
Christoph Hellwig
- [PATCH 00/12] acl: remove remaining posix acl handlers,
Christian Brauner
- [PATCH 01/12] xattr: simplify listxattr helpers, Christian Brauner
- [PATCH 02/12] xattr, posix acl: add listxattr helpers, Christian Brauner
- [PATCH 03/12] xattr: remove unused argument, Christian Brauner
- [PATCH 04/12] fs: drop unused posix acl handlers, Christian Brauner
- [PATCH 05/12] erofs: drop posix acl handlers, Christian Brauner
- [PATCH 06/12] ext2: drop posix acl handlers, Christian Brauner
- [PATCH 07/12] ext4: drop posix acl handlers, Christian Brauner
- [PATCH 08/12] f2fs: drop posix acl handlers, Christian Brauner
- [PATCH 09/12] jffs2: drop posix acl handlers, Christian Brauner
- [PATCH 10/12] ocfs2: drop posix acl handlers, Christian Brauner
- [PATCH 12/12] acl: remove posix acl handlers, Christian Brauner
- [PATCH 11/12] reiserfs: drop posix acl handlers, Christian Brauner
- Re: [PATCH 00/12] acl: remove remaining posix acl handlers, Christian Brauner
- [GIT PULL] fuse acl fix for v6.2-rc6,
Christian Brauner
- [PATCH v2 0/12] udf: Unify aops,
Jan Kara
- [PATCH v2 01/12] udf: Unify .read_folio for normal and in-ICB files, Jan Kara
- [PATCH v2 02/12] udf: Convert in-ICB files to use udf_writepages(), Jan Kara
- [PATCH v2 06/12] udf: Add handling of in-ICB files to udf_bmap(), Jan Kara
- [PATCH v2 04/12] udf: Convert in-ICB files to use udf_write_begin(), Jan Kara
- [PATCH v2 03/12] udf: Convert in-ICB files to use udf_direct_IO(), Jan Kara
- [PATCH v2 07/12] udf: Switch to single address_space_operations, Jan Kara
- [PATCH v2 08/12] udf: Mark aops implementation static, Jan Kara
- [PATCH v2 11/12] udf: Convert udf_adinicb_writepage() to memcpy_to_page(), Jan Kara
- [PATCH v2 12/12] udf: Convert udf_expand_file_adinicb() to avoid kmap_atomic(), Jan Kara
- [PATCH v2 10/12] udf: Switch udf_adinicb_readpage() to kmap_local_page(), Jan Kara
- [PATCH v2 05/12] udf: Convert all file types to use udf_write_end(), Jan Kara
- [PATCH v2 09/12] udf: Move udf_adinicb_readpage() to inode.c, Jan Kara
- [PATCH v2 0/6] introduce vm_flags modifier functions,
Suren Baghdasaryan
- build direct-io.c conditionally,
Christoph Hellwig
- [ANNOUNCE] New mailing list for fsverity development, Eric Biggers
- [PATCH v8 RESEND 0/8] fs: clean up internal i_version handling,
Jeff Layton
- [PATCH v9 0/8] iov_iter: Improve page extraction (pin or just list),
David Howells
- replacement i_version counter for xfs,
Jeff Layton
- [PATCH 0/22] udf: Fix couple of preallocation related bugs,
Jan Kara
- [PATCH 03/22] udf: Move incrementing of goal block directly into inode_getblk(), Jan Kara
- [PATCH 05/22] udf: Use udf_bread() in udf_get_pblock_virt15(), Jan Kara
- [PATCH 01/22] udf: Unify types in anchor block detection, Jan Kara
- [PATCH 06/22] udf: Use udf_bread() in udf_load_vat(), Jan Kara
- [PATCH 04/22] udf: Factor out block mapping into udf_map_block(), Jan Kara
- [PATCH 08/22] udf: Convert udf_symlink_filler() to use udf_bread(), Jan Kara
- [PATCH 02/22] udf: Drop VARCONV support, Jan Kara
- [PATCH 11/22] udf: Add flag to disable block preallocation, Jan Kara
- [PATCH 10/22] udf: Pass mapping request into inode_getblk(), Jan Kara
- [PATCH 09/22] udf: Fold udf_block_map() into udf_map_block(), Jan Kara
- [PATCH 18/22] udf: Protect truncate and file type conversion with invalidate_lock, Jan Kara
- [PATCH 13/22] udf: Fold udf_getblk() into udf_bread(), Jan Kara
- [PATCH 12/22] udf: Use udf_map_block() in udf_getblk(), Jan Kara
- [PATCH 14/22] udf: Protect rename against modification of moved directory, Jan Kara
- [PATCH 07/22] udf: Do not call udf_block_map() on ICB files, Jan Kara
- [PATCH 15/22] udf: Push i_data_sem locking into udf_expand_file_adinicb(), Jan Kara
- [PATCH 22/22] udf: Fix off-by-one error when discarding preallocation, Jan Kara
- [PATCH 16/22] udf: Push i_data_sem locking into udf_extend_file(), Jan Kara
- [PATCH 20/22] udf: Do not allocate blocks on page writeback, Jan Kara
- [PATCH 21/22] udf: Fix file corruption when appending just after end of preallocated extent, Jan Kara
- [PATCH 17/22] udf: Simplify error handling in udf_file_write_iter(), Jan Kara
- [PATCH 19/22] udf: Allocate blocks on write page fault, Jan Kara
- [PATCH 0/10] udf: Unify aops,
Jan Kara
- [PATCH 03/10] udf: Convert in-ICB files to use udf_direct_IO(), Jan Kara
- [PATCH 05/10] udf: Convert all file types to use udf_write_end(), Jan Kara
- [PATCH 09/10] udf: Move udf_adinicb_readpage() to inode.c, Jan Kara
- [PATCH 02/10] udf: Convert in-ICB files to use udf_writepages(), Jan Kara
- [PATCH 06/10] udf: Add handling of in-ICB files to udf_bmap(), Jan Kara
- [PATCH 08/10] udf: Mark aops implementation static, Jan Kara
- [PATCH 04/10] udf: Convert in-ICB files to use udf_write_begin(), Jan Kara
- [PATCH 07/10] udf: Switch to single address_space_operations, Jan Kara
- [PATCH 10/10] udf: Switch udf_adinicb_readpage() to kmap_local_page(), Jan Kara
- [PATCH 01/10] udf: Unify .read_folio for normal and in-ICB files, Jan Kara
- [PATCH v8 0/4] Implement IOCTL to get and/or the clear info about PTEs,
Muhammad Usama Anjum
- What would happen if the block device driver/firmware found some block of a bio is corrupted?,
Qu Wenruo
- [GIT PULL] fscrypt MAINTAINERS entry update for 6.2-rc6,
Eric Biggers
- [GIT PULL] fsverity MAINTAINERS entry update for 6.2-rc6,
Eric Biggers
- [RESEND RFC PATCH v1 00/20] mm: process/cgroup ksm support,
Stefan Roesch
- [RESEND RFC PATCH v1 20/20] selftests/vm: add two functions for debugging merge outcome, Stefan Roesch
- [RESEND RFC PATCH v1 05/20] mm: support disabling of ksm for a process, Stefan Roesch
- [RESEND RFC PATCH v1 19/20] selftests/vm: add KSM fork test, Stefan Roesch
- [RESEND RFC PATCH v1 10/20] docs: document general_profit sysfs knob, Stefan Roesch
- [RESEND RFC PATCH v1 15/20] docs: document new procfs ksm knobs, Stefan Roesch
- [RESEND RFC PATCH v1 13/20] mm: expose ksm process profit metric in ksm_stat, Stefan Roesch
- [RESEND RFC PATCH v1 04/20] mm: invoke madvise for all vmas in scan_get_next_rmap_item, Stefan Roesch
- [RESEND RFC PATCH v1 17/20] selftests/vm: add KSM prctl merge test, Stefan Roesch
- [RESEND RFC PATCH v1 08/20] mm: split off pages_volatile function, Stefan Roesch
- [RESEND RFC PATCH v1 11/20] mm: calculate ksm process profit metric, Stefan Roesch
- [RESEND RFC PATCH v1 16/20] tools: add new prctl flags to prctl in tools dir, Stefan Roesch
- [RESEND RFC PATCH v1 12/20] mm: add ksm_merge_type() function, Stefan Roesch
- [RESEND RFC PATCH v1 01/20] mm: add new flag to enable ksm per process, Stefan Roesch
- [RESEND RFC PATCH v1 03/20] mm: add flag to __ksm_exit call, Stefan Roesch
- [RESEND RFC PATCH v1 09/20] mm: expose general_profit metric, Stefan Roesch
- [RESEND RFC PATCH v1 18/20] selftests/vm: add KSM get merge type test, Stefan Roesch
- [RESEND RFC PATCH v1 07/20] mm: add tracepoints to ksm, Stefan Roesch
- [RESEND RFC PATCH v1 06/20] mm: add new prctl option to get and set ksm for a process, Stefan Roesch
- [RESEND RFC PATCH v1 14/20] mm: expose ksm merge type in ksm_stat, Stefan Roesch
- [RESEND RFC PATCH v1 02/20] mm: add flag to __ksm_enter, Stefan Roesch
- Re: [RESEND RFC PATCH v1 00/20] mm: process/cgroup ksm support, David Hildenbrand
- [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list),
David Howells
- [PATCH v8 01/10] iov_iter: Define flags to qualify page extraction., David Howells
- [PATCH v8 05/10] block: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v8 04/10] iomap: don't get an reference on ZERO_PAGE for direct I/O block zeroing, David Howells
- [PATCH v8 03/10] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v8 02/10] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v8 09/10] block: convert bio_map_user_iov to use iov_iter_extract_pages, David Howells
- [PATCH v8 07/10] block: Switch to pinning pages., David Howells
- [PATCH v8 06/10] block: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v8 08/10] block: Convert bio_iov_iter_get_pages to use iov_iter_extract_pages, David Howells
- [PATCH v8 10/10] mm: Renumber FOLL_PIN and FOLL_GET down, David Howells
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), John Hubbard
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Hildenbrand
- Re: [PATCH v8 00/10] iov_iter: Improve page extraction (pin or just list), David Howells
- Re: [RESEND RFC PATCH v1 07/20] mm: add tracepoints to ksm, Steven Rostedt
- [PATCH v5 0/3] Checkpoint Support for Syscall User Dispatch,
Gregory Price
- Re: [GIT PULL] gfs2 writepage fix,
Linus Torvalds
- [PATCH v4 0/3] Checkpoint Support for Syscall User Dispatch,
Gregory Price
- return an ERR_PTR from __filemap_get_folio v2,
Christoph Hellwig
- consolidate btrfs checksumming, repair and bio splitting v4,
Christoph Hellwig
- [PATCH 01/34] block: export bio_split_rw, Christoph Hellwig
- [PATCH 02/34] btrfs: better document struct btrfs_bio, Christoph Hellwig
- [PATCH 05/34] btrfs: simplify btrfs_lookup_bio_sums, Christoph Hellwig
- [PATCH 07/34] btrfs: save the bio iter for checksum validation in common code, Christoph Hellwig
- [PATCH 08/34] btrfs: pre-load data checksum for reads in btrfs_submit_bio, Christoph Hellwig
- [PATCH 06/34] btrfs: slightly refactor btrfs_submit_bio, Christoph Hellwig
- [PATCH 03/34] btrfs: add a btrfs_inode pointer to struct btrfs_bio, Christoph Hellwig
- [PATCH 04/34] btrfs: remove the direct I/O read checksum lookup optimization, Christoph Hellwig
- [PATCH 09/34] btrfs: add a btrfs_data_csum_ok helper, Christoph Hellwig
- [PATCH 10/34] btrfs: handle checksum validation and repair at the storage layer, Christoph Hellwig
- [PATCH 11/34] btrfs: remove btrfs_bio_free_csum, Christoph Hellwig
- [PATCH 12/34] btrfs: remove btrfs_bio_for_each_sector, Christoph Hellwig
- [PATCH 13/34] btrfs: remove now unused checksumming helpers, Christoph Hellwig
- [PATCH 14/34] btrfs: remove the device field in struct btrfs_bio, Christoph Hellwig
- [PATCH 16/34] btrfs: rename the iter field in struct btrfs_bio, Christoph Hellwig
- [PATCH 15/34] btrfs: remove the io_failure_record infrastructure, Christoph Hellwig
- [PATCH 17/34] btrfs: remove the is_metadata flag in struct btrfs_bio, Christoph Hellwig
- [PATCH 18/34] btrfs: remove the submit_bio_start helpers, Christoph Hellwig
- [PATCH 19/34] btrfs: simplify the btrfs_csum_one_bio calling convention, Christoph Hellwig
- [PATCH 20/34] btrfs: handle checksum generation in the storage layer, Christoph Hellwig
- [PATCH 21/34] btrfs: handle recording of zoned writes in the storage layer, Christoph Hellwig
- [PATCH 31/34] btrfs: remove now spurious bio submission helpers, Christoph Hellwig
- [PATCH 22/34] btrfs: support cloned bios in btree_csum_one_bio, Christoph Hellwig
- [PATCH 29/34] btrfs: remove submit_encoded_read_bio, Christoph Hellwig
- [PATCH 23/34] btrfs: allow btrfs_submit_bio to split bios, Christoph Hellwig
- [PATCH 30/34] btrfs: remove the fs_info argument to btrfs_submit_bio, Christoph Hellwig
- [PATCH 24/34] btrfs: pass the iomap bio to btrfs_submit_bio, Christoph Hellwig
- [PATCH 26/34] btrfs: remove stripe boundary calculation for compressed I/O, Christoph Hellwig
- [PATCH 28/34] btrfs: remove struct btrfs_io_geometry, Christoph Hellwig
- [PATCH 27/34] btrfs: remove stripe boundary calculation for encoded I/O, Christoph Hellwig
- [PATCH 32/34] btrfs: calculate file system wide queue limit for zoned mode, Christoph Hellwig
- [PATCH 25/34] btrfs: remove stripe boundary calculation for buffered I/O, Christoph Hellwig
- [PATCH 34/34] iomap: remove IOMAP_F_ZONE_APPEND, Christoph Hellwig
- [PATCH 33/34] btrfs: split zone append bios in btrfs_submit_bio, Christoph Hellwig
- Re: consolidate btrfs checksumming, repair and bio splitting v4, Christoph Hellwig
- [PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list),
David Howells
- [PATCH v7 1/8] iov_iter: Define flags to qualify page extraction., David Howells
- [PATCH v7 3/8] mm: Provide a helper to drop a pin/ref on a page, David Howells
- [PATCH v7 4/8] block: Rename BIO_NO_PAGE_REF to BIO_PAGE_REFFED and invert the meaning, David Howells
- [PATCH v7 2/8] iov_iter: Add a function to extract a page list from an iterator, David Howells
- [PATCH v7 5/8] block: Add BIO_PAGE_PINNED, David Howells
- [PATCH v7 7/8] block: Fix bio_flagged() so that gcc can better optimise it, David Howells
- [PATCH v7 6/8] block: Make bio structs pin pages rather than ref'ing if appropriate, David Howells
- [PATCH v7 8/8] mm: Renumber FOLL_GET and FOLL_PIN down, David Howells
- Re: [PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list), Matthew Wilcox
- Re: [PATCH v7 0/8] iov_iter: Improve page extraction (ref, pin or just list), David Howells
- [PATCH v3 0/6] Composefs: an opportunistically sharing verified image filesystem,
Alexander Larsson
[Index of Archives]
[Linux Ext4 Filesystem]
[Union Filesystem]
[NTFS 3]
[Ceph Users]
[AutoFS]
[Kernel Announce]
[Kernel Newbies]
[Kernel Development]
[Linux RAID]
[IETF Annouce]
[Security]
[Netfilter]
[Bugtraq]