Linux Filesystem Development
[Prev Page][Next Page]
- [PATCH v5 29/30] kselftest/arm64: Add test case for POR_EL0 signal frame records, (continued)
- [PATCH 0/2] iomap: flush dirty cache over unwritten mappings on zero range,
Brian Foster
- [PATCH] ufs: Remove redundant inode number check from ufs_nfs_get_inode,
sergii . boryshchenko
- [PATCH] fs: switch f_iocb_flags and f_version,
Christian Brauner
- [PATCH] fs: switch f_iocb_flags and f_ra, Christian Brauner
- [PATCH v13 00/10] enable bs > ps in XFS,
Pankaj Raghav (Samsung)
- [PATCH v13 01/10] fs: Allow fine-grained control of folio sizes, Pankaj Raghav (Samsung)
- [PATCH v13 02/10] filemap: allocate mapping_min_order folios in the page cache, Pankaj Raghav (Samsung)
- [PATCH v13 03/10] readahead: allocate folios with mapping_min_order in readahead, Pankaj Raghav (Samsung)
- [PATCH v13 04/10] mm: split a folio in minimum folio order chunks, Pankaj Raghav (Samsung)
- [PATCH v13 05/10] filemap: cap PTE range to be created to allowed zero fill in folio_map_range(), Pankaj Raghav (Samsung)
- [PATCH v13 07/10] xfs: use kvmalloc for xattr buffers, Pankaj Raghav (Samsung)
- [PATCH v13 06/10] iomap: fix iomap_dio_zero() for fs bs > system page size, Pankaj Raghav (Samsung)
- [PATCH v13 08/10] xfs: expose block size in stat, Pankaj Raghav (Samsung)
- [PATCH v13 09/10] xfs: make the calculation generic in xfs_sb_validate_fsb_count(), Pankaj Raghav (Samsung)
- [PATCH v13 10/10] xfs: enable block size larger than page size support, Pankaj Raghav (Samsung)
- Re: [PATCH v13 00/10] enable bs > ps in XFS, Luis Chamberlain
- [PATCH] fs: s/__u32/u32/ for s_fsnotify_mask,
Christian Brauner
- [PATCH] fs: remove unused path_put_init(),
Christian Brauner
- [syzbot] [squashfs?] possible deadlock in fsnotify_destroy_mark,
syzbot
- [PATCH v2 00/17] Wire up getrandom() vDSO implementation on powerpc,
Christophe Leroy
- [PATCH v2 01/17] asm-generic/unaligned.h: Extract common header for vDSO, Christophe Leroy
- [PATCH v2 03/17] vdso: Add __arch_get_k_vdso_rng_data(), Christophe Leroy
- [PATCH v2 02/17] vdso: Clean header inclusion in getrandom, Christophe Leroy
- [PATCH v2 04/17] vdso: Add missing c-getrandom-y in Makefile, Christophe Leroy
- [PATCH v2 06/17] vdso: Change getrandom's generation to unsigned long, Christophe Leroy
- [PATCH v2 05/17] vdso: Avoid call to memset() by getrandom, Christophe Leroy
- [PATCH v2 07/17] mm: Define VM_DROPPABLE for powerpc/32, Christophe Leroy
- [PATCH v2 08/17] powerpc: Add little endian variants of LWZX_BE and STWX_BE, Christophe Leroy
- [PATCH v2 09/17] powerpc/vdso32: Add crtsavres, Christophe Leroy
- [PATCH v2 10/17] powerpc/vdso: Refactor CFLAGS for CVDSO build, Christophe Leroy
- [PATCH v2 11/17] powerpc/vdso: Wire up getrandom() vDSO implementation, Christophe Leroy
- [PATCH v2 12/17] selftests: vdso: Fix powerpc64 vdso_config, Christophe Leroy
- [PATCH v2 13/17] selftests: vdso: Don't hard-code location of vDSO sources, Christophe Leroy
- [PATCH v2 14/17] selftests: vdso: Make test_vdso_getrandom look for the right vDSO function, Christophe Leroy
- [PATCH v2 15/17] selftests: vdso: Fix build of test_vdso_chacha, Christophe Leroy
- [PATCH v2 16/17] selftests: vdso: Make VDSO function call more generic, Christophe Leroy
- [PATCH v2 17/17] selftests: vdso: Add support for vdso_test_random for powerpc, Christophe Leroy
- Re: [PATCH v2 00/17] Wire up getrandom() vDSO implementation on powerpc, Jason A. Donenfeld
- [PATCH v2 00/16] overlayfs: Optimize override/revert creds,
Vinicius Costa Gomes
- [PATCH v2 01/16] cred: Add a light version of override/revert_creds(), Vinicius Costa Gomes
- [PATCH v2 02/16] fs/backing-file: Convert to revert/override_creds_light(), Vinicius Costa Gomes
- [PATCH v2 03/16] fs/overlayfs: Introduce ovl_override_creds_light(), Vinicius Costa Gomes
- [PATCH v2 04/16] overlayfs: Document critical override_creds() operations, Vinicius Costa Gomes
- [PATCH v2 06/16] cred: Introduce cred_guard() and cred_scoped_guard() helpers, Vinicius Costa Gomes
- [PATCH v2 07/16] fs/backing-file: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 05/16] overlayfs: Use ovl_override_creds_light()/revert_creds_light(), Vinicius Costa Gomes
- [PATCH v2 08/16] overlayfs/copy_up: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 09/16] overlayfs/dir: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 10/16] overlayfs/file: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 11/16] overlayfs/inode: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 12/16] overlayfs/namei: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 13/16] overlayfs/readdir: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 14/16] overlayfs/xattrs: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 15/16] overlayfs/util: Convert to cred_guard(), Vinicius Costa Gomes
- [PATCH v2 16/16] overlayfs: Remove ovl_override_creds_light(), Vinicius Costa Gomes
- [PATCH v11 00/39] arm64/gcs: Provide support for GCS in userspace,
Mark Brown
- [PATCH v11 01/39] mm: Introduce ARCH_HAS_USER_SHADOW_STACK, Mark Brown
- [PATCH v11 02/39] arm64/mm: Restructure arch_validate_flags() for extensibility, Mark Brown
- [PATCH v11 03/39] prctl: arch-agnostic prctl for shadow stack, Mark Brown
- [PATCH v11 04/39] mman: Add map_shadow_stack() flags, Mark Brown
- [PATCH v11 05/39] arm64: Document boot requirements for Guarded Control Stacks, Mark Brown
- [PATCH v11 06/39] arm64/gcs: Document the ABI for Guarded Control Stacks, Mark Brown
- [PATCH v11 07/39] arm64/sysreg: Add definitions for architected GCS caps, Mark Brown
- [PATCH v11 08/39] arm64/gcs: Add manual encodings of GCS instructions, Mark Brown
- [PATCH v11 09/39] arm64/gcs: Provide put_user_gcs(), Mark Brown
- [PATCH v11 10/39] arm64/gcs: Provide basic EL2 setup to allow GCS usage at EL0 and EL1, Mark Brown
- [PATCH v11 11/39] arm64/cpufeature: Runtime detection of Guarded Control Stack (GCS), Mark Brown
- [PATCH v11 12/39] arm64/mm: Allocate PIE slots for EL0 guarded control stack, Mark Brown
- [PATCH v11 13/39] mm: Define VM_SHADOW_STACK for arm64 when we support GCS, Mark Brown
- [PATCH v11 14/39] arm64/mm: Map pages for guarded control stack, Mark Brown
- [PATCH v11 15/39] KVM: arm64: Manage GCS access and registers for guests, Mark Brown
- [PATCH v11 16/39] arm64/idreg: Add overrride for GCS, Mark Brown
- [PATCH v11 17/39] arm64/hwcap: Add hwcap for GCS, Mark Brown
- [PATCH v11 18/39] arm64/traps: Handle GCS exceptions, Mark Brown
- [PATCH v11 19/39] arm64/mm: Handle GCS data aborts, Mark Brown
- [PATCH v11 20/39] arm64/gcs: Context switch GCS state for EL0, Mark Brown
- [PATCH v11 21/39] arm64/gcs: Ensure that new threads have a GCS, Mark Brown
- [PATCH v11 22/39] arm64/gcs: Implement shadow stack prctl() interface, Mark Brown
- [PATCH v11 23/39] arm64/mm: Implement map_shadow_stack(), Mark Brown
- [PATCH v11 24/39] arm64/signal: Set up and restore the GCS context for signal handlers, Mark Brown
- [PATCH v11 25/39] arm64/signal: Expose GCS state in signal frames, Mark Brown
- [PATCH v11 26/39] arm64/ptrace: Expose GCS via ptrace and core files, Mark Brown
- [PATCH v11 27/39] arm64: Add Kconfig for Guarded Control Stack (GCS), Mark Brown
- [PATCH v11 28/39] kselftest/arm64: Verify the GCS hwcap, Mark Brown
- [PATCH v11 29/39] kselftest/arm64: Add GCS as a detected feature in the signal tests, Mark Brown
- [PATCH v11 30/39] kselftest/arm64: Add framework support for GCS to signal handling tests, Mark Brown
- [PATCH v11 31/39] kselftest/arm64: Allow signals tests to specify an expected si_code, Mark Brown
- [PATCH v11 32/39] kselftest/arm64: Always run signals tests with GCS enabled, Mark Brown
- [PATCH v11 33/39] kselftest/arm64: Add very basic GCS test program, Mark Brown
- [PATCH v11 34/39] kselftest/arm64: Add a GCS test program built with the system libc, Mark Brown
- [PATCH v11 35/39] kselftest/arm64: Add test coverage for GCS mode locking, Mark Brown
- [PATCH v11 36/39] kselftest/arm64: Add GCS signal tests, Mark Brown
- [PATCH v11 37/39] kselftest/arm64: Add a GCS stress test, Mark Brown
- [PATCH v11 38/39] kselftest/arm64: Enable GCS for the FP stress tests, Mark Brown
- [PATCH v11 39/39] KVM: selftests: arm64: Add GCS registers to get-reg-list, Mark Brown
- [PATCHES] fdtable series v2,
Al Viro
- [PATCH 01/12] close_range(): fix the logics in descriptor table trimming, Al Viro
- [PATCH 08/12] fs/file.c: add fast path in find_next_fd(), Al Viro
- [PATCH 04/12] close_files(): don't bother with xchg(), Al Viro
- [PATCH 06/12] fs/file.c: remove sanity_check and add likely/unlikely in alloc_fd(), Al Viro
- [PATCH 10/12] file.c: merge __{set,clear}_close_on_exec(), Al Viro
- [PATCH 05/12] move close_range(2) into fs/file.c, fold __close_range() into it, Al Viro
- [PATCH 03/12] remove pointless includes of <linux/fdtable.h>, Al Viro
- [PATCH 11/12] make __set_open_fd() set cloexec state as well, Al Viro
- [PATCH 09/12] alloc_fdtable(): change calling conventions., Al Viro
- [PATCH 02/12] get rid of ...lookup...fdget_rcu() family, Al Viro
- [PATCH 07/12] fs/file.c: conditionally clear full_fds, Al Viro
- [PATCH 12/12] expand_files(): simplify calling conventions, Al Viro
- [PATCHES] fdtable series v3, Al Viro
- Re: [PATCHES] fdtable series v3, Linus Torvalds
- Re: [PATCHES] fdtable series v3, Christian Brauner
[PATCH v2 0/9] fuse: writeback clean up / refactoring,
Joanne Koong
- [PATCH v2 1/9] fuse: drop unused fuse_mount arg in fuse_writepage_finish(), Joanne Koong
- [PATCH v2 2/9] fuse: refactor finished writeback stats updates into helper function, Joanne Koong
- [PATCH v2 3/9] fuse: update stats for pages in dropped aux writeback list, Joanne Koong
- [PATCH v2 4/9] fuse: clean up error handling in fuse_writepages(), Joanne Koong
- [PATCH v2 5/9] fuse: move initialization of fuse_file to fuse_writepages() instead of in callback, Joanne Koong
- [PATCH v2 6/9] fuse: convert fuse_writepages_fill() to use a folio for its tmp page, Joanne Koong
- [PATCH v2 8/9] fuse: refactor out shared logic in fuse_writepages_fill() and fuse_writepage_locked(), Joanne Koong
- [PATCH v2 7/9] fuse: move folio_start_writeback to after the allocations in fuse_writepage_locked(), Joanne Koong
- [PATCH v2 9/9] fuse: tidy up error paths in fuse_writepages_fill() and fuse_writepage_locked(), Joanne Koong
- Re: [PATCH v2 0/9] fuse: writeback clean up / refactoring, Miklos Szeredi
[syzbot] [bcachefs?] [jfs?] kernel BUG in vfs_get_tree,
syzbot
[PATCH 00/10] Simplify the page flags a little,
Matthew Wilcox (Oracle)
- [PATCH 08/10] mm: Remove page_has_private(), Matthew Wilcox (Oracle)
- [PATCH 04/10] mm: Remove PageSwapCache, Matthew Wilcox (Oracle)
- [PATCH 09/10] mm: Rename PG_mappedtodisk to PG_owner_2, Matthew Wilcox (Oracle)
- [PATCH 10/10] x86: Remove PG_uncached, Matthew Wilcox (Oracle)
- [PATCH 06/10] mm: Remove PageMlocked, Matthew Wilcox (Oracle)
- [PATCH 07/10] mm: Remove PageOwnerPriv1, Matthew Wilcox (Oracle)
- [PATCH 03/10] mm: Remove PageReadahead, Matthew Wilcox (Oracle)
- [PATCH 02/10] mm: Remove PageSwapBacked, Matthew Wilcox (Oracle)
- [PATCH 05/10] mm: Remove PageUnevictable, Matthew Wilcox (Oracle)
- [PATCH 01/10] mm: Remove PageActive, Matthew Wilcox (Oracle)
ANNOUNCE: nfs-utils-2.7.1 released., Steve Dickson
[PATCH RFC v2 0/6] inode: turn i_state into u32,
Christian Brauner
[PATCH v2] fs/exfat: add NFS export support,
andrii . polianytsia
[RFC PATCH 1/1] fs: ext4: Don't use CMA for buffer_head, zhaoyang.huang
[PATCH v3 1/2] fs: Fix file_set_fowner LSM hook inconsistencies,
Mickaël Salaün
[PATCH v1] mnt_idmapping: Use kmemdup_array instead of kmemdup for multiple allocation,
Yu Jiaoliang
[PATCH -next] radix tree test suite: Remove usage of the deprecated ida_simple_xx() API,
Hongbo Li
[PATCH -next] fs: use LIST_HEAD() to simplify code,
Hongbo Li
convert XFS perag lookup to xarrays v2,
Christoph Hellwig
[PATCH v1] mm:page-writeback:use folio_next_index() helper in writeback_iter(), Yuesong Li
sort out the fallocate mode mess,
Christoph Hellwig
[PATCH 0/8] netfs/cachefiles: Some bugfixes,
Zizhi Wo
- [PATCH 3/8] cachefiles: Fix missing pos updates in cachefiles_ondemand_fd_write_iter(), Zizhi Wo
- [PATCH 1/8] cachefiles: Fix incorrect block calculations in __cachefiles_prepare_write(), Zizhi Wo
- [PATCH 2/8] cachefiles: Fix incorrect length return value in cachefiles_ondemand_fd_write_iter(), Zizhi Wo
- [PATCH 6/8] cachefiles: Modify inappropriate error return value in cachefiles_daemon_secctx(), Zizhi Wo
- [PATCH 4/8] cachefiles: Clear invalid cache data in advance, Zizhi Wo
- [PATCH 5/8] cachefiles: Clean up in cachefiles_commit_tmpfile(), Zizhi Wo
- [PATCH 8/8] netfs/fscache: Add a memory barrier for FSCACHE_VOLUME_CREATING, Zizhi Wo
- [PATCH 7/8] cachefiles: Fix NULL pointer dereference in object->file, Zizhi Wo
- Re: [PATCH 0/8] netfs/cachefiles: Some bugfixes, Zizhi Wo
- Re: [PATCH 1/8] cachefiles: Fix incorrect block calculations in __cachefiles_prepare_write(), David Howells
- Re: [PATCH 4/8] cachefiles: Clear invalid cache data in advance, David Howells
- Re: [PATCH 5/8] cachefiles: Clean up in cachefiles_commit_tmpfile(), David Howells
- Re: [PATCH 8/8] netfs/fscache: Add a memory barrier for FSCACHE_VOLUME_CREATING, David Howells
- Re: [PATCH 7/8] cachefiles: Fix NULL pointer dereference in object->file, David Howells
- Re: [PATCH 3/8] cachefiles: Fix missing pos updates in cachefiles_ondemand_fd_write_iter(), David Howells
- Re: [PATCH 6/8] cachefiles: Modify inappropriate error return value in cachefiles_daemon_secctx(), David Howells
[PATCH 5/4] Squashfs: Ensure all readahead pages have been used,
Phillip Lougher
[PATCH 0/4] mm, netfs, afs: Truncation fixes,
David Howells
[PATCH] fuse: Add open-gettr for fuse-file-open,
Bernd Schubert
[PATCH] MAINTAINERS: add the VFS git tree,
Eric Biggers
[PATCH fstests v2] generic/755: test that inode's ctime is updated on unlink,
Jeff Layton
[PATCH] Documentation: iomap: fix a typo,
Pankaj Raghav (Samsung)
[syzbot] [ntfs3?] WARNING in iov_iter_revert (5), syzbot
[syzbot] [exfat?] KCSAN: data-race in dio_bio_end_io / dio_new_bio (3), syzbot
[PATCH] writeback: Refine the show_inode_state() macro definition,
Julian Sun
[RFC PATCH 1/1] fs: jbd2: try to launch cp transaction when bh refer cma,
zhaoyang.huang
[linus:master] [9p] e3786b29c5: xfstests.generic.465.fail,
kernel test robot
[PATCH -next v2] zonefs: add support for FS_IOC_GETFSSYSFSPATH,
Liao Chen
[PATCH v2] mm: allow read-ahead with IOCB_NOWAIT set, Yafang Shao
[PATCH bpf-next] bpf: use kfunc hooks instead of program types,
Matteo Croce
[PATCH] Documentation: Document the kernel flag bdev_allow_write_mounted,
Guilherme G. Piccoli
[PATCH 1/2] fuse: drop unused fuse_mount arg in fuse_writepage_finish,
Joanne Koong
[PATCH v12 00/24] nfs/nfsd: add support for localio,
Mike Snitzer
- [PATCH v12 01/24] nfs_common: factor out nfs_errtbl and nfs_stat_to_errno, Mike Snitzer
- [PATCH v12 02/24] nfs_common: factor out nfs4_errtbl and nfs4_stat_to_errno, Mike Snitzer
- [PATCH v12 03/24] nfs: factor out {encode,decode}_opaque_fixed to nfs_xdr.h, Mike Snitzer
- [PATCH v12 04/24] nfsd: factor out __fh_verify to allow NULL rqstp to be passed, Mike Snitzer
- [PATCH v12 05/24] nfsd: fix nfsfh tracepoints to properly handle NULL rqstp, Mike Snitzer
- [PATCH v12 06/24] nfsd: add nfsd_file_acquire_local(), Mike Snitzer
- [PATCH v12 07/24] SUNRPC: remove call_allocate() BUG_ONs, Mike Snitzer
- [PATCH v12 08/24] SUNRPC: add rpcauth_map_clnt_to_svc_cred_local, Mike Snitzer
- [PATCH v12 09/24] nfs_common: add NFS LOCALIO auxiliary protocol enablement, Mike Snitzer
- [PATCH v12 10/24] nfsd: add localio support, Mike Snitzer
- [PATCH v12 11/24] nfsd: implement server support for NFS_LOCALIO_PROGRAM, Mike Snitzer
- [PATCH v12 12/24] SUNRPC: replace program list with program array, Mike Snitzer
- [PATCH v12 13/24] nfs: pass struct file to nfs_init_pgio and nfs_init_commit, Mike Snitzer
- [PATCH v12 14/24] nfs: add localio support, Mike Snitzer
- [PATCH v12 15/24] nfs: enable localio for non-pNFS IO, Mike Snitzer
- [PATCH v12 16/24] pnfs/flexfiles: enable localio support, Mike Snitzer
- [PATCH v12 17/24] nfs/localio: use dedicated workqueues for filesystem read and write, Mike Snitzer
- [PATCH v12 18/24] nfs: implement client support for NFS_LOCALIO_PROGRAM, Mike Snitzer
- [PATCH v12 19/24] nfs: add Documentation/filesystems/nfs/localio.rst, Mike Snitzer
- [PATCH v12 20/24] nfsd: use GC for nfsd_file returned by nfsd_file_acquire_local, Mike Snitzer
- [PATCH v12 21/24] nfs_common: expose localio's required nfsd symbols to nfs client, Mike Snitzer
- [PATCH v12 22/24] nfs: push localio nfsd_file_put call out to client, Mike Snitzer
- [PATCH v12 23/24] nfs: switch client to use nfsd_file for localio, Mike Snitzer
- [PATCH v12 24/24] nfs: add FAQ section to Documentation/filesystems/nfs/localio.rst, Mike Snitzer
- Re: [PATCH v12 00/24] nfs/nfsd: add support for localio, Chuck Lever III
- Re: [PATCH v12 00/24] nfs/nfsd: add support for localio, Jeff Layton
- Re: [PATCH v12 00/24] nfs/nfsd: add support for localio, Chuck Lever
[PATCH] fuse: use unsigned type for getxattr/listxattr size truncation,
Jann Horn
Re: [fuse-devel] Symlink caching: Updating the target can result in corrupted symlinks - kernel issue?,
Bernd Schubert
[PATCH -next] netfs: Remove unused declaration netfs_queue_write_request(), Yue Haibing
KASAN: stack-out-of-bounds Write in end_buffer_read_sync,
Hui Guo
[PATCH] fs/exfat: add NFS export support,
andrii . polianytsia
[PATCH] Revert "pidfd: prevent creation of pidfds for kthreads", Christian Brauner
[brauner-vfs:vfs.misc.jeff] [[DRAFT UNTESTED] fs] 6a0f6c435f: BUG:kernel_NULL_pointer_dereference,address,
kernel test robot
[PATCH 0/9 RFC] Make wake_up_{bit,var} less fragile,
NeilBrown
- [PATCH 1/9] i915: remove wake_up on I915_RESET_MODESET., NeilBrown
- [PATCH 2/9] Introduce atomic_dec_and_wake_up_var()., NeilBrown
- [PATCH 3/9] XFS: use wait_var_event() when waiting of i_pincount., NeilBrown
- [PATCH 4/9] Use wait_var_event() instead of I_DIO_WAKEUP, NeilBrown
- [PATCH 5/9] Block: switch bd_prepare_to_claim to use ___wait_var_event(), NeilBrown
- [PATCH 6/9] block/pktdvd: switch congestion waiting to ___wait_var_event(), NeilBrown
- [PATCH 7/9] Improve and expand wake_up_bit() interface., NeilBrown
- [PATCH 8/9] Improve and extend wake_up_var() interface., NeilBrown
- [PATCH 9/9] Use clear_and_wake_up_bit() where appropriate., NeilBrown
- Re: [PATCH 0/9 RFC] Make wake_up_{bit,var} less fragile, Linus Torvalds
- Re: [PATCH 0/9 RFC] Make wake_up_{bit,var} less fragile, Christian Brauner
[PATCH 0/4] Squashfs: Update code to not use page->index,
Phillip Lougher
[viro-vfs:work.headers.unaligned 2/2] arch/x86/../../../arch/x86/lib/insn.c:16:10: fatal error: ../include/linux/unaligned.h: No such file or directory, kernel test robot
[bug report] fs: Allow statmount() in foreign mount namespace,
Dan Carpenter
[PATCH v5 0/7] block atomic writes for xfs,
John Garry
[PATCH v2] netfs: fix the mismatch used for CONFIG_FSCACHE_DEBUG,
yangerkun
[PATCH v7 0/8] Improve the copy of task comm,
Yafang Shao
[Index of Archives]
[Linux Ext4 Filesystem]
[Union Filesystem]
[NTFS 3]
[Ceph Users]
[AutoFS]
[Kernel Announce]
[Kernel Newbies]
[Kernel Development]
[Linux RAID]
[IETF Annouce]
[Security]
[Netfilter]
[Bugtraq]