Linux Arch
[Prev Page][Next Page]
- [PATCH v17 04/10] landlock: Add ptrace restrictions, (continued)
- sort out the flush_icache_range mess,
Christoph Hellwig
- [PATCH 01/31] arm: fix the flush_icache_range arguments in set_fiq_handler, Christoph Hellwig
- [PATCH 02/31] arm64: fix the flush_icache_range arguments in machine_kexec, Christoph Hellwig
- [PATCH 03/31] MIPS: unexport __flush_icache_user_range, Christoph Hellwig
- [PATCH 04/31] nds32: unexport flush_icache_page, Christoph Hellwig
- [PATCH 06/31] unicore32: remove flush_cache_user_range, Christoph Hellwig
- [PATCH 05/31] powerpc: unexport flush_icache_user_range, Christoph Hellwig
- [PATCH 08/31] asm-generic: don't include <linux/mm.h> in cacheflush.h, Christoph Hellwig
- [PATCH 23/31] sh: implement flush_icache_user_range, Christoph Hellwig
- [PATCH 24/31] xtensa: implement flush_icache_user_range, Christoph Hellwig
- [PATCH 22/31] asm-generic: add a flush_icache_user_range stub, Christoph Hellwig
- [PATCH 21/31] mm: rename flush_icache_user_range to flush_icache_user_page, Christoph Hellwig
- [PATCH 29/31] binfmt_flat: use flush_icache_user_range, Christoph Hellwig
- [PATCH 28/31] exec: use flush_icache_user_range in read_code, Christoph Hellwig
- [PATCH 31/31] module: move the set_fs hack for flush_icache_range to m68k, Christoph Hellwig
- [PATCH 30/31] nommu: use flush_icache_user_range in brk and mmap, Christoph Hellwig
- [PATCH 26/31] m68k: implement flush_icache_user_range, Christoph Hellwig
- [PATCH 27/31] exec: only build read_code when needed, Christoph Hellwig
- [PATCH 25/31] arm: rename flush_cache_user_range to flush_icache_user_range, Christoph Hellwig
- [PATCH 07/31] asm-generic: fix the inclusion guards for cacheflush.h, Christoph Hellwig
- [PATCH 09/31] asm-generic: improve the flush_dcache_page stub, Christoph Hellwig
- [PATCH 11/31] arm64: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 12/31] c6x: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 14/31] ia64: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 15/31] microblaze: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 17/31] openrisc: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 18/31] powerpc: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 19/31] riscv: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 20/31] arm,sparc,unicore32: remove flush_icache_user_range, Christoph Hellwig
- [PATCH 16/31] m68knommu: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 13/31] hexagon: use asm-generic/cacheflush.h, Christoph Hellwig
- [PATCH 10/31] alpha: use asm-generic/cacheflush.h, Christoph Hellwig
- Re: sort out the flush_icache_range mess, Geert Uytterhoeven
- [RFC PATCH 0/7] mm: Get rid of vmalloc_sync_(un)mappings(),
Joerg Roedel
- [PATCH 4.4 032/312] MIPS: Define AT_VECTOR_SIZE_ARCH for ARCH_DLINFO, Greg Kroah-Hartman
- [PATCH V3 0/3] mm/hugetlb: Add some new generic fallbacks,
Anshuman Khandual
- [PATCH v2] mm: expand documentation over __read_mostly,
Luis Chamberlain
- [PATCH V2 0/3] mm/hugetlb: Add some new generic fallbacks,
Anshuman Khandual
- Re: [PATCH v2 17/20] mm: free_area_init: allow defining max_zone_pfn in descending order,
Vineet Gupta
- RFC: Adding arch-specific user ABI documentation in linux-man,
Dave Martin
- Re: [PATCH 00/14] Move the ReST files from Documentation/*.txt,
Akira Yokosawa
- [PATCH V18 0/2] mm/debug: Add tests validating architecture page table helpers,
Anshuman Khandual
- [PATCH v5 0/4] Introduce the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH v4 0/4] Introduce the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH 12/14] docs: move remaining stuff under Documentation/*.txt to Documentation/staging,
Mauro Carvalho Chehab
- [PATCH] asm-generic: remove an empty ifdef block from signal.h, Christoph Hellwig
- [PATCH v10 00/26] Control-flow Enforcement: Shadow Stack,
Yu-cheng Yu
- [PATCH v10 03/26] x86/fpu/xstate: Introduce CET MSR XSAVES supervisor states, Yu-cheng Yu
- [PATCH v10 01/26] Documentation/x86: Add CET description, Yu-cheng Yu
- [PATCH v10 02/26] x86/cpufeatures: Add CET CPU feature flags for Control-flow Enforcement Technology (CET), Yu-cheng Yu
- [PATCH v10 06/26] x86/mm: Change _PAGE_DIRTY to _PAGE_DIRTY_HW, Yu-cheng Yu
- [PATCH v10 12/26] mm: Introduce VM_SHSTK for shadow stack memory, Yu-cheng Yu
- [PATCH v10 14/26] x86/mm: Update maybe_mkwrite() for shadow stack, Yu-cheng Yu
- [PATCH v10 13/26] x86/mm: Shadow Stack page fault error checking, Yu-cheng Yu
- [PATCH v10 11/26] x86/mm: Update ptep_set_wrprotect() and pmdp_set_wrprotect() for transition from _PAGE_DIRTY_HW to _PAGE_COW, Yu-cheng Yu
- [PATCH v10 24/26] x86/cet/shstk: ELF header parsing for shadow stack, Yu-cheng Yu
- [PATCH v10 23/26] ELF: Introduce arch_setup_elf_property(), Yu-cheng Yu
- [PATCH v10 26/26] x86/cet/shstk: Add arch_prctl functions for shadow stack, Yu-cheng Yu
- [PATCH v10 25/26] x86/cet/shstk: Handle thread shadow stack, Yu-cheng Yu
- [PATCH v10 20/26] x86/cet/shstk: Handle signals for shadow stack, Yu-cheng Yu
- [PATCH v10 22/26] ELF: Add ELF program property parsing support, Yu-cheng Yu
- [PATCH v10 19/26] x86/cet/shstk: User-mode shadow stack support, Yu-cheng Yu
- [PATCH v10 21/26] ELF: UAPI and Kconfig additions for ELF program properties, Yu-cheng Yu
- [PATCH v10 18/26] mm: Update can_follow_write_pte() for shadow stack, Yu-cheng Yu
- [PATCH v10 17/26] mm/mmap: Add shadow stack pages to memory accounting, Yu-cheng Yu
- [PATCH v10 16/26] mm: Add guard pages around a shadow stack., Yu-cheng Yu
- [PATCH v10 15/26] mm: Fixup places that call pte_mkwrite() directly, Yu-cheng Yu
- [PATCH v10 10/26] x86/mm: Update pte_modify for _PAGE_COW, Yu-cheng Yu
- [PATCH v10 09/26] drm/i915/gvt: Change _PAGE_DIRTY to _PAGE_DIRTY_BITS, Yu-cheng Yu
- [PATCH v10 08/26] x86/mm: Introduce _PAGE_COW, Yu-cheng Yu
- [PATCH v10 07/26] x86/mm: Remove _PAGE_DIRTY_HW from kernel RO pages, Yu-cheng Yu
- [PATCH v10 04/26] x86/cet: Add control-protection fault handler, Yu-cheng Yu
- [PATCH v10 05/26] x86/cet/shstk: Add Kconfig option for user-mode Shadow Stack, Yu-cheng Yu
- Re: [PATCH v10 00/26] Control-flow Enforcement: Shadow Stack, Josh Poimboeuf
- Re: [PATCH v10 00/26] Control-flow Enforcement: Shadow Stack, Sean Christopherson
- [PATCH v3 0/4] Introduce the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH 1/2] powerpc: Keep .rela* sections when CONFIG_RELOCATABLE is defined,
H.J. Lu
- [PATCH v8 0/8] powerpc: switch VDSO to C implementation,
Christophe Leroy
- [PATCH v8 8/8] powerpc/vdso: Provide __kernel_clock_gettime64() on vdso32, Christophe Leroy
- [PATCH v8 7/8] lib/vdso: force inlining of __cvdso_clock_gettime_common(), Christophe Leroy
- [PATCH v8 6/8] powerpc/vdso: Switch VDSO to generic C implementation., Christophe Leroy
- [PATCH v8 5/8] powerpc/vdso: Prepare for switching VDSO to generic C implementation., Christophe Leroy
- [PATCH v8 4/8] powerpc/processor: Move cpu_relax() into asm/vdso/processor.h, Christophe Leroy
- [PATCH v8 2/8] powerpc/vdso: Remove __kernel_datapage_offset and simplify __get_datapage(), Christophe Leroy
- [PATCH v8 3/8] powerpc/vdso: Remove unused \tmp param in __get_datapage(), Christophe Leroy
- [PATCH v8 1/8] powerpc/vdso64: Switch from __get_datapage() to get_datapage inline macro, Christophe Leroy
- Re: [PATCH v8 0/8] powerpc: switch VDSO to C implementation, Christophe Leroy
- Re: [PATCH v8 0/8] powerpc: switch VDSO to C implementation, Michael Ellerman
- [PATCH 1/2] powerpc: Discard .rela* sections if CONFIG_RELOCATABLE is undefined,
H.J. Lu
- Re: [PATCH 3/4] lib: logic_pio: Introduce MMIO_LOWER_RESERVED,
John Garry
- [RFC] ptrace, pidfd: add pidfd_ptrace syscall,
Hagen Paul Pfeifer
- [PATCH v2 0/6] Introduce the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH 4/6] bitops: Remove code related to for_each_set_clump8, Syed Nayyar Waris
- [PATCH 0/6] Introduce the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH 1/6] bitops: Introduce the the for_each_set_clump macro,
Syed Nayyar Waris
- [PATCH v3] io: correct doc-mismatches for io mem ops,
Wang Wenhu
- [PATCH v2 0/6] arm64: tlb: add support for TTL feature,
Zhenyu Ye
- [PATCH v2] io: correct documentation mismatches for io memcpy,
Wang Wenhu
- [PATCH 0/4] arm64: MTE swap and hibernation support,
Steven Price
- [PATCH] io: correct documentation mismatches for io memcpy,
Wang Wenhu
- [PATCH v2] arch: split MODULE_ARCH_VERMAGIC definitions out to <asm/vermagic.h>,
Masahiro Yamada
- [PATCH v4 00/11] Rework READ_ONCE() to improve codegen,
Will Deacon
- [PATCH v4 02/11] netfilter: Avoid assigning 'const' pointer to non-const pointer, Will Deacon
- [PATCH v4 01/11] compiler/gcc: Raise minimum GCC version for kernel builds to 4.8, Will Deacon
- [PATCH v4 03/11] net: tls: Avoid assigning 'const' pointer to non-const pointer, Will Deacon
- [PATCH v4 04/11] fault_inject: Don't rely on "return value" from WRITE_ONCE(), Will Deacon
- [PATCH v4 05/11] arm64: csum: Disable KASAN for do_csum(), Will Deacon
- [PATCH v4 06/11] READ_ONCE: Simplify implementations of {READ,WRITE}_ONCE(), Will Deacon
- [PATCH v4 07/11] READ_ONCE: Enforce atomicity for {READ,WRITE}_ONCE() memory accesses, Will Deacon
- [PATCH v4 08/11] READ_ONCE: Drop pointer qualifiers when reading from scalar types, Will Deacon
- [PATCH v4 09/11] locking/barriers: Use '__unqual_scalar_typeof' for load-acquire macros, Will Deacon
- [PATCH v4 10/11] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros, Will Deacon
- [PATCH v4 11/11] gcov: Remove old GCC 3.4 support, Will Deacon
- Re: [PATCH v4 00/11] Rework READ_ONCE() to improve codegen, Linus Torvalds
- [PATCH v3 00/23] arm64: Memory Tagging Extension user-space support,
Catalin Marinas
- [PATCH v3 02/23] arm64: mte: system register definitions, Catalin Marinas
- [PATCH v3 03/23] arm64: mte: CPU feature detection and initial sysreg configuration, Catalin Marinas
- [PATCH v3 01/23] arm64: alternative: Allow alternative_insn to always issue the first instruction, Catalin Marinas
- [PATCH v3 04/23] arm64: mte: Use Normal Tagged attributes for the linear map, Catalin Marinas
- [PATCH v3 05/23] arm64: mte: Assembler macros and default architecture for .S files, Catalin Marinas
- [PATCH v3 06/23] arm64: mte: Tags-aware clear_page() implementation, Catalin Marinas
- [PATCH v3 07/23] arm64: mte: Tags-aware copy_page() implementation, Catalin Marinas
- [PATCH v3 08/23] arm64: Tags-aware memcmp_pages() implementation, Catalin Marinas
- [PATCH v3 09/23] arm64: mte: Add specific SIGSEGV codes, Catalin Marinas
- [PATCH v3 10/23] arm64: mte: Handle synchronous and asynchronous tag check faults, Catalin Marinas
- [PATCH v3 11/23] mm: Introduce arch_calc_vm_flag_bits(), Catalin Marinas
- [PATCH v3 12/23] arm64: mte: Add PROT_MTE support to mmap() and mprotect(), Catalin Marinas
- [PATCH v3 13/23] mm: Introduce arch_validate_flags(), Catalin Marinas
- [PATCH v3 14/23] arm64: mte: Validate the PROT_MTE request via arch_validate_flags(), Catalin Marinas
- [PATCH v3 15/23] mm: Allow arm64 mmap(PROT_MTE) on RAM-based files, Catalin Marinas
- [PATCH v3 16/23] arm64: mte: Allow user control of the tag check mode via prctl(), Catalin Marinas
- [PATCH v3 17/23] arm64: mte: Allow user control of the generated random tags via prctl(), Catalin Marinas
- [PATCH v3 18/23] arm64: mte: Restore the GCR_EL1 register after a suspend, Catalin Marinas
- [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Catalin Marinas
- Re: [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Peter Collingbourne
- Re: [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Kevin Brodsky
- Re: [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Dave Martin
- Re: [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Luis Machado
- Re: [PATCH v3 19/23] arm64: mte: Add PTRACE_{PEEK,POKE}MTETAGS support, Luis Machado
- [PATCH v3 20/23] fs: Allow copy_mount_options() to access user-space in a single pass, Catalin Marinas
- [PATCH v3 21/23] arm64: mte: Check the DT memory nodes for MTE support, Catalin Marinas
- [PATCH v3 22/23] arm64: mte: Kconfig entry, Catalin Marinas
- [PATCH v3 23/23] arm64: mte: Add Memory Tagging Extension documentation, Catalin Marinas
- [PATCH V17 0/2] mm/debug: Add tests validating architecture page table helpers,
Anshuman Khandual
- Implement close-on-fork,
Nate Karstens
- [PATCH] arch: split MODULE_ARCH_VERMAGIC definitions out to <asm/vermagic.h>,
Masahiro Yamada
- [PATCH v16 00/10] Landlock LSM,
Mickaël Salaün
- [PATCH v16 03/10] landlock: Set up the security framework and manage credentials, Mickaël Salaün
- [PATCH v16 04/10] landlock: Add ptrace restrictions, Mickaël Salaün
- [PATCH v16 09/10] samples/landlock: Add a sandbox manager example, Mickaël Salaün
- [PATCH v16 05/10] fs,landlock: Support filesystem access-control, Mickaël Salaün
- [PATCH v16 02/10] landlock: Add ruleset and domain management, Mickaël Salaün
- [PATCH v16 10/10] landlock: Add user and kernel documentation, Mickaël Salaün
- [PATCH v16 07/10] arch: Wire up landlock() syscall, Mickaël Salaün
- [PATCH v16 01/10] landlock: Add object management, Mickaël Salaün
- [PATCH v16 08/10] selftests/landlock: Add initial tests, Mickaël Salaün
- [PATCH v16 06/10] landlock: Add syscall implementation, Mickaël Salaün
- [PATCH 5/9] x86: make sure _etext includes function sections, Kristen Carlson Accardi
- [PATCH memory-model 0/10] LKMM updates for v5.8, Paul E. McKenney
- [PATCH lkmm tip/core/rcu 01/10] tools/memory-model: Add recent references, paulmck
- [PATCH lkmm tip/core/rcu 04/10] Documentation: LKMM: Add litmus test for RCU GP guarantee where updater frees object, paulmck
- [PATCH lkmm tip/core/rcu 06/10] MAINTAINERS: Update maintainers for new Documentaion/litmus-tests/,
paulmck
- [PATCH lkmm tip/core/rcu 08/10] Documentation/litmus-tests: Introduce atomic directory, paulmck
- [PATCH lkmm tip/core/rcu 07/10] tools/memory-model: Add an exception for limitations on _unless() family, paulmck
- [PATCH lkmm tip/core/rcu 09/10] Documentation/litmus-tests/atomic: Add a test for atomic_set(), paulmck
- [PATCH lkmm tip/core/rcu 10/10] Documentation/litmus-tests/atomic: Add a test for smp_mb__after_atomic(), paulmck
- [PATCH lkmm tip/core/rcu 02/10] tools/memory-model: Fix "conflict" definition, paulmck
- [PATCH lkmm tip/core/rcu 05/10] Documentation: LKMM: Add litmus test for RCU GP guarantee where reader stores, paulmck
- [PATCH lkmm tip/core/rcu 03/10] Documentation: LKMM: Move MP+onceassign+derefonce to new litmus-tests/rcu/, paulmck
- [PATCH v3 00/12] Rework READ_ONCE() to improve codegen,
Will Deacon
- [PATCH v3 03/12] net: tls: Avoid assigning 'const' pointer to non-const pointer, Will Deacon
- [PATCH v3 01/12] compiler/gcc: Emit build-time warning for GCC prior to version 4.8, Will Deacon
- [PATCH v3 06/12] READ_ONCE: Simplify implementations of {READ,WRITE}_ONCE(), Will Deacon
- [PATCH v3 07/12] READ_ONCE: Enforce atomicity for {READ,WRITE}_ONCE() memory accesses, Will Deacon
- [PATCH v3 09/12] locking/barriers: Use '__unqual_scalar_typeof' for load-acquire macros, Will Deacon
- [PATCH v3 04/12] fault_inject: Don't rely on "return value" from WRITE_ONCE(), Will Deacon
- [PATCH v3 10/12] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros, Will Deacon
- [PATCH v3 08/12] READ_ONCE: Drop pointer qualifiers when reading from scalar types, Will Deacon
- [PATCH v3 11/12] compiler/gcc: Raise minimum GCC version for kernel builds to 4.8, Will Deacon
- [PATCH v3 12/12] gcov: Remove old GCC 3.4 support, Will Deacon
- [PATCH v3 02/12] netfilter: Avoid assigning 'const' pointer to non-const pointer, Will Deacon
- [PATCH v3 05/12] arm64: csum: Disable KASAN for do_csum(), Will Deacon
- Re: [PATCH v3 00/12] Rework READ_ONCE() to improve codegen, Christian Borntraeger
- [PATCH v2 00/33] Documentation fixes for Kernel 5.8,
Mauro Carvalho Chehab
- [PATCH v4 00/14] mm: remove __ARCH_HAS_5LEVEL_HACK,
Mike Rapoport
- [PATCH v4 04/14] hexagon: remove __ARCH_USE_5LEVEL_HACK, Mike Rapoport
- [PATCH v4 07/14] openrisc: add support for folded p4d page tables, Mike Rapoport
- [PATCH v4 08/14] powerpc: add support for folded p4d page tables, Mike Rapoport
- [PATCH v4 09/14] sh: fault: Modernize printing of kernel messages, Mike Rapoport
- [PATCH v4 03/14] arm64: add support for folded p4d page tables, Mike Rapoport
- [PATCH v4 06/14] nios2: add support for folded p4d page tables, Mike Rapoport
- [PATCH v4 14/14] mm: remove __ARCH_HAS_5LEVEL_HACK and include/asm-generic/5level-fixup.h, Mike Rapoport
- [PATCH v4 13/14] asm-generic: remove pgtable-nop4d-hack.h, Mike Rapoport
- [PATCH v4 12/14] unicore32: remove __ARCH_USE_5LEVEL_HACK, Mike Rapoport
- [PATCH v4 05/14] ia64: add support for folded p4d page tables, Mike Rapoport
- [PATCH v4 10/14] sh: drop __pXd_offset() macros that duplicate pXd_index() ones, Mike Rapoport
- [PATCH v4 11/14] sh: add support for folded p4d page tables, Mike Rapoport
decruft the vmalloc API v2,
Christoph Hellwig
[PATCH 26/29] mm: remove vmalloc_user_node_flags, Christoph Hellwig
[PATCH 28/29] powerpc: use __vmalloc_node in alloc_vm_stack, Christoph Hellwig
[PATCH 29/29] s390: use __vmalloc_node in stack_alloc, Christoph Hellwig
[PATCH 27/29] arm64: use __vmalloc_node in arch_alloc_vmap_stack, Christoph Hellwig
[PATCH 25/29] mm: switch the test_vmalloc module to use __vmalloc_node, Christoph Hellwig
[PATCH 24/29] mm: remove __vmalloc_node_flags_caller, Christoph Hellwig
[PATCH 23/29] mm: remove both instances of __vmalloc_node_flags, Christoph Hellwig
[PATCH 20/29] gpu/drm: remove the powerpc hack in drm_legacy_sg_alloc, Christoph Hellwig
[PATCH 22/29] mm: remove the prot argument to __vmalloc_node, Christoph Hellwig
[PATCH 17/29] mm: remove unmap_vmap_area, Christoph Hellwig
[PATCH 18/29] mm: remove the prot argument from vm_map_ram, Christoph Hellwig
[PATCH 16/29] mm: remove map_vm_range, Christoph Hellwig
[PATCH 14/29] mm: rename vmap_page_range to map_kernel_range, Christoph Hellwig
[PATCH 12/29] mm: pass addr as unsigned long to vb_free, Christoph Hellwig
[PATCH 13/29] mm: remove vmap_page_range_noflush and vunmap_page_range, Christoph Hellwig
[PATCH 09/29] mm: unexport unmap_kernel_range_noflush, Christoph Hellwig
[PATCH 08/29] mm: remove __get_vm_area, Christoph Hellwig
[PATCH 06/29] powerpc: add an ioremap_phb helper, Christoph Hellwig
[PATCH 02/29] x86: fix vmap arguments in map_irq_stack, Christoph Hellwig
[PATCH 04/29] staging: media: ipu3: use vmap instead of reimplementing it, Christoph Hellwig
[PATCH 03/29] staging: android: ion: use vmap instead of vm_map_ram, Christoph Hellwig
[PATCH] csky: Fixup perf probe -x hungup, guoren
[PATCH 0/3] mm/hugetlb: Add some new arch enabling macros,
Anshuman Khandual
[RFC PATCH v3 0/2] arm64: tlb: add support for TLBI RANGE instructions,
Zhenyu Ye
[PATCH v4 0/3] Support userspace-selected fds,
Josh Triplett
[PATCH v4 3/3] fs: pipe2: Support O_SPECIFIC_FD, Josh Triplett
[PATCH v2 0/4] huge vmalloc mappings,
Nicholas Piggin
[Index of Archives]
[Kernel Announce]
[Kernel Newbies]
[Linux RAID]
[IETF Annouce]
[Security]
[Netdev]
[Linux Wireless]
[Netfilter]
[Bugtraq]