Re: Error running from procmail

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sun, Feb 20, 2022 at 09:09:32PM +0100, Adrian van Bloois wrote:
> Hi Sean,
> This seems a bit complicated, I tried something else.
> I set the sticky bit on the morse binary so it was rwsr-xr-x but that
> didn't work either.

I assume by that you mean the setuid bit. That should work in theory
(assuming the morse binary is actually owned by the local user), but it
may still require you to manually override bits of the environment (e.g.
your $HOME) to make it work. I think my suggestion of a sudo-able script
would be easier.

> Now I tried to run the same thing fron the crontab, on my laptops that
> works very well, but on the PC I get:
> pa_simple_Write failed
> Somehow I feel it might be more of an alsa problem then an issue with
> pulseaudio, but I'm no export.

I don't think any of this is an alsa issue. You're just trying to use
pulseaudio in a way that it was not intended to operate. Pulse is
primarily intended for single-user, non-root, desktop / interactive
applications. What you're asking for is certainly possible, but it will
require some manual configuration to make it work.

An alternative configuration for allowing multiple users access to
pulseaudio simultaneously is the system-wide configuration. See this
page for details:


[Index of Archives]     [Linux Audio Users]     [AMD Graphics]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux